Subject: [nfsv4] Error code suitable for a RELEASE_LOCKOWNER for lock-owner that has already been released

From: Saul Tamari <[email-masked]>
Date: Thu, 14 Feb 2013 17:45:13 -0500

Hi,

I'm trying to figure out which error should an NFS4.0 server return in
response to a RELEASE_LOCKOWNER request for a lock-owner that has been
already released.
RFC3530 lists the following errors as the allowed errors but I'm not
sure any one of them suits this case.
NFS4ERR_ADMIN_REVOKED
NFS4ERR_BADXDR
NFS4ERR_EXPIRED
NFS4ERR_LEASE_MOVED
NFS4ERR_LOCKS_HELD
NFS4ERR_RESOURCE
NFS4ERR_SERVERFAULT
NFS4ERR_STALE_CLIENTID

Thanks,
Saul

---

From: Marcel Telka <[email-masked]>
Date: Fri, 15 Feb 2013 00:29:41 +0100

> response to a RELEASE_LOCKOWNER request for a lock-owner that has been

NFS4_OK

-- 
+-------------------------------------------+
| Marcel Telka   e-mail:   [email-masked]  |
|                homepage: http://telka.sk/ |
|                jabber:   [email-masked] |
+-------------------------------------------+

---

From: Saul Tamari <[email-masked]>
Date: Fri, 15 Feb 2013 11:49:23 -0500

Thanks!