Subject: [nfsv4] End of last call for RFC3530-bis

From: Spencer Shepler <[email-masked]>
Date: Mon, 25 Feb 2013 17:05:46 +0000

Having received no comments during the last call for RFC3530-bis, the document is ready to our AD for further progression in the IESG/IETF review process.

Thanks,
Spencer

---

From: "Haynes, Tom" <[email-masked]>
Date: Mon, 25 Feb 2013 17:32:54 +0000

We did get one minor comment before, so I will push that out now.

On Feb 25, 2013, at 9:05 AM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Spencer

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Feb 2013 22:28:12 +0100

Hi Spencer, all,

I will hold two drafts until the end of the IETF meeting and start the 
IETF LC right after the IETF meeting. This will ensure that the 
community has sufficient time for the LC, as right now everybody is busy 
with the IETF meeting prep.

   Martin

On 02/25/2013 06:05 PM, Spencer Shepler wrote:
> Having received no comments during the last call for RFC3530-bis, the
> document is ready to our AD for further progression in the IESG/IETF
> review process.
>
>
> Thanks,
>
> Spencer
>

-- 
[email-masked]

NEC Laboratories Europe
NEC Europe Limited
Registered Office:
Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB
Registered in England 2832014

---

From: Tigran Mkrtchyan <[email-masked]>
Date: Wed, 27 Feb 2013 20:02:19 +0100

Hi Spencer et al.

just notices this today: all opaque sizes have a constant except one
stateid4.other.

this can go to into one of the nfs specs/bis/errata in:

change:

  struct stateid4 {
                    uint32_t        seqid;
                    opaque          other[12];
                  };

with:

const NFS4_STATEID4_SIZE = 12;

  struct stateid4 {
                    uint32_t        seqid;
                    opaque          other[NFS4_STATEID4_SIZE];
                  };

3530 page 22, 5661 page 91.

this change of xdr will not have any impact on existing implementations.

Tigran.

On Tue, Feb 26, 2013 at 10:28 PM, Martin Stiemerling
<[email-masked]> wrote:
> Hi Spencer, all,
>
> I will hold two drafts until the end of the IETF meeting and start the IETF
> LC right after the IETF meeting. This will ensure that the community has
> sufficient time for the LC, as right now everybody is busy with the IETF
> meeting prep.
>
>   Martin
>
>
> [email-masked]

---

From: "J. Bruce Fields" <[email-masked]>
Date: Thu, 28 Feb 2013 13:06:55 -0500

>                     opaque          other[NFS4_STATEID4_SIZE];

I actually prefer this as it is--I don't think this size is used in
enough places for there to be an obvious benefit to naming it, and I
prefer not to have to go track down the definition to figure out how big
a stateid is.

If we do this, just one minor nit on the name: make it something like
NFS4_STATEID4_OPAQUE_SIZE.  Otherwise it sounds like it's the size of a
stateid, which is confusing.

--b.