Subject: [nfsv4] Future working group meetings (and minutes from IETF86 posted)

From: Spencer Shepler <[email-masked]>
Date: Tue, 2 Apr 2013 17:45:16 +0000

[Note I have posted draft minutes from our IETF 86 meeting.]

Beepy and I have discussed our policy/behavior for meeting at the IETF meetings.

In the past, we have always asked for a slot to meet.

In the future, we will solicit agenda items and monitor WG alias activity to decide if we submit a request to meet face-to-face at the IETF meetings.

So, please assume that we will not meet face-to-face and bring discussions here to drive ideas and issues forward.

Thanks,
Spencer

---

From: "Noveck, David" <[email-masked]>
Date: Tue, 2 Apr 2013 18:13:27 -0400

> So, please assume that we will not meet face-to-face

I think the intention is really:

So, please don't assume that we will meet face-to-face.

> bring discussions here to drive ideas and issues forward

I agree that we should do that.  However, if you are indeed "monitor[ing] WG alias activity to decide if we submit a request to meet face-to-face at the IETF meetings", we need to have an understood schedule for when that decision is to be made.

Given the unpleasant realities of corporate travel approval and airline flight booking nightmares, a decision should be made two months before the meeting date.

If not, we would always wind up having to assume that we will not be meeting face-to-face.  I don't think that would be a good thing.

It looks like we need a decision for IETF87 by 5/28, which means that the discussions which should form the basis for that decision have to start very soon.

> In the future, we will solicit agenda items

If the decision is to be made by 5/28, the agenda items would need to be started on before that.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Tuesday, April 02, 2013 1:45 PM
To: [email-masked]
Subject: [nfsv4] Future working group meetings (and minutes from IETF86 posted)

Thanks,
Spencer

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 3 Apr 2013 00:02:36 +0000

Thanks for the clarity in wording, Dave.  Your rephrasing is more appropriate.

Understand that there are lead times to effective travel. I will do my best to query for agenda items, etc. early enough to allow people to adapt to the need for travel.

Spencer

From: Noveck, David [mailto:[email-masked]]
Sent: Tuesday, April 2, 2013 3:13 PM
To: Spencer Shepler; [email-masked]
Subject: RE: [nfsv4] Future working group meetings (and minutes from IETF86 posted)

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Tuesday, April 02, 2013 1:45 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [nfsv4] Future working group meetings (and minutes from IETF86 posted)

Thanks,
Spencer

---

From: "Noveck, David" <[email-masked]>
Date: Wed, 3 Apr 2013 13:28:20 -0400

The thing is that if you figure out the schedule considerations, it is not clear that you wind up with something workable.

With a four-month inter-meeting cycle, you have:

*         some period of time at the front for people to finish up things discussed at the last working group meeting.

*         Some period to think up discussion items.

*         A call for them.

*         Time for their writing, posting and discussion.

*         Some judgment made regarding the implications of the discussion.

*         Two months at least at the end

I can imagine this working in  some sort of textbook-style best case, but I don't think there will be time for people to write things up with such tight time constraints, especially given that they are writing without any assurance of a meeting to discuss their contributions.   If we consider how v4.0, v4.1 and FedFS would have gotten done (or not) under this sort of regime, things get kind of depressing.

There's a reason we now ask for agenda items a few weeks (and not ten weeks) before the meeting.  I think  it is that asking for them so far in advance would slow things down unacceptably.

After thinking through the implications, this is seeming to be a lot like "no new ideas" in effect, if not necessarily in intention.

We haven't had much discussion of this step within the group before its announcement, so I'm not sure of the motivation.

I certainly haven't seen a lack of useful discussion at the meetings we have had.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Tuesday, April 02, 2013 8:03 PM
To: Noveck, David; [email-masked]
Subject: Re: [nfsv4] Future working group meetings (and minutes from IETF86 posted)

Spencer

From: Noveck, David [mailto:[email-masked]]
Sent: Tuesday, April 2, 2013 3:13 PM
To: Spencer Shepler; [email-masked]<mailto:[email-masked]>
Subject: RE: [nfsv4] Future working group meetings (and minutes from IETF86 posted)

Thanks,
Spencer

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Wed, 3 Apr 2013 13:33:03 -0400 (EDT)

Hi,

I'm a bit worried about this, as well.  It does seem to me (admittedly, I've only been to 4 meetings) that the list is very quiet, given the range of things that are being and could be worked on.  

Matt

----- "David Noveck" <[email-masked]> wrote:
> 
> 
> 
> After thinking through the implications, this is seeming to be a lot
> like “no new ideas” in effect, if not necessarily in intention.
> 
> 
> 
> We haven’t had much discussion of this step within the group before
> its announcement, so I’m not sure of the motivation.
> 
> 
> 
> I certainly haven’t seen a lack of useful discussion at the meetings
> we have had.
> 

-- 
Matt Benjamin
The Linux Box
206 South Fifth Ave. Suite 150
Ann Arbor, MI  48104

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Chuck Lever <[email-masked]>
Date: Wed, 3 Apr 2013 10:40:05 -0700

On Apr 3, 2013, at 10:28 AM, "Noveck, David" <[email-masked]> wrote:

> I certainly haven’t seen a lack of useful discussion at the meetings we have had.

I agree.  Though the travel obligation is sometimes onerous, the discussions outside the meeting room have at least as much value to me as the discussions inside the room.  Not meeting in person means there is one less opportunity to have face-to-face interaction with protocol architects.  These are often individuals who do not attend other community events such as Connectathon.

--
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: Marc Eshel <[email-masked]>
Date: Wed, 3 Apr 2013 11:04:00 -0700

I think that it should be something that is decided by consensus, like 
every thing else that this group does. Maybe when the time comes the 
agenda can be posted and the group can agree if we need a meeting or not.
Marc.

From:   Chuck Lever <[email-masked]>
To:     Spencer Shepler <[email-masked]>, 
Cc:     [email-masked]
Date:   04/03/2013 10:44 AM
Subject:        Re: [nfsv4] Future working group meetings (and minutes 
from    IETF86  posted)
Sent by:        [email-masked]

On Apr 3, 2013, at 10:28 AM, "Noveck, David" <[email-masked]> wrote:

> I certainly haven?t seen a lack of useful discussion at the meetings we 
have had.

I agree.  Though the travel obligation is sometimes onerous, the 
discussions outside the meeting room have at least as much value to me as 
the discussions inside the room.  Not meeting in person means there is one 
less opportunity to have face-to-face interaction with protocol 
architects.  These are often individuals who do not attend other community 
events such as Connectathon.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "faibish, sorin" <[email-masked]>
Date: Wed, 3 Apr 2013 14:14:37 -0400

I am of same opinion.

./Sorin

Sent from my iPhone

On Apr 3, 2013, at 2:04 PM, "Marc Eshel" <[email-masked]<mailto:[email-masked]>> wrote:

I think that it should be something that is decided by consensus, like every thing else that this group does. Maybe when the time comes the agenda can be posted and the group can agree if we need a meeting or not.
Marc.

From:        Chuck Lever <[email-masked]<mailto:[email-masked]>>
To:        Spencer Shepler <[email-masked]<mailto:[email-masked]>>,
Cc:        [email-masked]<mailto:[email-masked]>
Date:        04/03/2013 10:44 AM
Subject:        Re: [nfsv4] Future working group meetings (and minutes from        IETF86        posted)
Sent by:        [email-masked]<mailto:[email-masked]>
________________________________

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 3 Apr 2013 19:03:01 +0000

If there is active work, it should be apparent there is a need for a face-to-face meeting.

Beepy and I were working from the current work items and activity.

The bulk of our work is now in the hands of our AD and the IESG as part of RFC publication.

If other work becomes active, then we can meet to resolve the big issues.

If we find that email is not sufficient for driving forward on future work items, I might suggest design group or working group conference calls as was usd for the NFSv4.2 review process.  That seemed to work well.

Spencer

From: Marc Eshel [mailto:[email-masked]]
Sent: Wednesday, April 3, 2013 11:04 AM
To: Chuck Lever
Cc: [email-masked]; Spencer Shepler
Subject: Re: [nfsv4] Future working group meetings (and minutes from IETF86 posted)