Subject: [nfsv4] AD question about i18n in draft-ietf-nfsv4-rfc3530bis

From: Martin Stiemerling <[email-masked]>
Date: Tue, 28 May 2013 17:33:54 +0200

Hi all,

This question came up in the IESG review about Section 12
of draft-ietf-nfsv4-rfc3530bis about i18n:

Is any implementation implementing what's in Section 12 on 
internationalization?

Thanks in advance,

   Martin

-- 
IETF Transport Area Director

[email-masked]

NEC Laboratories Europe
NEC Europe Limited
Registered Office:
Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB
Registered in England 2832014

---

From: "Haynes, Tom" <[email-masked]>
Date: Wed, 29 May 2013 01:00:16 +0000

On May 28, 2013, at 8:33 AM, Martin Stiemerling <[email-masked]> wrote:

> Is any implementation implementing what's in Section 12 on internationalization?

Not to my knowledge.

We know there are implementations of that in 3530.

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, David" <[email-masked]>
Date: Wed, 29 May 2013 12:16:25 -0400

> We know there are implementations of that in 3530.

I don't believe that there ever were.  When I read what was in the internationalization section of RFC3530, it seemed doubtful to me that any client or servers implemented stringprep.  So I asked people if they implemented what was in RFC3530 and never got a positive answer.  Answers were more like, "No", "huh?", "I don't think so, but I don't understand what is required".  I may even have got an "Are you kidding?".

What is in the RFC3530bis draft is an attempt to at least allow servers to do what they had been doing, and for clients who had been interoperating with them to continue to do so.  I think I succeeded in that but I'm not sure I got something that NFS implementers would actually read.

It may be that I left servers too much latitude.  I think it may be that there is no current client who could handle the range of server behavior that the current bis draft allows.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Haynes, Tom
Sent: Tuesday, May 28, 2013 9:00 PM
To: Martin Stiemerling
Cc: [email-masked]
Subject: Re: [nfsv4] AD question about i18n in draft-ietf-nfsv4-rfc3530bis

On May 28, 2013, at 8:33 AM, Martin Stiemerling <[email-masked]> wrote:

> Hi all,
> 
> This question came up in the IESG review about Section 12 of 
> draft-ietf-nfsv4-rfc3530bis about i18n:
> 

Not to my knowledge.