Subject: [nfsv4] status and next steps for RFC5664bis

From: Spencer Shepler <[email-masked]>
Date: Wed, 15 May 2013 05:45:57 +0000

Hello,

The following bis document expired 8 months ago and is part of the working group's charter.
http://tools.ietf.org/id/draft-ietf-nfsv4-rfc5664bis-01.txt

Please provide a timeline for updates or an opinion that the work should be removed from the charter and the WG's milestones.

Thanks,
Spencer

---

From: "Welch, Brent" <[email-masked]>
Date: Wed, 15 May 2013 06:38:43 +0000

Thank you for the gentle reminder.  We think we just have mechanics to go through.  I realize I've said that before.  My travel schedule lightens up over the next month, so I'll make sure we have an update by June 7.

--
Brent

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Tuesday, May 14, 2013 10:46 PM
To: [email-masked]; Harrosh, Boaz; Welch, Brent
Cc: [email-masked]
Subject: [nfsv4] status and next steps for RFC5664bis

Hello,

Thanks,
Spencer

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 15 May 2013 11:26:26 +0000

Thanks, Brent.  We will start the last call for this document when the I-D is available.

Spencer

From: Welch, Brent [mailto:[email-masked]]
Sent: Tuesday, May 14, 2013 11:39 PM
To: Spencer Shepler; [email-masked]; Harrosh, Boaz
Cc: [email-masked]
Subject: RE: status and next steps for RFC5664bis

--
Brent

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Tuesday, May 14, 2013 10:46 PM
To: [email-masked]<mailto:[email-masked]>; Harrosh, Boaz; Welch, Brent
Cc: [email-masked]<mailto:[email-masked]>
Subject: [nfsv4] status and next steps for RFC5664bis

Hello,

Thanks,
Spencer

---

From: "Noveck, David" <[email-masked]>
Date: Wed, 15 May 2013 12:48:20 -0400

IIRC, there was some discussion of moving this to last-call and I was asked to provide a review.  I could dig that up if anybody is interested.  The last I heard was that my comments would be responded to, but I've heard nothing since then.

My understanding is that there is no interest  in continuing this and those who were interested in this are now interested in doing what I call the son-of-pNFS-object work instead.   Can people who really know tell me whether I'm right?

It appears that the administrative/charter side of things has not kept pace with the technical  interests of working group participants.    Clearly that's an undesirable situation, but I have no idea how it would be best rectified.

Assuming I'm right, it would be a shame if the following sort of argument prevailed:

*         How can we discuss  yet a new mapping type when we have this 56664bis stuff hanging fire?

*         If there is no energy to do the latter, how can the working group do the former?

The relevant points are that sometimes people make mistakes and also that circumstances change and make previous decisions, even those made by rough consensus, incorrect in retrospect.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Wednesday, May 15, 2013 1:46 AM
To: [email-masked]; Boaz Harrosh ([email-masked]); [email-masked]
Cc: [email-masked]
Subject: [nfsv4] status and next steps for RFC5664bis

Hello,

Thanks,
Spencer

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 15 May 2013 16:52:14 +0000

Brent has committed an updated I-D within the next month or so.

Spencer

From: Noveck, David [mailto:[email-masked]]
Sent: Wednesday, May 15, 2013 9:48 AM
To: Spencer Shepler; [email-masked]; Boaz Harrosh ([email-masked]); [email-masked]
Cc: [email-masked]
Subject: RE: status and next steps for RFC5664bis

To: [email-masked]<mailto:[email-masked]>; Boaz Harrosh ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>

Hello,

Thanks,
Spencer

---

From: Benny Halevy <[email-masked]>
Date: Wed, 15 May 2013 20:37:03 +0300

On Wed, May 15, 2013 at 7:48 PM, Noveck, David <[email-masked]> wrote:
> IIRC, there was some discussion of moving this to last-call and I was asked
> to provide a review.  I could dig that up if anybody is interested.  The
> last I heard was that my comments would be responded to, but I’ve heard
> nothing since then.
>
>
>
> My understanding is that there is no interest  in continuing this and those
> who were interested in this are now interested in doing what I call the
> son-of-pNFS-object work instead.   Can people who really know tell me
> whether I’m right?

Speaking for Tonian only - we are indeed focusing on the flexible files layout
(what you call the son-of-pNFS-object).

Based on the discussions we had in the IETF 85 meeting, there was not enough
(and committed) interest in supporting T-10 OSD in the new layout I proposed
but rather define it as an evolutionary  progression of the files-layout, adding
the flexibility of a per-file layout and RAID support over
NFS-attached Data Servers.
Hence I essentially forked it off of pnfs-object and that will be
clear in the new I-D
I'm planning to submit.

>
>
>
> It appears that the administrative/charter side of things has not kept pace
> with the technical  interests of working group participants.    Clearly
> that’s an undesirable situation, but I have no idea how it would be best
> rectified.
>
>
>
> Assuming I’m right, it would be a shame if the following sort of argument
> prevailed:
>
> ·         How can we discuss  yet a new mapping type when we have this
> 56664bis stuff hanging fire?

The new layout proposal is going to be independent of rfc5664(bis).

>
> ·         If there is no energy to do the latter, how can the working group
> do the former?

ditto.

Benny

>
>
>
> The relevant points are that sometimes people make mistakes and also that
> circumstances change and make previous decisions, even those made by rough
> consensus, incorrect in retrospect.
>
>
>
>
>
>
>
>
>
>
>
>
>
> The following bis document expired 8 months ago and is part of the working
> group’s charter.
>
> Please provide a timeline for updates or an opinion that the work should be
> removed from the charter and the WG’s milestones.
>
>
>
> Thanks,
>
> Spencer
>
>