Subject: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

From: Spencer Shepler <[email-masked]>
Date: Wed, 29 May 2013 15:46:45 +0000

See below for the draft agenda at this time.  Please let me know what I have missed or needs to be adjusted...

We have a number of topics it seems.  It also appears the content will be slides given the lack of backing I-Ds at this point.

Let's close by the end of today such that we can move forward with a meeting request if we need one.

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

Flexible File Layouts (Halevy) (15-20 minutes)

FedFS issues (Lever) (15 minutes)
      - this is a placeholder; expecting additional detail for this item

pNFS Lustre layout (Faibish)

Coherent data caching for NFS - (Eshel) (20 minutes)

RPCSECGSSv3 - (williams - uncommittted)

End-to-end Integrity - (Lever) (time ?)

Versioning Model - (Noveck) (time ?)

---

From: "faibish, sorin" <[email-masked]>
Date: Wed, 29 May 2013 11:48:39 -0400

I will need 20 minutes as well. Thanks

./Sorin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Wednesday, May 29, 2013 11:47 AM
To: [email-masked]
Subject: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

---

From: Chuck Lever <[email-masked]>
Date: Wed, 29 May 2013 12:06:37 -0400

Hi-

Let's say 15 minutes for end-to-end.

The "additional detail" for FedFS is going to be worked out on [email-masked] before the end of July.

On May 29, 2013, at 11:46 AM, Spencer Shepler <[email-masked]> wrote:

>  
> See below for the draft agenda at this time.  Please let me know what I have missed or needs to be adjusted…
>  
> Let’s close by the end of today such that we can move forward with a meeting request if we need one.
>  
> Spencer
>  
>  
>  
>  
> NFSv4 Working Group
> Berlin
> July 28, 2013
>  
>  
> Note Well
>  
> Agenda Bashing
>  
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

-- 
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 29 May 2013 16:15:36 +0000

Updated.  Thanks, Sorin.

From: faibish, sorin [mailto:[email-masked]]
Sent: Wednesday, May 29, 2013 8:49 AM
To: Spencer Shepler; [email-masked]
Subject: RE: closing on the IETF87 NFSv4 WG meeting (review and comment)

./Sorin

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Wednesday, May 29, 2013 11:47 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 29 May 2013 16:19:06 +0000

Thanks, will update.

From: Chuck Lever [mailto:[email-masked]]
Sent: Wednesday, May 29, 2013 9:07 AM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

Hi-

The "additional detail" for FedFS is going to be worked out on [email-masked]<mailto:[email-masked]> before the end of July.

On May 29, 2013, at 11:46 AM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Noveck, David" <[email-masked]>
Date: Wed, 29 May 2013 12:47:25 -0400

Since we clearly need one, let's decide now whether we will in fact meet, given that this has already been delayed beyond the previously agreed time and people need to make travel arrangements.

I can see a need for a short delay as we work out the length of the requested meeting, but it is best if we consider the will-we-meet question closed.

Can we get an immediate decision on the meeting-at-IETF87 question?  How about an email to the group by 2PM EDT today?

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

---

From: "Haynes, Tom" <[email-masked]>
Date: Wed, 29 May 2013 16:51:14 +0000

5-10 minutes for 4.2.

We might also need some time to finalize on 3530bis, especially i18n.

On May 29, 2013, at 8:46 AM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Wed, 29 May 2013 12:52:59 -0400 (EDT)

Hi,

I am willing to attend a meeting, if one is held.

I've hesitated to request time as the things I'm interested in are mainly post-4.2.  However, I would be able to present a status update on our striped metadata implementation, and have points on which we would like feedback.

Thanks,

Matt

----- "David Noveck" <[email-masked]> wrote:

> Since we clearly need one, let’s decide now whether we will in fact
> meet, given that this has already been delayed beyond the previously
> agreed time and people need to make travel arrangements.
> 
> 
> 
> I can see a need for a short delay as we work out the length of the
> requested meeting, but it is best if we consider the will-we-meet
> question closed.
> 
> 
> 
> Can we get an immediate decision on the meeting-at-IETF87 question?
> How about an email to the group by 2PM EDT today?
> 
> 
> 
> 
> 
> We have a number of topics it seems. It also appears the content will
> be slides given the lack of backing I-Ds at this point.
> 
> 
> 

-- 
Matt Benjamin
The Linux Box
206 South Fifth Ave. Suite 150
Ann Arbor, MI  48104

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 30 May 2013 02:01:29 +0000

Draft agenda is below.  I have requested a single, 2.5 session for Berlin.

This is not a last call for the agenda.  If you have additions or edits to be made, please let me know.

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

NFSv4.2 open items (Haynes) (5-10 minutes)

3530bis (e.g. I18N) (Haynes) (10 minutes)

ACL discussion (Haynes) (10 minutes)

pNFS Lustre layout (Faibish) (20 minutes)

End-to-end Integrity - (Lever) (15 minutes)

From: Haynes, Tom [mailto:[email-masked]]
Sent: Wednesday, May 29, 2013 9:51 AM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

5-10 minutes for 4.2.

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

---

From: Chuck Lever <[email-masked]>
Date: Thu, 30 May 2013 10:51:46 -0400

Hi Spencer-

Re: items on the agenda: how are we moving forward with the FedFS multi-domain work?  I would like to see attention either on the mailing list or during the meeting (or both) to how multi-domain will move forward.

On May 29, 2013, at 10:01 PM, Spencer Shepler <[email-masked]> wrote:

> On May 29, 2013, at 8:46 AM, Spencer Shepler <[email-masked]> wrote:
> 
> 
>

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Thu, 30 May 2013 11:37:41 -0400 (EDT)

metastripe?

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Thu, 30 May 2013 14:22:11 -0400 (EDT)

Yes, will update the ID, and highlight on list.

Matt

----- "Spencer Shepler" <[email-masked]> wrote:

> Matt,
> 
> I have added this:
> Metastripe - (Benjamin) (15 minutes)
> 
> And assume that you would like review feedback on your I-D prior to
> the meeting.
> Will you have an update of the I-D or areas where you would like
> specific feedback?
> 
> Spencer
> 
> -----Original Message-----
> From: Matt W. Benjamin [mailto:[email-masked]] 
> Sent: Thursday, May 30, 2013 8:38 AM
> To: Spencer Shepler
> Cc: [email-masked]
> > This is not a last call for the agenda. If you have additions or
> edits 
> > to be made, please let me know.
> > 
> > 
> > 
> > Spencer
> > 
> 
> --
> Matt Benjamin
> The Linux Box

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 30 May 2013 18:15:02 +0000

Matt,

I have added this:

And assume that you would like review feedback on your I-D prior to the meeting.
Will you have an update of the I-D or areas where you would like specific feedback?

Spencer

-----Original Message-----
From: Matt W. Benjamin [mailto:[email-masked]] 
Sent: Thursday, May 30, 2013 8:38 AM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

metastripe?

http://linuxbox.com

tel.  734-761-4689
fax.  734-769-8938
cel.  734-216-5309

---

From: spencer shepler <[email-masked]>
Date: Thu, 30 May 2013 11:37:50 -0700

Are you referring to Andy's I-D?

http://datatracker.ietf.org/doc/draft-adamson-nfsv4-multi-domain-federated-fs-reqs/

Spencer

On Thu, May 30, 2013 at 7:51 AM, Chuck Lever <[email-masked]> wrote:

> Hi Spencer-
>
> Re: items on the agenda: how are we moving forward with the FedFS
> multi-domain work?  I would like to see attention either on the mailing
> list or during the meeting (or both) to how multi-domain will move forward.
>
>
>
> ****
> This is not a last call for the agenda.  If you have additions or edits to
> be made, please let me know.****
>
> Spencer****
>
>
>
> NFSv4 Working Group****
> Berlin****
> July 28, 2013****
>
>
> Note Well****
>
> Agenda Bashing****
>
> NFSv4.2 open items (Haynes) (5-10 minutes)****
>
> 3530bis (e.g. I18N) (Haynes) (10 minutes)****
>
> ACL discussion (Haynes) (10 minutes)****
>
> Flexible File Layouts (Halevy) (15-20 minutes)****
>
> FedFS issues (Lever) (15 minutes)****
>       - this is a placeholder; expecting additional detail for this item**
> **
>
> pNFS Lustre layout (Faibish) (20 minutes)****
>
> Coherent data caching for NFS - (Eshel) (20 minutes)****
>
> RPCSECGSSv3 - (williams - uncommittted)****
>
> End-to-end Integrity - (Lever) (15 minutes)****
>
> Versioning Model - (Noveck) (time ?)****
>
>
> *From:* Haynes, Tom [mailto:[email-masked]]
> *Sent:* Wednesday, May 29, 2013 9:51 AM
> *To:* Spencer Shepler
> *Cc:* [email-masked]
> *Subject:* Re: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and
> comment)****
> ** **
> 5-10 minutes for 4.2.****
> ** **
> We might also need some time to finalize on 3530bis, especially i18n.****
> ** **
> ** **
> On May 29, 2013, at 8:46 AM, Spencer Shepler <[email-masked]>
> wrote:****
>
>
> ****
>
>  ****
> See below for the draft agenda at this time.  Please let me know what I
> have missed or needs to be adjusted…****
>  ****
> We have a number of topics it seems.  It also appears the content will be
> slides given the lack of backing I-Ds at this point.****
>  ****
> Let’s close by the end of today such that we can move forward with a
> meeting request if we need one.****
>  ****
> Spencer****
>  ****
>  ****
>  ****
>  ****
> NFSv4 Working Group****
> Berlin****
> July 28, 2013****
>  ****
>  ****
> Note Well****
>  ****
> Agenda Bashing****
>  ****
> Flexible File Layouts (Halevy) (15-20 minutes)****
>  ****
> FedFS issues (Lever) (15 minutes)****
>       - this is a placeholder; expecting additional detail for this item**
> **
>  ****
> pNFS Lustre layout (Faibish)****
>  ****
> Coherent data caching for NFS - (Eshel) (20 minutes)****
>  ****
> RPCSECGSSv3 - (williams - uncommittted)****
>  ****
> End-to-end Integrity - (Lever) (time ?)****
>  ****
> Versioning Model - (Noveck) (time ?)****
>  ****
>  ****
>  ****
> https://www.ietf.org/mailman/listinfo/nfsv4****
>
> ** **

---

From: Chuck Lever <[email-masked]>
Date: Thu, 30 May 2013 14:50:35 -0400

> http://datatracker.ietf.org/doc/draft-adamson-nfsv4-multi-domain-federated-fs-reqs/

Yes.

---

From: Spencer Shepler <[email-masked]>
Date: Thu, 30 May 2013 18:59:25 +0000

Okay.  Then the question is to the working group then.  Andy posted a message awhile back

http://www.ietf.org/mail-archive/web/nfsv4/current/msg11964.html

ask me about the options for the draft.

I took this to be a query for the working group in general.  It is the working group that needs to express interest, take time to review and provide feedback, generally move the I-D forward.

So, Chuck has expressed interest and in my mind others need to as well and then spend time reviewing the I-D.  Andy didn't ask for a slot for the next IETF meeting; thus we should use the WG alias to move this forward....

Spencer

From: Chuck Lever [mailto:[email-masked]]
Sent: Thursday, May 30, 2013 11:51 AM
To: spencer shepler
Cc: Spencer Shepler; [email-masked]
Subject: Re: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

On May 30, 2013, at 2:37 PM, spencer shepler <[email-masked]<mailto:[email-masked]>> wrote:

Yes.

Spencer

On Thu, May 30, 2013 at 7:51 AM, Chuck Lever <[email-masked]<mailto:[email-masked]>> wrote:
Hi Spencer-

On May 29, 2013, at 10:01 PM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing

From: Haynes, Tom [mailto:Tom.Haynes@<mailto:Tom.Haynes@>netapp.com<http://netapp.com/>]
Sent: Wednesday, May 29, 2013 9:51 AM
To: Spencer Shepler
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nfsv4] closing on the IETF87 NFSv4 WG meeting (review and comment)

5-10 minutes for 4.2.

Spencer

NFSv4 Working Group
Berlin
July 28, 2013

Note Well

Agenda Bashing