Subject: [nfsv4] Berlin July 31st agenda and various next steps

From: Spencer Shepler <[email-masked]>
Date: Mon, 22 Jul 2013 16:03:39 +0000

All,

Note: For a variety of personal and business related reasons, Beepy and I will not be attending the Berlin meeting in person.
We will be listening in to the audio and on jabber.  Tom Haynes has agreed to chair the meeting and our AD, Martin, will be present.

I have included the current Berlin meeting agenda below and note the removal of the RPCSECGSS place-holder.
At maximum agenda time, we are "over".  Tom will work with those presenting to manage the time appropriately.

--

We have a number of open items that need to be addressed by the working group.
These have been identified before and, IMO, effective progress has not been made on a majority of them.
Let's close on as many of these as possible in the coming weeks and use Berlin as a forcing function.

What follows is my enumeration and opinion of where we stand.  If I have these wrong or am missing something, please speak up. Ordering implies my priority for resolution.

1)      RFC3530bis - After an initial review by our AD and IESG, this document has been returned to the WG.  The main issue is related to I18N handling (capturing implemented practice vs. alignment with NFSv4.1). Note the FedFS documents are awaiting this as reference.

2)      RPCSECGSS-v3 - see next item

3)      NFSv4.2 - While we have completed the WG last call for this document, I am holding it for submission to AD/IESG for publication.  We must resolve the issue of RPCSECGSS-v3 use or dependency.  Given the lack of discussion and energy on RPCSECGSS-v3, I suggest that the dependency be broken in NFSv4.2 use of it.  Obviously, the RPCSECGSS-v3 work can continue forward but IMO creating the co-dependency is fraught with delay and it is better to break the dependency now and move forward with NFSv4.2.

4)      RFC5664bis - an email version of this has been supplied but a full submission must be made.  Once this is in, I will start a WG last call on the document such that we can move forward with its completion.

5)      Multi-domain FedFS - Given the lack of review/discussion from the WG on this topic, I believe we should revise the charter and remove the work item; as a reminder, there are two deliverables associated with this work: "NFSv4.0/4.1 Cross Domain FedFS Document" and "NFSv4 Multi-Domain best practice"

6)      Migration Issues I-D: this is making good progress, continue with the work as planned.

Thanks,
Spencer

NFSv4 Working Group
Berlin
0900-1130 CEST
Schoeneberg 1/2
July 31, 2013

Note Well

Agenda Bashing

NFSv4.2 open items (Haynes) (5-10 minutes)
http://datatracker.ietf.org/doc/draft-ietf-nfsv4-minorversion2/
http://datatracker.ietf.org/doc/draft-ietf-nfsv4-minorversion2-dot-x/

3530bis (e.g. I18N) (Haynes) (10 minutes)
http://datatracker.ietf.org/doc/draft-ietf-nfsv4-minorversion2-dot-x/
http://datatracker.ietf.org/doc/draft-ietf-nfsv4-rfc3530bis-dot-x/

ACL discussion (Haynes) (10 minutes)

Flexible File Layouts (Halevy) (15-20 minutes)
http://datatracker.ietf.org/doc/draft-bhalevy-nfsv4-flex-files/

FedFS issues (Lever) (15 minutes)
http://datatracker.ietf.org/doc/draft-cel-nfsv4-fedfs-security-addendum/

pNFS Lustre layout (Faibish) (20 minutes)
http://datatracker.ietf.org/doc/draft-faibish-nfsv4-pnfs-lustre-layout/

Coherent data caching for NFS - (Eshel) (20 minutes)

End-to-end Integrity - (Lever) (15 minutes)

Versioning Model - (Noveck) (20 minutes)

Metadata Striping - (Benjamin) (15 minutes)
http://datatracker.ietf.org/doc/draft-mbenjamin-nfsv4-pnfs-metastripe/

---

From: Chuck Lever <[email-masked]>
Date: Mon, 22 Jul 2013 12:45:47 -0400

Hi-

The "End-to-end Integrity" agenda item has an associated draft:

  http://datatracker.ietf.org/doc/draft-cel-nfsv4-end2end-data-protection/

Since we have a draft now, it can be discussed on the mailing list in lieu of rehashing this topic during the meeting.  I'll also be available outside of the WG meeting to discuss this.

Tom can consider the end-to-end agenda item as the first that can be dropped if we are short on time.

On Jul 22, 2013, at 12:03 PM, Spencer Shepler <[email-masked]> wrote:

> At maximum agenda time, we are “over”.  Tom will work with those presenting to manage the time appropriately.
>  
> --
>  
> Let’s close on as many of these as possible in the coming weeks and use Berlin as a forcing function.
>  
> 1)      RFC3530bis – After an initial review by our AD and IESG, this document has been returned to the WG.  The main issue is related to I18N handling (capturing implemented practice vs. alignment with NFSv4.1). Note the FedFS documents are awaiting this as reference.
> 2)      RPCSECGSS-v3 – see next item
> 3)      NFSv4.2 – While we have completed the WG last call for this document, I am holding it for submission to AD/IESG for publication.  We must resolve the issue of RPCSECGSS-v3 use or dependency.  Given the lack of discussion and energy on RPCSECGSS-v3, I suggest that the dependency be broken in NFSv4.2 use of it.  Obviously, the RPCSECGSS-v3 work can continue forward but IMO creating the co-dependency is fraught with delay and it is better to break the dependency now and move forward with NFSv4.2.
> 4)      RFC5664bis – an email version of this has been supplied but a full submission must be made.  Once this is in, I will start a WG last call on the document such that we can move forward with its completion.
> 5)      Multi-domain FedFS – Given the lack of review/discussion from the WG on this topic, I believe we should revise the charter and remove the work item; as a reminder, there are two deliverables associated with this work: “NFSv4.0/4.1 Cross Domain FedFS Document” and “NFSv4 Multi-Domain best practice”
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

-- 
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: Spencer Shepler <[email-masked]>
Date: Mon, 22 Jul 2013 17:04:23 +0000

Thanks for the generosity, Chuck.  I hope that we can keep it on the agenda.  If not, then some in person discussion would be good.

Btw: for this and any other topic that receives substantive discussion outside of the WG meeting, it would be great to see a short summary on the WG alias.

Spencer

From: Chuck Lever [mailto:[email-masked]]
Sent: Monday, July 22, 2013 9:46 AM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] Berlin July 31st agenda and various next steps

Hi-

On Jul 22, 2013, at 12:03 PM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

All,

--

Thanks,
Spencer

NFSv4 Working Group
Berlin
0900-1130 CEST
Schoeneberg 1/2
July 31, 2013

Note Well

Agenda Bashing

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4