Subject: [nfsv4] Vancouver IETF meeting (Nov 3-8) - Request for NFS working group items

From: Spencer Shepler <[email-masked]>
Date: Tue, 3 Sep 2013 16:06:54 +0000

Hello. The cutoff for working group meeting requests is Sept 23rd.

Please send (to the alias) work items that should be on the list for potential agenda items.

If you own a particular work item or are contributing to one and had planned on completing work or having something out for review between now and then, please note that as well for overall planning.

I would like to make a consensus call by Sept 18th for a decision if we will be asking for time in Vancouver.

Thanks,
Spencer

---

From: "Noveck, David" <[email-masked]>
Date: Tue, 3 Sep 2013 14:22:24 -0400

I'll be submitting one document regarding NFS extension/versioning by September 18.  In some sense it's a follow-up to my presentation at ietf 87. There's a chance that I will have as second document to submit before the IETF88 document submission deadline.  In any case, there will be only one meting slot needed.

I think we will need some more work on internationalization.  Even  if we clear the RFC3530bis hurdle, there will need to be work on a later document addressing internationalization for all NFSv4 protocols, dealing with précis, etc.  It seems the working group has to talk about what direction to take in that regard.

> I would like to make a consensus call by Sept 18th for a decision if we will be asking for time in Vancouver.

My view is that we should ask for time to meet in Vancouver.  Is there anybody that thinks we should not?

Our experience with IETF87 leads me to believe that even when there are people who think there will be nothing to discuss, it is not wise to plan based on their optimistic anticipation that everything will be resolved without any need for face-to-face group discussion.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Tuesday, September 03, 2013 12:07 PM
To: [email-masked]
Subject: [nfsv4] Vancouver IETF meeting (Nov 3-8) - Request for NFS working group items

Thanks,
Spencer

---

From: Chuck Lever <[email-masked]>
Date: Thu, 5 Sep 2013 16:00:26 -0400

> If you own a particular work item or are contributing to one and had planned on completing work or having something out for review between now and then, please note that as well for overall plannin…

I'm planning to update the NFS end-to-end draft before IETF 88, but I'm not planning a presentation at this time.

I can provide a very brief FedFS update as part of the normal NFS State of the Union presentation.  Agenda items for RFC3530bis, internationalization, NFSv4.2, and RPCGSS v3 progress reports go without saying.

The Linux client migration implementation is getting merged into upstream Linux.  I'm interested in any presentation or conversation on NFSv4 migration, and can report implementation experience, if desired.

During IETF 87, Sorin reported he has uncovered some NFS/RDMA performance scalability issues.  I'm interested in any follow-up on that work (focused on RDMA specifics rather than the Lustre components).

I'm interested in Dave Noveck's NFS extensibility work.

> I would like to make a consensus call by Sept 18th for a decision if we will be asking for time in Vancouver.

Fwiw, I'm in favor of meeting in Vancouver.

-- 
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: "Noveck, David" <[email-masked]>
Date: Fri, 6 Sep 2013 14:10:43 -0400

Ø  I can provide a very brief FedFS update as part of the normal NFS State of the Union presentation.  Agenda items for RFC3530bis, internationalization, NFSv4.2, and RPCGSS v3 progress reports go without saying.

It should go without saying, but it does make sense to say it.  Since you can't have an agenda item without someone to present it, we need to have volunteers who are willing to be present in Vancouver.  So here are my suggestions on who it makes sense to report on these items.

FedFS: Chuck
RFC3530bis: Tom
Internationalization:  Me, but if there is a travel approval issue, David Black is the right person to do this.
NFSv4.2: Tom
RPCGSS v3: Andy.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Chuck Lever
Sent: Thursday, September 05, 2013 4:00 PM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] Vancouver IETF meeting (Nov 3-8) - Request for NFS working group items

On Sep 3, 2013, at 12:06 PM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Spencer Shepler <[email-masked]>
Date: Fri, 6 Sep 2013 18:14:00 +0000

And the second requirement is that they agree with your assignments.

So Tom and Andy need to speak up.

Also, is there any particular reason that an "update" couldn't be done to the email alias?  Certainly having open discussion is great but awaiting the arrival of November's meeting shouldn't be a hold on update/progress/status-mongering... :)

Spencer

From: Noveck, David [mailto:[email-masked]]
Sent: Friday, September 6, 2013 11:11 AM
To: Chuck Lever; Spencer Shepler
Cc: [email-masked]
Subject: RE: [nfsv4] Vancouver IETF meeting (Nov 3-8) - Request for NFS working group items

?  I can provide a very brief FedFS update as part of the normal NFS State of the Union presentation.  Agenda items for RFC3530bis, internationalization, NFSv4.2, and RPCGSS v3 progress reports go without saying.

FedFS: Chuck
RFC3530bis: Tom

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Chuck Lever
Sent: Thursday, September 05, 2013 4:00 PM
To: Spencer Shepler
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nfsv4] Vancouver IETF meeting (Nov 3-8) - Request for NFS working group items

---

From: "McDonald, Alex" <[email-masked]>
Date: Fri, 6 Sep 2013 19:00:43 +0000

I"d appreciate a copy of your FedFS update prior to Vancouver if you have something ready. I'd like to promote it via the SNIA ESF sig by writing a summary blog; credit for the source material will be of course attributed.

Let me know what you think. Thanks.

Sent on my bb

From: Noveck, David [mailto:[email-masked]]
Sent: Friday, September 06, 2013 11:10 AM
To: Chuck Lever <[email-masked]>; Spencer Shepler <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [nfsv4] Vancouver IETF meeting (Nov 3-8) - Request for NFS working group items

It should go without saying, but it does make sense to say it.  Since you can’t have an agenda item without someone to present it, we need to have volunteers who are willing to be present in Vancouver.  So here are my suggestions on who it makes sense to report on these items.

FedFS: Chuck
RFC3530bis: Tom

---

From: "Haynes, Tom" <[email-masked]>
Date: Fri, 6 Sep 2013 22:40:54 +0000

On Sep 6, 2013, at 11:14 AM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

Squeaking up as requested.

---

From: "Matt W. Benjamin" <[email-masked]>
Date: Tue, 10 Sep 2013 19:09:36 -0400 (EDT)

Hi Spencer,

We'd like to express support for meeting in Vancouver.

We would like to present on client encryption, and potential protocol interactions wrt filename encoding, other metadata, named attributes, and end-to-end integrity concepts already being discussed.

Thanks,

Matt

----- "Spencer Shepler" <[email-masked]> wrote:

> Hello. The cutoff for working group meeting requests is Sept 23 rd .
> 
> 
> 
> If you own a particular work item or are contributing to one and had
> planned on completing work or having something out for review between
> now and then, please note that as well for overall planning.
> 
> 
> 
> I would like to make a consensus call by Sept 18 th for a decision if
> we will be asking for time in Vancouver.
> 
> 
> 
> Thanks,
> 
> Spencer 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

-- 
Matt Benjamin
The Linux Box
206 South Fifth Ave. Suite 150
Ann Arbor, MI  48104

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Andy Adamson <[email-masked]>
Date: Wed, 11 Sep 2013 08:54:50 -0400

I would also like to express support for meeting in Vancouver.

I'd like to report on an update to draft-ietf-nfsv4-rpcsec-gssv3 and
additional text to draft-ietf-nfsv4-minorversion2-19 as one option to
address the security requirements of inter-server server-side copy and
full mode labeled NFS.

-->Andy