Subject: [nfsv4] Mismatch between OPEN/share modes and actual permissions

From: "Adamson, Dros" <[email-masked]>
Date: Wed, 25 Sep 2013 19:35:32 +0000

This proposal by Trond seems to have been forgotten:

 http://www.ietf.org/mail-archive/web/nfsv4/current/msg10244.html

I think we should keep this in mind for NFSv4.3.

Should we include Trond's suggested change to RFC3530bis?

-dros

---

From: "Noveck, David" <[email-masked]>
Date: Thu, 26 Sep 2013 08:58:58 -0400

Up until I (crazy guy that I am :-), proposed it (in draft-dnoveck-nfs-extension-00), it had been assumed that we could not change the XDR in a bis document.

I do propose, in the referenced document, that we do allow this sort of thing but I propose that we limit ourselves to two cases:

	Bug fixes

      	Backport of working features from  a later minor version.

I don't think this is important enough to consider as a bug fix, but opinions might differ on that.

 > I think we should keep this in mind for NFSv4.3.

Why not NFSv4.2?  I don't see how this could be so important that it is worth putting into nfsv4.0, and so deferrable that we wouldn't put it into NFSv4.2.

> Should we include Trond's suggested change to RFC3530bis?

Only after it is in some current version (e.g. v4.2) and working.  This is the kind of thing that it makes sense to backport into v4.0, but if we do, we should make sure it also goes into v4.1 at the same time. (update document or maybe errata).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adamson, Dros
Sent: Wednesday, September 25, 2013 3:36 PM
To: [email-masked]
Subject: [nfsv4] Mismatch between OPEN/share modes and actual permissions

-dros
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Adamson, Dros" <[email-masked]>
Date: Thu, 26 Sep 2013 13:21:17 +0000

> Up until I (crazy guy that I am :-), proposed it (in draft-dnoveck-nfs-extension-00), it had been assumed that we could not change the XDR in a bis document.

The proposed change to the bis is different from the proposed change to v4.2 and doesn't change the XDR - it recommends adding an ACCESS call after the OPEN in the OPEN compound to work around the lack of an "open for execute" share mode.

> Why not NFSv4.2?  

NFSv4.2 sounds good to me.

> I don't see how this could be so important that it is worth putting into nfsv4.0, and so deferrable that we wouldn't put it into NFSv4.2.

Although they address the same problem, the proposed change to the bis is different from the proposed change to NFSv4.[2-3].

> Only after it is in some current version (e.g. v4.2) and working.  This is the kind of thing that it makes sense to backport into v4.0, but if we do, we should make sure it also goes into v4.1 at t…

The approach from the proposed change to the bis is already implemented in the Linux NFSv4 (.*) client as it's fully allowed by rfc3530 & rfc5661.

-dros