Subject: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

From: "Noveck, David" <[email-masked]>
Date: Tue, 10 Sep 2013 11:20:34 -0400

The -03 is due to expire within the next few weeks.

Despite the existence of draft-ietf-nfvs4-rfc3530-migration-update, I think we want to keep this in existence because:

*         It is the only published discussion of v4.1 issues for migration.

*         It provides a lot of the rationale for the changes in draft-ietf-nfvs4-rfc3530-migration-update, and is referred to in that document to explain the background and why the updates introduced in that document were made.

A diff between the .xml files for -03 and -04 is attached.  If you have any comments about those or know of other stuff that should be put in the -04, let me know.

---

From: Chuck Lever <[email-masked]>
Date: Tue, 10 Sep 2013 12:04:23 -0400

Dave-

For the record, is it still your plan that NFSv4.1-related migration issues will be discussed more fully in an as-yet-unwritten document?  The status of that document is "waiting for more implementation experience," correct?

On Sep 10, 2013, at 11:20 AM, "Noveck, David" <[email-masked]> wrote:

> ·         It is the only published discussion of v4.1 issues for migration.
> ·         It provides a lot of the rationale for the changes in draft-ietf-nfvs4-rfc3530-migration-update, and is referred to in that document to explain the background and why the updates introduced in that document were made.
>  

-- 
Chuck Lever
chuck[dot]lever[at]oracle[dot]com

---

From: "Noveck, David" <[email-masked]>
Date: Tue, 10 Sep 2013 12:55:45 -0400

I'm expecting there will be a standards-track document updating RFC5661, just as draft-ietf-nfsv4-rfc3530-migration-update will update RFC3530 or its successor RFC.

Ø  The status of that document is "waiting for more implementation experience,"

Actually the status of that (non)-document is "Does not exist yet" :)

However the reason for the non-existence is some combination of "Don't seem to have the time" and "Waiting for implementation experience".

From: Chuck Lever [mailto:[email-masked]]
Sent: Tuesday, September 10, 2013 12:04 PM
To: Noveck, David
Cc: nfsv4 list ([email-masked])
Subject: Re: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

Dave-

On Sep 10, 2013, at 11:20 AM, "Noveck, David" <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 10 Sep 2013 17:03:38 +0000

I would suggest that work not wait on an update of RFC5661.  If there is large errata or clarifications needed, it is likely best to capture those as individual RFCs such that they are available to the communicate in a time effective manner and present a "smaller" amount of work for closure.

Spencer

From: [email-masked] [mailto:[email-masked]] On Behalf Of Noveck, David
Sent: Tuesday, September 10, 2013 9:56 AM
To: Chuck Lever
Cc: nfsv4 list ([email-masked])
Subject: Re: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

?  The status of that document is "waiting for more implementation experience,"

From: Chuck Lever [mailto:[email-masked]]
Sent: Tuesday, September 10, 2013 12:04 PM
To: Noveck, David
Cc: nfsv4 list ([email-masked]<mailto:[email-masked]>)
Subject: Re: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

Dave-

---

From: "Noveck, David" <[email-masked]>
Date: Tue, 10 Sep 2013 13:40:27 -0400

From: Noveck, David
Sent: Tuesday, September 10, 2013 1:24 PM
To: 'Spencer Shepler'
Subject: RE: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

Ø  I would suggest that work not wait on an update of RFC5661.

I think we are in violent agreement.  The document I foresee will not wait on an update of RFC5661.  Instead, it will be an update of RFC5661.  This is the same as draft-ietf-rfc3530-migration-update which is marked "Updates: 3530  (when approved)", although we will likely change that to "Updates xxxx (when approved)" once we know xxxx, i.e. rfc3530bis's RFC number.

BTW, if there is a later document which obsoletes RFC5661, then it would have to incorporate all the updates made by the document we are thinking of (let's call it "draft-ietf-nfsv4-rfc5661-migration-update")

From: Spencer Shepler [mailto:[email-masked]]
Sent: Tuesday, September 10, 2013 1:04 PM
To: Noveck, David; Chuck Lever
Cc: nfsv4 list ([email-masked]<mailto:[email-masked]>)
Subject: RE: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

Spencer

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Noveck, David
Sent: Tuesday, September 10, 2013 9:56 AM
To: Chuck Lever
Cc: nfsv4 list ([email-masked]<mailto:[email-masked]>)
Subject: Re: [nfsv4] new version of draft-ietf-nfsv4-migration-issues

>  The status of that document is "waiting for more implementation experience,"

Dave-

---

From: "Haynes, Tom" <[email-masked]>
Date: Tue, 10 Sep 2013 18:27:09 +0000

On Sep 10, 2013, at 10:03 AM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

it is likely best to capture those as individual RFCs such that they are available to the communicate in a time effective manner and present a “smaller” amount of work for closure.

Amen.