Subject: [nfsv4] Regarding NFSv4 File Open Operation

From: siva sankar <[email-masked]>
Date: Wed, 23 Oct 2013 17:36:08 +0800 (SGT)

Hi,

I am trying out to patch the kernel NFSv4 file_operations open() call.

But, from the logs, i don't see open() call being fired for file(present on shared nfs server) open operartion(cat /mnt/share/abc.txt).

However, in case of NFSv3, i could see open() call being fired for same file(present on shared nfs server) open operation.

Can anybody let me me how to patch open() system call in NFSv4?
Basically, i want my patch function to be fired first which will internally invoke the actual NFSv4's open call.

I am working on RHEL6.4 kernel v2.6.32 64-Bit.

Thanks in advance.

Regards,
Siva

---

From: "J. Bruce Fields" <[email-masked]>
Date: Fri, 25 Oct 2013 13:49:11 -0400

> I am working on RHEL6.4 kernel v2.6.32 64-Bit.

This list is for discussions of the NFSv4 protocol.  For questions about
the linux implemenation of NFSv4, please use [email-masked].

--b.