Subject: Re: [nfsv4] [PATCH 2/2] Destroy copy_confirm_auth handle when copy_from_auth destroyed

From: Andy Adamson <[email-masked]>
Date: Mon, 7 Jul 2014 08:37:37 -0400

On Mon, Jun 30, 2014 at 1:33 PM, Tom Haynes
<[email-masked]> wrote:
>
> On Jun 27, 2014, at 10:49 AM, [email-masked] wrote:
>
>> From: Andy Adamson <[email-masked]>
>>
>> Signed-off-by: Andy Adamson <[email-masked]>
>> ---
>> nfsv42_middle_copy.xml | 8 ++++++++
>> 1 file changed, 8 insertions(+)
>>
>> diff --git a/nfsv42_middle_copy.xml b/nfsv42_middle_copy.xml
>> index 928758d..6de7836 100644
>> --- a/nfsv42_middle_copy.xml
>> +++ b/nfsv42_middle_copy.xml
>> @@ -1058,6 +1058,14 @@
>>           </t>
>>
>>           <t>
>> +           The copy_confirm_auth RPCSEC_GSS3 handle is associated with a
>> +           copy_from_auth RPCSEC_GSS3 handle on the source server via
>> +           the shared secret and MUST be locally destroyed
>> +           (no RPCSEC_GSS3_DESTROY as the source server is no the initator)
>
> The second “no” is definitely a “not”.
>
> Is the first as well?

No - just the second. Could say (there is no RPCSEC_GSS3_DESTROY as
the source server is not the initiator).

-->Andy

>
> Thanks.
>
>
>> +           when the copy_from_auth RPCSEC_GSSv3 handle is destroyed.
>> +          </t>
>> +
>> +          <t>
>>             If the client sends an OFFLOAD_CANCEL to the source server to
>>             rescind the destination server's synchronous copy privilege, it
>>             uses the privileged "copy_from_auth" RPCSEC_GSSv3 handle and the
>> --
>> 1.8.5.2 (Apple Git-48)
>>
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Tom Haynes <[email-masked]>
Date: Mon, 14 Jul 2014 12:45:56 -0400

Agreed, can you resubmit the patch set with those changes?