Subject: [nfsv4] RPCSEC_GSSv3/LNFS and NFSv4.2 draft status

From: Tom Haynes <[email-masked]>
Date: Mon, 14 Jul 2014 17:03:16 -0400

Thanks for the edits Andy, I’ve pushed them out.

Having said that, I’m about to nuke the wording on delegations with LNFS. A little birdie
(okay, Trond) pointed out a serious issue with that approach:

> The file I/O operations are the only ones that take delegation
> stateids; the rest can't be protected this way.
> Furthermore, a bunch of operations actually require you to _discard_
> the delegation before execution (e.g. unlink(), rename(), ...) so
> cannot even be protected by implication.

I’m not going to advocate the CB method nor the change_sec_label.

Instead, I’m going to point out the issue, that we don’t have enough data
on how often a label changes (we suspect it is very rare), etc. The client
can grab a new copy of the attribute if it cares. But any other approach
needs to wait until we get implementation experience, which means 4.3.

---

From: "Adamson, Andy" <[email-masked]>
Date: Mon, 14 Jul 2014 21:47:18 +0000

> Thanks for the edits Andy, I’ve pushed them out.

You’re welcome - and good.
>> cannot even be protected by implication.

Good points WRT delegations.

> needs to wait until we get implementation experience, which means 4.3.

OK :) 

—>Andy
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4