Subject: Re: [nfsv4] New Version Notification for draft-haynes-nfsv4-versioning-02.txt

From: Tom Haynes <[email-masked]>
Date: Mon, 10 Nov 2014 17:48:49 -0800

Hi Spencer,

In the discussions on list, I’ve seen support for taking this as a WG document.

The plan would be to remove Section 2 from the NFSv4.2 draft and point
the reader there (as an Informative Reference) to this document. I.e., do not
gate NFSv4.2 on this document.

We would then reach consensus on this document in the WG and push it
through.

So, I am asking that we take this as a WG document.

Thanks,
Tom

> On Nov 10, 2014, at 5:44 PM, [email-masked] wrote:
> 
> 
> A new version of I-D, draft-haynes-nfsv4-versioning-02.txt
> has been successfully submitted by Thomas Haynes and posted to the
> IETF repository.
> 
> Name:		draft-haynes-nfsv4-versioning
> Revision:	02
> Title:		NFSv4 Version Management
> Document date:	2014-11-10
> Group:		Individual Submission
> Pages:		20
> URL:            http://www.ietf.org/internet-drafts/draft-haynes-nfsv4-versioning-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-haynes-nfsv4-versioning/
> Htmlized:       http://tools.ietf.org/html/draft-haynes-nfsv4-versioning-02
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-haynes-nfsv4-versioning-02
> 
> Abstract:
>   This document describes the management of versioning within the NFSv4
>   family of protocols.  It covers the creation of minor versions, the
>   addition of OPTIONAL features to existing minor versions, and the
>   correction of flaws in features already published as Proposed
>   Standards.  The rules for minor versioning set out in this document
>   supersede the multiple sets of minor versioning rules in RFC3530 and
>   RFC5661.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 11 Nov 2014 18:34:44 +0000

Tom,

I agree with the summary of the WG's interest in the work and the need to separate it from the NFSv4.2 I-D.

As to the reference from the NFSv4.2 specification, it will need to be a general reference and not a reference to another I-D such that NFSv4.2 can move forward.

Please proceed.

Spencer

> -----Original Message-----
> From: Tom Haynes [mailto:[email-masked]]
> Sent: Monday, November 10, 2014 5:49 PM
> To: Spencer Shepler
> Cc: NFSv4
> Subject: Re: New Version Notification for draft-haynes-nfsv4-versioning-02.txt
> 
> Hi Spencer,
> 
> The plan would be to remove Section 2 from the NFSv4.2 draft and point the
> reader there (as an Informative Reference) to this document. I.e., do not gate
> NFSv4.2 on this document.
> 
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >