Subject: [nfsv4] [[email-masked]: New Version Notification for draft-hellwig-nfsv4-scsi-layout-01.txt]

From: Christoph Hellwig <[email-masked]>
Date: Mon, 23 Mar 2015 20:35:39 +0100

I've posted a new version of the scsi-layouts draft, this contains
various minor changes, mostly based on the feedback from Bruce.

----- Forwarded message from [email-masked] -----

Date: Mon, 23 Mar 2015 12:34:33 -0700
From: [email-masked]
Subject: New Version Notification for draft-hellwig-nfsv4-scsi-layout-01.txt
To: Christoph Hellwig <[email-masked]>, Christoph Hellwig <[email-masked]>

A new version of I-D, draft-hellwig-nfsv4-scsi-layout-01.txt
has been successfully submitted by Christoph Hellwig and posted to the
IETF repository.

Name:		draft-hellwig-nfsv4-scsi-layout
Revision:	01
Title:		Parallel NFS (pNFS) SCSI Layout
Document date:	2015-03-23
Group:		Individual Submission
Pages:		12
URL:            http://www.ietf.org/internet-drafts/draft-hellwig-nfsv4-scsi-layout-01.txt
Status:         https://datatracker.ietf.org/doc/draft-hellwig-nfsv4-scsi-layout/
Htmlized:       http://tools.ietf.org/html/draft-hellwig-nfsv4-scsi-layout-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-hellwig-nfsv4-scsi-layout-01

Abstract:
   Parallel NFS (pNFS) extends Network File Sharing version 4 (RFC5661)
   to allow clients to directly access file data on the storage used by
   the NFSv4 server.  This ability to bypass the server for data access
   can increase both performance and parallelism, but requires
   additional client functionality for data access, some of which is
   dependent on the class of storage used.  The main pNFS operations
   document specifies storage-class-independent extensions to NFS, the
   pNFS Block/Volume Layout (RFC5663) specifies the additional
   extensions for use of pNFS with block-and volume-based storage, while
   this document provides extensions to the pNFS Block/Volume Layout
   document to provide reliable fencing and better device
   discoverability for SCSI based shared storage devices.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

----- End forwarded message -----

---

From: Tom Haynes <[email-masked]>
Date: Tue, 24 Mar 2015 09:37:52 -0500

This looks stable. I’d like to propose we make it a WG document.

Any objections from the WG?

> On Mar 23, 2015, at 2:35 PM, Christoph Hellwig <[email-masked]> wrote:
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 24 Mar 2015 16:00:05 +0000

Thanks, Tom.  Reasonable suggestion.  As Tom suggests, any comments/concerns before we move this to WG doc?

> -----Original Message-----
> From: nfsv4 [mailto:[email-masked]] On Behalf Of Tom Haynes
> Sent: Tuesday, March 24, 2015 7:38 AM
> To: Christoph Hellwig
> Cc: [email-masked]
> Subject: Re: [nfsv4] [[email-masked]: New Version Notification for
> draft-hellwig-nfsv4-scsi-layout-01.txt]
> 
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >

---

From: "Black, David" <[email-masked]>
Date: Tue, 24 Mar 2015 16:06:33 +0000

I support WG adoption of this draft - I still need to find the time to do a careful
review of the SCSI aspects, but this draft is a good thing to do, IMHO.

Thanks,
--David

> From: nfsv4 [mailto:[email-masked]] On Behalf Of Spencer Shepler
> Sent: Tuesday, March 24, 2015 12:00 PM
> To: Tom Haynes; Christoph Hellwig
> Cc: [email-masked]
> > > URL:            http://www.ietf.org/internet-drafts/draft-hellwig-nfsv4-
> scsi-
> > layout-01.txt
> > > Diff:           http://www.ietf.org/rfcdiff?url2=draft-hellwig-nfsv4-scsi-
> layout-
> > 01
> > >
> > > Abstract: