Subject: [nfsv4] draft-ietf-nfsv4-minorversion2-dot-x-33.txt corrections

From: "Mora, Jorge" <[email-masked]>
Date: Thu, 12 Mar 2015 21:53:56 +0000

The only attributes new to NFSV4.2 are 78, 79 and 80, so the following:

   /// %/*
   /// % * new to NFSV4.1
   /// % */
   /// const FATTR4_DIR_NOTIF_DELAY    = 56;
   /// const FATTR4_DIRENT_NOTIF_DELAY = 57;
   /// const FATTR4_DACL               = 58;
   /// const FATTR4_SACL               = 59;
   /// const FATTR4_CHANGE_POLICY      = 60;
   ///
   /// %/*
   /// % * new to NFSV4.2
   /// % */
   /// const FATTR4_FS_STATUS          = 61;
   /// const FATTR4_FS_LAYOUT_TYPES    = 62;
   /// const FATTR4_LAYOUT_HINT        = 63;
   /// const FATTR4_LAYOUT_TYPES       = 64;
   /// const FATTR4_LAYOUT_BLKSIZE     = 65;
   /// const FATTR4_LAYOUT_ALIGNMENT   = 66;
   /// const FATTR4_FS_LOCATIONS_INFO  = 67;
   /// const FATTR4_MDSTHRESHOLD       = 68;
   /// const FATTR4_RETENTION_GET      = 69;
   /// const FATTR4_RETENTION_SET      = 70;
   /// const FATTR4_RETENTEVT_GET      = 71;
   /// const FATTR4_RETENTEVT_SET      = 72;
   /// const FATTR4_RETENTION_HOLD     = 73;
   /// const FATTR4_MODE_SET_MASKED    = 74;
   /// const FATTR4_FS_CHARSET_CAP     = 76;
   /// /* 77 is currently unused */
   /// const FATTR4_SPACE_FREED        = 78;
   /// const FATTR4_CHANGE_ATTR_TYPE   = 79;
   /// const FATTR4_SEC_LABEL          = 80;

Should be:

   /// %/*
   /// % * new to NFSV4.1
   /// % */
   /// const FATTR4_DIR_NOTIF_DELAY    = 56;
   /// const FATTR4_DIRENT_NOTIF_DELAY = 57;
   /// const FATTR4_DACL               = 58;
   /// const FATTR4_SACL               = 59;
   /// const FATTR4_CHANGE_POLICY      = 60;
   /// const FATTR4_FS_STATUS          = 61;
   /// const FATTR4_FS_LAYOUT_TYPES    = 62;
   /// const FATTR4_LAYOUT_HINT        = 63;
   /// const FATTR4_LAYOUT_TYPES       = 64;
   /// const FATTR4_LAYOUT_BLKSIZE     = 65;
   /// const FATTR4_LAYOUT_ALIGNMENT   = 66;
   /// const FATTR4_FS_LOCATIONS_INFO  = 67;
   /// const FATTR4_MDSTHRESHOLD       = 68;
   /// const FATTR4_RETENTION_GET      = 69;
   /// const FATTR4_RETENTION_SET      = 70;
   /// const FATTR4_RETENTEVT_GET      = 71;
   /// const FATTR4_RETENTEVT_SET      = 72;
   /// const FATTR4_RETENTION_HOLD     = 73;
   /// const FATTR4_MODE_SET_MASKED    = 74;
   /// const FATTR4_FS_CHARSET_CAP     = 76;
   /// /* 77 is currently unused */

   ///
   /// %/*
   /// % * new to NFSV4.2
   /// % */

/// const FATTR4_SPACE_FREED = 78; /// const FATTR4_CHANGE_ATTR_TYPE = 79; /// const FATTR4_SEC_LABEL = 80;

Also, why are there lots of "%" characters all over the document?

-Jorge

---

From: Tom Haynes <[email-masked]>
Date: Mon, 16 Mar 2015 18:31:07 -0700

> On Mar 12, 2015, at 2:53 PM, Mora, Jorge <[email-masked]> wrote:
> 

I’ve noticed some issues around this even with the v4.1. I’ll fix this up.

> 
> Also, why are there lots of “%” characters all over the document?
> 

I think it is something to do with rpcgen….

> 
> —Jorge
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4