Subject: [nfsv4] NFS4.2 netloc_type4 definition

From: Olga Kornievskaia <[email-masked]>
Date: Thu, 5 Mar 2015 09:49:58 -0500

Hi folks,

netloc_type4 enum defines values starting from 0. Isn't it customary
to start from 1 (and assume 0 is an invalid valid that implementation
can check for)?

Thanks.

---

From: Tom Haynes <[email-masked]>
Date: Thu, 5 Mar 2015 10:11:40 -0800

> On Mar 5, 2015, at 6:49 AM, Olga Kornievskaia <[email-masked]> wrote:
> 
> Hi folks,
> 

Plenty of counter examples:

time_how4
change_attr_type4
data_content4
stable_how4
createmode4
opentype4

That said, 

diff --git a/dotx.d/spit_types.sh b/dotx.d/spit_types.sh
index 1f9599e..fdd4abf 100755
--- a/dotx.d/spit_types.sh
+++ b/dotx.d/spit_types.sh
@@ -1279,9 +1279,9 @@ EOF
 
 cat << EOF > $i
 enum netloc_type4 {
-	NL4_NAME	= 0,
-	NL4_URL		= 1,
-	NL4_NETADDR	= 2
+	NL4_NAME	= 1,
+	NL4_URL		= 2,
+	NL4_NETADDR	= 3
 };
 union netloc4 switch (netloc_type4 nl_type) {
 	case NL4_NAME:		utf8str_cis nl_name;

---

From: Olga Kornievskaia <[email-masked]>
Date: Thu, 5 Mar 2015 13:56:55 -0500

Thanks.

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4