Subject: [nfsv4] [PATCH] *** Proposed change on stats ***

From: Tom Haynes <[email-masked]>
Date: Fri, 10 Apr 2015 11:13:56 -0700

In looking at the stats, the size of the count was
unbalanced. Also, the restriction of resetting the
stats seems harsh.

Comments?

Tom Haynes (1):
  Allow for accumlation of stats

 dotx.d/type_io_info.x            | 2 +-
 nfsv42_middle_op_layoutstats.xml | 6 ++++--
 2 files changed, 5 insertions(+), 3 deletions(-)

-- 
1.8.3.1

---

From: Tom Haynes <[email-masked]>
Date: Fri, 10 Apr 2015 11:13:57 -0700

Signed-off-by: Tom Haynes <[email-masked]>
---
 dotx.d/type_io_info.x            | 2 +-
 nfsv42_middle_op_layoutstats.xml | 6 ++++--
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/dotx.d/type_io_info.x b/dotx.d/type_io_info.x
index fa1a22a..1c628f4 100644
--- a/dotx.d/type_io_info.x
+++ b/dotx.d/type_io_info.x
@@ -1,4 +1,4 @@
 struct io_info4 {
-	uint32_t	ii_count;
+	uint64_t	ii_count;
 	uint64_t	ii_bytes;
 };
diff --git a/nfsv42_middle_op_layoutstats.xml b/nfsv42_middle_op_layoutstats.xml
index d0773a5..f7e26a1 100644
--- a/nfsv42_middle_op_layoutstats.xml
+++ b/nfsv42_middle_op_layoutstats.xml
@@ -54,8 +54,10 @@
     </t>
 
     <t>
-      The client MUST reset the statistics after getting a
-      successfully reply from the metadata server.  The first
+      The statistics are cummulative, i.e., multiple LAYOUTSTATS
+      updates can be in flight at the same time. The metadata
+      server can examine the packet's timestamp to order the
+      different calls.  The first
       LAYOUTSTATS sent by the client SHOULD be from the opening
       of the file.  The choice of how often to update the metadata
       server is made by the client.
-- 
1.8.3.1

---

From: Benny Halevy <[email-masked]>
Date: Sat, 11 Apr 2015 11:35:32 +0300

Makes sense
On Apr 10, 2015 21:14, "Tom Haynes" <[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>