Subject: [nfsv4] Request for information

From: "McDonald, Alex" <[email-masked]>
Date: Mon, 20 Apr 2015 16:10:36 +0000

Chapesses and chaps

I'm looking for some background information on the flexfiles layout proposal for some work I'm doing on behalf of the SNIA Ethernet Storage Forum. This information will be used to update the whitepaper on NFSv4 and as part of a series of webcasts promoting file protocols that the SNIA ESF do on a regular basis.

I've read the draft and have some of the more recent conversations from this list. I'm looking for backgrounders or summaries of the proposal that covers the use cases, either documents or web based, and if anyone would be as kind to take a 30 minute toll free phone call from me after I've digested the information that would be much appreciated.

I can be contacted directly on alexmc at netapp dot com. Thanks in advance. 

Alex McDonald
Standards & Industry Associations Group
CTO Office
NetApp

---

From: Benny Halevy <[email-masked]>
Date: Tue, 21 Apr 2015 15:08:12 +0300

Hi Alex, the original use cases were discussed here:
http://www.ietf.org/proceedings/85/slides/slides-85-nfsv4-2.pdf

NSF Objects is the predecessor of the flex files layout where
the original idea was to extend the objects layout to allow using nfs
as the storage protocol.  Eventually, after taking into account the working
group feedback it seemed more appealing to change direction slightly and
define a layout that will be a rough superset of the original files layout
yet provide a more flexible per-file layout, as described in the
presentation.

I'll be happy to discuss further in more details over the phone.

Regards,

Benny

On Mon, Apr 20, 2015 at 7:10 PM, McDonald, Alex <[email-masked]>
wrote:

> Chapesses and chaps
>
> I'm looking for some background information on the flexfiles layout
> proposal for some work I'm doing on behalf of the SNIA Ethernet Storage
> Forum. This information will be used to update the whitepaper on NFSv4 and
> as part of a series of webcasts promoting file protocols that the SNIA ESF
> do on a regular basis.
>
> I've read the draft and have some of the more recent conversations from
> this list. I'm looking for backgrounders or summaries of the proposal that
> covers the use cases, either documents or web based, and if anyone would be
> as kind to take a 30 minute toll free phone call from me after I've
> digested the information that would be much appreciated.
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: "McDonald, Alex" <[email-masked]>
Date: Tue, 21 Apr 2015 12:16:20 +0000

Thanks Benny, appreciated.

Alex McDonald
Standards & Industry Associations Group
CTO Office
NetApp
+44 7795 046686 Mobile Phone
[email-masked]<mailto:[email-masked]>
twitter: @alextangent<http://twitter.com/alextangent>
Follow us: [Description: Description: Facebook] <http://www.facebook.com/NetApp?REF_SOURCE=ems-facebook> [Description: Description: Twitter] <http://twitter.com/#netapp?REF_SOURCE=ems-twitter> [Description: Description: Linked In] <http://www.linkedin.com/groups/NetApp-111681/about?REF_SOURCE=ems-linkedin> [Description: Description: YouTube] <http://www.youtube.com/user/NetAppTV?REF_SOURCE=ems-youtube> [Description: Description: Slideshare] <http://www.slideshare.net/NetApp?REF_SOURCE=ems-slideshare> [Description: Description: Community] <https://communities.netapp.com/welcome?REF_SOURCE=ems-cty>

From: nfsv4 [mailto:[email-masked]] On Behalf Of Benny Halevy
Sent: 21 April 2015 13:08
To: McDonald, Alex
Cc: [email-masked]
Subject: Re: [nfsv4] Request for information

yet provide a more flexible per-file layout, as described in the presentation.

Regards,

Benny

On Mon, Apr 20, 2015 at 7:10 PM, McDonald, Alex <[email-masked]<mailto:[email-masked]>> wrote:
Chapesses and chaps

Alex McDonald

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4