Subject: [nfsv4] [Technical Errata Reported] RFC7530 (4471)

From: RFC Errata System <[email-masked]>
Date: Sat, 12 Sep 2015 02:09:00 -0700 (PDT)

The following errata report has been submitted for RFC7530,
"Network File System (NFS) Version 4 Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7530&eid=4471

--------------------------------------
Type: Technical
Reported by: Marcel Telka <[email-masked]>

Section: 16.10.4.

Original Text
-------------
   In the case that the lock is denied, the owner, offset, and length of
   a conflicting lock are returned.

Corrected Text
--------------
   In the case that the lock is denied, the owner, offset, length, and
   type of a conflicting lock are returned.

Notes
-----
The locktype in LOCK4denied is not specified for the LOCK operation.  See 16.11.4. for similar wording for LOCKT.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7530 (draft-ietf-nfsv4-rfc3530bis-35)
--------------------------------------
Title               : Network File System (NFS) Version 4 Protocol
Publication Date    : March 2015
Author(s)           : T. Haynes, Ed., D. Noveck, Ed.
Category            : PROPOSED STANDARD
Source              : Network File System Version 4
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: David Noveck <[email-masked]>
Date: Sat, 19 Sep 2015 06:04:23 -0400

The correction is a valid one.
On Sep 12, 2015 5:09 AM, "RFC Errata System" <[email-masked]>
wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>