Subject: Re: [nfsv4] WG Last call for NFSv4.0 migration: Specification Update - ends Sept 4th.

From: Spencer Shepler <[email-masked]>
Date: Fri, 11 Sep 2015 07:01:21 +0000

Apologies if I missed them but are there any outstanding comments/feedback for this last call?

Any comments, even in the affirmative, would be helpful.

Spencer

From: nfsv4 [mailto:[email-masked]] On Behalf Of Spencer Shepler
Sent: Wednesday, August 12, 2015 11:03 AM
To: NFSv4 <[email-masked]>
Subject: [nfsv4] WG Last call for NFSv4.0 migration: Specification Update - ends Sept 4th.

Per Dave's request, we are starting WG last call for:

NFSv4.0 migration: Specification Update
http://datatracker.ietf.org/doc/draft-ietf-nfsv4-rfc3530-migration-update/<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fdatatracker.ietf.org%2fdoc%2fdraft-ietf-nfsv4-rfc3530-migration-update%2f&data=01%7c01%7csshepler%40microsoft.com%7cecf7dc90b97e4fb3ced708d2a34033ff%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=lUQXYyIjMuajjHm4wh%2fPKL95UYGYliYMalbBRwkgngc%3d>

You will find the text version of the document located here:

https://www.ietf.org/id/draft-ietf-nfsv4-rfc3530-migration-update-07.txt<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fid%2fdraft-ietf-nfsv4-rfc3530-migration-update-07.txt&data=01%7c01%7csshepler%40microsoft.com%7cecf7dc90b97e4fb3ced708d2a34033ff%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=RYrLfb%2f1d7p47d3SZyLHD8zmFGAcfqbiBTtjcRbbZ0g%3d>

Given the end of summer timing, we will run this last call through Sept 4th.

Please let me know if this is insufficient time for the review.

As always, comments should be directed to the author and the WG alias.

Thanks,
Spencer

---

From: Chuck Lever <[email-masked]>
Date: Fri, 11 Sep 2015 10:36:17 -0400

Hi Spencer-

I've prototyped many of the recommendations in this document
in the Linux NFS client. They successfully address the issues
with state migration in NFSv4.0 (RFC 7530).

On Sep 11, 2015, at 3:01 AM, Spencer Shepler <[email-masked]> wrote:

> Per Dave’s request, we are starting WG last call for:
>  
> http://datatracker.ietf.org/doc/draft-ietf-nfsv4-rfc3530-migration-update/
>  
> https://www.ietf.org/id/draft-ietf-nfsv4-rfc3530-migration-update-07.txt
>  
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

--
Chuck Lever

---

From: Spencer Shepler <[email-masked]>
Date: Fri, 11 Sep 2015 15:39:57 +0000

Thank you, Chuck.

Any other comments or implementation experience?

Spencer

-----Original Message-----
From: Chuck Lever [mailto:[email-masked]] 
Sent: Friday, September 11, 2015 7:36 AM
To: Spencer Shepler <[email-masked]>
Cc: NFSv4 <[email-masked]>
Subject: Re: [nfsv4] WG Last call for NFSv4.0 migration: Specification Update - ends Sept 4th.

Hi Spencer-

I've prototyped many of the recommendations in this document in the Linux NFS client. They successfully address the issues with state migration in NFSv4.0 (RFC 7530).

On Sep 11, 2015, at 3:01 AM, Spencer Shepler <[email-masked]> wrote:

> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fdatatr
> acker.ietf.org%2fdoc%2fdraft-ietf-nfsv4-rfc3530-migration-update%2f&da
> ta=01%7c01%7csshepler%40microsoft.com%7c332f04ffb9f64d8339d108d2bab65c
> de%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=1gSjQa2DIkSH1NOUGnhlKq
> JYv3cJSjcpPoW6S4qEb8E%3d
>  
> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.i
> etf.org%2fid%2fdraft-ietf-nfsv4-rfc3530-migration-update-07.txt&data=0
> 1%7c01%7csshepler%40microsoft.com%7c332f04ffb9f64d8339d108d2bab65cde%7
> c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=p3Q4IBJGLAyoCq2mNg89ho2s3P
> MGcE7dfDpdcksvqpw%3d
>  
> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.i
> etf.org%2fmailman%2flistinfo%2fnfsv4&data=01%7c01%7csshepler%40microso
> ft.com%7c332f04ffb9f64d8339d108d2bab65cde%7c72f988bf86f141af91ab2d7cd0
> 11db47%7c1&sdata=AxunZtEPTtMuHDvi79A8IDTAXmdPCOuAo5Pk2jkBzTk%3d

--
Chuck Lever

---

From: Chuck Lever <[email-masked]>
Date: Sat, 12 Sep 2015 14:04:56 -0400

> Any other comments or implementation experience?

The Solaris NFS team has prototyped two server-side elements
of the migration I-D:

 - The server expects GETATTR + RENEW in response to
    NFS4ERR_LEASE_MOVED.

 - State-bearing operations return NFS4ERR_DELAY on the PUTFH
    in the same compound.

Lease merging (enabled by UCS clients) has not been prototyped.

My Linux client prototype interoperates with the Solaris
server prototype.

--
Chuck Lever