Subject: Re: [nfsv4] review of draft-ietf-nfsv4-minorversion2-39.txt

From: Tom Haynes <[email-masked]>
Date: Sat, 17 Oct 2015 10:37:39 -0400

Hi Jorge,

Thanks for the review and especially checking the tables - I really appreciate that
last part!

Thanks,
Tom

> On Sep 15, 2015, at 3:50 PM, Mora, Jorge <[email-masked]> wrote:
> 
> Minor corrections:
> 
> *** On the sixth paragraph on section:
> 4.10.1.1.5.  Finishing or Stopping a Secure Inter-Server Copy
> 
>    stored on the destination server.  The destination server will then
>    delete the <"copy_to_auth", user id, source list, nounce, nounce MIC,
>    context handle, handle version> privilege and the associated
>    "copy_confirm_auth" RPCSEC_GSSv3 handle.  The client MUST destroy
> 
> What is "bounce"?

A RPCSEC_GSSv3 term, see that document?

> What are the "<" and ">"? Is the list enclosed by "<" and ">" related to "privilege”?

Yes

> 
> 
> *** Spelling error "uiniquely" on second paragraph on section:
> 4.10.1.2.  Inter-Server Copy via ONC RPC without RPCSEC_GSS
> 
>    used to uiniquely identify the destination server to the source
> 
> 

fixed

> 
> *** Spelling error "delallocates" on 13th paragraph on section:
> 7.  Space Reservation
> 
>    DEALLOCATE  This operation delallocates the blocks backing a region
> 

fixed

> 
> 
> *** Missing IO_ADVISE from Table 2 on section:
> 11.2.  New Operations and Their Valid Errors

fixed

> 
> 
> *** Missing IO_ADVISE from the table "Operations" on section:
> 13.  Operations: REQUIRED, RECOMMENDED, or OPTIONAL

fixed

> 
> Also, this table and the next table "Callback Operations" don't have a table number.
> These should be "Table 5" and "Table 6" respectively and all other table
> numbers must be adjusted.

Is that a “MUST” or a “must”. :-)

This is controlled by having an existing reference to the table. Since there are none, no numbers
were generated.

However, I see the use of having numbers later, so I added these as suggested.

> 
> 
> *** Spelling error "destinaton" on sixth paragraph on section:
> 15.3.3.  DESCRIPTION
> 
>    know which netloc4 network location the destinaton might use to
>  

fixed

> 
> *** Duplicate word "the the" on 7th paragraph on section:
> 15.10.3.  DESCRIPTION
> 
>    di_length returned MAY be for the entire hole.  If the the owner has
> 

fixed

> 
> 
> *** Spelling error "o" and "wlll" on 8th paragraph on section:
> 15.13.3.  DESCRIPTION
> 
>    multiple o the clone block size wlll be zeroed.
> 

fixed

> 
> 
> *** Duplicate word "see see" on 9th paragraph on section:
> 15.13.3.  DESCRIPTION
> 
>    The CLONE operation is atomic in that other operations may not see     <--
>    see any intermediate states between the state of the two files before
> 

fixed

> 
> —Jorge
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Tom Haynes <[email-masked]>
Date: Sat, 17 Oct 2015 11:41:50 -0400

> On Oct 17, 2015, at 10:37 AM, Tom Haynes <[email-masked]> wrote:
> 
> Hi Jorge,
> 
>> On Sep 15, 2015, at 3:50 PM, Mora, Jorge <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Minor corrections:
>> 

So these should be “nonce”.

But Andy, I see you’ve removed that from draft 12 of the RPCSEC_GSSv3 document (might
have been removed earlier, but I’m just checking the last one).

Do we need to make a change here?

---

From: "Adamson, Andy" <[email-masked]>
Date: Mon, 19 Oct 2015 18:58:04 +0000

> On Oct 17, 2015, at 11:41 AM, Tom Haynes <[email-masked]> wrote:
> 
> 

Yes - thought I’d caught all those references. Thanks Jorge.

Please change this:

to this:

stored on the destination server.  The destination server will then
   delete the <"copy_to_auth", user id, source list> privilege and the associated
   "copy_confirm_auth" RPCSEC_GSSv3 handle.  The client MUST destroy

—>Andy