Subject: [nfsv4] [PATCH 1/1] Detail on NFS4ERR_PARTNER_NO_AUTH use for server to server copy

From: <[email-masked]>
Date: Tue, 17 Nov 2015 11:08:12 -0500

From: Andy Adamson <[email-masked]>

Signed-off-by: Andy Adamson <[email-masked]>
---
 nfsv42_middle_copy.xml       | 16 ++++++++++++++--
 nfsv42_middle_new_errors.xml |  6 ++++++
 2 files changed, 20 insertions(+), 2 deletions(-)

diff --git a/nfsv42_middle_copy.xml b/nfsv42_middle_copy.xml
index a01668b..9058f1f 100644
--- a/nfsv42_middle_copy.xml
+++ b/nfsv42_middle_copy.xml
@@ -655,6 +655,12 @@
       COPY_NOTIFY requests that use only AUTH_SYS.
     </t>
 
+    <t>
+      If a server requires the use of RPCSEC_GSSv3 copy_to_auth,
+      copy_from_auth, or copy_confirm_auth and it is not used,
+      the server will reject the request with NFS4ERR_PARTNER_NO_AUTH.
+    </t>
+
     <section title="Inter-Server Copy Security" anchor="sec:SSC-sec">
       <section title="Inter-Server Copy via ONC RPC with RPCSEC_GSSv3"  anchor="sec:SSC-rpc-with-gss">
         <t>
@@ -951,8 +957,14 @@
 
               <t>
                 If the source server fails to verify the copy_from_auth
-                privilege the COPY operation will be rejected with
-                NFS4ERR_PARTNER_NO_AUTH, causing in turn the client to
+                privilege the COPY_NOTIFY operation will be rejected with
+                NFS4ERR_PARTNER_NO_AUTH.
+              </t>
+
+              <t>
+                If the destination server fails to verify the copy_to_auth
+                or copy_confirm_auth privilege, the COPY will be rejeced with
+                NFS4ERR_PARTNER_NO_AUTH, causing the client to
                 destroy the associated copy_from_auth and copy_to_auth
                 RPCSEC_GSSv3 structured privilege assertion handles.
               </t>
diff --git a/nfsv42_middle_new_errors.xml b/nfsv42_middle_new_errors.xml
index 581556e..4e0ac70 100644
--- a/nfsv42_middle_new_errors.xml
+++ b/nfsv42_middle_new_errors.xml
@@ -77,6 +77,12 @@
           offload request after the copy lease time expired, or for some
           other permission problem.
         </t>
+        <t>
+          The destination server does not authorize a server-to-server copy
+          offload operation. This may be due to an inter server COPY
+          request where the destination server requires RPCSEC_GSSv3 and
+          it is not used, or some other permissions problem.
+        </t>
       </section>
 
       <section title="NFS4ERR_PARTNER_NOTSUPP (Error Code 10088)" anchor="err_PARTNER_NOTSUPP">
-- 
1.9.3 (Apple Git-50)

---

From: Tom Haynes <[email-masked]>
Date: Wed, 18 Nov 2015 15:36:52 -0800

applied!

> On Nov 17, 2015, at 8:08 AM, [email-masked] wrote:
>