Subject: Re: [nfsv4] NFSv4 meeting at IETF 95 Buenos Aires

From: Spencer Shepler <[email-masked]>
Date: Wed, 6 Jan 2016 16:49:38 +0000

Dave,

From: http://www.ietf.org/meeting/important-dates-2016.html

2016-02-19 (Friday): Cut-off date for requests to schedule Working Group meetings at UTC 23:59

Which is 6 weeks prior to the meeting.

To answer your question, yes, we can wait until a couple days before the deadline listed above to make a decision.

Spencer

From: David Noveck [mailto:[email-masked]]
Sent: Saturday, December 19, 2015 4:47 AM
To: Chuck Lever <[email-masked]>
Cc: [email-masked]; Spencer Shepler <[email-masked]>
Subject: Re: [nfsv4] NFSv4 meeting at IETF 95 Buenos Aires

I think we need more clarity about when any such decision might be made.  Although it's probably not his  intention, Spencer's message could be read as suggesting such a decision might be made in the very near future.  Since IETF95 is three and a half months away, that doesn't make sense to me.

We need to keep in mind that:

  *   Travel approval and booking delays means that a decision to go to IETF95 would have to be made a month or more before the meeting.
If we make the decision too late, we may decide to meet and then have very few people there to participate.  Some people can participate by phone but an in-room discussion does have benefits.

  *   In many cases, deciding to put in the effort into putting together a presentation can be expected to take a considerable time.
If we decide not to meet based on the fact that people don't know what they will present months in advance, the group will often not meet when there are good reasons to do so.

To help people plan their arrangements, we should have a clear target date for this decision in mind.  My proposal is that we make the target date for this decision six weeks before the meeting.  Is that OK with you, Spencer?

As Chuck has pointed out, document review is often done well on the mailing list.  As a result, time at working group meetings is best devoted to discussion/proposal of new initiatives.  If there is someone with an idea about something the working group might take on once the five-year experience with v4.2 is over, I'd like to hear about it.  That is something that could be done in an I-D, but I think there would be cases in which a presentation to the working group might be helpful. If there are people out there with some ideas they want to present, I urge them to start working now if they think that IETF95 might be a useful forum.  There would be an opportunity to survey interest on the working group list before committing to producing a presentation.

There are also cases in which review on the working group list has not been working so well.  So far there has been no review of draft-ietf-nfsv4-versioning-02.  I've asked people to review the current draft on the mailing list, but I'm not sure what the response will be.  In any case, I think it is likely that I will give a presentation to the working group at IETF95 (probably by phone) about this document.  In the best case, we'll review and try to address existing contentious issues and talk about when WGLC might be appropriate.   If there has been not been much  review, we might also consider the working group's other options regarding our versioning model.

I think a discussion of Tom's documents could be helpful.  I could participate by phone. I'd be OK discussing draft-ietf-nfsv4-flex-files-07 and draft-ietf-nfsv4-layout-types-04 (if Tom intends to pursue that) if we saw those any time up to the two-weeks-before-meeting publication cutoff.  Other people might need more time to look at these, so earlier on these would be better.

Also, given the way things are progressing on draft-ietf-nfsv4-rfc5666bis, I'm thinking that April might be a good time to review the process so far and to discuss a possible WGLC for that document.  I hope Chuck could give a presentation by phone on any remaining contentious issues, timing for WGLC, and what areas he would like people to pay particular attention to during last call.
 On Dec 11, 2015, at 4:47 PM, Tom Haynes <[email-masked]<mailto:[email-masked]>> wrote:
>
>
>> On Dec 11, 2015, at 9:06 AM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:
>>
>>
>> Given that hotel registration is opening up for IETF 95, I wanted to query for agenda items for IETF 95 to determine if we will be meeting.
>>
>> Thoughts?
>
> I’d like to wrap up my remaining documents - Layout thoughts and the Flex Files.
>
> I’d also be interested in hearing something about Chuck’s work.

IETF 95 conflicts with the 2016 OpenFabrics Developer Workshop.

I could present something by phone. However, our work is
being done on the mailing list and there are several active
Working Group documents. I'm not sure what more I could
say about this at a meeting. If there's a specific area
where live interaction might be warranted, I'm happy to
take requests to see if there's material for a presentation.

--
Chuck Lever

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv
4<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fnfsv4&data=01%7c01%7csshepler%40microsoft.com%7c1eea36372a51456e18b108d308727a51%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=hsybF8sEtNUYmIjUg0D%2b4S%2bBB%2f7NaD1PBsRuo211iDE%3d>

---

From: Chuck Lever <[email-masked]>
Date: Wed, 6 Jan 2016 11:56:17 -0500

> On Dec 11, 2015, at 4:57 PM, Chuck Lever <[email-masked]> wrote:
> 
> 
>> On Dec 11, 2015, at 4:47 PM, Tom Haynes <[email-masked]> wrote:
>> 
>> 
>>> On Dec 11, 2015, at 9:06 AM, Spencer Shepler <[email-masked]> wrote:
>>> 
>>> 

If we meet in BA in April, I can present an update on
RDMA-related work. Something like:

	• Progress of work on rfc5666bis
	• Plans for rfc5667bis
	• Thoughts about an RPC-over-RDMA Version Two

Lever (20 minutes, likely by phone)

But there's nothing here that can't be pushed to Berlin if
there isn't strong interest in meeting in April.

--
Chuck Lever

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 6 Jan 2016 17:02:53 +0000

Thanks, Chuck.  I would be happy to host a Working Group conference call at any time to cover the same material so that we don't artificially wait for the physical meetings.

Spencer

-----Original Message-----
From: Chuck Lever [mailto:[email-masked]] 
Sent: Wednesday, January 6, 2016 8:56 AM
To: Spencer Shepler <[email-masked]>
Cc: [email-masked]
Subject: Re: [nfsv4] NFSv4 meeting at IETF 95 Buenos Aires

> I could present something by phone. However, our work is being done on 
> the mailing list and there are several active Working Group documents. 
> I'm not sure what more I could say about this at a meeting. If there's 
> a specific area where live interaction might be warranted, I'm happy 
> to take requests to see if there's material for a presentation.

If we meet in BA in April, I can present an update on RDMA-related work. Something like:

But there's nothing here that can't be pushed to Berlin if there isn't strong interest in meeting in April.

--
Chuck Lever