Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rfc5667bis-02.txt

From: [email-masked]
Date: Thu, 25 Aug 2016 10:32:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 of the IETF.

        Title           : Network File System (NFS) Upper Layer Binding To RPC-Over-RDMA 
        Author          : Charles Lever
	Filename        : draft-ietf-nfsv4-rfc5667bis-02.txt
	Pages           : 12
	Date            : 2016-08-25

Abstract:
   This document specifies Upper Layer Bindings of Network File System
   (NFS) protocol versions to RPC-over-RDMA transports.  These bindings
   are required to enable RPC-based protocols to use direct data
   placement on RPC-over-RDMA transports.  This document obsoletes RFC
   5667.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rfc5667bis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-nfsv4-rfc5667bis-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rfc5667bis-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chuck Lever <[email-masked]>
Date: Thu, 25 Aug 2016 13:35:40 -0400

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rfc5667bis-02.txt
> Date: August 25, 2016 at 1:32:39 PM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> 
> 

I'm interested in comments about the readiness of this document for WGLC.

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Thu, 25 Aug 2016 14:18:53 -0400

This document is in pretty good shape.  I've read through it and most of the
issues that I've found are quite minor and could be dealt with in the
context
of WGLC.

One exception concerns section 4.2.  I can summarize the second
paragraph as saying essentially "Gosh, this is impossible".  I assume that
there is a missing third paragraph that explains how people can and
should deal with the (formal) lack of response size limitation.

For v4.1-v4.2, reference should be made to ca_maxresponsesize.  With regard
to v4.0, things are more troublesome, but the experience of existing
successful
implementations should be part of dealing with this issue.  Although,
theoretically,
one could have a one-megabyte acl, the fact that they don't exist needs to
taken
into account.

In any case, once we have a proposed approach to the issue raised by section
4.2, the working group will need to discuss its adequacy and, if there is
general
agreement that it is reasonable, WGLC would be in order,.

On Thu, Aug 25, 2016 at 1:35 PM, Chuck Lever <[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Chuck Lever <[email-masked]>
Date: Thu, 25 Aug 2016 15:00:25 -0400

> On Aug 25, 2016, at 2:18 PM, David Noveck <[email-masked]> wrote:
> 
> issues that I've found are quite minor and could be dealt with in the context
> of WGLC.
> 
> to v4.0, things are more troublesome, but the experience of existing successful
> implementations should be part of dealing with this issue.  Although, theoretically,
> one could have a one-megabyte acl, the fact that they don't exist needs to taken 
> into account.

That helps. I will work on adding that information to S4.2 while
waiting for additional comments.

> 4.2, the working group will need to discuss its adequacy and, if there is general

--
Chuck Lever