Subject: [nfsv4] xattr questions

From: Bruce Fields <[email-masked]>
Date: Tue, 21 Feb 2017 11:56:06 -0500

Do you have XML source for the xattr draft someplace?  (I was
considering whether to take some of the XDR-related boilerplate.)

Also: where's the latest linux xattr code?  Are you planning to submit
it again soon?  I can't recall seeing it recently.

--b.

On Sun, Aug 21, 2016 at 05:09:37PM -0700, Marc Eshel wrote:
> update Manoj email.
> 
> 
> 
> From:   Marc Eshel/Almaden/IBM
> To:     Bruce Fields <[email-masked]>
> Cc:     Andreas Gruenbacher <[email-masked]>, Manoj Naik 
> <[email-masked]>
> Date:   08/21/2016 05:05 PM
> Subject:        Re: draft-naik-nfsv4-xattrs
> 
> 
> I think we should have a consistent way of discovering if a feature is 
> supported or not and for now continue to use the fattr flags to indicate 
> support.
> I don't care if it is 81 or 82. Manoj?
> Marc. 
> 
> 
> 
> 
> From:   Bruce Fields <[email-masked]>
> To:     Andreas Gruenbacher <[email-masked]>
> Cc:     Manoj Naik <[email-masked]>, Marc Eshel/Almaden/IBM@IBMUS
> Date:   08/17/2016 12:33 PM
> Subject:        Re: draft-naik-nfsv4-xattrs
> 
> 
> 
> On Wed, Aug 17, 2016 at 03:32:22PM -0400, Bruce Fields wrote:
> > One minor detail on draft-ietf-nfsv4-xattrs: fattr4_xattr_support seems
> > unnecessary, as you'll discover the lack of support the first time you
> > try to use one of the new operations.
> > 
> > Could we remove it?
> 
> (Also, a minor consideration, but: with that removed there's no conflict
> at all between the umask and xattr specs.  But obviously if you really
> need it, we could flip a coin to decide who gets attribute number 81 and
> who moves to 82.)
> 
> --b.
> 
> 
> 
> 
>

---

From: spencer shepler <[email-masked]>
Date: Tue, 21 Feb 2017 09:01:10 -0800

Bruce,

The xattrs I-D was updated on Jan 31st by Manoj.  Adding his other email to
help in visibility in his inbox for your other questions.

Spencer

On Tue, Feb 21, 2017 at 8:56 AM, Bruce Fields <[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Manoj Naik <[email-masked]>
Date: Tue, 21 Feb 2017 18:28:54 +0000

The source is nroff. Not sure how good the conversion to XML will be, but if it’s useful, I can send it directly to you.

Manoj.

On 2/21/17, 8:56 AM, "nfsv4 on behalf of Bruce Fields" <[email-masked] on behalf of [email-masked]> wrote:

    
    --b.

---

From: Bruce Fields <[email-masked]>
Date: Tue, 21 Feb 2017 14:10:53 -0500

> The source is nroff. Not sure how good the conversion to XML will be, but if it’s useful, I can send it directly to you.

Eh, in that case I'll just work it out from what's published.

What about the state of the linux code?

--b.

---

From: Manoj Naik <[email-masked]>
Date: Tue, 21 Feb 2017 19:20:30 +0000

I’d sent the client side xattr patch to Matt Benjamin / Frank Filz (Redhat) - I believe some of the server side code is there for Ganesha. I’ll send it to you in a separate email.

Manoj.

On 2/21/17, 11:10 AM, "Bruce Fields" <[email-masked]> wrote:

    
    
    --b.