Subject: [nfsv4] [Editorial Errata Reported] RFC7530 (4934)

From: RFC Errata System <[email-masked]>
Date: Wed, 15 Feb 2017 03:04:07 -0800 (PST)

The following errata report has been submitted for RFC7530,
"Network File System (NFS) Version 4 Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7530&eid=4934

--------------------------------------
Type: Editorial
Reported by: Marcel Telka <[email-masked]>

Section: 9.1.7.

Original Text
-------------
   When a request is received, its sequence number (r) is compared to
   that of the last one received (L).  Only if it has the correct next
   sequence, normally L + 1, is the request processed beyond the point
   of seqid checking.  Given a properly functioning client, the response
   to (r) must have been received before the last request (L) was sent.

Corrected Text
--------------
   When a request is received, its sequence number (r) is compared to
   that of the last one received (L).  Only if it has the correct next
   sequence, normally L + 1, is the request processed beyond the point
   of seqid checking.  Given a properly functioning client, the response
   to (L) must have been received before the subsequent request (r) was
   sent.

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7530 (draft-ietf-nfsv4-rfc3530bis-35)
--------------------------------------
Title               : Network File System (NFS) Version 4 Protocol
Publication Date    : March 2015
Author(s)           : T. Haynes, Ed., D. Noveck, Ed.
Category            : PROPOSED STANDARD
Source              : Network File System Version 4
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: David Noveck <[email-masked]>
Date: Wed, 15 Feb 2017 11:59:08 -0500

I think it is a valid correction.

On Feb 15, 2017 11:52 AM, "RFC Errata System" <[email-masked]>
wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: David Noveck <[email-masked]>
Date: Wed, 15 Feb 2017 16:46:20 -0500

---------- Forwarded message ----------
From: David Noveck <[email-masked]>
Date: Wed, Feb 15, 2017 at 11:59 AM
Subject: Re: [nfsv4] [Editorial Errata Reported] RFC7530 (4934)
To: RFC Editor <[email-masked]>
Cc: Spencer Dawkins at IETF <[email-masked]>,
[email-masked], text/[email-masked],
[email-masked], [email-masked],
charset=[email-masked], [email-masked], [email-masked],
[email-masked], [email-masked]