Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rfc5667bis-07.txt

From: [email-masked]
Date: Thu, 09 Mar 2017 09:06:43 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 of the IETF.

        Title           : Network File System (NFS) Upper Layer Binding To RPC-Over-RDMA Version One
        Author          : Charles Lever
	Filename        : draft-ietf-nfsv4-rfc5667bis-07.txt
	Pages           : 19
	Date            : 2017-03-09

Abstract:
   This document specifies Upper Layer Bindings of Network File System
   (NFS) protocol versions to RPC-over-RDMA Version One, enabling the
   use of Direct Data Placement.  This document obsoletes RFC 5667.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rfc5667bis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-nfsv4-rfc5667bis-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rfc5667bis-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chuck Lever <[email-masked]>
Date: Thu, 9 Mar 2017 12:20:52 -0500

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rfc5667bis-07.txt
> Date: March 9, 2017 at 12:06:43 PM EST
> To: <[email-masked]>
> Cc: [email-masked]
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

This revision:

- picks up the latest revision of rpcrdma-bidirection

- merges Dave Noveck's review of -06

- clarifies reply size estimation for NLM

Note that MOUNT/NLM/NSM operation on RPC-over-RDMA has also
never been implemented, and is thus speculative. A disclaimer
that TCP is typically used for these protocols has been left
at the top of that section, but perhaps more is needed there.

This revision does not attempt to address whether multiple
chunks are allowed in a single RPC transaction.

Allowing multiple NFS READ and WRITE operations per COMPOUND
is an issue for NFS implementations on all transports. Does
an NFS/TCP client have a way to probe a server to see if it
can handle such a request?

--
Chuck Lever