Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

From: Spencer Shepler <[email-masked]>
Date: Mon, 8 May 2017 22:25:42 +0000

Thanks for the input.  I have requested a single, 2.5 hour session for IETF99 in Prague the week of July 16th.

Spencer

From: nfsv4 [mailto:[email-masked]] On Behalf Of Adamson, Andy
Sent: Thursday, April 27, 2017 7:08 AM
To: Christoph Hellwig <[email-masked]>; Chuck Lever <[email-masked]>
Cc: [email-masked]
Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

I would also like to meet and clear up NFS4 and NFS4.1 mulitpath.

-->Andy

________________________________
From: nfsv4 <[email-masked]> on behalf of Christoph Hellwig <[email-masked]>
Sent: Sunday, April 23, 2017 4:14:07 AM
To: Chuck Lever
Cc: Christoph Hellwig; [email-masked]
Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

On Sat, Apr 22, 2017 at 11:28:28AM -0400, Chuck Lever wrote:
> I have cycles to help with a draft, if you'd like to offload
> some of that work.

Drafting should be easy - I'll need to get my prototype into a shape where
I even want to document it.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnfsv4&data=02%7C01%7Csshepler%40microsoft.com%7C0faa9162b3f34934769508d48d770212%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636288989654278779&sdata=mYH16wA5K5N9snEYNpstsWgW7OBrDMkaKmhqNG%2FhrrU%3D&reserved=0>

---

From: Thomas Haynes <[email-masked]>
Date: Wed, 10 May 2017 00:15:22 +0000

Peeking head out of hole in the ground, ground I say!

Flex files wrap up (to force me to finish) - 10 minutes

Futures: 10 minutes
Do not return Open State if a Delegation is also issued
Soft Quiescing of Writes for Snapshotting

On May 8, 2017, at 3:25 PM, Spencer Shepler <[email-masked]<mailto:[email-masked]>> wrote:

Spencer

From: nfsv4 [mailto:[email-masked]] On Behalf Of Adamson, Andy
Sent: Thursday, April 27, 2017 7:08 AM
To: Christoph Hellwig <[email-masked]<mailto:[email-masked]>>; Chuck Lever <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

-->Andy

________________________________
From: nfsv4 <[email-masked]<mailto:[email-masked]>> on behalf of Christoph Hellwig <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, April 23, 2017 4:14:07 AM
To: Chuck Lever
Cc: Christoph Hellwig; [email-masked]<mailto:[email-masked]>
Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnfsv4&data=02%7C01%7Csshepler%40microsoft.com%7C0faa9162b3f34934769508d48d770212%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636288989654278779&sdata=mYH16wA5K5N9snEYNpstsWgW7OBrDMkaKmhqNG%2FhrrU%3D&reserved=0>
_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Rick Macklem <[email-masked]>
Date: Wed, 10 May 2017 01:05:45 +0000

Just fyi, I no longer have an interest in the changes that I posted last year.
However, I am interested in using Flexible File Layout, due to the client side mirroring.

My attempt at a pNFS server using GlusterFS was a flop (terrible performance),
but I now has a simple pNFS service running on FreeBSD ok, using File Layout.
I'd like to add mirroring using Flexible File Layout over the next year.
If anyone is interested in trying this, you can look at:
  http://people.freebsd.org/~rmacklem/pnfs-planb-setup.txt

rick
________________________________________
From: nfsv4 <[email-masked]> on behalf of Thomas Haynes <[email-masked]>
Sent: Tuesday, May 9, 2017 8:15:22 PM
To: Spencer Shepler
Cc: [email-masked]
Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

Futures: 10 minutes

Spencer

-->Andy

---

From: David Noveck <[email-masked]>
Date: Wed, 10 May 2017 11:40:10 -0400

Tom is the first to actually post time requests, and now it seems clear
that 150 minutes are going to be tight.

Tom has quite reasonably asked for twenty minutes.
No actual time estimates have been posted but it is hard to imagine a
charter discussion taking less than 30 minutes

Assuming Administrivia takes no time, this leaves 100 minutes to divide
among:

Christoph talking about NVMe and an RDMA-based layout.

Chuck talking about next steps for RDMA.
Some combination of Andy, me, and Chuck talking about migration, trunking
and the interactions between them, for both NFSv4.0 and NFSv4.1.

I think we need to consider having multiple sessions and get the requests
made while time is still available.  In any case, we need to move from
"this is what I'd like to hear/talk abut" to "this is my agenda item and
this is the time I need to deal with it".  Also, there may be people who
have felt that, with two months still to go, there is plenty of time left
to make requests.  Now that reasonable assumption is no longer valid.  If
you need to talk to the group at IETF99, let us know soon.

On Tue, May 9, 2017 at 8:15 PM, Thomas Haynes <[email-masked]>
wrote:

> On May 8, 2017, at 3:25 PM, Spencer Shepler <[email-masked]>
> wrote:
>
>
> *From:* nfsv4 [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Adamson, Andy
> *Sent:* Thursday, April 27, 2017 7:08 AM
> *To:* Christoph Hellwig <[email-masked]>; Chuck Lever <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on
> meeting)
>
>
> ------------------------------
> *From:* nfsv4 <[email-masked]> on behalf of Christoph Hellwig <
> [email-masked]>
> *Sent:* Sunday, April 23, 2017 4:14:07 AM
> *To:* Chuck Lever
> *Cc:* Christoph Hellwig; [email-masked]
> *Subject:* Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on
> meeting)
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnfsv4&data=02%7C01%7Csshepler%40microsoft.com%7C0faa9162b3f34934769508d48d770212%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636288989654278779&sdata=mYH16wA5K5N9snEYNpstsWgW7OBrDMkaKmhqNG%2FhrrU%3D&reserved=0>

---

From: "Adamson, Andy" <[email-masked]>
Date: Wed, 10 May 2017 15:44:25 +0000

If there is interest and time (and my travel is approved), I could present a demo of RPCSEC_GSSv3 work in linux where I have Full Mode labeling and inter-ssc copy_from/to_auth coded and working now - I anticipate having the final copy_confirm_auth GSSv3 privilege working as well.

-->Andy

________________________________
From: nfsv4 <[email-masked]> on behalf of David Noveck <[email-masked]>
Sent: Wednesday, May 10, 2017 11:40:10 AM
To: Thomas Haynes
Cc: [email-masked]
Subject: Re: [nfsv4] IETF 99 - July 16-21 - Prague (request for WG on meeting)

Tom is the first to actually post time requests, and now it seems clear that 150 minutes are going to be tight.

Tom has quite reasonably asked for twenty minutes.
No actual time estimates have been posted but it is hard to imagine a charter discussion taking less than 30 minutes

Assuming Administrivia takes no time, this leaves 100 minutes to divide among:
Christoph talking about NVMe and an RDMA-based layout.
Chuck talking about next steps for RDMA.
Some combination of Andy, me, and Chuck talking about migration, trunking and the interactions between them, for both NFSv4.0 and NFSv4.1.

I think we need to consider having multiple sessions and get the requests made while time is still available.  In any case, we need to move from "this is what I'd like to hear/talk abut" to "this is my agenda item and this is the time I need to deal with it".  Also, there may be people who have felt that, with two months still to go, there is plenty of time left to make requests.  Now that reasonable assumption is no longer valid.  If you need to talk to the group at IETF99, let us know soon.

On Tue, May 9, 2017 at 8:15 PM, Thomas Haynes <[email-masked]<mailto:[email-masked]>> wrote:
Peeking head out of hole in the ground, ground I say!

Futures: 10 minutes

Spencer

-->Andy

---

From: spencer shepler <[email-masked]>
Date: Wed, 10 May 2017 08:55:40 -0700

Cutoff for additional meeting requests is June 2nd.  At this point, I am
not inclined so submit another meeting request.  We need time requests from
all contributors to get a better sense of agenda.

I would also suggest that the charter discussion should continue in email
and if needed, we can set up a conference call to discuss further before
the Prague meeting (to offset time used in agenda).

I would also ask that for new topics that people consider writing short
I-Ds or short write-ups that can be shared with the WG alias prior to the
meeting to make the time in meeting more effective.

Spencer

On Wed, May 10, 2017 at 8:44 AM, Adamson, Andy <[email-masked]>
wrote:

> If there is interest and time (and my travel is approved), I could present
> a demo of RPCSEC_GSSv3 work in linux where I have Full Mode labeling and
> inter-ssc copy_from/to_auth coded and working now - I anticipate having the
> final copy_confirm_auth GSSv3 privilege working as well.
>
>
> -->Andy
> *From:* nfsv4 <[email-masked]> on behalf of David Noveck <
> [email-masked]>
> *Sent:* Wednesday, May 10, 2017 11:40:10 AM
> *To:* Thomas Haynes
>
> *Cc:* [email-masked]
>> *To:* Christoph Hellwig <[email-masked]>; Chuck Lever <[email-masked]
>> >
>> *Cc:* [email-masked]

---

From: Chuck Lever <[email-masked]>
Date: Wed, 10 May 2017 12:05:51 -0400

> On May 10, 2017, at 11:40 AM, David Noveck <[email-masked]> wrote:
> 

I don't think anyone wants to hear me droning about RDMA
for 30 minutes. Let's cut this off at 20 minutes.

> Some combination of Andy, me, and Chuck talking about migration, trunking and the interactions between them, for both NFSv4.0 and NFSv4.1.

I can forfeit my time here, though I will participate
actively as an audience member. Migration issues in NFSv4.1
and Andy's multi-pathing work are most interesting to me.

> I think we need to consider having multiple sessions and get the requests made while time is still available.

Focusing on using the existing time wisely seems like a
better approach. Otherwise we will try to fill up 300
minutes and a lot of that will be topics that can easily
be dealt with on list, or for which there is limited
interest.

> In any case, we need to move from "this is what I'd like to hear/talk abut" to "this is my agenda item and this is the time I need to deal with it".

That will leave us with a lot of proposed talks, and no
gauge of what is actually interesting to people. In other
words, IMO both types of responses are valuable.

> Also, there may be people who have felt that, with two months still to go, there is plenty of time left to make requests.  Now that reasonable assumption is no longer valid.  If you need to talk to the group at IETF99, let us know soon.
> 
> 
> On Tue, May 9, 2017 at 8:15 PM, Thomas Haynes <[email-masked]> wrote:
>> On May 8, 2017, at 3:25 PM, Spencer Shepler <[email-masked]> wrote:
>> 
>>  

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Wed, 10 May 2017 15:14:58 -0400

> for 30 minutes. Let's cut this off at 20 minutes.

Although I did use the phrase "Chuck talking", I didn't mean that you would
be talking (or "droning" as you put it) the whole 30 minutes.  I did
anticipate that there would be questions and a discussion of the topic,
"Next steps for RDMA" in addition to your presentation.

> Focusing on using the existing time wisely seems like a better approach.

I accept that it might be too late to switch to a longer time.

> Otherwise we will try to fill up 300 minutes

I want to be clear that I wasn't suggesting that we try to fill up two
150-minute sessions.  I believe there are some shorter sessions, including
some one-hour ones.

On Wed, May 10, 2017 at 12:05 PM, Chuck Lever <[email-masked]>
wrote:

> > Some combination of Andy, me, and Chuck talking about migration,
> trunking and the interactions between them, for both NFSv4.0 and NFSv4.1.
>
> > I think we need to consider having multiple sessions and get the
> requests made while time is still available.
>
> > In any case, we need to move from "this is what I'd like to hear/talk
> abut" to "this is my agenda item and this is the time I need to deal with
> it".
>
> > Also, there may be people who have felt that, with two months still to
> go, there is plenty of time left to make requests.  Now that reasonable
> assumption is no longer valid.  If you need to talk to the group at IETF99,
> let us know soon.
> >
> >
> >> To: Christoph Hellwig <[email-masked]>; Chuck Lever <[email-masked]
> >
> >> Cc: [email-masked]