Subject: [nfsv4] rdattr_error attribute and GETATTR

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Fri, 8 Feb 2019 17:57:10 +0100 (CET)

Dear nfsv4 spec writers/editors,

according rfc 7530 and 5661:

5.8.1.12.  Attribute 11: rdattr_error

   Error returned from an attempt to retrieve attributes during a
   READDIR operation.

What should server do if rdattr_error attribute is requested with a regular
GETATTR operation? I see three options:

  1) return INVAL
  2) ignore (e.g. do not include in the result)
  3) return value NFS_OK

Thanks for clarification,
   Tigran.

---

From: Trond Myklebust <[email-masked]>
Date: Fri, 8 Feb 2019 14:05:51 -0500

Hi Tigran

>   2) ignore (e.g. do not include in the result)
According to https://tools.ietf.org/html/rfc5661#section-18.7.3 "The server
MUST return an error if it supports an attribute on the target but cannot
obtain its value". That applies to all write-only attributes, and so
presumably it also applies to the readdir-only attributes.

So that would imply option 1.

Note that this is also consistent with the more explicit recommendation for
VERIFY in https://tools.ietf.org/html/rfc5661#section-18.31.4

Cheers
  Trond

---

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Fri, 8 Feb 2019 21:07:59 +0100 (CET)

Hi Trond,

----- Original Message -----
> From: "Trond Myklebust" <[email-masked]>
> To: "Tigran Mkrtchyan" <[email-masked]>
> Cc: "NFSv4" <[email-masked]>
> Sent: Friday, February 8, 2019 8:05:51 PM
> Subject: Re: [nfsv4] rdattr_error attribute and GETATTR