Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-00.txt

From: [email-masked]
Date: Mon, 25 Mar 2019 11:19:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 WG of the IETF.

        Title           : Remote Procedure Call Encryption By Default
        Authors         : Trond Myklebust
                          Charles Lever
	Filename        : draft-ietf-nfsv4-rpc-tls-00.txt
	Pages           : 16
	Date            : 2019-03-25

Abstract:
   This document describes a mechanism that enables encryption of in-
   transit Remote Procedure Call (RPC) transactions with minimal
   administrative overhead and full interoperation with ONC RPC
   implementations that do not support this mechanism.  This document
   updates RFC 5531.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rpc-tls/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-nfsv4-rpc-tls-00
https://datatracker.ietf.org/doc/html/draft-ietf-nfsv4-rpc-tls-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chuck Lever <[email-masked]>
Date: Mon, 25 Mar 2019 14:23:55 -0400

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-00.txt
> Date: March 25, 2019 at 2:19:44 PM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> 

The personal draft draft-cel-nfsv4-rpc-tls was submitted for an early
SecDir review. This revision, draft-ietf-nfsv4-rpc-tls-00, is now a
Working Group document, and includes corrections and additions suggested
by the SecDir review.

--
Chuck Lever

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Mar 2019 08:02:56 +0100

> Working Group document, and includes corrections and additions suggested

It would be somewhat useful if that "replaces" relationship was captured in the datatracker.

Lars

---

From: David Noveck <[email-masked]>
Date: Tue, 26 Mar 2019 05:43:06 -0400

Agree.  Unfortunately, it is easy to forget this when submitting the
replacement document and there doesn't seem to be any way to establish this
relationship afterwards.

The big problem with forgetting to do this is that the superseded document
remains on the nfsv4 documents page and can lead to confusion.  This has
been a drag at times when I forgot to correctly deal with the document
replacement question when submitting a working group document.

On Tue, Mar 26, 2019, 3:04 AM Lars Eggert <[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Mar 2019 11:34:28 +0100

On 2019-3-26, at 10:43, David Noveck <[email-masked]> wrote:
> there doesn't seem to be any way to establish this relationship afterwards.

The chairs have access to functionality that does this.

Lars

---

From: Chuck Lever <[email-masked]>
Date: Tue, 26 Mar 2019 10:04:42 -0400

Hi Spencer-

Here is an example of a datatracker page that reports the history
of both the Working Group document and the personal draft upon
which it was based.

   https://datatracker.ietf.org/doc/rfc7942/

Can you enable this feature for the recently promoted
draft-ietf-nfsv4-rpc-tls-00 ? For reference, the personal draft is
still active on the NFSv4 WG home page.

> Begin forwarded message:
> 
> From: Lars Eggert <[email-masked]>
> Subject: Re: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-00.txt
> Date: March 26, 2019 at 6:34:28 AM EDT
> To: David Noveck <[email-masked]>
> Cc: Chuck Lever <[email-masked]>, NFSv4 <[email-masked]>
> 

--
Chuck Lever

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 26 Mar 2019 09:20:39 -0500

Hi, Chuck,

> still active on the NFSv4 WG home page.

I did this and then snapped that you probably meant "Spencer (S)".

My apologies for still not recognizing what to do with Anycast addresses!
But it's updated as I understood you were requesting.

Best wishes with this draft.

Spencer

---

From: Chuck Lever <[email-masked]>
Date: Tue, 26 Mar 2019 10:27:27 -0400

> On Mar 26, 2019, at 10:20 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Chuck,
> 
> My apologies for still not recognizing what to do with Anycast addresses! But it's updated as I understood you were requesting.

My fault entirely. But this is a cool feature! Thanks for enabling it!

--
Chuck Lever