Subject: [nfsv4] IETF 105 - Montreal - NFSv4 WG meeting ?

From: spencer shepler <[email-masked]>
Date: Thu, 25 Apr 2019 13:07:07 -0700

The WG/BOF scheduling is open.

Does the working group have the topics/agenda items necessary to meet face
to face?

Spencer

---

From: Chuck Lever <[email-masked]>
Date: Thu, 25 Apr 2019 16:52:21 -0400

> On Apr 25, 2019, at 4:50 PM, Chuck Lever <[email-masked]> wrote:
> 
> Hi Spencer,
> 
>> On Apr 25, 2019, at 4:07 PM, spencer shepler <[email-masked]> wrote:
>> 
>> 
>> Does the working group have the topics/agenda items necessary to meet face to face?
> 
> Thanks for bringing this up! Possible topics:
> 
> - Milestone updates (fs_locations and related, RPC/RDMA)
> - Towards a set of Working Group github repositories
> - Improving the performance of NFS directory operations
> - An emerging Computational Storage architecture for NFS
> - Long-term strategies for RPC over encrypted transports
> - Replacing RFC 5661

I should add
- Open issues with integrity measurement

> There are active I-Ds associated with most of these areas.
> 
> --
> Chuck Lever
> 
> 
> 

--
Chuck Lever

---

From: Chuck Lever <[email-masked]>
Date: Thu, 25 Apr 2019 16:50:46 -0400

Hi Spencer,

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Thu, 25 Apr 2019 16:56:43 -0400

I can't see us not meeting given that the last time we met was at IETF102
and that we are in the midst of major effort to move NFSv4 security from
its current unsatisfactory state to something better.

With regard to filling up a timeslot, I'll let Check and Trond (who, as I
undertand it wil be working on a v4-specific document to go with Chuck's
RPC-generic one) define their agenda items.

With regard to my own needs, we will need to discuss work on a possible
rfc5661bis.   It is now pretty clear that the IESG will want to see this.
The only question is whether they will be OK with publishing
rfc5661-msns-update soon.   Even if they are, there will be a need for an
rfc5661bis that includes a new Security Considerations section (with a real
threat analysis) and that will have to be co-ordinated with Trond and Chuck.

I know Tom thinks I'm crazy to even consider this, but, so far as I know,
there is no working group consensus on this point :-)

Also, there are there are a number of documets with target dates in the
second half of 2019., that we need to briefly discuss.  Given the securitty
work  underway, I don't see any need to add any non-security milestones for
2020 right now.

On Thu, Apr 25, 2019 at 4:07 PM spencer shepler <[email-masked]>
wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Chuck Lever <[email-masked]>
Date: Thu, 25 Apr 2019 17:04:03 -0400

From my list:

The directory performance and computational storage topics are
not mature and can be considered low priority for this meeting.

The others intersect with your suggestions except for the
integrity measurement topic, which I would like to keep on the
agenda for now.

> On Apr 25, 2019, at 4:56 PM, David Noveck <[email-masked]> wrote:
> 
> I can't see us not meeting given that the last time we met was at IETF102 and that we are in the midst of major effort to move NFSv4 security from its current unsatisfactory state to something better.
> 
> With regard to filling up a timeslot, I'll let Check and Trond (who, as I undertand it wil be working on a v4-specific document to go with Chuck's RPC-generic one) define their agenda items.
> 
> With regard to my own needs, we will need to discuss work on a possible rfc5661bis.   It is now pretty clear that the IESG will want to see this.  The only question is whether they will be OK with publishing rfc5661-msns-update soon.   Even if they are, there will be a need for an rfc5661bis that includes a new Security Considerations section (with a real threat analysis) and that will have to be co-ordinated with Trond and Chuck.
> 
> I know Tom thinks I'm crazy to even consider this, but, so far as I know, there is no working group consensus on this point :-)
> 
> Also, there are there are a number of documets with target dates in the second half of 2019., that we need to briefly discuss.  Given the securitty work  underway, I don't see any need to add any non-security milestones for 2020 right now.
> 
>> On Thu, Apr 25, 2019 at 4:07 PM spencer shepler <[email-masked]> wrote:
>> 

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Thu, 25 Apr 2019 18:35:15 -0400

I agree that we should discuss integrity measurement face to face.  It
seems that some of the issues with this could go round  and round
indefinitely on the mailing list, without making much progress.

On Thu, Apr 25, 2019, 17:04 Chuck Lever <[email-masked]> wrote:

> > I can't see us not meeting given that the last time we met was at
> IETF102 and that we are in the midst of major effort to move NFSv4 security
> from its current unsatisfactory state to something better.
> >
> > With regard to filling up a timeslot, I'll let Check and Trond (who, as
> I undertand it wil be working on a v4-specific document to go with Chuck's
> > I know Tom thinks I'm crazy to even consider this, but, so far as I
> know, there is no working group consensus on this point :-)
> >