Subject: [nfsv4] Potential charter update - removal of "use of NVMe in accessing a pNFS SCSI Layout" work item

From: spencer shepler <[email-masked]>
Date: Mon, 20 May 2019 08:39:56 -0700

Given the dates and the lack of activity within the working group, I would
like the working group to consider removing the following work item from
our milestones.

"Jun 2018 Submit final document describing use of NVMe in accessing a pNFS
SCSI Layout (as Proposed Standard)"

Is there work occurring but not on the alias or in I-D form that I am not
aware of?
If so, that is great but if not, I suggest we remove the item until such
time there are personal I-Ds to consider.

Spencer

---

From: Chuck Lever <[email-masked]>
Date: Mon, 20 May 2019 11:43:00 -0400

> On May 20, 2019, at 11:39 AM, spencer shepler <[email-masked]> wrote:
> 
> 
> Given the dates and the lack of activity within the working group, I would like the working group to consider removing the following work item from our milestones.
> 
> "Jun 2018	Submit final document describing use of NVMe in accessing a pNFS SCSI Layout (as Proposed Standard)"
> 
> Is there work occurring but not on the alias or in I-D form that I am not aware of? 
> If so, that is great but if not, I suggest we remove the item until such time there are personal I-Ds to consider.
> 
> Spencer

Hi Spencer-

I am planning a discussion and review of charter milestones at IETF 105.
Is there a pressing need to remove this item before that discussion?

--
Chuck Lever

---

From: spencer shepler <[email-masked]>
Date: Mon, 20 May 2019 08:46:57 -0700

I would prefer that we discuss and close on as many of the outstanding
discussions via the alias - prior to the face to face meeting.

So, I am just going through what we have outstanding, etc.

Any other updates people would like to provide?

Spencer

On Mon, May 20, 2019 at 8:43 AM Chuck Lever <[email-masked]> wrote:

> > Given the dates and the lack of activity within the working group, I
> would like the working group to consider removing the following work item
> from our milestones.
> >
> > "Jun 2018     Submit final document describing use of NVMe in accessing
> a pNFS SCSI Layout (as Proposed Standard)"
> >

---

From: Chuck Lever <[email-masked]>
Date: Mon, 20 May 2019 11:54:26 -0400

> On May 20, 2019, at 11:46 AM, spencer shepler <[email-masked]> wrote:
> 
> 
> I would prefer that we discuss and close on as many of the outstanding discussions via the alias - prior to the face to face meeting.

My understanding is that the author intends to revive the document when he has the
resources to complete it. There has been no movement here recently and the author
has allowed the document to expire.

However we have discussed the topic at every IETF meeting for the past few years
because there is still plenty of interest in seeing it completed. We agreed to
leave the item on the charter as a placeholder.

Perhaps it is a topic that is not appropriate as a milestone. Somehow we should
document the WG's continued interest in this area. Any suggestions?

--
Chuck Lever

---

From: "Benjamin Coddington" <[email-masked]>
Date: Mon, 20 May 2019 12:01:02 -0400

On 20 May 2019, at 11:54, Chuck Lever wrote:

> My understanding is that the author intends to revive the document when he
> has the resources to complete it. There has been no movement here recently
> and the author has allowed the document to expire.
>
> However we have discussed the topic at every IETF meeting for the past few
> years because there is still plenty of interest in seeing it completed. We
> agreed to leave the item on the charter as a placeholder.
>
> Perhaps it is a topic that is not appropriate as a milestone. Somehow we
> should document the WG's continued interest in this area. Any suggestions?

I'm interested in picking up work on NVMe access for pNFS SCSI Layouts.

What would be the practical result of removing this work item from the
milestone list?

Ben

---

From: Chuck Lever <[email-masked]>
Date: Mon, 20 May 2019 12:02:56 -0400

> On May 20, 2019, at 12:01 PM, Benjamin Coddington <[email-masked]> wrote:
> 

For a prototype implementation, probably nothing. You can still communicate
any interesting findings to the document author or the Working Group.

--
Chuck Lever

---

From: spencer shepler <[email-masked]>
Date: Mon, 20 May 2019 09:37:45 -0700

Since it has been 18 months the expiration, etc., I just want to be
realistic about keeping it as a WG milestone.

The work can certainly continue and we can readapt the milestones - just
doing some housecleaning.

Spencer

On Mon, May 20, 2019 at 9:03 AM Chuck Lever <[email-masked]> wrote:

> >>> On May 20, 2019, at 11:46 AM, spencer shepler <
> [email-masked]>
> >>> wrote:
> >>>
> >>>

---

From: David Noveck <[email-masked]>
Date: Mon, 20 May 2019 13:21:08 -0400

> Given the dates and the lack of activity within the working group, I
would like the working group to consider
> removing the following work item from our milestones.

That makes sense.   The last time we reviewed milestone progress, this item
was clearly lagging but we
decided to wait a while, since Christoph was still reported to be
interested.   Given the time that has elapsed,
it may be time to admit defeat here.

> "Jun 2018     Submit final document describing use of NVMe in accessing a
pNFS SCSI Layout (as Proposed
> Standard)"

Note that we have similar issues with the other miilestone that Christoph
was intending to address.   Although, Sept.  2019 is in the future, given
that there is no draft on this topic, this milestone is probably
unrealizable and should be reconsidered as well.

Sep 2019 - Submit final document describing pNFS RDMA Layout (as
Proposed Standard)

aware of?

Maybe, but if so, I'm not aware of it either.   Has anyone else heard
anything?

I think this should be done as part of the milestone review at IETF105.
 When Chuck and I had been discussing the
agenda for the July meeting, we wound up splitting the milestone review.
 I was intending to cover the nearer-term milestones while Chuck was
addressing RDMA cm convention item and RPC-over--RDMA version two.

We had been  assuming that the two non-progressing milesones would be left
as is, but it seems that is no longer a viable option.   If Chuck is OK
with taking this on, then we can decide on plans for both of these items in
Montreal.

On Mon, May 20, 2019 at 11:40 AM spencer shepler <[email-masked]>
wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Chuck Lever <[email-masked]>
Date: Mon, 20 May 2019 13:34:41 -0400

> On May 20, 2019, at 12:37 PM, spencer shepler <[email-masked]> wrote:
> 
> 
> Since it has been 18 months the expiration, etc., I just want to be realistic about keeping it as a WG milestone.
> 
> The work can certainly continue and we can readapt the milestones - just doing some housecleaning.

Perfectly reasonable. You just happened to start with a complicated one!

--
Chuck Lever

---

From: "faibish, sorin" <[email-masked]>
Date: Mon, 20 May 2019 18:20:08 +0000

Spencer,

If the agenda is not closed yet I would like 10 minutes to discuss new attributes for data reduction. Just slides presenting the problem and few ways to address it. It could bridge into the pNFS SCSI but only indirectly as the purpose of the new attributes are referring to NVMe. Please let me know if I can get 10 min. thanks

./Sorin

From: nfsv4 <[email-masked]> On Behalf Of spencer shepler
Sent: Monday, May 20, 2019 12:38 PM
To: Chuck Lever
Cc: NFSv4
Subject: Re: [nfsv4] Potential charter update - removal of "use of NVMe in accessing a pNFS SCSI Layout" work item

[EXTERNAL EMAIL]

Spencer

On Mon, May 20, 2019 at 9:03 AM Chuck Lever <[email-masked]<mailto:[email-masked]>> wrote:

> On May 20, 2019, at 12:01 PM, Benjamin Coddington <[email-masked]<mailto:[email-masked]>> wrote:
>
>>> On May 20, 2019, at 11:46 AM, spencer shepler <[email-masked]<mailto:[email-masked]>>
>>> wrote:
>>>
>>>

--
Chuck Lever

---

From: spencer shepler <[email-masked]>
Date: Tue, 21 May 2019 08:11:32 -0700

Sorin,

It would be helpful to have access to some of these ideas prior to a
presentation at the meeting.  Email or a short, personal I-D would be
preferred so that we can see how it fits into the overall agenda.

Spencer

On Mon, May 20, 2019 at 11:20 AM faibish, sorin <[email-masked]>
wrote:

> Spencer,
>
>
>
> If the agenda is not closed yet I would like 10 minutes to discuss new
> attributes for data reduction. Just slides presenting the problem and few
> ways to address it. It could bridge into the pNFS SCSI but only indirectly
> as the purpose of the new attributes are referring to NVMe. Please let me
> know if I can get 10 min. thanks
>
>
>
> ./Sorin
>
>
>
> *From:* nfsv4 <[email-masked]> *On Behalf Of * spencer shepler
> *Sent:* Monday, May 20, 2019 12:38 PM
> *To:* Chuck Lever
> *Cc:* NFSv4
> *Subject:* Re: [nfsv4] Potential charter update - removal of "use of NVMe
> in accessing a pNFS SCSI Layout" work item
>
>
>
> [EXTERNAL EMAIL]
>
>
>

---

From: "faibish, sorin" <[email-masked]>
Date: Tue, 21 May 2019 18:01:45 +0000

Will do. I discussed with David Black as well and he will try to help me. Thanks for considering this

./Sorin

From: spencer shepler <[email-masked]>
Sent: Tuesday, May 21, 2019 11:12 AM
To: faibish, sorin
Cc: Chuck Lever; NFSv4
Subject: Re: [nfsv4] Potential charter update - removal of "use of NVMe in accessing a pNFS SCSI Layout" work item

[EXTERNAL EMAIL]

Sorin,

It would be helpful to have access to some of these ideas prior to a presentation at the meeting.  Email or a short, personal I-D would be preferred so that we can see how it fits into the overall agenda.

Spencer

On Mon, May 20, 2019 at 11:20 AM faibish, sorin <[email-masked]<mailto:[email-masked]>> wrote:
Spencer,

./Sorin

From: nfsv4 <[email-masked]<mailto:[email-masked]>> On Behalf Of spencer shepler
Sent: Monday, May 20, 2019 12:38 PM
To: Chuck Lever
Cc: NFSv4
Subject: Re: [nfsv4] Potential charter update - removal of "use of NVMe in accessing a pNFS SCSI Layout" work item

[EXTERNAL EMAIL]

Spencer

--
Chuck Lever