Subject: [nfsv4] xattr or COPY implementations

From: [email-masked] (J. Bruce Fields)
Date: Wed, 9 Oct 2019 13:44:19 -0400

There are outstanding Linux kernel client and server patches for xattrs
and for server-to-server COPY.

Are there any other implementations released or in progress?  Will they
be available for testing at the bakeathon next week?  If not, do you
expect them to be at another event in the future?

--b.

---

From: Rick Macklem <[email-masked]>
Date: Wed, 9 Oct 2019 22:06:42 +0000

J. Bruce Fields wrote:
>Are there any other implementations released or in progress?
I have xattr support here:
https://svn.freebsd.org/base/projects/nfsv42/sys
(there is intra server copy in it, but no inter server copy)

>Will they
>be available for testing at the bakeathon next week?
Only if someone there can download/install a fairly recent FreeBSD-current
and then replace the kernel with one built from the above sources.

>  If not, do you
Ditto above, rick

---

From: "van der Linden, Frank" <[email-masked]>
Date: Thu, 10 Oct 2019 15:58:58 +0000

Aside from submitting the patches you mention, I also fixed the nfs-ganesha implementation (that was based on an earlier draft of the spec, and did not have VFS backend support).

I haven't had time to clean up and submit the patches, but I can probably make them available by next week if someone wants to use it during a bikeathon. I used these nfs-ganesha changes for initial testing of the Linux kernel client side.

Frank

On 10/9/19, 10:45 AM, "nfsv4 on behalf of J. Bruce Fields" <[email-masked] on behalf of [email-masked]> wrote:

--b.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Frank Filz" <[email-masked]>
Date: Thu, 10 Oct 2019 09:12:10 -0700

> Aside from submitting the patches you mention, I also fixed the nfs-ganesha
> implementation (that was based on an earlier draft of the spec, and did not have
> VFS backend support).
> 
> I haven't had time to clean up and submit the patches, but I can probably make
> them available by next week if someone wants to use it during a bikeathon. I
> used these nfs-ganesha changes for initial testing of the Linux kernel client side.
> 
> Frank

If you have these ready, we should be able to get some testing. Kaleb Keithley will be there with a nfs-ganesha setup with most of the FSALs running.

Frank

> On 10/9/19, 10:45 AM, "nfsv4 on behalf of J. Bruce Fields" <nfsv4-
> [email-masked] on behalf of [email-masked]> wrote:
> 
> There are outstanding Linux kernel client and server patches for xattrs and for
> server-to-server COPY.
> 
> Are there any other implementations released or in progress?  Will they be
> available for testing at the bakeathon next week?  If not, do you expect them to
> be at another event in the future?
> 
> --b.
>

---

From: "van der Linden, Frank" <[email-masked]>
Date: Thu, 10 Oct 2019 16:26:07 +0000

Ok, let me see if I can get them out quickly.

Frank

Frank