Subject: Re: [nfsv4] AD review of draft-ietf-nfsv4-rpcrdma-cm-pvt-data

From: "McDonald, Alex" <[email-masked]>
Date: Tue, 5 Nov 2019 15:02:29 +0000

The first is kinda sorta jumping around the registration page at https://www.infinibandta.org/ibta-specification/<https://protect2.fireeye.com/v1/url?k=622241c7-3ef6466b-6222015c-8667c4afe13e-c542f080840fdbd3&q=1&e=74cf81e6-d431-43d1-8aca-853647f89252&u=https%3A%2F%2Fwww.infinibandta.org%2Fibta-specification%2F> ... And the second is a zip file where the copy says "Proprietary and Confidential". I'm a bit twitchy about that for general consumption, since as it says at https://www.infinibandta.org/membership/

IBTA membership benefits include: Access to: The InfiniBand architecture specifications, design and programming guideline documents

IANAL but I know a lot of them.

--
Alex

________________________________
From: Magnus Westerlund
Sent: Tuesday, November 05, 2019 09:24
To: McDonald, Alex; [email-masked]; magnus.westerlund=[email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [nfsv4] AD review of draft-ietf-nfsv4-rpcrdma-cm-pvt-data

Hi,

Regarding the URL: I think you can take the URL for the document from this page. It is at least publicly available and I was able to download the spec:

https://www.infinibandta.org/ibta-specifications-download/

So I think the document URL you want to include is this one:

https://cw.infinibandta.org/document/dl/7859

Cheers

Magnus

From: nfsv4 <[email-masked]> On Behalf Of McDonald, Alex
Sent: den 4 november 2019 17:57
To: Chuck Lever <[email-masked]>; Magnus Westerlund <magnus.westerlund=[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nfsv4] AD review of draft-ietf-nfsv4-rpcrdma-cm-pvt-data

>>       8. IBARCH URL Is not valid, it results in a 404.

>Well, that's unfortunate. That's the same URL that's cited in RFC 8166.

> Could use this one instead: <http://www.infinibandta.org/specs<https://protect2.fireeye.com/v1/url?k=390efdd2-65dafa7e-390ebd49-8667c4afe13e-845ba5a4f7c97a19&q=1&e=74cf81e6-d431-43d1-8aca-853647f89252&u=http%3A%2F%2Fwww.infinibandta.org%2Fspecs>>.

Also gets a 404. The spec at https://www.infinibandta.org/ibta-specification/<https://protect2.fireeye.com/v1/url?k=622241c7-3ef6466b-6222015c-8667c4afe13e-c542f080840fdbd3&q=1&e=74cf81e6-d431-43d1-8aca-853647f89252&u=https%3A%2F%2Fwww.infinibandta.org%2Fibta-specification%2F> is available only to members. (Most of my IBTA historical links no longer work; the site appears to have had a link makeover in the last few years.)

--

Alex

---

From: Chuck Lever <[email-masked]>
Date: Tue, 5 Nov 2019 11:01:04 -0500

I was going with https://www.infinibandta.org/ibta-specification/

Any objection to that one? Or is a document-specific URL required?

> On Nov 5, 2019, at 10:02 AM, McDonald, Alex <[email-masked]> wrote:
> 
> The first is kinda sorta jumping around the registration page at https://www.infinibandta.org/ibta-specification/ ... And the second is a zip file where the copy says "Proprietary and Confidential". I'm a bit twitchy about that for general consumption, since as it says at https://www.infinibandta.org/membership/
> 
> > Could use this one instead: <http://www.infinibandta.org/specs>.
> 
> Also gets a 404. The spec at https://www.infinibandta.org/ibta-specification/ is available only to members. (Most of my IBTA historical links no longer work; the site appears to have had a link makeover in the last few years.)
>  
> -- 
> Alex
> 

--
Chuck Lever

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 6 Nov 2019 13:15:05 +0000

On Tue, 2019-11-05 at 11:01 -0500, Chuck Lever wrote:
> I was going with 
> https://protect2.fireeye.com/v1/url?k=489ab08e-14109267-489af015-0cc47ad93e2e-6b57160bfeb284d6&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=https%3A%2F%2Fwww.infinibandta.org%2Fibta-specification%2F
> 

Normally I would say that it should be a locator of the actual referenced
document.  

Cheers

Magnus

> > The first is kinda sorta jumping around the registration page at 
> > https://protect2.fireeye.com/v1/url?k=2ab988b3-7633aa5a-2ab9c828-0cc47ad93e2e-abe067112395460e&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=https%3A%2F%2Fwww.infinibandta.org%2Fibta-specification%2F
> >  ... And the second is a zip file where the copy says "Proprietary and
> > Confidential". I'm a bit twitchy about that for general consumption, since
> > as it says at 
> > https://protect2.fireeye.com/v1/url?k=81f51ad1-dd7f3838-81f55a4a-0cc47ad93e2e-4c6a38be105d9d28&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=https%3A%2F%2Fwww.infinibandta.org%2Fmembership%2F
> > 
> > IBTA membership benefits include: Access to: The InfiniBand architecture
> > specifications, design and programming guideline documents
> > 
> > To: McDonald, Alex; [email-masked]; 
> > magnus.westerlund=[email-masked]
> > Regarding the URL: I think you can take the URL for the document from this
> > page. It is at least publicly available and I was able to download the spec:
> >  
> > 
https://protect2.fireeye.com/v1/url?k=d52a8dad-89a0af44-d52acd36-0cc47ad93e2e-ab8f66b5f9956428&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=https%3A%2F%2Fwww.infinibandta.org%2Fibta-specifications-download%2F
> > So I think the document URL you want to include is this one:
https://protect2.fireeye.com/v1/url?k=aca33b16-f02919ff-aca37b8d-0cc47ad93e2e-d9c6f865a109734d&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=https%3A%2F%2Fcw.infinibandta.org%2Fdocument%2Fdl%2F7859
> > To: Chuck Lever <[email-masked]>; Magnus Westerlund <
> > magnus.westerlund=[email-masked]>
> > > Could use this one instead: <
> > > https://protect2.fireeye.com/v1/url?k=d5014e4b-898b6ca2-d5010ed0-0cc47ad93e2e-99e3ecc8429b73c7&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=http%3A%2F%2Fwww.infinibandta.org%2Fspecs
> > > >.
> > 
> > Also gets a 404. The spec at 
> > https://protect2.fireeye.com/v1/url?k=efdfbe94-b3559c7d-efdffe0f-0cc47ad93e2e-ec5c23b283d610ae&q=1&e=d8e41474-996f-4d79-8719-80f8346fc794&u=https%3A%2F%2Fwww.infinibandta.org%2Fibta-specification%2F
> >  is available only to members. (Most of my IBTA historical links no longer
> > work; the site appears to have had a link makeover in the last few years.)
> >  
> > -- 
> > Alex
> > 
> 
> --
> Chuck Lever
> 
> 
> 
-- 
Cheers

Magnus Westerlund 

----------------------------------------------------------------------
Networks, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------