Subject: [nfsv4] NFSv4-wide documents on security, internationalization

From: David Noveck <[email-masked]>
Date: Mon, 25 Nov 2019 11:19:15 -0500

This was discussed at IETF105 but I want to make others in the working
group aware of my plans.

Internationalization and security are two areas that would need to be
addressed by rfc5661bis. After my presentation, Tom suggested that, since
the handling of these areas would be the same for all minor versions, it
would make sense to address these areas in NFSv4-wide documents, rather
than on a per-minor-version basis, as had been traditional.

At the time, I agreed to Tom's suggestion after giving the matter all of
fifteen seconds consideration, since it made so much sense. Since then, it
has become integral to my rfc5661bis plans and I have started working on
that basis.  Given that documents are planned, I might as well let people
know now.

The work on the internationalization document is farthest along.  I'm
working on an I-D based, in large part, on the internationalization section
of RFC7530, modified to deal with all NFSv4 minor versions. I anticipate
submitting it in December. Its form is such that it could be promoted to a
working group document. It is now marked as updating rfc's 7530 and 5661
but it's major function is to allow rfc5661bis to be written without an
internationalization section; the introduction will point to this new
document.

Work on the security document is not as far along, but, given the progress
of rpc-tls, it is now time to build up momentum in this area.  I have
started on an informational I-D laying out our choices in this area, to
help focus working group discussion with regard to this area.   I expect to
submit it in January.  This document will be analogous to migration-issues
and will probably not be published as an RFC.

My feeling is that we probably will not start on the standards-track nfsv4
security document until after IETF107 and that work on that document and
rfc5661bis will proceed in parallel.

---

From: "Black, David" <[email-masked]>
Date: Mon, 25 Nov 2019 19:52:37 +0000

> The work on the internationalization document is farthest along.  I'm working on an I-D based, in large part, on the internationalization section of RFC7530, modified to deal with all NFSv4 minor versions.
As someone who put a bunch of time/effort into that portion of RFC 7530 (truth be told, Dave N. did the bulk of the work), I strongly support this approach of developing that text into a general NVSv4 i18n doc.

Thanks, --David

From: nfsv4 <[email-masked]> On Behalf Of David Noveck
Sent: Monday, November 25, 2019 11:19 AM
To: NFSv4; [email-masked]; [email-masked]
Subject: [nfsv4] NFSv4-wide documents on security, internationalization

[EXTERNAL EMAIL]
This was discussed at IETF105 but I want to make others in the working group aware of my plans.

Internationalization and security are two areas that would need to be addressed by rfc5661bis. After my presentation, Tom suggested that, since the handling of these areas would be the same for all minor versions, it would make sense to address these areas in NFSv4-wide documents, rather than on a per-minor-version basis, as had been traditional.

At the time, I agreed to Tom's suggestion after giving the matter all of fifteen seconds consideration, since it made so much sense. Since then, it has become integral to my rfc5661bis plans and I have started working on that basis.  Given that documents are planned, I might as well let people know now.

The work on the internationalization document is farthest along.  I'm working on an I-D based, in large part, on the internationalization section of RFC7530, modified to deal with all NFSv4 minor versions. I anticipate submitting it in December. Its form is such that it could be promoted to a working group document. It is now marked as updating rfc's 7530 and 5661 but it's major function is to allow rfc5661bis to be written without an internationalization section; the introduction will point to this new document.

Work on the security document is not as far along, but, given the progress of rpc-tls, it is now time to build up momentum in this area.  I have started on an informational I-D laying out our choices in this area, to help focus working group discussion with regard to this area.   I expect to submit it in January.  This document will be analogous to migration-issues and will probably not be published as an RFC.

My feeling is that we probably will not start on the standards-track nfsv4 security document until after IETF107 and that work on that document and rfc5661bis will proceed in parallel.