Subject: [nfsv4] draft-ietf-nfsv4-rpc-tls WGLC is now closed

From: Chuck Lever <[email-masked]>
Date: Mon, 16 Dec 2019 14:21:47 -0500

Hi-

Working Group Last Call for draft-ietf-nfsv4-rpc-tls closed on Friday Dec 13.
I request that the Datatracker recognize completion of Last Call.

Thanks to all who read through the document and posted comments. I've collected
the comments in an updated draft. Here is a diff with rpc-tls-04:

https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-nfsv4-rpc-tls.txt&url2=https://chucklever.github.io/i-d-rpc-tls/draft-ietf-nfsv4-rpc-tls.txt

David, Tom, could you review these changes and let me know if I've understood
and correctly applied your comments?

Tigran, addressing Tom's comments necessitated a change in Section 5.1.1 to
language that you requested. Please review the changes and let me know if there
is a problem with the new text.

I'm willing to wait until year's end for late comments. If you have anything to
add, please don't hesitate to speak up.

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Mon, 16 Dec 2019 14:52:22 -0500

> I request that the Datatracker recognize completion of Last Call.

I'll do that within the next few days, once we have responses from everyone
whose
comments were incorporated.

> I'm willing to wait until year's end for late comments.

I'm not.   I assume the people who commented can, within a few days, let us
know whether the document is ready to go
.

> If you have anything to

That's very nice of you but I'm not sure how to accommodate late comments
once
WGLC is officially over, especially if I declare document consensus.

I don't see a need to effectively put off the end of WGLC until 12/31.

If people have small edirotial nits, you can incorporate them during  IESG
consideration.

If someone comes up with a stop-the-presses comment, they can raise the
issue during IETF
last call :-(, but I don't expect that to happen.

---

From: Chuck Lever <[email-masked]>
Date: Mon, 16 Dec 2019 14:58:16 -0500

> On Dec 16, 2019, at 2:52 PM, David Noveck <[email-masked]> wrote:
> 
> 
> 
> On Mon, Dec 16, 2019 at 2:21 PM Chuck Lever <[email-masked] <mailto:[email-masked]>> wrote:
> Hi-
> 
> I'll do that within the next few days, once we have responses from everyone whose
> https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-nfsv4-rpc-tls.txt&url2=https://chucklever.github.io/i-d-rpc-tls/draft-ietf-nfsv4-rpc-tls.txt <https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-nfsv4-rpc-tls.txt&url2=https://chucklever.github.io/i-d-rpc-tls/draft-ietf-nfsv4-rpc-tls.txt>
> 
> That's very nice of you but I'm not sure how to accommodate late comments once 

So that's not how it worked for cm-pvt-data. Tom's comments didn't arrive until after WGLC closed, and I was told that there are typically comments that arrive late. Was I misled?

I don't think you can declare a consensus until I provide a fresh revision that addresses WGLC comments?

Not trying to start a fight, but I thought I was doing the right thing here.

> If people have small edirotial nits, you can incorporate them during  IESG consideration.
> 
> If someone comes up with a stop-the-presses comment, they can raise the issue during IETF 

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Mon, 16 Dec 2019 22:56:14 -0500

On Mon, Dec 16, 2019, 2:59 PM Chuck Lever <[email-masked]> wrote:

> So that's not how it worked for cm-pvt-data. Tom's comments didn't arrive
> until after WGLC closed,
>

Cm-pvt data was a different situation.  WGLC was over, consensus had been
decided and the document is  now in AD review.

and I was told that there are typically comments that arrive late.

There sometimes are.

Was I misled?

I don't think so.

> I don't think you can declare a consensus until I provide a fresh revision
> that addresses WGLC comments.
>

My understanding was that you had done that.  Also. I thought that by
asking me to record the last call as being over you were asking me either
to declare consensus or no consensus yet.

>
> Not trying to start a fight,
>

There is no fight but there is a disagreement/misunderstanding that we need
to resolve.

but I thought I was doing the right thing here..

Yes but. I'm still not clear what you want to do here.  Should we put off
the end of WGLC until 12/31?

---

From: "Mkrtchyan, Tigran" <[email-masked]>
Date: Tue, 17 Dec 2019 11:44:46 +0100 (CET)

Hi Chuck,

looks good to me. Just couple of typos:

antecedants -> antecedents
Offloadng -> Offloading
authentictation -> authentication
facilites -> facilities
opportunitic -> opportunistic
'entries is to be considered' -> 'entries are to be considered'?

Thanks for the effort, 
   Tigran.

----- Original Message -----
> From: "Chuck Lever" <[email-masked]>
> To: "Dave Noveck" <[email-masked]>, "Tom Talpey" <[email-masked]>, "Tigran Mkrtchyan" <[email-masked]>
> Cc: "NFSv4" <[email-masked]>
> Sent: Monday, December 16, 2019 8:21:47 PM
> Subject: draft-ietf-nfsv4-rpc-tls WGLC is now closed

---

From: Chuck Lever <[email-masked]>
Date: Tue, 17 Dec 2019 11:21:57 -0500

Thanks, Tigran. Will get these fixed up.

> On Dec 17, 2019, at 5:44 AM, Mkrtchyan, Tigran <[email-masked]> wrote:
> 
> 
> 
> Hi Chuck,
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

--
Chuck Lever

---

From: Chuck Lever <[email-masked]>
Date: Tue, 17 Dec 2019 11:26:34 -0500

> On Dec 16, 2019, at 10:56 PM, David Noveck <[email-masked]> wrote:
> 
> 
> 
> On Mon, Dec 16, 2019, 2:59 PM Chuck Lever <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
>> On Dec 16, 2019, at 2:52 PM, David Noveck <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
> So that's not how it worked for cm-pvt-data. Tom's comments didn't arrive until after WGLC closed, 
> 
> Cm-pvt data was a different situation.  WGLC was over, consensus had been decided and the document is  now in AD review.
> 
> I don't think you can declare a consensus until I provide a fresh revision that addresses WGLC comments.
> 
> My understanding was that you had done that.  Also. I thought that by asking me to record the last call as being over you were asking me either to declare consensus or no consensus yet.

OK. My confusion, sorry.

I have not yet provided a final revision because I'm requesting that the reviewers check my changes. Once everyone has replied and the dust settles, I will submit a fresh revision, and ask that you make a consensus declaration.

> There is no fight but there is a disagreement/misunderstanding that we need to resolve.
> 
> Yes but. I'm still not clear what you want to do here.  Should we put off the end of WGLC until 12/31?
> 
> 

--
Chuck Lever