Subject: [nfsv4] FW: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-01.txt

From: <[email-masked]>
Date: Wed, 25 Dec 2019 15:37:27 +0000

Chairs,

As we discussed during IETF 105 I updated the draft replacing xattr with named attributes.

- draft-faibish-data-reduction-xattrs-pvt-00 expires on December 30
- draft-faibish-nfsv4-data-reduction-attributes-01 has been submitted to replace it.

Please find draft-faibish-nfsv4-data-reduction-attributes-01 that changed xattr with named attributes. I want to ask the opinion of the WG if the use of named attributes for data reduction is acceptable. I would like to present the new draft and discuss the adding new named attributes for data reduction in Vancouver. Thank you

./Sorin

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, December 24, 2019 9:02 PM
To: Shilane, Philip; faibish, sorin; Black, David
Subject: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-01.txt

[EXTERNAL EMAIL] 

A new version of I-D, draft-faibish-nfsv4-data-reduction-attributes-01.txt
has been successfully submitted by Sorin Faibish and posted to the IETF repository.

Name:		draft-faibish-nfsv4-data-reduction-attributes
Revision:	01
Title:		Support for Data Reduction Attributes in nfsv4 Version 2
Document date:	2019-12-24
Group:		Individual Submission
Pages:		12
URL:            https://www.ietf.org/internet-drafts/draft-faibish-nfsv4-data-reduction-attributes-01.txt
Status:         https://datatracker.ietf.org/doc/draft-faibish-nfsv4-data-reduction-attributes/
Htmlized:       https://tools.ietf.org/html/draft-faibish-nfsv4-data-reduction-attributes-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-faibish-nfsv4-data-reduction-attributes
Diff:           https://www.ietf.org/rfcdiff?url2=draft-faibish-nfsv4-data-reduction-attributes-01

Abstract:
   This document proposes extending NFSv4 operations to add new
   named attributes to be used in the protocol to provide information
   about the data reduction properties of files. The new data reduction
   attributes are proposed to allow the client application to
   communicate to the NFSv4 server data reduction attributes
   associated with files and directories using new metadata,
   communicated to the Block Storage data reduction engines.
   Corresponding new named attributes are proposed to allow clients
   and client applications to query the server for data reduction
   attributes support and allow to get and set data reduction
   attributes on files and directories. Such data reduction
   metadata is used as hints to the file server about what type of data
   reduction to apply. The proposed data reduction attributes include
   achievable ratios for compression and deduplication plus whether
   each data reduction technique applies to a file or directory.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Rick Macklem <[email-masked]>
Date: Wed, 25 Dec 2019 21:17:06 +0000

Just out of curiosity, what NFSv4 clients implement named attributes?
(I know FreeBSD does not.)

It just seems more likely that xattrs will be supported, since FreeBSD13 will
have them and patches for the Linux client seem to be in progress.

rick

________________________________________
From: nfsv4 <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Wednesday, December 25, 2019 10:37 AM
To: [email-masked]
Subject: [nfsv4] FW: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-01.txt

Chairs,

../Sorin

-----Original Message-----
From: [email-masked] <[email-masked]>
Sent: Tuesday, December 24, 2019 9:02 PM
To: Shilane, Philip; faibish, sorin; Black, David
Subject: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-01.txt

[EXTERNAL EMAIL]

Abstract:

The IETF Secretariat

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: <[email-masked]>
Date: Wed, 25 Dec 2019 21:37:13 +0000

-----Original Message-----
From: Rick Macklem <[email-masked]> 
Sent: Wednesday, December 25, 2019 4:17 PM
To: faibish, sorin; [email-masked]
Subject: Re: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-01.txt

[EXTERNAL EMAIL] 

Just out of curiosity, what NFSv4 clients implement named attributes?
(I know FreeBSD does not.)
[sf] I followed the recommendations from the meeting in Montreal where the WG was against using xattrr for this protocol as it was stated by the WG that there is no current implementation of xattr in NFSv4.2. It may be a poor choice, I understand.

It just seems more likely that xattrs will be supported, since FreeBSD13 will have them and patches for the Linux client seem to be in progress.
[sf] I know that after the meeting some other implementers mentioned in email that Ganesha, for example implemented xattr. So, I will want to discuss this during the next meeting and get the consensus on the attribute mechanism that will be accepted by the WG. I have posted the draft using named attributes as an alternative solution but I can still go back to xattr for which I had an implementation plan. So, please help me with this decision as you already have an implementation in FreeBSD. 

rick

Chairs,

../Sorin

-----Original Message-----
From: [email-masked] <[email-masked]>
Sent: Tuesday, December 24, 2019 9:02 PM
To: Shilane, Philip; faibish, sorin; Black, David
Subject: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-01.txt

[EXTERNAL EMAIL]

Abstract:

The IETF Secretariat

---

From: David Noveck <[email-masked]>
Date: Thu, 26 Dec 2019 05:26:01 -0500

> As we discussed during IETF 105 I updated the draft replacing xattr with

IIRC, the major issue with the use of xattrs was that the NFSv4.2 protocol
reserves all such attributes to hold application data, whose format/use is
not specified by the protocol.

The problem with a shift to named attributes is that named attributes have
exactly the same issue.

> Please find draft-faibish-nfsv4-data-reduction-attributes-01 that changed
> xattr with named attributes. I want to ask the opinion of the WG if the use
> of named attributes for data reduction is acceptable

Named attributes don't address the need.

You just need to describe your proposed new optional attributes.  The
attribute set is not that hard to extend, if there is a need to do so.
Other extension proposals have done that.

. I would like to present the new draft and discuss the adding new named
> attributes for data reduction in Vancouver.

There's should be time to shift away from named attributes.  You have until
3/9 to submit an -02.

Thank you
> Subject: New Version Notification for
> draft-faibish-nfsv4-data-reduction-attributes-01.txt
>
>
> [EXTERNAL EMAIL]
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-faibish-nfsv4-data-reduction-attributes-01.txt
> Status:
> https://datatracker.ietf.org/doc/draft-faibish-nfsv4-data-reduction-attributes/
> Htmlized:
> https://tools.ietf.org/html/draft-faibish-nfsv4-data-reduction-attributes-01
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-faibish-nfsv4-data-reduction-attributes
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-faibish-nfsv4-data-reduction-attributes-01
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>