Subject: [nfsv4] FW: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-02.txt

From: <[email-masked]>
Date: Mon, 30 Dec 2019 21:38:29 +0000

Please find a new version draft-faibish-nfsv4-data-reduction-attributes-02 that changed named attributes to RECOMMENDED. I want to ask the opinion of the WG if the use of RECOMMENDED attributes for data reduction is acceptable. 

./Sorin

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, December 30, 2019 4:35 PM
To: Shilane, Philip; faibish, sorin; Black, David
Subject: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-02.txt

[EXTERNAL EMAIL] 

A new version of I-D, draft-faibish-nfsv4-data-reduction-attributes-02.txt
has been successfully submitted by Sorin Faibish and posted to the IETF repository.

Name:		draft-faibish-nfsv4-data-reduction-attributes
Revision:	02
Title:		Support for Data Reduction Attributes in nfsv4 Version 2
Document date:	2019-12-24
Group:		Individual Submission
Pages:		12
URL:            https://www.ietf.org/internet-drafts/draft-faibish-nfsv4-data-reduction-attributes-02.txt
Status:         https://datatracker.ietf.org/doc/draft-faibish-nfsv4-data-reduction-attributes/
Htmlized:       https://tools.ietf.org/html/draft-faibish-nfsv4-data-reduction-attributes-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-faibish-nfsv4-data-reduction-attributes
Diff:           https://www.ietf.org/rfcdiff?url2=draft-faibish-nfsv4-data-reduction-attributes-02

Abstract:
   This document proposes extending NFSv4 operations to add new
   named attributes to be used in the protocol to provide information
   about the data reduction properties of files. The new data reduction
   attributes are proposed to allow the client application to
   communicate to the NFSv4 server data reduction attributes
   associated with files and directories using new metadata,
   communicated to the Block Storage data reduction engines.
   Corresponding new named attributes are proposed to allow clients
   and client applications to query the server for data reduction
   attributes support and allow to get and set data reduction
   attributes on files and directories. Such data reduction
   metadata is used as hints to the file server about what type of data
   reduction to apply. The proposed data reduction attributes include
   achievable ratios for compression and deduplication plus whether
   each data reduction technique applies to a file or directory.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: David Noveck <[email-masked]>
Date: Mon, 30 Dec 2019 17:06:20 -0500

On Mon, Dec 30, 2019, 4:38 PM <[email-masked]> wrote:

> Please find a new version draft-faibish-nfsv4-data-reduction-attributes-02
> that changed named attributes to RECOMMENDED. I want to ask the opinion of
> the WG if the use of RECOMMENDED attributes for data reduction is acceptable

Works for me.

> .
> ../Sorin
> Subject: New Version Notification for
> draft-faibish-nfsv4-data-reduction-attributes-02.txt
>
>
> [EXTERNAL EMAIL]
>
>

There's a problem with the submission.

-02 is just -01 with a new number. Still about named attributes.

Will need to submit your new document as -03.

> URL:
> https://www.ietf.org/internet-drafts/draft-faibish-nfsv4-data-reduction-attributes-02.txt
> Status:
> https://datatracker.ietf.org/doc/draft-faibish-nfsv4-data-reduction-attributes/
> Htmlized:
> https://tools.ietf.org/html/draft-faibish-nfsv4-data-reduction-attributes-02
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-faibish-nfsv4-data-reduction-attributes
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-faibish-nfsv4-data-reduction-attributes-02
>
> Abstract:
>    named

!!!!!!

attributes to be used in the protocol to provide information
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>