Subject: [nfsv4] Session Dealing with Current WG agenda at IETF 107

From: David Noveck <[email-masked]>
Date: Wed, 18 Dec 2019 12:59:02 -0500

I've requested two two-hour sessions at IETF 107.  Planning for the session
dealing with the current wg agenda is farthest along and  we have a
tentative schedule, which I will describe in this mail.  The other session,
dealing with the future, is not as far along and I will send out informaion
about it on a few days.

The current working group agenda consists of:

   - existing active WG documents
   - milestones for which there are no existing WG documents yet
   - A few additional items, for which WG documents are expected, in
   connection with rfc5661bis.

Attached is a powerpoint describing the state of this agenda.   I didn't
include a .pdf because the size (500K) might run afoul of WG list size
limits.   I can send one directly to anybody who wants one.

Regarding the items on slide two, no time has been allocated.   We hope
these will be published by March.    If they aren't, I will want to discuss
that somewhere where ethanol is available, rather than in a wg session.

Regarding the items on slide three:

   - Sorin will be presenting on the NVMe pNFS document.    I'm allocating
   twenty minutes to this.   Given the 4/2020 target date for (now) requesting
   publication,  it will be important to get any lingering questions resolved
   before WGLC.
   - Chuck does not anticipte any need for discussion of this
   document/milestone.  If this document is to be discussed at IETF107, it
   will be in connection with the NFSv4-wide security rework that is going to
   be referenced by rfc5661bis.

With regard to the items on slide four:

   - Given the decision to drop the milestone for the RDMA layout type,
   this will not be discussed in this session.  If there is someone who is
   brave (or foolish, judgment call) enough to want to discuss reviving this,
   we might allocate some time in the future-work session.
   - Chuck is anticipating a 15-minute talk on rpc-pver-rdma version 2..  I
   think the focus will be on the items added to version one and whether thet
   are are adequate to meet our goals for a version 2: big enough to be
   worthwhile but small enough to get done in a reasonable time.

With regard to the items on slide five:

   - I've allocated 15 mnutes for a discussion of the state of delstid
   (will be -01 by IETF107).   If the authors need more time for this, they
   should let me know.
   - No time specfically allocated for nfs-ulb-v2. If there is neef for
   bried discussion of this, it could be folded into the discussion of
   rpc-over-rdma version 2.
   - Chuck will be giving a 15 minute talk on integrtiy meaurement.   I
   expect the discussion to focus on the metadata format description.    The
   intention would be to make progress about questions about its adequacy.

I'm allocating 40 minutes for discussion of the items on slide six.   We
will spend at least 10 minutes on each document and allocate the extra ten
minutes as seems most appropriate given the situation in March.

This adds up to 105 minutes, so the schedule should not be tight.   If
people anticipate needing more time, please tell me before the meeting,
rather than having everybody assuming they can run over without difficulty
and leaving someone with only 5 or ten minutes when they need fifteen.

---

From: Chuck Lever <[email-masked]>
Date: Wed, 18 Dec 2019 13:48:55 -0500

> On Dec 18, 2019, at 12:59 PM, David Noveck <[email-masked]> wrote:
> 
> I've requested two two-hour sessions at IETF 107.  Planning for the session dealing with the current wg agenda is farthest along and  we have a tentative schedule, which I will describe in this mail.  The other session, dealing with the future, is not as far along and I will send out informaion about it on a few days. 
> 
> 	• existing active WG documents
> 	• milestones for which there are no existing WG documents yet
> 	• A few additional items, for which WG documents are expected, in connection with rfc5661bis.
> Attached is a powerpoint describing the state of this agenda.   I didn't include a .pdf because the size (500K) might run afoul of WG list size limits.   I can send one directly to anybody who wants one.
> 
> Regarding the items on slide two, no time has been allocated.   We hope these will be published by March.    If they aren't, I will want to discuss that somewhere where ethanol is available, rather than in a wg session..  
> 
> 	• Sorin will be presenting on the NVMe pNFS document.    I'm allocating twenty minutes to this.   Given the 4/2020 target date for (now) requesting publication,  it will be important to get any lingering questions resolved before WGLC.
> 	• Chuck does not anticipte any need for discussion of this document/milestone.  If this document is to be discussed at IETF107, it will be in connection with the NFSv4-wide security rework that is going to be referenced by rfc5661bis.
> 	• Given the decision to drop the milestone for the RDMA layout type, this will not be discussed in this session.  If there is someone who is brave (or foolish, judgment call) enough to want to discuss reviving this, we might allocate some time in the future-work session. 
> 	• Chuck is anticipating a 15-minute talk on rpc-pver-rdma version 2..  I think the focus will be on the items added to version one and whether thet are are adequate to meet our goals for a version 2: big enough to be worthwhile but small enough to get done in a reasonable time.
> 	• I've allocated 15 mnutes for a discussion of the state of delstid (will be -01 by IETF107).   If the authors need more time for this, they should let me know.
> 	• No time specfically allocated for nfs-ulb-v2. If there is neef for bried discussion of this, it could be folded into the discussion of rpc-over-rdma version 2.

It will be folded into the rpcrdma-version-two discussion. There isn't much to say about it.

> 	• Chuck will be giving a 15 minute talk on integrtiy meaurement.   I expect the discussion to focus on the metadata format description.    The intention would be to make progress about questions about its adequacy.
> I'm allocating 40 minutes for discussion of the items on slide six.   We will spend at least 10 minutes on each document and allocate the extra ten minutes as seems most appropriate given the situation in March. 
> 
> This adds up to 105 minutes, so the schedule should not be tight.   If people anticipate needing more time, please tell me before the meeting, rather than having everybody assuming they can run over without difficulty and leaving someone with only 5 or ten minutes when they need fifteen.
> <WgAgendaDec.pptx>_______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

--
Chuck Lever