Subject: Re: [nfsv4] FYI on an update to "RDMA Flush" I-D and IETF107

From: Chuck Lever <[email-masked]>
Date: Mon, 2 Mar 2020 11:36:33 -0500

[ Cc: corrected ]

> On Mar 1, 2020, at 12:41 PM, Tom Talpey <[email-masked]> wrote:
> 
> A couple of things FYI.
> 
> - I am updating the draft-talpey-rdma-commit document* in
> advance of IETF107. This is an iWARP extension in support of
> RDMA access to persistent memory, although it is somewhat more
> general than simply pmem. There is a parallel effort in IBTA.
> 
> - Because there is no longer an RDDP working group, one option
> discussed in the past with several WG chairs and Transport ADs was
> to move this forward in the NFSv4 WG. With the new chair situation,
> and the document republication, it may be worthwhile to discuss
> this again. I believe there is good merit to the idea.
> 
> - I plan to attend IETF107 NFSv4 WG meeting, but can only be
> there one day. I hope to discuss this further there. If you
> would like me to say something as part of the agenda, I am
> happy to do so.
> 
> Tom.
> 
> 
> * https://datatracker.ietf.org/doc/draft-talpey-rdma-commit/

The final IETF 107 session agenda has been published, and now both
nfsv4 WG sessions are planned for Thursday afternoon.

I propose the addition of a 10-minute session led by Tom, if there
is room on the nfsv4 agenda, to discuss the following matters:

- A review of the material for those unfamiliar with RDMA Flush
- Whether this work falls in the current WG charter
- Whether the I-D should be adopted as an nfsv4 WG document
- Whether a milestone is needed
- Whether this is a one-time proposal, or if we are agreeing
  that until there is another IETF home for RDMA-related documents,
  the nfsv4 WG should act as shepherd for such work.

--
Chuck Lever

---

From: "Black, David" <[email-masked]>
Date: Mon, 2 Mar 2020 17:02:56 +0000

As a TSVWG WG chair and a former RDDP WG chair, I support exploring working on RDMA Flush for iWARP in the NFSV4 WG.   The CM private data draft has ably demonstrated that the NFSV4 WG participants have considerable familiarity with RDMA, which is much more than I would expect of the TSVWG WG participants.  The TSVWG WG would remain an option in its role as a "catch-all" WG for Transport Area work that needs to be done and lacks a good "home" elsewhere in the Transport Area, but having the NFSV4 WG be that "home" would be a fine outcome.

Thanks, --David
----------------------------------------------------------------
David L. Black, Sr. Distinguished Engineer, Dell EMC
Dell Technologies, Infrastructure Systems Group
176 South St., Hopkinton, MA  01748
+1 (774) 350-9323           Mobile: +1 (978) 394-7754
[email-masked]
----------------------------------------------------------------

> -----Original Message-----
> From: nfsv4 <[email-masked]> On Behalf Of Chuck Lever
> Sent: Monday, March 2, 2020 11:37 AM
> To: Tom Talpey
> Cc: nfsv4-chairs; NFSv4
> Subject: Re: [nfsv4] FYI on an update to "RDMA Flush" I-D and IETF107
> 
> 
> [EXTERNAL EMAIL]
> 
> [ Cc: corrected ]
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: David Noveck <[email-masked]>
Date: Mon, 2 Mar 2020 12:57:20 -0500

Assuming Tom is OK with making this presentation, I will add it to the next
iteration of the agenda.

To keep ten minutes available we will have to enforce time discipline for
existing talks.

If Tom does not provide a short description by EOD tomorrow, I will do my
best to boil down Chuck's reasonable list into something that fits the
existing agenda format.