Subject: [nfsv4] Proposed charter changes

From: David Noveck <[email-masked]>
Date: Thu, 21 May 2020 07:03:42 -0400

As discussed previously, the working group will adopt Tom's personal rddp
extension draft.

With regard to the charter, I think the proposal below would clarify how we
deal with extension proposals that are of interest to us, but are not,
strictly speaking, extensions to NFSv4.

Specifically I propose replacing the second paragraph of the extensions
section which now reads:

Similarly, associated ONC protocol components that have a versioning/

extension framework can be incrementally extended, when necessary.

By the following two-paragraph replacement:

In dealing with needed extensions to areas that underlay NFSv4, the working
group's role will depend on the specific area needing extension.  In the
case of associated ONC protocol components, those that have a
versioning/extension framework can be incrementally, when necessary.

In the case of lower-level facilities of particular importance to NFSv4,
the working group will work with the responsible working group to make sure
needed extensions are available.  In cases in which there is no responsible
working group, it can help develop the necessary extension itself.

---

From: Tom Talpey <[email-masked]>
Date: Thu, 21 May 2020 14:15:33 +0000

The second sentence of the first paragraph is missing the word “extended” (after “incrementally”).

In the second paragraph, the “lower-level” term might be better as “lower-layer, for example transport”.

Will we work with irresponsible working groups? :-) (Tom ducks)

From: David Noveck <[email-masked]>
Sent: Thursday, May 21, 2020 7:04 AM
To: Magnus Westerlund <[email-masked]>; Tom Talpey <[email-masked]>
Cc: NFSv4 <[email-masked]>
Subject: [EXTERNAL] Proposed charter changes

As discussed previously, the working group will adopt Tom's personal rddp extension draft.

With regard to the charter, I think the proposal below would clarify how we deal with extension proposals that are of interest to us, but are not, strictly speaking, extensions to NFSv4.

Specifically I propose replacing the second paragraph of the extensions section which now reads:

In dealing with needed extensions to areas that underlay NFSv4, the working group's role will depend on the specific area needing extension.  In the case of associated ONC protocol components, those that have a versioning/extension framework can be incrementally, when necessary.

In the case of lower-level facilities of particular importance to NFSv4, the working group will work with the responsible working group to make sure needed extensions are available.  In cases in which there is no responsible working group, it can help develop the necessary extension itself.

---

From: David Noveck <[email-masked]>
Date: Thu, 21 May 2020 12:28:14 -0400

> The second sentence of the first paragraph is missing the word “extended”

Oops.

> “lower-layer, for example transport”.

That's better.

> Will we work with irresponsible working groups? :-) (Tom ducks)
I'm not sure whether we will or we won't.  It's just that the charter
really can't ask us to do that.

>
>
> *From:* David Noveck <[email-masked]>
> *Sent:* Thursday, May 21, 2020 7:04 AM
> *To:* Magnus Westerlund <[email-masked]>; Tom Talpey <
> [email-masked]>
> *Cc:* NFSv4 <[email-masked]>
> *Subject:* [EXTERNAL] Proposed charter changes
>
>
>
> With regard to the charter, I think the proposal below would clarify how
> we deal with extension proposals that are of interest to us, but are not,
> In dealing with needed extensions to areas that underlay NFSv4, the
> working group's role will depend on the specific area needing extension.
> In the case of associated ONC protocol components, those that have a