Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-08.txt

From: [email-masked]
Date: Fri, 19 Jun 2020 07:00:34 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 WG of the IETF.

        Title           : Towards Remote Procedure Call Encryption By Default
        Authors         : Trond Myklebust
                          Charles Lever
	Filename        : draft-ietf-nfsv4-rpc-tls-08.txt
	Pages           : 23
	Date            : 2020-06-19

Abstract:
   This document describes a mechanism that, through the use of
   opportunistic Transport Layer Security (TLS), enables encryption of
   in-transit Remote Procedure Call (RPC) transactions while
   interoperating with ONC RPC implementations that do not support this
   mechanism.  This document updates RFC 5531.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rpc-tls/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-nfsv4-rpc-tls-08
https://datatracker.ietf.org/doc/html/draft-ietf-nfsv4-rpc-tls-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rpc-tls-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chuck Lever <[email-masked]>
Date: Fri, 19 Jun 2020 10:11:46 -0400

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-08.txt
> Date: June 19, 2020 at 10:00:34 AM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> 

Yesterday, tls-reg-review approved our request to reserve an ALPN
for RPC-over-TLS. Revision 08 addresses Gen-ART review comments and
converts the document's source XML to xml2rfc version 3.

I believe the document is ready for the next step.

--
Chuck Lever

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 22 Jun 2020 08:03:53 +0000

Hi,

I have pushed the buttons for getting this put on the IESG telechat on the
9th of July. We are a bit to late for this weeks IESG telechat. 

Cheers

Magnus Westerlund

> -----Original Message-----
> From: Chuck Lever <[email-masked]>
> Sent: den 19 juni 2020 16:12
> To: [email-masked]
> Cc: NFSv4 <[email-masked]>
> Subject: Fwd: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-08.txt
> 
> 
> > Begin forwarded message:
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.
> Yesterday, tls-reg-review approved our request to reserve an ALPN for RPC-
> over-TLS. Revision 08 addresses Gen-ART review comments and converts the
> document's source XML to xml2rfc version 3.
>