Subject: [nfsv4] FW: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-03.txt

From: <[email-masked]>
Date: Wed, 24 Jun 2020 20:01:38 +0000

I posted a new version of the draft mainly to change the authors of the draft. I will present my plans for an implementation during the meeting/call. No additional changes were made at this time. Thank you

Sorin Faibish, SDE, DellEMC Midrange Division

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, June 24, 2020 3:55 PM
To: faibish, sorin; Shilane, Philip
Subject: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-03.txt

[EXTERNAL EMAIL] 

A new version of I-D, draft-faibish-nfsv4-data-reduction-attributes-03.txt
has been successfully submitted by Sorin Faibish and posted to the IETF repository.

Name:		draft-faibish-nfsv4-data-reduction-attributes
Revision:	03
Title:		Support for Data Reduction Attributes in nfsv4 Version 2
Document date:	2020-06-24
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-faibish-nfsv4-data-reduction-attributes-03.txt
Status:         https://datatracker.ietf.org/doc/draft-faibish-nfsv4-data-reduction-attributes/
Htmlized:       https://tools.ietf.org/html/draft-faibish-nfsv4-data-reduction-attributes-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-faibish-nfsv4-data-reduction-attributes
Diff:           https://www.ietf.org/rfcdiff?url2=draft-faibish-nfsv4-data-reduction-attributes-03

Abstract:
   This document proposes extending NFSv4 operations to add new
   RECOMMENDED attributes to be used in the protocol to provide
   information about the data reduction properties of files. The new
   data reduction attributes are proposed to allow the client
   application to communicate to the NFSv4 server data reduction
   attributes associated with files and directories using new metadata,
   communicated to the Block Storage data reduction engines.
   Corresponding new RECOMMENDED attributes are proposed to allow
   clients and client applications to query the server for data
   reduction attributes support and allow to get and set data reduction
   attributes on files and directories. Such data reduction
   metadata is used as hints to the file server about what type of data
   reduction to apply. The proposed data reduction attributes include
   achievable ratios for compression and deduplication plus whether
   each data reduction technique applies to a file or directory.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: David Noveck <[email-masked]>
Date: Thu, 25 Jun 2020 06:13:03 -0400

On Wed, Jun 24, 2020, 4:01 PM <[email-masked]> wrote:

> I posted a new version of the draft mainly to change the authors of the
> draft.

I suppose that the impending expiration of the -02 also had a role.

I was confused by the diffs from -02 since almost all the changes were
things we had already seen in the post-107 virtual meeting.  I suppose that
the document that we discussed at that time has not been posted until now.
???

I will present my plans for an implementation during the meeting/call.

If you are requesting a speaking slot at that meeting and it seems as if
you are, you need to send me something that tells me what you intend to
talk about and how much time you intend to take.

Normally "plans for an implementation" might be an OK description but in
this case the specific attributes you intend to implement have never been
described, so I'll need some clarification on that, as would anyone who
might be interested in interoperating with your proposed implementation.

No additional changes were made at this time.

In the eleven months since the -00 was published, there has been very
limited progress toward describing the substance of the proposed attributes
and I think the working group will want to hear about your plans to make
progress in that regard. The need for that description was made clear at
the post-107 meeting.

Also, you agreed to work on the nvme/pNFS document and we will need a
progress report on that effort.

Thank you
> Subject: New Version Notification for
> draft-faibish-nfsv4-data-reduction-attributes-03.txt
>
>
> [EXTERNAL EMAIL]
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-faibish-nfsv4-data-reduction-attributes-03.txt
> Status:
> https://datatracker.ietf.org/doc/draft-faibish-nfsv4-data-reduction-attributes/
> Htmlized:
> https://tools.ietf.org/html/draft-faibish-nfsv4-data-reduction-attributes-03
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-faibish-nfsv4-data-reduction-attributes
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-faibish-nfsv4-data-reduction-attributes-03
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: <[email-masked]>
Date: Thu, 25 Jun 2020 20:33:58 +0000

From: nfsv4 <[email-masked]> On Behalf Of David Noveck
Sent: Thursday, June 25, 2020 6:13 AM
To: faibish, sorin
Cc: NFSv4
Subject: Re: [nfsv4] FW: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-03.txt

[EXTERNAL EMAIL]

On Wed, Jun 24, 2020, 4:01 PM <[email-masked]<mailto:[email-masked]>> wrote:
I posted a new version of the draft mainly to change the authors of the draft.

I suppose that the impending expiration of the -02 also had a role.
[sf] and drop David Black from the authors.

I was confused by the diffs from -02 since almost all the changes were things we had already seen in the post-107 virtual meeting.  I suppose that the document that we discussed at that time has not been posted until now. ???
[sf] Correct.

If you are requesting a speaking slot at that meeting and it seems as if you are, you need to send me something that tells me what you intend to talk about and how much time you intend to take.
[sf] Yes please plan for 15 min slot.

Normally "plans for an implementation" might be an OK description but in this case the specific attributes you intend to implement have never been described, so I'll need some clarification on that, as would anyone who might be interested in interoperating with your proposed implementation.
[sf] Yes, I will include the proposed attributes in the slides that I will present for discussions and agreement.

In the eleven months since the -00 was published, there has been very limited progress toward describing the substance of the proposed attributes and I think the working group will want to hear about your plans to make progress in that regard. The need for that description was made clear at the post-107 meeting.
[sf] I don’t disagree and this is what I intent to include in the plan as well.

Also, you agreed to work on the nvme/pNFS document and we will need a progress report on that effort.
[sf] We made some progress and Christophe did a first review and started a git where we checked the document and started the review. I am still waiting for a last review of David Black. I might post the draft as it is now (needs more cleanup) so the WG can start a review. In any case we intent to get a spot to present the progress made since 107. We need a slot for this, maybe 20min. thank you

./Sorin

Thank you

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, June 24, 2020 3:55 PM
To: faibish, sorin; Shilane, Philip
Subject: New Version Notification for draft-faibish-nfsv4-data-reduction-attributes-03.txt

[EXTERNAL EMAIL]

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: David Noveck <[email-masked]>
Date: Fri, 26 Jun 2020 05:44:44 -0400

On Thu, Jun 25, 2020, 4:34 PM <[email-masked]> wrote:

>
>
>
>
> *From:* nfsv4 <[email-masked]> *On Behalf Of * David Noveck
> *Sent:* Thursday, June 25, 2020 6:13 AM
> *To:* faibish, sorin
> *Cc:* NFSv4
> *Subject:* Re: [nfsv4] FW: New Version Notification for
> [sf] Yes please plan for 15 min slot
>
> present for discussions and agreement.
Ok. You've given me enough detail to include this in the preliminary agenda.

> [sf] We made some progress and Christophe did a first review and started a
> git where we checked the document and started the review. I am still
> waiting for a last review of David Black. I might post the draft as it is
> now (needs more cleanup) so the WG can start a review.
>

I'd like that, but I think I have to check with Magnus to make sure there
is no rule preventing us from discussing a very recently submitted draft,
as there would be in the case in which we were meetimg the week of IETF
108. Sigh.

In any case we intent to get a spot to present the progress made since 107.
We need a slot for this, maybe 20min. thank you

> Great. Will do. Who should the agenda list as presenters?