Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpcrdma-version-two-03.txt

From: [email-masked]
Date: Mon, 10 Aug 2020 05:51:13 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 WG of the IETF.

        Title           : RPC-over-RDMA Version 2 Protocol
        Authors         : Charles Lever
                          David Noveck
	Filename        : draft-ietf-nfsv4-rpcrdma-version-two-03.txt
	Pages           : 88
	Date            : 2020-08-10

Abstract:
   This document specifies the second version of a transport protocol
   that conveys Remote Procedure Call (RPC) messages using Remote Direct
   Memory Access (RDMA).  This version of the protocol is extensible.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rpcrdma-version-two/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-nfsv4-rpcrdma-version-two-03
https://datatracker.ietf.org/doc/html/draft-ietf-nfsv4-rpcrdma-version-two-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rpcrdma-version-two-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chuck Lever <[email-masked]>
Date: Mon, 10 Aug 2020 09:01:55 -0400

Hello-

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpcrdma-version-two-03.txt
> Date: August 10, 2020 at 8:51:13 AM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> 

This revision makes significant changes to the document and protocol:

- Replace deprecated iWARP terminology with references to RDMAP, DDP, and MPA
- Re-organize the discussion of "XDR Encoding with Chunks"
- Update the discussion of reverse-direction operation
- Fix errors in the XDR definition
- Split up the RDMA2_MSG and RDMA2_NOMSG header types, and introduce a Call chunk
- Document all these changes in Appendix C

In addition to deep prototyping, there are still a handful of areas that
still need work; for example, "Host Authentication".

--
Chuck Lever