Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-09.txt

From: [email-masked]
Date: Fri, 18 Sep 2020 05:22:49 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 WG of the IETF.

        Title           : Towards Remote Procedure Call Encryption By Default
        Authors         : Trond Myklebust
                          Charles Lever
	Filename        : draft-ietf-nfsv4-rpc-tls-09.txt
	Pages           : 26
	Date            : 2020-09-18

Abstract:
   This document describes a mechanism that, through the use of
   opportunistic Transport Layer Security (TLS), enables encryption of
   Remote Procedure Call (RPC) transactions while they are in-transit.
   The proposed mechanism interoperates with ONC RPC implementations
   that do not support it.  This document updates RFC 5531.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rpc-tls/

There is also a HTML versions available at:
https://www.ietf.org/id/draft-ietf-nfsv4-rpc-tls-09.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rpc-tls-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chuck Lever <[email-masked]>
Date: Fri, 18 Sep 2020 08:28:38 -0400

Hello-

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-09.txt
> Date: September 18, 2020 at 8:22:49 AM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> 

This revision contains proposed updates to address the many DISCUSS
and COMMENT ballot positions offered during IESG review. Magnus
suggested that I provide a fresh revision as the easiest vehicle
to explore these updates, and we can go forward from here with any
additional changes needed.

--
Chuck Lever

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 18 Sep 2020 13:02:18 +0000

Hi Chuck!

Thank you for merging the changes in -09.  (As previously discussed) This text addresses my DISCUSS and COMMENT feedback.  I've cleared my ballot.

Regards,
Roman

> -----Original Message-----
> From: Chuck Lever <[email-masked]>
> Sent: Friday, September 18, 2020 8:29 AM
> To: Martin Duke <[email-masked]>; Roman Danyliw
> <[email-masked]>; Benjamin Kaduk <[email-masked]>
> Cc: The IESG <[email-masked]>; [email-masked]; nfsv4-chairs
> <[email-masked]>; NFSv4 <[email-masked]>
> Subject: Fwd: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-09.txt
> 
> Hello-
> 
> > Begin forwarded message:
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> This revision contains proposed updates to address the many DISCUSS and
> COMMENT ballot positions offered during IESG review. Magnus suggested that
> I provide a fresh revision as the easiest vehicle to explore these updates, and
> we can go forward from here with any additional changes needed.
> 
> 
> --
> Chuck Lever
> 
>