Subject: [nfsv4] [Technical Errata Reported] RFC8881 (6308)

From: RFC Errata System <[email-masked]>
Date: Fri, 16 Oct 2020 15:00:55 -0700 (PDT)

The following errata report has been submitted for RFC8881,
"Network File System (NFS) Version 4 Minor Version 1 Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6308

--------------------------------------
Type: Technical
Reported by: Calum Mackay <[email-masked]>

Section: 18.32.3

Original Text
-------------
   *  The server MUST commit the data at a level at least as high as
      that committed.

Corrected Text
--------------
   *  The server MUST commit the data at a level at least as high as
      that requested.

Notes
-----
The meaning is probably obvious, but perhaps a MUST ought
to be unambiguous?

---

editorial: also, the point above this one uses the word "stronger"
where this point uses "high", both for the stability level.

The two lines should probably use the same word.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8881 (draft-ietf-nfsv4-rfc5661sesqui-msns-04)
--------------------------------------
Title               : Network File System (NFS) Version 4 Minor Version 1 Protocol
Publication Date    : August 2020
Author(s)           : D. Noveck, Ed., C. Lever
Category            : PROPOSED STANDARD
Source              : Network File System Version 4
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 20 Oct 2020 13:56:04 +0000

Hi,

Authors, can you please comment on this Errata. Appears a straight forward one
to verify if it correct.

/Magnus

> "Network File System (NFS) Version 4 Minor Version 1 Protocol".
https://protect2.fireeye.com/v1/url?k=ab0db258-f5ad0836-ab0df2c3-86b1886cfa64-24ef43ab44e776da&q=1&e=84f54505-cd2c-40e6-a5e7-27c22813adc1&u=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6308

---

From: Chuck Lever <[email-masked]>
Date: Tue, 20 Oct 2020 10:52:38 -0400

Hi Magnus-

I asked Calum to file this for the WG to verify.
It looks like a valid comment to me.

> On Oct 20, 2020, at 9:56 AM, Magnus Westerlund <[email-masked]> wrote:
> 
> Hi,
> 

--
Chuck Lever

---

From: "Noveck, David" <[email-masked]>
Date: Tue, 20 Oct 2020 15:20:18 +0000

Looks valid to me as well.

-----Original Message-----
From: Chuck Lever <[email-masked]> 
Sent: Tuesday, October 20, 2020 10:53 AM
To: Magnus Westerlund <[email-masked]>
Cc: Noveck, David <[email-masked]>; David Noveck <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Technical Errata Reported] RFC8881 (6308)

NetApp Security WARNING: This is an external email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

Hi Magnus-

> Authors, can you please comment on this Errata. Appears a straight 
> forward one to verify if it correct.
>
> /Magnus
>
>> The following errata report has been submitted for RFC8881, "Network 
>> File System (NFS) Version 4 Minor Version 1 Protocol".
>>
> https://protect2.fireeye.com/v1/url?k=ab0db258-f5ad0836-ab0df2c3-86b18
> 86cfa64-24ef43ab44e776da&q=1&e=84f54505-cd2c-40e6-a5e7-27c22813adc1&u=
> https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6308
>>
>> The meaning is probably obvious, but perhaps a MUST ought to be 
>> unambiguous?
>>
>> ---
>>
>> use "Reply All" to discuss whether it should be verified or rejected. 
>> When a decision is reached, the verifying party can log in to change 
>> the status and edit the report, if necessary.
>>

--
Chuck Lever

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 27 Oct 2020 08:38:03 +0000

Hi,

Then I will verify it. 

/Magnus

On Tue, 2020-10-20 at 15:20 +0000, Noveck, David wrote:
> Cc: Noveck, David <[email-masked]>; David Noveck <
> [email-masked]>; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> NetApp Security WARNING: This is an external email. Do not click links or open
> attachments unless you recognize the sender and know the content is safe.
> 
> 
> 
> 
> Hi Magnus-
>