Subject: Re: [nfsv4] Fwd: I-D Action: draft-ietf-nfsv4-rpc-tls-10.txt

From: Magnus Westerlund <[email-masked]>
Date: Mon, 2 Nov 2020 09:21:43 +0000

Thanks Chuck,

Ben does this resolve your discuss?

Cheers

Magnus

On Sat, 2020-10-31 at 12:28 -0400, Chuck Lever wrote:
> Hello all-
> 
> 
> > Begin forwarded message:
> > 
> > From: [email-masked]
> > Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpc-tls-10.txt
> > Date: October 31, 2020 at 12:24:00 PM EDT
> > To: <[email-masked]>
> > Cc: [email-masked]
> > Reply-To: [email-masked]
> > 
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > This draft is a work item of the Network File System Version 4 WG of the
> > IETF.
> > 
> >        Title           : Towards Remote Procedure Call Encryption By Default
> >        Authors         : Trond Myklebust
> >                          Charles Lever
> > 	Filename        : draft-ietf-nfsv4-rpc-tls-10.txt
> > 	Pages           : 26
> > 	Date            : 2020-10-31
> > 
> > Abstract:
> >   This document describes a mechanism that, through the use of
> >   opportunistic Transport Layer Security (TLS), enables encryption of
> >   Remote Procedure Call (RPC) transactions while they are in-transit.
> >   The proposed mechanism interoperates with ONC RPC implementations
> >   that do not support it.  This document updates RFC 5531.
> > 
> > 
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rpc-tls/
> > 
> > There is also an HTML version available at:
> > https://www.ietf.org/archive/id/draft-ietf-nfsv4-rpc-tls-10.html
> > 
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rpc-tls-10
> > 
> > 
> > Please note that it may take a couple of minutes from the time of submission
> > until the htmlized version and diff are available at tools.ietf.org.
> > 
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> 
> As requested, this new revision proposes updates to address Ben
> Kaduk's DISCUSS and COMMENT positions.
> 
> 
> --
> Chuck Lever
> 
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 2 Nov 2020 17:31:51 -0800

> Thanks Chuck,

Seconded -- thanks Chuck!

> Ben does this resolve your discuss?

Yes, and I've updated my position in the datatracker.

-Ben

---

From: Chuck Lever <[email-masked]>
Date: Tue, 3 Nov 2020 08:48:26 -0500

> On Nov 2, 2020, at 8:31 PM, Benjamin Kaduk <[email-masked]> wrote:
> 

Thank you for your very thorough review!

The "must typically" phrase you noticed is unintentional. I'll queue
up a reversal of those two words for the next revision.

--
Chuck Lever
[email-masked]