Subject: [nfsv4] Interim meeting for nfsv4 working group

From: David Noveck <[email-masked]>
Date: Fri, 4 Dec 2020 15:43:46 -0500

We were originally thinking of doing an interim meeting close to the IETF
meeting in virtual Bangkok, but I haven't followed up on that, so that,
given the holidays and needs for notice, December is not going to work out
very well.  I think we should plan an interim meeting for January 2021.

I anticipate that we will meet some time in the last two weeks of January,
between 1/18 and 1/31.   Given that we have had no participants outside
Europe and North America, I expect the meeting to start 1600 UTC.  If
anyone has issues with the time or date range, let us know soon. For now, I
expect the default date to be 1/26.

I anticipate a single two-hour meeting focusing on work already in progress
although we might have time for a few short presentations of new ideas.
Let me know soon about things you want to talk about so I can plan for
those.

I have the following areas in mind for discussion of the meeting:

   - Discussion.of rfc5661bis progress including the internationalization
   and security work done so far in draft-dnoveck-nfsv4-{internalization,
   security-needs}.
   - Discussion of the next steps for security,given where rpc-tls is
   (approved but not an RPC for a while).   I'm hoping that Chuck will present.
   - Discussion of progress so far and expected next steps for the pNFS
   NVMe work.   I'm assuming David and Sorin will decide how to split this up.

If you intend to present or have opinions about what should be presented,
let us know on the mailing list. I'd like to be able to arrive at an agenda
in the next few weeks.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 4 Dec 2020 20:30:54 -0800

> I have the following areas in mind for discussion of the meeting:
[...]
>    (approved but not an RPC for a while).   I'm hoping that Chuck will present.

It looks like rpc-tls is in MISSINGREF due to three drafts, all of which
I'm responsible AD for:

- draft-ietf-kitten-tls-channel-bindings-for-tls13 is still in the WG but
  as of the -01 should be pretty much done; we're just looking for a couple
  more reviews (and I have some arms I can twist)
- draft-ietf-tls-dtls-connection-id will go to IETF LC once
  https://github.com/tlswg/dtls-conn-id/pull/77 is merged, and it's
  currently in the "give WG members a chance to object" stage
- draft-ietf-tls-dtls13 is waiting for a revised I-D in response to my AD
  evaluation comments.  It's been a couple weeks since we heard from the
  author about it, so I will ask for an update.

-Ben

---

From: Chuck Lever <[email-masked]>
Date: Sat, 5 Dec 2020 13:24:41 -0500

Hi David-

> On Dec 4, 2020, at 3:43 PM, David Noveck <[email-masked]> wrote:
> 
> We were originally thinking of doing an interim meeting close to the IETF meeting in virtual Bangkok, but I haven't followed up on that, so that, given the holidays and needs for notice, December is not going to work out very well.  I think we should plan an interim meeting for January 2021.
> 
> I anticipate that we will meet some time in the last two weeks of January, between 1/18 and 1/31.   Given that we have had no participants outside Europe and North America, I expect the meeting to start 1600 UTC.  If anyone has issues with the time or date range, let us know soon. For now, I expect the default date to be 1/26.
> 
> I anticipate a single two-hour meeting focusing on work already in progress although we might have time for a few short presentations of new ideas.  Let me know soon about things you want to talk about so I can plan for those.
> 
> Discussion.of rfc5661bis progress including the internationalization and security work done so far in draft-dnoveck-nfsv4-{internalization, security-needs}.
> Discussion of the next steps for security,given where rpc-tls is (approved but not an RPC for a while).   I'm hoping that Chuck will present.
We can discuss this offline to determine a presentation plan.

> Discussion of progress so far and expected next steps for the pNFS NVMe work.   I'm assuming David and Sorin will decide how to split this up.
> If you intend to present or have opinions about what should be presented, let us know on the mailing list. I'd like to be able to arrive at an agenda in the next few weeks.
> 
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

--
Chuck Lever