Subject: [nfsv4] questions about flow control (follow up)

From: Chuck Lever III <[email-masked]>
Date: Wed, 2 Jun 2021 18:57:32 +0000

As a prelude to further technical discussion, I've researched
a few flow control protocols, and come up with (admittedly
incomplete) proposed language. Please see Section 4.2:

https://chucklever.github.io/i-d-rpcrdma-version-two/draft-ietf-nfsv4-rpcrdma-version-two.html#name-reliable-message-delivery

There is an rfcdiff available:

https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-nfsv4-rpcrdma-version-two.txt&url2=https://chucklever.github.io/i-d-rpcrdma-version-two/draft-ietf-nfsv4-rpcrdma-version-two.txt

We can hold a design call if interactive dialog is needed,
but if folks feel the proposed language is a lot closer and
have only minor suggestions, the call can be skipped.

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Sat, 12 Jun 2021 04:02:38 -0400

> have only minor suggestions, the call can be skipped.

I don't feel a design call is necessary.  I will probably be able to
provide some suggested textual changes for a -05 to be submitted before the
ietf111 window closes.   I'll try to provide those by 7/5.

BTW, how much time do you expect to devote to RPC-over-RDMA v2 at the wg
meeting?

>
> --
> Chuck Lever
>
>
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Chuck Lever III <[email-masked]>
Date: Sat, 12 Jun 2021 16:16:49 +0000

> On Jun 12, 2021, at 4:02 AM, David Noveck <[email-masked]> wrote:
> 
> I don't feel a design call is necessary.

Thanks for your review! I'm still open to hear from others about whether a design
call is preferred in advance of IETF 111, but it's getting late to squeeze one in.

> I will probably be able to provide some suggested textual changes for a -05 to be submitted before the ietf111 window closes.   I'll try to provide those by 7/5.

Noted that the draft submission window closes on July 12.

> BTW, how much time do you expect to devote to RPC-over-RDMA v2 at the wg meeting?

Let's shoot for 15 minutes. I'm hoping it will be quicker than that.

--
Chuck Lever