Subject: [nfsv4] Current agenda for wg meeting as part of IETF111

From: "Noveck, David" <[email-masked]>
Date: Wed, 7 Jul 2021 10:25:27 +0000

This is very preliminary and I urge anyone who knows  anything relevant that is not being addressed to speak up soon.

It appears that we have a fair amount of extra time available for additional presentations but there is no prospect of fitting everything into a single one-hour session,  without rushing people.

I have treated the two sessions as a single meeting, which it is.  For example, there is time for note-well and agenda bashing only once.

This ordering makes sense to me.   If anyone would like a re-ordering, for example,  to enable use of  a one-day pass, let me know and I'll change things as necessary.

Who
Time
Subject
Detail
DN
10 min.
Misc.
Introduction, note-well, agenda-bashing.   Discussion of note-taking.
DN
15 min.
5661bis
Discussion of current state of the rfc5661bis effort, including the associated NFSv4-wide documents.
DN
15 min.
Security
Discussion of draft-dnoveck-nfsv4-security-00 (to be submitted soon) and future plans to move forward in this area.
CEL
15 min.
Ror v2
Discussion of draft-ietf-nfsv4-rpcrdma-version-two-05,  draft-ietf-nfsv4-nfs-ulb-v2-05<https://datatracker.ietf.org/doc/draft-ietf-nfsv4-nfs-ulb-v2/> and needed steps on the way to WGLC.
CEL
15 min.
Quic
Discussion of the path forward for NFSv4 to enable use of this transport.
All
20 min.
Future work
Discussion of things the working group should be doing and that have not been done, including:

  *   Things we planned to do but never followed up on, including pNFS-NVMe and pNFS-RDMA.
  *   New ideas to address other needs which are part of our charter but  have not been given serious attention

---

From: Chuck Lever III <[email-masked]>
Date: Wed, 7 Jul 2021 13:30:45 +0000

On Jul 7, 2021, at 6:25 AM, Noveck, David <David.Noveck=[email-masked]<mailto:David.Noveck=[email-masked]>> wrote:

This ordering makes sense to me.   If anyone would like a re-ordering, for example,  to enable use of  a one-day pass, let me know and I’ll change things as necessary.

Who
Time
Subject
Detail
DN
10 min.
Misc.

I'm giving a talk on RPC-with-TLS status and follow-up. Please allocate 15 minutes for this talk, but it will probably be less than that.

Also I'm considering talking for a few minutes about draft-cel-nfsv4-hash-interchange-format. I haven't written slides yet, but I'm guessing 10 or 15 minutes will be adequate.

--
Chuck Lever