Subject: Re: [nfsv4] draft-ietf-nfsv4-rpc-tls matters to address during AUTH48

From: David Noveck <[email-masked]>
Date: Sun, 1 Aug 2021 08:39:05 -0400

There are a couple of issues I noticed.

In a number of places, you change "RPC-over-RDMA" to "RPC-with-RDMA" which
is not appropriate since that document is already published as an RFC.

In one place you refer to the "RPC-with-TLS *protocol*" (emphasis added).
As I understood things, part of the idea behind the over-with switch was
that RPC-with-TLS was no longer a protocol, but  a feature to be applied to
existing protocols.   The text in draft-dnoveck-nfsv4-security-00 takes
that view.

On Fri, Jul 30, 2021 at 10:51 AM Chuck Lever III <[email-masked]>
wrote:

> Hi-
>
> As discussed during yesterday's nfsv4 WG session, I've mocked up
> a few editorial changes to rpc-tls to address issues that have
> arisen since it was added to the RFC Editor's queue.
>
> - Appendix B: replaced the ASN.1 fragment with a module
> - Renamed "RPC-over-TLS" as "RPC-with-TLS"
>
> A diff with -11 can be viewed here:
>
>
> https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-nfsv4-rpc-tls.txt&url2=https://chucklever.github.io/i-d-rpc-tls/draft-ietf-nfsv4-rpc-tls.txt
>
>
> --
> Chuck Lever
>
>
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: Chuck Lever III <[email-masked]>
Date: Sun, 1 Aug 2021 15:25:15 +0000

On Aug 1, 2021, at 8:39 AM, David Noveck <[email-masked]<mailto:[email-masked]>> wrote:

In a number of places, you change "RPC-over-RDMA" to "RPC-with-RDMA" which is not appropriate since that document is already published as an RFC.

In one place you refer to the "RPC-with-TLS protocol" (emphasis added).  As I understood things, part of the idea behind the over-with switch was that RPC-with-TLS was no longer a protocol, but  a feature to be applied to existing protocols.   The text in draft-dnoveck-nfsv4-security-00 takes that view.

Nice catches! These have been addressed.

On Fri, Jul 30, 2021 at 10:51 AM Chuck Lever III <[email-masked]<mailto:[email-masked]>> wrote:
Hi-

--
Chuck Lever