Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpcrdma-version-two-06.txt

From: [email-masked]
Date: Sun, 02 Jan 2022 08:58:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 WG of the IETF.

        Title           : RPC-over-RDMA Version 2 Protocol
        Authors         : Charles Lever
                          David Noveck
	Filename        : draft-ietf-nfsv4-rpcrdma-version-two-06.txt
	Pages           : 90
	Date            : 2022-01-02

Abstract:
   This document specifies the second version of a transport protocol
   that conveys Remote Procedure Call (RPC) messages using Remote Direct
   Memory Access (RDMA).  This version of the protocol is extensible.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-rpcrdma-version-two/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-nfsv4-rpcrdma-version-two-06.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-rpcrdma-version-two-06

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Chuck Lever III <[email-masked]>
Date: Sun, 2 Jan 2022 17:09:40 +0000

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-rpcrdma-version-two-06.txt
> Date: January 2, 2022 at 11:58:51 AM EST
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> 

Changes since ietf-nfsv4-rpcrdma-version-two-05
- Explicitly discuss Call-only operation
- Working draft of new flow control mechanism
- Prevent document expiry (scheduled for 2022-01-07)

Section 4.2.1 now describes an interoperable flow control mechanism that
handles asymmetric message exchange without restricting bandwidth. In
addition, it fits within the same header field footprint as RPC/RDMA
version 1.

Chairs, please request a second TSV early review for this document.

Many thanks for your attention, and happy new year.

--
Chuck Lever