Subject: [nfsv4] Fwd: New Version Notification for draft-cel-nfsv4-rpc-over-quicv1-00.txt

From: Chuck Lever III <[email-masked]>
Date: Fri, 7 Jan 2022 18:25:16 +0000

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-cel-nfsv4-rpc-over-quicv1-00.txt
> Date: January 7, 2022 at 1:17:34 PM EST
> To: "Benjamin Coddington" <[email-masked]>, "Charles Lever" <[email-masked]>, "Chuck Lever" <[email-masked]>, "Scott Mayhew" <[email-masked]>
> 
> 
> A new version of I-D, draft-cel-nfsv4-rpc-over-quicv1-00.txt
> has been successfully submitted by Chuck Lever and posted to the
> IETF repository.
> 
> Name:		draft-cel-nfsv4-rpc-over-quicv1
> Revision:	00
> Title:		Remote Procedure Call over QUIC Version 1
> Document date:	2022-01-07
> Group:		Individual Submission
> Pages:		8
> URL:            https://www.ietf.org/archive/id/draft-cel-nfsv4-rpc-over-quicv1-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-cel-nfsv4-rpc-over-quicv1/
> Html:           https://www.ietf.org/archive/id/draft-cel-nfsv4-rpc-over-quicv1-00.html
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-cel-nfsv4-rpc-over-quicv1
> 
> 
> Abstract:
>   This document specifies a protocol for conveying Remote Procedure
>   (RPC) messages on QUIC version 1 connections.  It requires no
>   revision to application RPC protocols or the RPC protocol itself.

During a recent nfsv4 working group meeting, the WG decided not to
pursue RPC-over-QUIC until there was a clearer idea of its benefits
relative to RPC on existing transports.

This brief personal draft can act as a parking place for ideas and
motivation for RPC-over-QUIC while implementations and rationale
develop more fully. In addition it can act as a reference when
asked by external observers about our putative plans for RPC-over-
QUIC.

Please feel free to send comments or throw rotting fruit.

--
Chuck Lever

---

From: David Noveck <[email-masked]>
Date: Sat, 8 Jan 2022 06:58:00 -0500

On Fri, Jan 7, 2022, 1:25 PM Chuck Lever III <[email-masked]> wrote:

> > To: "Benjamin Coddington" <[email-masked]>, "Charles Lever" <
> [email-masked]>, "Chuck Lever" <[email-masked]>, "Scott
> Mayhew" <[email-masked]>
> >
> >

Thanks for putting this together.

> > URL:
> https://www.ietf.org/archive/id/draft-cel-nfsv4-rpc-over-quicv1-00.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-cel-nfsv4-rpc-over-quicv1/
> > Html:
> https://www.ietf.org/archive/id/draft-cel-nfsv4-rpc-over-quicv1-00.html
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-cel-nfsv4-rpc-over-quicv1
> >
> >
> > Abstract:
> >   (RPC) messages on QUIC version 1 connections.

This is not accurate.  I think it would be better if the abstract were
consistent with Chuck's description of this document later in his message.

It requires no
> >   revision to application RPC protocols or the RPC protocol itself.

It is anticipated that implementation of an eventual protocol would not
require ...

> develop more fully.

I understand there are no implementations. When there is sufficient
interest to start on those, it will be time for the working group to pursue
this work with a document that seeks to specify an actual protocol.

In addition it can act as a reference when
> Please feel free to send comments or throw rotting fruit.

I'll be sending comments about the document in the next few days.

With regard to throwing rotting fruit, I have to note that it is probably
not possible to do that while being appropriately respectful of the
document authors, as IETF policies require.

>
> --
> Chuck Lever
>
>
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>