Subject: Re: [Nfvrg] Feedback on Nemo Status

From: Zhoutianran <[email-masked]>
Date: Tue, 26 May 2015 07:20:47 +0000

Hi Sue,
Thanks for your write up.
The attached figure shows my consideration on how to coordinate intent related work.
In IETF, I think we can work on:

l  Use case for intent networking

l  Intent definition

l  Gap analysis to other working groups in IETF

l  Intent network models

l  Intent description language facilitating intent expression
And we can discuss all these topics in this mailing list.
Then we can implement the intent engine and the protocol related to the controller NBI in open source projects, e.g. OpenDaylight.

Best Regards,
Terence
From: Susan Hares [mailto:[email-masked]]
Sent: Saturday, May 23, 2015 4:25 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Zhoutianran; Xiayinben
Subject: Feedback on Nemo Status

I was asked to provide an overview for the Cablelabs write-up for their MSO.   Does this write-up capture the Nemo work?

Sue Hares

--------------
NeMo provides a simple transaction based Intent-based NBI, enabling applications to creat, modify and takedown virtual networks built on virtual nodes with policy-controlled flows. The NeMo Intent NBI allows an application to communicate with a controller, providing 10 commands:

·        4 network commands: Node, Link, Flow, Policy

·        6 controller communication commands: connect, disconnect, transact, commit, notification, query
An application exchanges NeMo commands using the REST Protocol to a controller running a Nemo language processing engine to instruct the controller to set up a virtual network of nodes and links with flow policy to control the data flows across the network links.
NeMo uses an application's view of the compute, storage, and network to allow an application to set any grouping of compute, storage, or network as a virtual 'node'. This allows the application to decide what constitutes a compute node and what constitute a 'link' and a 'flow'.  From the application's viewpoint, it intends to connect two or more nodes in a network.  It does not matter to the application if the node is a single virtual machine (VM) or a cluster of interconnected compute and storage devices with many network connections. NeMo's NBI API hides this complexity, making the application's commands prescriptive and simple.   Nemo's
Nemo's language engine in the controller is associated with a model that allows a group of applications to have a set of pre-loaded defintions (model sematics) for nodes, flows, or policy.  For example, a company nodes could be defined along with the necessary flows for accounting traffic or big-data transfers.

[NEMO Engine]

Technically, Nemo is a declarative, domain specific policy language.

Status and Relevance

Nemo has open source projects in:

·        Open Daylight (https://wiki.opendaylight.org/view/Project_Proposals:NEMO)

Goals of ODL project:

o   Design and develop consistent NBI models and patterns for intent networks.

o   Design the syntax for a language style NBI.

o   Design and develop a NEMO language engine for language parsing and model mapping to SB models. It is possible to reuse the ongoing NIC project in OpenDaylight for the intent manager and model mapping component

·        OPNFV (Movie)

Goals:

o   Provide a more abstract NBI alternative by extending the general cloud platform to simplify the orchestrator and VNF manager

o   Compose various scenarios with a same set of abstractions

o   Use the MDA approach for NBI consistency and interface automation

·        IB-Nemo Pre-BOF in the IETF (www.nemo-project.net<http://www.nemo-project.net>)

o   Mail list: [email-masked]<mailto:[email-masked]>

Goals:

o   Focus on a clear definition of Intent that can be operationalized in networks,

§  https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/

o   Define use cases scenarios for Nemo,

o   Provide a gap analysis for other work in the IETF, and

o   Standardize a protocol language for Nemo

§  https://datatracker.ietf.org/doc/draft-xia-sdnrg-nemo-language/

§  https://datatracker.ietf.org/doc/draft-xia-sdnrg-nemo-language/

o   Standardize data models to provide

§  https://datatracker.ietf.org/doc/draft-zhou-netmod-intent-nemo/

---

From: Xiayinben <[email-masked]>
Date: Tue, 26 May 2015 08:32:35 +0000

Hope this can be a initial point to clarify the scope and composition of intent network.
Let’s make intent to be a practical technology rather than a marketing buzzword.
Yinben
发件人: Ibnemo [mailto:[email-masked]] 代表 Zhoutianran
发送时间: 2015年5月26日 15:21
收件人: Susan Hares
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: [Ibnemo] Feedback on Nemo Status

Hi Sue,

l  Intent definition

l  Intent network models

Best Regards,
Terence

Sue Hares

--------------

・         4 network commands: Node, Link, Flow, Policy

・         6 controller communication commands: connect, disconnect, transact, commit, notification, query
An application exchanges NeMo commands using the REST Protocol to a controller running a Nemo language processing engine to instruct the controller to set up a virtual network of nodes and links with flow policy to control the data flows across the network links.
NeMo uses an application’s view of the compute, storage, and network to allow an application to set any grouping of compute, storage, or network as a virtual ‘node’. This allows the application to decide what constitutes a compute node and what constitute a ‘link’ and a ‘flow’.  From the application’s viewpoint, it intends to connect two or more nodes in a network.  It does not matter to the application if the node is a single virtual machine (VM) or a cluster of interconnected compute and storage devices with many network connections. NeMo’s NBI API hides this complexity, making the application’s commands prescriptive and simple.   Nemo’s
Nemo’s language engine in the controller is associated with a model that allows a group of applications to have a set of pre-loaded defintions (model sematics) for nodes, flows, or policy.  For example, a company nodes could be defined along with the necessary flows for accounting traffic or big-data transfers.

Status and Relevance

・         Open Daylight (https://wiki.opendaylight.org/view/Project_Proposals:NEMO)

Goals of ODL project:

・         OPNFV (Movie)

Goals:

・         IB-Nemo Pre-BOF in the IETF (www.nemo-project.net<http://www.nemo-project.net>)

Goals:

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 30 May 2015 14:50:16 -0400

Yinben: 

I agree that the most important thing is to make the Intent based work
practical based on real use cases.   I will write-up my collection of
real-world use case people have shared with me.  

To talk about these use cases,  we need a clear way to discuss intent.  I
think the draft on https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/
is a good start to discuss the definition of Intent.   I will start a thread
to discuss I think understanding Intent is important. 

Based on your input and Tianran’s I have updated my overview of the Intent
based landscape I’m working on for a industry forum.  I’ve attached it. I
would appreciate if you would review it and let me know what you think. 

Sue Hares 

From: Xiayinben [mailto:[email-masked]] 
Sent: Tuesday, May 26, 2015 4:33 AM
To: Zhoutianran; Susan Hares
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Make Intent network to be practical //Re: [Ibnemo] Feedback on Nemo
Status

Hope this can be a initial point to clarify the scope and composition of
intent network.

Let’s make intent to be a practical technology rather than a marketing
buzzword.

Yinben

发件人: Ibnemo [ <mailto:[email-masked]>
mailto:[email-masked]] 代表 Zhoutianran
发送时间: 2015年5月26日 15:21
收件人: Susan Hares
抄送:  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]>
[email-masked];  <mailto:[email-masked]> [email-masked]
主题: Re: [Ibnemo] Feedback on Nemo Status

Hi Sue,

The attached figure shows my consideration on how to coordinate intent
related work. 

l  Intent definition

l  Intent network models

Then we can implement the intent engine and the protocol related to the
controller NBI in open source projects, e.g. OpenDaylight.

Best Regards,

Terence

From: Susan Hares [ <mailto:[email-masked]> mailto:[email-masked]] 
Sent: Saturday, May 23, 2015 4:25 AM
To:  <mailto:[email-masked]> [email-masked]
Cc: Zhoutianran; Xiayinben
Subject: Feedback on Nemo Status 

I was asked to provide an overview for the Cablelabs write-up for their MSO.
Does this write-up capture the Nemo work? 

Sue Hares 

--------------

NeMo provides a simple transaction based Intent-based NBI, enabling
applications to creat, modify and takedown virtual networks built on virtual
nodes with policy-controlled flows. The NeMo Intent NBI allows an
application to communicate with a controller, providing 10 commands: 

・         6 controller communication commands: connect, disconnect,
transact, commit, notification, query

An application exchanges NeMo commands using the REST Protocol to a
controller running a Nemo language processing engine to instruct the
controller to set up a virtual network of nodes and links with flow policy
to control the data flows across the network links.  

NeMo uses an application’s view of the compute, storage, and network to
allow an application to set any grouping of compute, storage, or network as
a virtual ‘node’. This allows the application to decide what constitutes a
compute node and what constitute a ‘link’ and a ‘flow’.  From the
application’s viewpoint, it intends to connect two or more nodes in a
network.  It does not matter to the application if the node is a single
virtual machine (VM) or a cluster of interconnected compute and storage
devices with many network connections. NeMo’s NBI API hides this
complexity, making the application’s commands prescriptive and simple.
Nemo’s  

Nemo’s language engine in the controller is associated with a model that
allows a group of applications to have a set of pre-loaded defintions (model
sematics) for nodes, flows, or policy.  For example, a company nodes could
be defined along with the necessary flows for accounting traffic or big-data
transfers.   

Status and Relevance

・         Open Daylight (
<https://wiki.opendaylight.org/view/Project_Proposals:NEMO>
https://wiki.opendaylight.org/view/Project_Proposals:NEMO) 

Goals of ODL project: 

o   Design and develop consistent NBI models and patterns for intent
networks.

o   Design and develop a NEMO language engine for language parsing and model
mapping to SB models. It is possible to reuse the ongoing NIC project in
OpenDaylight for the intent manager and model mapping component

・         OPNFV (Movie)   

Goals: 

o   Provide a more abstract NBI alternative by extending the general cloud
platform to simplify the orchestrator and VNF manager

・         IB-Nemo Pre-BOF in the IETF ( <http://www.nemo-project.net>
www.nemo-project.net) 

o   Mail list:  <mailto:[email-masked]> [email-masked]

Goals: 

o   Focus on a clear definition of Intent that can be operationalized in
networks, 

§   <https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/>
https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/

§   <https://datatracker.ietf.org/doc/draft-xia-sdnrg-nemo-language/>
https://datatracker.ietf.org/doc/draft-xia-sdnrg-nemo-language/

§   <https://datatracker.ietf.org/doc/draft-zhou-netmod-intent-nemo/>
https://datatracker.ietf.org/doc/draft-zhou-netmod-intent-nemo/