Subject: Re: [Nfvrg] [Ibnemo] Defining a Common Model for intent

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Mon, 1 Jun 2015 09:15:12 +0000

Hi,

A small clarification proposal for draft https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/ .

In section 2.4, I would leave the following as a paragraph

For example, in the network area the intent of end-users could be
safe connectivity between two sites which a technology independent
and device independent requirement. For business-based network
designers, the network connectivity can be selected which is device-
independent but technology specific. An example of the business-based
technology is the L3VPN.

And change:

For network administrators, intent can be
specific operations on a set of devices such as configuring IP
addresses on network servers in a data center.

To

For network administrators, intent can be <new>defining a network topology like a router connected to a firewall, connected to a load balancer and this to two L2 networks where WWW servers sit or specifying the</new> operations on a set of devices such as configuring IP addresses on network servers in a data center.

Rationale behind this is again, that intent should be anything that is invariant and that expresses what a network operator/administrator may need to do, as opposed to how he would do that, i.e. The router is a HW device from vendor X or a virtual machine running a specific routing daemon over a given data-path implementation.

Best, /PA

---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 1 Jun 2015 17:32:50 -0400

Pedro:

I like this addition to the draft.   Does the “new-sue” editorial addition is included to “smooth” the English. 

Sue 

For network administrators, <new-sue> an example of intent<new-sue> can be <new>defining a network topology like a router connected to a firewall, connected to a load balancer and this to two L2 networks where WWW servers sit or specifying the</new> operations on a set of devices such as configuring IP addresses on network servers in a data center.

From: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]] 
Sent: Monday, June 01, 2015 5:15 AM
To: Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] Defining a Common Model for intent

Hi,

A small clarification proposal for draft  <https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/> https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/ .

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: Xiayinben <[email-masked]>
Date: Tue, 2 Jun 2015 03:17:10 +0000

Pedro,

Agree with you.
According to your example, I think ‘intent’ should be classified by user’s role  more accuracy than by layer.
Sometime users’s role have layer relationship, but not always same layer relationship.

Best regards,
Yinben

发件人: Ibnemo [mailto:[email-masked]] 代表 PEDRO ANDRES ARANDA GUTIERREZ
发送时间: 2015年6月1日 17:15
收件人: Susan Hares; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [Ibnemo] Defining a Common Model for intent

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Natale, Bob" <[email-masked]>
Date: Tue, 2 Jun 2015 05:24:49 +0000

With all due respect:

1. I would recommend that anyone working on this topic, if he/she has not done so already, understand the “policy continuum” construct … a web search for ‘"policy continuum" Strassner’ will identify a good set of sources to start from for the network management domain.

2. Intents are statements of objectives or goals … they tend  to originate at the “higher” levels of the policy continuum … at some point (at “lower” layers of the policy continuum) they are translated to E-C-A type rules (more deterministic than intents)  for execution … much normally happens in between.

3. Designing solutions that minimize the number of translations between the statement of intent and the execution rules is essential .. and _possibly_ enabled by contemporary technologies via which “higher” layer intents can be translated to “lower” layer intents before hitting the ultimate E-C-A execution layer. This is a highly speculative statement on my part. But the “need” for multiple intermediate E-C-A translations at multiple layers of the policy continuum has heretofore been a major impediment to progress on policy-based management, IMHO.

The “with all due respect” aspect refers to the fact that the work that the active contributors to this thread are doing is very positive even if none of my comments are acted upon.

Avanti,
BobN

From: Ibnemo [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Monday, June 01, 2015 11:52 PM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: Defining a Common Model for intent

Hi Pedro,

Thanks for reviewing the draft and giving modification.

The question you have mentioned is a very important point for the abstraction of intent model. Maybe we can propose the transport market as a analogy.

1.       A customer wants to transport his goods from A to B. So his intent is getting his goods from A to B without carrying about how to do it. Then his intent is transferred to the transportation system.

2.       This system analyzes customer’s requirement, and choose a suitable way to complete the requirement. For example, the system choose truck as the means. So the intent of transportation system is transferring the goods with truck.

3.       The driver of this truck analyze the path from A to B, and choose a most appropriate path to complete this order which will save more time. So  the intent of driver may be transferring the goods with the least time. Then the driver will start the engine, step on the gas, etc.

From this analogy, the ultimate effect is the same, namely, transfer the goods from A to B. But the specific intent of different roles has some differences which depends on user’ role, knowledge, responsibility, etc. For example, transportation system is responsible for transporting goods, and he know the various ways. So he can form his intent by rendering the upper customer’s intent.

Supposing we divide users into different layers according to the implementation series, users in upper layer expresses his intent as what he want without having the knowledge about how to do it. Then the how procedure will be transferred to what in the lower layer according to knowledge and context. These transfer procedure lead to the completion of requirement. Same with the example in draft. Although the ultimate effect is same, the focus is different which will bring out the differentiation of intent.

This is just my immature opinion about intent. Do you think the differentiation of intent to complete the same thing is important and reasonable?

Best Regards,

Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月1日 17:15
收件人: Susan Hares; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Ibnemo] Defining a Common Model for intent

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "zhangyali (D)" <[email-masked]>
Date: Tue, 2 Jun 2015 03:52:03 +0000

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 02 Jun 2015 09:30:56 +0200

Hi Bob (long time no see) and others.

I am new to the whole topic of Intent Based Network Monitoring/Management.
I have to say though that for now I am somewhat in agreement with Bob's comments
that we should not introduce (too) many layers of translation. That would sound/look
(in my ears/views) too much like an organization with too many layers of management.

A "customer" (end-user) should not be required to understand all the technologies at all layers.
But further down (or up if you like) it is much better if there is "(technical) knowledge"
about the job at hand.

My 2 cents for now

Bert

On 02/06/15 07:24, Natale, Bob wrote:
>
> With all due respect:
>
> 1. I would recommend that anyone working on this topic, if he/she has not done so already, understand the “policy continuum” 
> construct … a web search for ‘"policy continuum" Strassner’ will identify a good set of sources to start from for the network 
> management domain.
>
> 2. Intents are statements of objectives or goals … they tend  to originate at the “higher” levels of the policy continuum … at 
> some point (at “lower” layers of the policy continuum) they are translated to E-C-A type rules (more deterministic than intents) 
>  for execution … much normally happens in between.
>
> 3. Designing solutions that minimize the number of translations between the statement of intent and the execution rules is 
> essential .. and _/possibly/_ enabled by contemporary technologies via which “higher” layer intents can be translated to “lower” 
> layer intents before hitting the ultimate E-C-A execution layer. This is a highly speculative statement on my part. But the “need” 
> for multiple intermediate E-C-A translations at multiple layers of the policy continuum has heretofore been a major impediment to 
> progress on policy-based management, IMHO.
>
> The “with all due respect” aspect refers to the fact that the work that the active contributors to this thread are doing is very 
> positive even if none of my comments are acted upon.
>
> Avanti,
>
> BobN
>
> *From:* Ibnemo [mailto:[email-masked]] *On Behalf Of *zhangyali (D)
> *Sent:* Monday, June 01, 2015 11:52 PM
> *To:* PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* [Ibnemo] 答复: Defining a Common Model for intent
>
> Hi Pedro,
>
> 1.A customer wants to transport his goods from A to B. So his intent is getting his goods from A to B without carrying about how 
> to do it. Then his intent is transferred to the transportation system.
>
> 2.This system analyzes customer’s requirement, and choose a suitable way to complete the requirement. For example, the system 
> choose truck as the means. So the intent of transportation system is transferring the goods with truck.
>
> 3.The driver of this truck analyze the path from A to B, and choose a most appropriate path to complete this order which will save 
> more time. So  the intent of driver may be transferring the goods with the least time. Then the driver will start the engine, step 
> on the gas, etc.
>
> From this analogy, the ultimate effect is the same, namely, transfer the goods from A to B. But the specific intent of different 
> roles has some differences which depends on user’ role, knowledge, responsibility, etc. For example, transportation system is 
> responsible for transporting goods, and he know the various ways. So he can form his intent by rendering the upper customer’s intent.
>
> Supposing we divide users into different layers according to the implementation series, users in upper layer expresses his intent 
> as /what/ he want without having the knowledge about /how/ to do it. Then the /how/ procedure will be transferred to /what /in the 
> lower layer according to knowledge and context. These transfer procedure lead to the completion of requirement. Same with the 
> example in draft. Although the ultimate effect is same, the focus is different which will bring out the differentiation of intent.
>
> *发件人**:*PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
> *发送时间:* 2015年6月1日 17:15
> *收件人:* Susan Hares; [email-masked] <mailto:[email-masked]>
> *抄送:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *主题:* Re: [Ibnemo] Defining a Common Model for intent
>
> Hi,
>
> A small clarification proposal for draft https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/.
>
> Rationale behind this is again, that intent should be anything that is invariant and that expresses/what/  a network operator/administrator may need to do, as opposed to/how/  he would do that, i.e. The router is a HW device from vendor X or a virtual machine running a specific routing daemon over a given data-path implementation.
> Best, /PA
>
> ---
>
> ------------------------------------------------------------------------------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la 
> lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha 
> recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and confidential information intended only for the use of the 
> individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any 
> dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in 
> error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é 
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a 
> leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta 
> mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
>
>
>
> _______________________________________________
> Ibnemo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ibnemo

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 2 Jun 2015 17:36:36 -0400

Yinben and Pedro:

I agree you that the role of the user is more accurate than layer, but could you provide examples at lower layers.  At the user level, a user can signal intent to create a connection from Boston Office to Denver office across the whole network.  

Sue 

From: Nfvrg [mailto:[email-masked]] On Behalf Of Xiayinben
Sent: Monday, June 01, 2015 11:17 PM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]; Lifengkai (Fengkai)
Subject: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Pedro,

Agree with you. 

Best regards,

Yinben 

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 2 Jun 2015 17:42:17 -0400

Yali:

When you state “So he can form his intent by rendering the upper customer’s intent”, I believe you are stating the the following: 

a)       The upper customer’s intent + context is passed down to the lower layer,

b)       The pure intent + context – becomes the lower layer intent through some process.

Did I understand your comments?  This would mean 

    customer intent == pure-intent + context == pure-intent + (layer n-1 intent + context)

How does this work practically? 

Sue 

From: zhangyali (D) [mailto:[email-masked]] 
Sent: Monday, June 01, 2015 11:52 PM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: 答复: [Ibnemo] Defining a Common Model for intent

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 2 Jun 2015 18:25:33 -0400

Bob:

Thank you for The Policy Continuum – A Formal Model (Steven Davy , Brendan Jennings and John Strassner). Is this the one you stated we should read?  

http://www.tssg.org/files/archives/2007_MACE_SDavy_Jennings_final.pdf

Davy, Jenning and Strassner.  In this continuum it suggests there are descending levels at: business, system (device and technology independent), administrator (device independent, technology dependent), device (device and technology specific), and instance (specific MIB, PIB, and CLI).  The system level is what Yali and Yinben have talked about when they speak about a connection from London to Beijing.  The administrator is a level of an L3VPN network with many devices.   I have suggested a few more layers that related in a gap analysis for I2NSF.  These layer match what the IETF is doing in the yang modules. 

+--------------------------------------------+

|Application Network Wide: Intent            |

+--------------------------------------------+

|Network-wide level: L3SM L3VPN service model|

+--------------------------------------------+

|Device level: Protocol Independent: I2RS    |

| RIB, Topology, Filter-Based RIB            |

+--------------------------------------------+

|Device Level: Protocol Yang modules         |

| (ISIS, OSPF, BGP, EVPN, L2VPN, L3VPN, etc.)|    

+--------------------------------------------+

| Device level: IP and System: NETMOD Models | 

| (config and oper-state), tunnels           |

+--------------------------------------------+  

Did I understand your policy continuum?    

The policy continuum paper states three axioms: 

“1) A policy may exist at any level of the continuum without the requirement of being associated to policies at other continuum levels. 

2) A policy may reference a set of lower level policies.  

3) A policy may be associated to more than one higher level policy”

Can you explain your comment: 

“the “need” for multiple intermediate E-C-A translations at multiple layers of the policy continuum has heretofore been a major impediment to progress on policy-based management, IMHO.” 

Does this come out of the formal language in the paper? 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Tuesday, June 02, 2015 1:25 AM
To: zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 3 Jun 2015 05:14:37 +0000

Hi Sue,

Yes, the Formal Model paper is a very good source, but should be augmented with a few others for a more complete understanding.

And it is very important to note that the policy continuum is not _my_ model … it is (to the best of my knowledge) John Strassner’s creation and I generally recommend Chap. 9, Examples of Using the Policy Continuum, in his book on Policy-Based Network Management: Solutions for the Next Generation (2004) as an essential source.

[Apologies for possibly rambling a bit in what follows … I am not an active contributor and I hate to take up the time of those who are just because I have a few minutes to post, but since Sue asked….]

I would note that the specific layer labels used in the policy continuum literature should not be considered absolute … i.e., other formulations (with more or (ideally) fewer layers) are possible, with different labels, denoting (e.g.) some domain-, marketplace-, or business model-specificity.

The key issue is the number and nature of the translations necessary from a statement of intent at the “top” layer to a set of actions at the “bottom” layer that serve to realize the intent. In John’s policy continuum the top layer is the “Business” layer and we might see policy expressions like “Optimize traffic flows for fairness to all active users” or “Optimize traffic flows for priority based on user account type” (e.g., the proverbial Platinum, Gold, Silver, Bronze casting). Those are deliberately stark examples … in reality, the Business layer promulgates enormous numbers of policies often overlapping and “frictional” … but take either stark example and consider how many translations it would take to result in a conforming set of actions in large-scale network of diverse devices, services, protocols, (and a very large)  etc. In current technology (and for the foreseeable future, at my age at least!) at some point such statements of intent from the Business layer have to get translated to E-C-A type rules.

I recognize an intent-based policy expression by its distance from a set of expression (usually “rules”) that execute actions that realize the outcome stated in the intent-based expression. In that view, it’s not an absolute (i.e., the diverse views of the Policy Continuum hold) and it’s also possible to envision cases where expressions of intent can be “directly” implemented by a resource or set of resources. SDN is a step in the direction of (1) reducing the number of translations necessary for a large class of intent-based policy expressions and (2) virtualizing the implementation actions from the perspective of the “upper” layers of the policy continuum (or continua).

So, SDN and the ecosystem of changes around it represent  a big opportunity to make progress on rationalizing policy management across the layers of the policy continuum. A necessary first step is having useful standards for policy-expressions from the “top” layer – and they typically talk in intent-based policy expressions there.

Btw, I presume that IBNemo* contributors are also following John’s work in the SUPA area as well … very important that these efforts are totally complementary and synergistic, IMHO.

[* - Is it “IBNemo”, “ibnemo”, “IB-nemo” or something else? … I see it written all of those ways, and possibly more....]

Avanti,
BobN

From: Susan Hares [mailto:[email-masked]]
Sent: Tuesday, June 02, 2015 6:26 PM
To: Natale, Bob; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

Bob:

Sue

From: Natale, Bob [mailto:[email-masked]]
Sent: Tuesday, June 02, 2015 1:25 AM
To: zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

With all due respect:

Avanti,
BobN

From: Ibnemo [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Monday, June 01, 2015 11:52 PM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Ibnemo] 答复: Defining a Common Model for intent

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 3 Jun 2015 14:45:19 +0000

Hi Terence,

As Bert has noted on a related thread today, it is sensible to focus on intent expression at the “top” layer first.

However, work on that should be cognizant of two things:
- Who/what are the intended consumers of such expressions?
- What is the “distance” from the top level intent expressions to executable actions that affect network behavior?

Those two things are interrelated and captured in the policy continuum concept and construct … you can conceptualize them differently, resulting in different constructs, and that is fine … but you cannot escape them. Any attempt to escape them will result, at best, in a beautiful language that will never be spoken in an operational context.

Avanti,
BobN

From: Ibnemo [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Wednesday, June 03, 2015 5:19 AM
To: Natale, Bob; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] Defining a Common Model for intent

Hi Bob,

I agree with you that the intent expression is the first important step. And that’s what we are going to do.
I think in this discussion group we will focus on the top layer intent. As I posted in the email on the “role based intent”, there will be only one intent layer and I do not think the “policy continuum” works or necessarily applied here. In contrast I would like a flat intent expression with many ways for both pure intent and the constrained intent.

Regards,
Terence

From: Ibnemo [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Wednesday, June 03, 2015 1:15 PM
To: Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ibnemo] RE: Defining a Common Model for intent

Hi Sue,

Avanti,
BobN

From: Susan Hares [mailto:[email-masked]]
Sent: Tuesday, June 02, 2015 6:26 PM
To: Natale, Bob; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Ibnemo] RE: Defining a Common Model for intent

Bob:

Sue

Subject: RE: [Ibnemo] RE: Defining a Common Model for intent

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Wed, 3 Jun 2015 15:12:23 +0000

For example,
A user’s intent is creating a connection from Boston office to Denver office;
BD(Business Designer) of Service Provider’s intent is creating user’s connection on demand and providing higher SLA guarantee to user’s flow than background flow(such as sync or backup flow)
Network administrator’s intent is monitoring physical connection’s utilization, when utilization over 80%, some background flows should be moved to other lower utilization  path.

In this example, providing higher SLA to user’s flow is BD’s intent but not user’s intent, because user doesn’t care about it.  Moving background flow to other path is network admin’s intent but not BD’s intent. How to move flow to other path is implementation detail in SDN controller but not network admin’s intent.

Use this example, I hope to express that a intent interface is related with a group of user’s role and what they are cared is what their intent elements.

Tianran started a thread for role based intent, we can combine discussion to there.

Yinben
发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年6月3日 5:37
收件人: Xiayinben; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]; Lifengkai (Fengkai)
主题: RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Yinben and Pedro:

Sue

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Lifengkai (Fengkai)

Pedro,

Agree with you.

Best regards,
Yinben

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Wed, 3 Jun 2015 15:53:58 +0000

Hi Bob,

In my understanding,  “policy continuum” is based on layer structure.
A characteristic of layer structure is mutually exclusive between layers.
But the intent of different roles are not mutually exclusive.
Do you think this is make sense?

Yinben

发件人: Nfvrg [mailto:[email-masked]] 代表 Natale, Bob
发送时间: 2015年6月3日 22:45
收件人: Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [Nfvrg] [Ibnemo] Defining a Common Model for intent

Hi Terence,

Avanti,
BobN

To: Natale, Bob; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 3 Jun 2015 16:31:19 +0000

Hi Yinben,

I would caution against taking too literal a view of “layers” as visual representations of logical roles or perspectives … the “mutual exclusion” between layers when viewed as logical roles or perspectives is something we want to reduce or eliminate today both because we (possibly) can (due to new technologies) and because doing so can reduce costs, increase operational agility, enable better customer/user experience, etc.

It might be the case that at early stages of a new technology, “crisp” boundaries between the layers of a layered model serve essential purposes but as the technology matures opportunities for “smoothing” evolve – whether via integration within the existing model, rearranging components in a new model, or otherwise. I think we’re at a point in time where a set of related technologies is maturing to the point where “smoothing” can (and must) occur in Policy-Based Network Management.

I know that’s not great IETF-speak (and I don’t mean that pejoratively), but I hope it makes sense. Moving forward on intent-based policy management will require some new thinking … and such new thinking is evident here and in the SUPA work underway … very encouraging … and I don’t want to retard the progress that IBNEMO and SUPA are making in that respect … but I do encourage everyone to question any blocking assumptions from old models (while leveraging what still works from those models, of course!).

Avanti,
BobN

From: Ibnemo [mailto:[email-masked]] On Behalf Of Xiayinben
Sent: Wednesday, June 03, 2015 11:54 AM
To: Natale, Bob; Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: Defining a Common Model for intent

Hi Bob,

Yinben

发件人: Nfvrg [mailto:[email-masked]] 代表 Natale, Bob
发送时间: 2015年6月3日 22:45
收件人: Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Nfvrg] [Ibnemo] Defining a Common Model for intent

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 3 Jun 2015 22:01:39 -0400

Bob:

I am so grateful you have time to post. I will look up his chapter 9 as well.  It is good to hear that John’s viewpoint is not rigid on the layers – but sees the top intent being served by the ECA actions at the bottom. 

I agree that one of the ways to see intent is intentà results language without particulars in between.  For networking, I have a hard time determining single layer intent.  For example,  run my accounting – needs a context of a cloud, a DC, or a PC.   And the network connects these actions. This is not really the top layer. 

I agree that SDN is a step to 1) reduce the number of translations for large class of intent-based policy, 

2) virtualize implementation actions.  However, this still leaves me with the userà intentàcontext basic and the division of intent to results or operations. 

I think I still have to go back to the policy basics. 

As to what’s in a name – a fish will smell the same (smile). 

Ibnemo – is the mail list – Intent-Based Network Modeling (IBNeMO  - or I-be-Nemo for cuteness). 

Please post again!  I look forward to your ideas which have helped a lot. 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Wednesday, June 03, 2015 1:15 AM
To: Susan Hares; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 3 Jun 2015 22:17:57 -0400

Tianran: 

Are you sure the two are distinct? I like your concept to focus on the top layer – because I think I know what happens there.  However, your intent at the top sitting on the top of several roles made me wonder if you and John are expressing an inherent general system property of the intent and policy systems. 

Groups of roles will request different functions.  This roles form hierarchical trees rooted in the intent.  Is John’s general architecture really the classing of roles and functions at different level?  Is  he understand what constitutes the intent roles at the top.  

I also need to start at the top since I think I know what intent is there.  I’m not sure what it looks like going downward (unless it is a reply of the ISO layer models).  

Did this help refine your idea at all?  Or am I just musing on the comparison between your ideas and John’s policy continuum. 

Sue 

 

Hi Bob,

Regards,

Terence

To: Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Natale, Bob" <[email-masked]>
Date: Thu, 4 Jun 2015 02:58:26 +0000

Hi Sue,

You said: “I also need to start at the top since I think I know what intent is there.  I’m not sure what it looks like going downward….”

That is a perceptive comment. The closer you get to the instance level – i.e., where network behavior can actually be controlled – the more applicable are E-C-A type expressions relative to Intent type expressions.

Highly advanced components move that pattern closer and closer to the instance execution context (e.g., via custom firmware, intelligent agents)  and that capability might become way more common in the future – when, among other things, standards support for interoperable Intent expressions exists :-) --  but for now “rule” expressions, rather than “goal” expression, come into play fairly high up in the continuum … and bear in mind that, for now, Intent (“goal”) expressions at the topmost layer(s) are often _manually_ converted to E-C-A rulesets for consumption at some lower layer(s) … a source of much cost and operational inefficiency.

Avanti,
BobN

From: Susan Hares [mailto:[email-masked]]
Sent: Wednesday, June 03, 2015 10:18 PM
To: 'Zhoutianran'; Natale, Bob; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Tianran:

Sue

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 4 Jun 2015 06:52:11 +0000

So what are the ‘layers’ in this discussion? Or should we completely avoid using the term layers? Maybe it’s better not to use the term at all than use it while we have different things in mind.

Thanks and Regards,

Dan

From: Ibnemo [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Wednesday, June 03, 2015 7:31 PM
To: Xiayinben; Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] 答复: Defining a Common Model for intent

Hi Yinben,

Avanti,
BobN

To: Natale, Bob; Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

http://www.tssg.org/files/archives/2007_MACE_SDavy_Jennings_final.pdf<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.tssg.org_files_archives_2007-5FMACE-5FSDavy-5FJennings-5Ffinal.pdf&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=WleNsgz40hTkjvPCURViEsY45BDsh72bW-ZbXSrImIU&s=my8JP_flFea2Zg07L14bGDtz1zVPsi3Nrgth40Fwtr4&e=>

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

A small clarification proposal for draft https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dxia-2Dibnemo-2Dicim_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=WleNsgz40hTkjvPCURViEsY45BDsh72bW-ZbXSrImIU&s=5hEQqDcz_lxSRjHz65scaJAkqZvAydJSS1y3w_GrYj4&e=> .

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 11:47:07 -0400

Bob:

In re-reading this post this morning – I saw I missed yesterday.   What do you mean by 

·         What is the “distance” from the top level intent expressions to executable actions that affect network behavior?

Is the distance from the top level intent to first executable actions – (the actions at business control that controllers the SDN controller) or the actions at the device level?  I thought you meant the first interpreter of the intent. 

Was I right? If so, this top level interpreter gets closely tied to role. 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Wednesday, June 03, 2015 10:45 AM
To: Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 11:54:43 -0400

Bob: 

What I think you are saying is that our current layers and the logical representation of these layer’s roles may be limiting to our design of a new system based on intent.  I agree the past roles of layers tend to put us back in the same layer boxes.  

This is why I asked in earlier mail about the intent-roles grouping being the top of a cyclic tree where the intent focuses the action and the roles/context provide the context down the policy continuum.  In general systems theory the intent-role groupings should from a unique subsystem within the policy and actions.   Does this theoretical suggestion make sense? 

Sue 

Sent: Wednesday, June 03, 2015 12:31 PM

Hi Yinben,

Avanti,

BobN

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 12:35:34 -0400

Yinben: 

I thought about your answer here over-night.  If the intent of different roles is not mutually exclusive, then either the intent is a complex structure or the role is context. 

If my intent is to buy pants, then the intent is simple. 

If the role is to pants shopping at the closest mall where mall is defined as many stores, then the intent is complex since it has context and constraints.   The role of shopping in closest mall requires determining the network connection to the local mall.  

Similarly, if the AS 1 wants to be a provider for other provides – this is a simple intent (AS 1 is a provider’s provider). 

If an AS 1 wants to be a provider for AS 2, it is a intent with context (AS1 is network AS2’s provider). 

If AS2 wants to load share traffic to AS2, it is complex intent 

a)      AS1 is AS2’s provider 

b)      AS 1 is load sharing traffic to AS 2 along all ports. 

These roles overlap because they are complex intent rather than pure unspecified intent.  Does this example help you understand my view of simple intent, complex intent, and intent with context. 

Sue 

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 12:38:06 -0400

Dan:

This is a good point.  As Bob Natale mentioned, our past layers may cause us to misunderstand our new paradigm of intent.  Yinben and Tianran/Terence indicated they wanted to start with the simple top layer because we think we know what that is. 

Sue 

From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, June 04, 2015 2:52 AM
To: Natale, Bob; Xiayinben; Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

Thanks and Regards,

Dan

Hi Yinben,

Avanti,

BobN

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

http://www.tssg.org/files/archives/2007_MACE_SDavy_Jennings_final.pdf <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.tssg.org_files_archives_2007-5FMACE-5FSDavy-5FJennings-5Ffinal.pdf&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=WleNsgz40hTkjvPCURViEsY45BDsh72bW-ZbXSrImIU&s=my8JP_flFea2Zg07L14bGDtz1zVPsi3Nrgth40Fwtr4&e=> 

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

A small clarification proposal for draft  <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dxia-2Dibnemo-2Dicim_&d=AwMGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=WleNsgz40hTkjvPCURViEsY45BDsh72bW-ZbXSrImIU&s=5hEQqDcz_lxSRjHz65scaJAkqZvAydJSS1y3w_GrYj4&e=> https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/ .

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 14:41:41 -0400

Tianran/ Terrence: 

Instinctively, I believe that role-based intent provides an ability to define and classify intent.  I know how to identify the role relationships, and the actions between roles.  However, I still do not really understand classify the relationship between intent and roles.  

My concern is that we are looking at general system theory where certain things are first order changes and other things are second-order changes.   A first order change is like the wind blowing.  A second order change is when the upper atmosphere jet stream changes causing a whole shift in weather patterns. 

If we classify intent by roles, will we find that roles are the “jet stream” that pushes a lot of intent.  Or will we find some “pure” intent classes are the jet stream that pushes a lot of intent or “jet stream” ?

Best wishes, 

Sue 

From: Zhoutianran [mailto:[email-masked]] 
Sent: Thursday, June 04, 2015 2:36 AM
To: Natale, Bob; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Hi Bob and Sue,

The role based intent gives the methodology to define and classify intent. I think both Bob and me realize the identifying roles is important. And yes, it’s on the top.

Of course, intent need to be implemented. We can do this compilation layer by layer, i.e., like policy continuum, from goal to fitness to ECA to …. By the way, it seems in policy continuum, everything is policy, and an intent can be compiled by policies all the way to device instructions. Please correct me if it is not.

My idea is:

On one hand, I would like a flat intent expression with many ways for both pure intent and the constrained intent.

On the other hand, I think the intent can be implemented by many existing layered functions like the figure I showed. And a cross layer design will make the intent implementation more flexible.

I am not going to create concepts but an operational solution. I think policy continuum is an option for intent implementation, but it’s not mandatory cannot escape.

Best Regards,

Terence

Sent: Wednesday, June 03, 2015 10:45 PM

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 14:55:59 -0400

Tianran/Terrence: 

We should consider both.  By considering the models, we will begin to understand the limits of our working system and how it fits best into the IETF set of systems of configuration, policy, and security.    I wish my email responses could include a sound button for cheers.  You deserve one for this one. 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Thursday, June 04, 2015 5:04 AM
To: Natale, Bob; Susan Hares; [email-masked]
Cc: [email-masked]
Subject: Re: [Ibnemo] Defining a Common Model for intent

Hi Bob and Sue,

I think our discussion falls into two categories: one is the intent modeling and intent expression, and the other is how to translate the intent into real implementations. And Bob shared opinion on the later, right?

The following figure I posted before shows my point on how to work with the two parts.

Do you think we should consider both of the two topics here?

Terence

intent network arch.gif

From: Natale, Bob [mailto:[email-masked]] 
Sent: Thursday, June 04, 2015 10:58 AM
To: Susan Hares; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Hi Sue,

Avanti,

BobN

Tianran: 

Sue 

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 04 Jun 2015 20:56:11 +0200

It may be jsut me, but adding "pure" intent and "impure" intent and jetstreams etc, it does just become more vague for me.

See also inline

On 04/06/15 20:41, Susan Hares wrote:
>
> Tianran/ Terrence:
>
> Instinctively, I believe that role-based intent provides an ability to define and classify intent.  I know how to identify the 
> role relationships, and the actions between roles.  However, I still do not really understand classify the relationship between 
> intent and roles.
>
> My concern is that we are looking at general system theory where certain things are first order changes and other things are 
> second-order changes.   A first order change is like the wind blowing.  A second order change is when the upper atmosphere jet 
> stream changes causing a whole shift in weather patterns.
>
> If we classify intent by roles, will we find that roles are the “jet stream” that pushes a lot of intent.  Or will we find some 
> “pure” intent classes are the jet stream that pushes a lot of intent or “jet stream” ?
>
I cannot make heads or tails from that sentence. Again, it may be just me.

Bert
>
> Best wishes,
>
> Sue
>
> *From:*Zhoutianran [mailto:[email-masked]]
> *Sent:* Thursday, June 04, 2015 2:36 AM
> *To:* Natale, Bob; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
> *Subject:* RE: [Ibnemo] Defining a Common Model for intent
>
> Hi Bob and Sue,
>
> Of course, intent need to be implemented. We can do this compilation layer by layer, i.e., like policy continuum, from goal to 
> fitness to ECA to …. By the way, it seems in policy continuum, everything is policy, and an intent can be compiled by policies all 
> the way to device instructions. Please correct me if it is not.
>
> My idea is:
>
> On the other hand, I think the intent can be implemented by many existing layered functions like the figure I showed. And a cross 
> layer design will make the intent implementation more flexible.
>
> *From:*Natale, Bob [mailto:[email-masked]]
> *Sent:* Wednesday, June 03, 2015 10:45 PM
> *To:* Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [Ibnemo] Defining a Common Model for intent
>
> Hi Terence,
>
> Those two things are interrelated and captured in the policy continuum concept and construct … you can conceptualize them 
> differently, resulting in different constructs, and that is fine … but you cannot escape them. Any attempt to escape them will 
> result, at best, in a beautiful language that will never be spoken in an operational context.
>
> Avanti,
>
> BobN
>
> *From:*Ibnemo [mailto:[email-masked]] *On Behalf Of *Zhoutianran
> *Sent:* Wednesday, June 03, 2015 5:19 AM
> *To:* Natale, Bob; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Ibnemo] Defining a Common Model for intent
>
> Hi Bob,
>
> I think in this discussion group we will focus on the top layer intent. As I posted in the email on the “role based intent”, there 
> will be only one intent layer and I do not think the “policy continuum” works or necessarily applied here. In contrast I would 
> like a flat intent expression with many ways for both pure intent and the constrained intent.
>
> Regards,
>
> Terence
>
> *From:*Ibnemo [mailto:[email-masked]] *On Behalf Of *Natale, Bob
> *Sent:* Wednesday, June 03, 2015 1:15 PM
> *To:* Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Ibnemo] RE: Defining a Common Model for intent
>
> Hi Sue,
>
> And it is very important to note that the policy continuum is not _/my/_ model … it is (to the best of my knowledge) John 
> Strassner’s creation and I generally recommend Chap. 9, Examples of Using the Policy Continuum, in his book on /Policy-Based 
> Network Management: Solutions for the Next Generation/ (2004) as an essential source.
>
> [Apologies for possibly rambling a bit in what follows … I am not an active contributor and I hate to take up the time of those 
> who are just because I have a few minutes to post, but since Sue asked….]
>
> I would note that the specific layer labels used in the policy continuum literature should not be considered absolute … i.e., 
> other formulations (with more or (ideally) fewer layers) are possible, with different labels, denoting (e.g.) some domain-, 
> marketplace-, or business model-specificity.
>
> The key issue is the number and nature of the translations necessary from a statement of intent at the “top” layer to a set of 
> actions at the “bottom” layer that serve to realize the intent. In John’s policy continuum the top layer is the “Business” layer 
> and we might see policy expressions like “Optimize traffic flows for fairness to all active users” or “Optimize traffic flows for 
> priority based on user account type” (e.g., the proverbial Platinum, Gold, Silver, Bronze casting). Those are deliberately stark 
> examples … in reality, the Business layer promulgates enormous numbers of policies often overlapping and “frictional” … but take 
> either stark example and consider how many translations it would take to result in a conforming set of actions in large-scale 
> network of diverse devices, services, protocols, (and a very large)  etc. In current technology (and for the foreseeable future, 
> at my age at least!) at some point such statements of intent from the Business layer have to get translated to E-C-A type rules.
>
> I recognize an intent-based policy expression by its distance from a set of expression (usually “rules”) that execute actions that 
> realize the outcome stated in the intent-based expression. In that view, it’s not an absolute (i.e., the diverse views of the 
> Policy Continuum hold) and it’s also possible to envision cases where expressions of intent can be “directly” implemented by a 
> resource or set of resources. SDN is a step in the direction of (1) reducing the number of translations necessary for a large 
> class of intent-based policy expressions and (2) virtualizing the implementation actions from the perspective of the “upper” 
> layers of the policy continuum (or continua).
>
> So, SDN and the ecosystem of changes around it represent  a big opportunity to make progress on rationalizing policy management 
> across the layers of the policy continuum. A necessary first step is having useful standards for policy-expressions from the “top” 
> layer – and they typically talk in intent-based policy expressions there.
>
> Btw, I presume that IBNemo* contributors are also following John’s work in the SUPA area as well … very important that these 
> efforts are totally complementary and synergistic, IMHO.
>
> *From:*Susan Hares [mailto:[email-masked]]
> *Sent:* Tuesday, June 02, 2015 6:26 PM
> *To:* Natale, Bob; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [Ibnemo] RE: Defining a Common Model for intent
>
> Bob:
>
> Davy, Jenning and Strassner.  In this continuum it suggests there are descending levels at: business, system (device and 
> technology independent), administrator (device independent, technology dependent), device (device and technology specific), and 
> instance (specific MIB, PIB, and CLI).  The system level is what Yali and Yinben have talked about when they speak about a 
> connection from London to Beijing.  The administrator is a level of an L3VPN network with many devices.   I have suggested a few 
> more layers that related in a gap analysis for I2NSF.  These layer match what the IETF is doing in the yang modules.
>
> “the “need” for multiple intermediate E-C-A translations at multiple layers of the policy continuum has heretofore been a major 
> impediment to progress on policy-based management, IMHO.”
>
> *From:*Natale, Bob [mailto:[email-masked]]
> *Sent:* Tuesday, June 02, 2015 1:25 AM
> *To:* zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [Ibnemo]RE: Defining a Common Model for intent
>
> With all due respect:
>
> *From:*Ibnemo [mailto:[email-masked]] *On Behalf Of *zhangyali (D)
> *To:* PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 15:04:18 -0400

Bert: 

Ok - give me an example from your context.  I tried BGP first,  general systems theory second, and wind 3rd.     The equations are: 

User --> intent --> context
Intent = object, results, constraint 

Where do roles fit in these equations? 
BGP:  
user (provider) --> intent (be providers provider) --> context (bgp infrastructure)
Intent (AS2 be provider's provider) --> object (AS1 provider), results (pass AS1 providers traffic), constraint (load-balance across all circuits connect to AS2). 

Now - what is a role-based intent or policy for BGP?  I'll welcome a practical answer. 

Sue 

-----Original Message-----
From: Bert Wijnen (IETF) [mailto:[email-masked]] 
Sent: Thursday, June 04, 2015 2:56 PM
To: Susan Hares; 'Zhoutianran'; 'Natale, Bob'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] Defining a Common Model for intent

See also inline

On 04/06/15 20:41, Susan Hares wrote:
>
> Tianran/ Terrence:
>
> Instinctively, I believe that role-based intent provides an ability to 
> define and classify intent.  I know how to identify the role 
> relationships, and the actions between roles.  However, I still do not really understand classify the relationship between intent and roles.
>
> If we classify intent by roles, will we find that roles are the “jet 
> stream” that pushes a lot of intent.  Or will we find some “pure” intent classes are the jet stream that pushes a lot of intent or “jet stream” ?
>

Bert
> The role based intent gives the methodology to define and classify 
> intent. I think both Bob and me realize the identifying roles is important. And yes, it’s on the top.
>
> Of course, intent need to be implemented. We can do this compilation 
> layer by layer, i.e., like policy continuum, from goal to fitness to 
> ECA to …. By the way, it seems in policy continuum, everything is policy, and an intent can be compiled by policies all the way to device instructions. Please correct me if it is not.
>
> My idea is:
>
> On the other hand, I think the intent can be implemented by many 
> existing layered functions like the figure I showed. And a cross layer design will make the intent implementation more flexible.
>
> I am not going to create concepts but an operational solution. I think 
> policy continuum is an option for intent implementation, but it’s not mandatory cannot escape.
>
> Best Regards,
>
> Terence
>
> *To:* Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA 
> GUTIERREZ'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> Those two things are interrelated and captured in the policy continuum 
> concept and construct … you can conceptualize them differently, 
> resulting in different constructs, and that is fine … but you cannot escape them. Any attempt to escape them will result, at best, in a beautiful language that will never be spoken in an operational context.
>
> Avanti,
>
> BobN
>
> *To:* Natale, Bob; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA 
> GUTIERREZ'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> I think in this discussion group we will focus on the top layer 
> intent. As I posted in the email on the “role based intent”, there 
> will be only one intent layer and I do not think the “policy continuum” works or necessarily applied here. In contrast I would like a flat intent expression with many ways for both pure intent and the constrained intent.
>
> Regards,
>
> Terence
>
> *Cc:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> And it is very important to note that the policy continuum is not 
> _/my/_ model … it is (to the best of my knowledge) John Strassner’s 
> creation and I generally recommend Chap. 9, Examples of Using the Policy Continuum, in his book on /Policy-Based Network Management: Solutions for the Next Generation/ (2004) as an essential source.
>
> [Apologies for possibly rambling a bit in what follows … I am not an 
> active contributor and I hate to take up the time of those who are 
> just because I have a few minutes to post, but since Sue asked….]
>
> I would note that the specific layer labels used in the policy 
> continuum literature should not be considered absolute … i.e., other 
> formulations (with more or (ideally) fewer layers) are possible, with different labels, denoting (e.g.) some domain-, marketplace-, or business model-specificity.
>
> The key issue is the number and nature of the translations necessary 
> from a statement of intent at the “top” layer to a set of actions at 
> the “bottom” layer that serve to realize the intent. In John’s policy 
> continuum the top layer is the “Business” layer and we might see 
> policy expressions like “Optimize traffic flows for fairness to all 
> active users” or “Optimize traffic flows for priority based on user 
> account type” (e.g., the proverbial Platinum, Gold, Silver, Bronze 
> casting). Those are deliberately stark examples … in reality, the Business layer promulgates enormous numbers of policies often overlapping and “frictional” … but take either stark example and consider how many translations it would take to result in a conforming set of actions in large-scale network of diverse devices, services, protocols, (and a very large)  etc. In current technology (and for the foreseeable future, at my age at least!) at some point such statements of intent from the Business layer have to get translated to E-C-A type rules.
>
> I recognize an intent-based policy expression by its distance from a 
> set of expression (usually “rules”) that execute actions that realize 
> the outcome stated in the intent-based expression. In that view, it’s 
> not an absolute (i.e., the diverse views of the Policy Continuum hold) 
> and it’s also possible to envision cases where expressions of intent can be “directly” implemented by a resource or set of resources. SDN is a step in the direction of (1) reducing the number of translations necessary for a large class of intent-based policy expressions and (2) virtualizing the implementation actions from the perspective of the “upper”
> So, SDN and the ecosystem of changes around it represent  a big 
> opportunity to make progress on rationalizing policy management across the layers of the policy continuum. A necessary first step is having useful standards for policy-expressions from the “top”
> Btw, I presume that IBNemo* contributors are also following John’s 
> work in the SUPA area as well … very important that these efforts are totally complementary and synergistic, IMHO.
>
> [* - Is it “IBNemo”, “ibnemo”, “IB-nemo” or something else? … I see it 
> written all of those ways, and possibly more....]
>
> Avanti,
>
> BobN
>
> *Cc:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> Thank you for The Policy Continuum – A Formal Model (Steven Davy , 
> Brendan Jennings and John Strassner). Is this the one you stated we should read?
>
> Davy, Jenning and Strassner.  In this continuum it suggests there are 
> descending levels at: business, system (device and technology 
> independent), administrator (device independent, technology dependent), device (device and technology specific), and instance (specific MIB, PIB, and CLI).  The system level is what Yali and Yinben have talked about when they speak about a
> “1) A policy may exist at any level of the continuum without the 
> requirement of being associated to policies at other continuum levels.
>
> “the “need” for multiple intermediate E-C-A translations at multiple 
> layers of the policy continuum has heretofore been a major impediment to progress on policy-based management, IMHO.”
>
> *Cc:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> construct … a web search for ‘"policy continuum" Strassner’ will 
> identify a good set of sources to start from for the network management domain.
>
> 2. Intents are statements of objectives or goals … they tend  to 
> originate at the “higher” levels of the policy continuum … at some 
> point (at “lower” layers of the policy continuum) they are translated to E-C-A type rules (more deterministic than intents)  for execution … much normally happens in between.
>
> 3. Designing solutions that minimize the number of translations 
> between the statement of intent and the execution rules is essential .. and _/possibly/_ enabled by contemporary technologies via which “higher” layer intents can be translated to “lower”
> for multiple intermediate E-C-A translations at multiple layers of the 
> policy continuum has heretofore been a major impediment to progress on policy-based management, IMHO.
>
> The “with all due respect” aspect refers to the fact that the work 
> that the active contributors to this thread are doing is very positive even if none of my comments are acted upon.
>
> Avanti,
>
> BobN
>
> <mailto:[email-masked]>
> *Cc:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> The question you have mentioned is a very important point for the 
> abstraction of intent model. Maybe we can propose the transport market as a analogy.
>
> 1.A customer wants to transport his goods from A to B. So his intent 
> is getting his goods from A to B without carrying about how to do it. Then his intent is transferred to the transportation system.
>
> 2.This system analyzes customer’s requirement, and choose a suitable 
> way to complete the requirement. For example, the system choose truck as the means. So the intent of transportation system is transferring the goods with truck.
>
> 3.The driver of this truck analyze the path from A to B, and choose a 
> most appropriate path to complete this order which will save more 
> time. So  the intent of driver may be transferring the goods with the least time. Then the driver will start the engine, step on the gas, etc.
>
> From this analogy, the ultimate effect is the same, namely, transfer 
> the goods from A to B. But the specific intent of different roles has 
> some differences which depends on user’ role, knowledge, responsibility, etc. For example, transportation system is responsible for transporting goods, and he know the various ways. So he can form his intent by rendering the upper customer’s intent.
>
> Supposing we divide users into different layers according to the 
> implementation series, users in upper layer expresses his intent as 
> /what/ he want without having the knowledge about /how/ to do it. Then 
> the /how/ procedure will be transferred to /what /in the lower layer according to knowledge and context. These transfer procedure lead to the completion of requirement. Same with the example in draft. Although the ultimate effect is same, the focus is different which will bring out the differentiation of intent.
>
> This is just my immature opinion about intent. Do you think the 
> differentiation of intent to complete the same thing is important and reasonable?
>
> Best Regards,
>
> Yali
>
> *抄送:* [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> For example, in the network area the intent of end-users could be safe 
> connectivity between two sites which a technology independent and 
> device independent requirement. For business-based network designers, 
> the network connectivity can be selected which is device- independent 
> but technology specific. An example of the business-based technology 
> is the L3VPN.
> And change:
> For network administrators, intent can be specific operations on a set 
> of devices such as configuring IP addresses on network servers in a 
> data center.
>
> To
>
> ----------------------------------------------------------------------
> --------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e é 
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa 
> senhoria o destinatário indicado, fica notificado de que a leitura, 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro, 
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e 
> proceda a sua destruição
>
>
>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 04 Jun 2015 22:36:43 +0200

Hi Sue, inline

> Where do roles fit in these equations?

I may already be lost in the above.
more below
> Intent (AS2 be provider's provider) --> object (AS1 provider), results (pass AS1 providers traffic), constraint (load-balance across all circuits connect to AS2).
Where is the (equal sign (=) from above? Or did you mean:

    Intent (AS2 be provider's provider) = object (AS1 provider), results (pass AS1 providers traffic),
                                          constraint (load-balance across all circuits connect to AS2).

> Now - what is a role-based intent or policy for BGP?  I'll welcome a practical answer.
So sofar, the role is just end-user I think.
In order to make this happen, some network architect or BGP routing maintainer, or maybe you call him
network operator,
needs to speak out this intent in BGP speak, no?
Or does he/she no longer use the intent based model?
Does he/she  just revert to old technology so to speak (for example use netconf and a YANG data model)
to update the RIB/FIB on various devices/routers?

Bert
>> GUTIERREZ'; [email-masked]

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 5 Jun 2015 04:22:48 +0000

Agreed (on the need to understand both sides).

As I noted earlier, successful development of the standards needed for the right side diagram must be cognizant of two things:

In the left side diagram, the intended consumer of intent expressions from the right side is the “Intent Engine” and the “Controller”, “Intent Engine”, “Run-time System”, and the network elements are all components of the “distance” from top-level intent expressions to network behavior.

Now, if we were producing the right side outputs for a single “Intent Engine” or a collection of them that operate identically, life would be simpler and my two constraints would be much easier to satisfy. But producing for a single consumer is only viable where there is a predominant de jure or de facto solution out there … no such thing exists for “Intent Engine” at this time … indeed, you should remove the “Open Source” label from the diagram, IMHO … we don’t want to exclude COTS products or private tools (do we?)

So, like Diego’s “Network SQL” analogy, we need to design a solution that (1) meets the requirements we set for IBNEMO as a means of expressing intents in the networking domain and (2) is compelling (effective and efficient) enough for wide adoption among (at a minimum) developers of “Intent Engines”.

Avanti,
BobN

From: Susan Hares [mailto:[email-masked]]
Sent: Thursday, June 04, 2015 2:56 PM
To: 'Zhoutianran'; Natale, Bob; [email-masked]
Cc: [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Tianran/Terrence:

Sue

From: Ibnemo [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Thursday, June 04, 2015 5:04 AM
To: Natale, Bob; Susan Hares; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ibnemo] Defining a Common Model for intent

Hi Bob and Sue,

Terence

[intent network arch.gif]

To: Susan Hares; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Sue,

Avanti,
BobN

To: 'Zhoutianran'; Natale, Bob; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Tianran:

Sue

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 5 Jun 2015 05:00:53 +0000

Hi Sue,

Concerning your point about layers and logical representation, I agree … John used the stack of layers approach as a visual aid (I believe) … its behavior is actually more like a spectrum than a stack of layers … a major need for success in policy-based management is to narrow the range of the spectrum from intents/goals to actions/behavior and/or reduce the impedance in getting from business intent to network behavior across that range. I realize this is somewhat abstract for an IETF forum … but I do think we are all working to establish some basic common understanding here.

Concerning your point about “intent-roles groupings”, I have to confess that (1) I don’t understand the discussion around those concepts on these threads and (2) have not yet found it possible to devote enough time to consider them more thoroughly (and I’m not sure that I will get that opportunity). I’m an old-timer (for real) and that might be a limiting factor for me on this point … the major hurdles in standardizing policy-based management have been in place for years, so we have some very familiar concepts and terminology … that can be an aid to progress or an obstacle … in the latter case, new concepts and terminology are needed … maybe we’re at that point, and my “tenure” is keeping me from realizing it.

Avanti,
BobN

From: Susan Hares [mailto:[email-masked]]
Sent: Thursday, June 04, 2015 11:55 AM
To: Natale, Bob; 'Xiayinben'; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

Bob:

Sue

To: Xiayinben; Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 5 Jun 2015 05:14:37 +0000

Hi Sue,

As you probably caught from an earlier post of mine this evening, the “distance” from the top level intent expression to executable actions that affect network behavior is the range (number and scope) of translations that have to take place to complete that journey.

Thus, a network resources that directly understood intent expression from some source and converted them into the necessary actions on itself would have a distance of zero from that source. A path that required a conversion of intent expressions into E-C-A rules and then into CLI scripts for execution by the network resource would have a distance of two+ from the intent source. (The “+” represents some operation that accounts for the difficulty of the specific translations relative to other possibilities). In reality, the distance numbers are typically higher than that and involve manual translation steps as well. (Given the imprecision of comparing “difficulty” in such things, “distance” is mostly a qualitative metric, not a truly quantitative one … used just as an aid in understanding.)

Avanti,
BobN

From: Susan Hares [mailto:[email-masked]]
Sent: Thursday, June 04, 2015 11:47 AM
To: Natale, Bob; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Bob:

Sue

To: Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 5 Jun 2015 05:57:23 +0000

Hi Terence,

I think you are on the mark with your observations below.

I have some reservations about the term “role”, but I believe I understand how you are using it and can roll with that.

As Dan noted and we have discussed in various postings, “layers” are not a good fit for a continuum (spectrum) model, particularly when they are envisioned like the ISO 7-Layer model … again, there’s some history behind their use in this context and we all can understand that the term should not be interpreted too rigidly here.

Totally agree about the continuum not being a mandatory implementation model … it is in many cases a de facto implementation model … in an ideal world, network elements would directly understand intent expressions and there would be no continuum … obviously, we are very far from that goal in the general case today.

Avanti,
BobN

Hi Bob and Sue,

My idea is:

Best Regards,
Terence

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Fri, 5 Jun 2015 08:35:23 +0000

Hi Tina,

IMHO, we have two different pairs of shoes here… because policy is already the ‘how’ side of the equation and with intent we are on the ‘what’ side. So once we have have sorted out the limits of intent, we will be able to define how we want to translate it into policy. It may well be that we intent somehow replicating the policy continuum stratification or that we can map families of intents to the different strata of the policy continuum and there we would have a link between IBNEMO and SUPA

My 2e-10 cents
/PA

De: Tina TSOU <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 5 de junio de 2015 07:06
Para: Xiayinben <[email-masked]<mailto:[email-masked]>>, "Natale, Bob" <[email-masked]<mailto:[email-masked]>>, Zhoutianran <[email-masked]<mailto:[email-masked]>>, Sue Hares <[email-masked]<mailto:[email-masked]>>, "zhangyali (D)" <[email-masked]<mailto:[email-masked]>>, PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Ibnemo] 答复: Defining a Common Model for intent

Dear Yinben et al,

See “policy continuum” in http://datatracker.ietf.org/doc/draft-strassner-supa-generic-policy-info-model/?include_text=1.

4.2. SUPA Approach

   The purpose of the SUPA Generic Policy Information Model (SGPIM)
  is to define a common framework for expressing policies at
   different levels of abstraction. SUPA uses the SGPIM as a common
   vocabulary for representing concepts that are common to expressing
   policy, but which are independent of language, protocol,
   repository, and level of abstraction. This enables different
   policies at different levels of abstraction to form a continuum,
   where more abstract policies can be translated into more concrete
   policies, and vice-versa.

Strassner, et al.         Expires November 09, 2015          [Page 21]
Internet-Draft            SUPA Generic Policy Model           May 2015

   It may be necessary to translate the form of a PolicyRule from a
   general to a more specific form (while keeping the abstraction
   level the same). For example, the declarative policy "Every
   network attached to a VM must be a private network owned by
   someone in the same group as the owner of the VM" may be
   translated to more formal form (e.g., Datalog, or the Congress
  version of Datalog). It may also be necessary to translate a
   Policy to a different level of abstraction. For example, the
   previous Policy may need to be translated to a form that network
   devices understand. A common framework for expressing policies
   that is independent of the level of abstraction is required in
   order to form such a continuum.

Thank you,
Tina

Sent: Wednesday, June 03, 2015 11:54 PM

Hi Bob,

Yinben

发件人: Nfvrg [mailto:[email-masked]] 代表Natale, Bob
发送时间: 2015年6月3日 22:45
收件人: Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>
抄送:[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Nfvrg] [Ibnemo] Defining a Common Model for intent

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月1日 17:15
收件人: Susan Hares; [email-masked]<mailto:[email-masked]>
抄送:[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Ibnemo] Defining a Common Model for intent

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

From: Zhoutianran <[email-masked]>
Date: Thu, 4 Jun 2015 06:36:18 +0000

Hi Bob and Sue,

My idea is:

Best Regards,
Terence

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Zhoutianran <[email-masked]>
Date: Thu, 4 Jun 2015 09:04:05 +0000

Hi Bob and Sue,

Terence

Hi Sue,

Avanti,
BobN

Tianran:

Sue

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

---

From: Tina TSOU <[email-masked]>
Date: Fri, 5 Jun 2015 05:06:23 +0000

Dear Yinben et al,

4.2. SUPA Approach

Thank you,
Tina

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Fri, 5 Jun 2015 15:14:34 +0000

Please let me draw my thought.
Here is current system which provide some functional interfaces{f(1),f(2)...f(n)} for its support operation.

	        f(1)   f(2)   ...    f(n)
		    ^     ^     ^     ^
		    |     |     |     |
		|----------------------------------------|
		| current system operation  |
		|----------------------------------------|

A user's role decides that what they really cared are some result{r(1),r(2)...r(m)}.

		|-------------------------------------|
		| Role really cared result  |
		|-------------------------------------|
          |     |     |     |
	      v     v     v     v
         r(1)   r(2)   ...   r(m)

There are some knowledge: r(x) can be achieved by a list of f(a),f(b)..,f(t) in some context c(j),c(k),...,c(l). Maybe some users have this knowledge and sometimes care a part of them. But no one wants to give whole list.
Whole picture like this,

		|-------------------------------------|
		| Role really cared result  |
		|-------------------------------------|
          |     |     |     |
	      v     v     v     v
         r(1)   r(2)   ...   r(m)
									|-------------------|
      O				           c(1)<--|           |
    - - + - -				        	|  context   |
      +      				   c(2)<--|           |
	 /  \							|           |
					  		   c(p)<--|           |
									|--------------------|
	     f(1)   f(2)   ...    f(n)
	     ^     ^     ^     ^
		 |     |     |     |
	   |----------------------------------------|
	   | current system operation  |
	   |----------------------------------------|

Pure intent is r(x) only;
Impure intent is r(x)+c(y)+f(z).  f(z) is part of list of f(a),f(b)..,f(t)
Non intent is list of f(a),f(b)..,f(t).  This is prescriptive way.

Yinben

-----邮件原件-----
发件人: Ibnemo [mailto:[email-masked]] 代表 Bert Wijnen (IETF)
发送时间: 2015年6月5日 2:56
收件人: Susan Hares; Zhoutianran; 'Natale, Bob'; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [Ibnemo] Defining a Common Model for intent

See also inline

Bert

---

From: Xiayinben <[email-masked]>
Date: Fri, 5 Jun 2015 15:07:03 +0000

Sue,

The meaning of what I said “intent of different roles are not mutually exclusive” actually is that we don’t need care the relationship between  two roles.
Maybe they are mutually exclusive and maybe they are overlap. That doesn’t matter.
I think our target is defining a group of intent for a role. Our focus is what this role really cared about. It should not be impacted by other roles.
But policy continuum, it seems it considers much about mapping high level policy to low level. This design of implementation impacts the definition of each layer’s content.  It creates impact between each layer.
I think the consideration about “distance” restrict the consideration about “expression”. So I prefer to decouple those two topics.
If we focus on what intent should be, we should not be impacted by implementation method.

BTW, thanks for your example, let me try to understand how to classify simple intent, intent with context and complex intent.

Yinben
发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年6月5日 0:36
收件人: Xiayinben; 'Natale, Bob'; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Yinben:

a)      AS1 is AS2’s provider

Sue

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 13:04:00 -0400

Bert: 

Thanks for the email.  It is wonderful to have you help us refine this definition. 

Sue 

-----Original Message-----
From: Ibnemo [mailto:[email-masked]] On Behalf Of Bert Wijnen (IETF)
Sent: Thursday, June 04, 2015 4:37 PM
To: Susan Hares; 'Zhoutianran'; 'Natale, Bob'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] Defining a Common Model for intent

Hi Sue, inline

> I may already be lost in the above.  
[Sue]: See https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/
See section 3.1  user--> intent --> context
See section 3.2  intent == object, results, constraint. 

>> BGP:
>> user (provider) --> intent (be providers provider) --> context (bgp 
>> infrastructure) Intent (AS2 be provider's provider) --> object (AS1 provider), results (pass AS1 providers traffic), constraint (load-balance across all circuits connect to AS2).

>                                          constraint (load-balance across all circuits connect to AS2).
[Sue]: yes,  I was not precise enough.   It should be a == 

Intent(AS be provider's provider) == object (AS provider), results (pass AS1 provider's traffic), 
                                                             Constraint (load-balance across all circuits connected to AS2)

>In order to make this happen, some network architect or BGP routing maintainer, or maybe you call him >network operator, needs to speak out this intent in BGP speak, no?
>Does he/she  just revert to old technology so to speak (for example use netconf and a YANG data model) to >update the RIB/FIB on various devices/routers?
[Sue]
Which end-user? The business guy at AS1 or the network-architect?  
My point is that the intent I listed above is a business intent for the Provider. In my mind this is an end-user intent.   We are using AS1 - but in reality it is someone like ATT, BT, DT, NTT, Rogers, Telefonica, etc.  

The translation of this intent into the network actions for the BGP routing maintainer is a translation of the end-user business level intent into layers that interpret this intent into BGP.  To put a Yang spin on this, it is the translation of the intent to the l3SM service yang modules.  He L3SM will be translated into the Yang policy for BGP at ASBRs or RR devices (BGP Yang Config, operational state, and I2RS ephemeral state), and these in-turn will impact other system level definitions on these devices. 

The key point is that we start with the Business User's business intent or an end-user's Intent (Connect me to Sally).   Is this what you expected? 
 
>> Instinctively, I believe that role-based intent provides an ability 
>> to define and classify intent.  I know how to identify the role 
>> I am not going to create concepts but an operational solution. I 
>> think policy continuum is an option for intent implementation, but it’s not mandatory cannot escape.
>>
>> Best Regards,
>>
>> Terence
>>
>> Those two things are interrelated and captured in the policy 
>> continuum concept and construct … you can conceptualize them 
>> differently, resulting in different constructs, and that is fine … but you cannot escape them. Any attempt to escape them will result, at best, in a beautiful language that will never be spoken in an operational context.
>>
>> Avanti,
>>
>> BobN
>>
>> not an absolute (i.e., the diverse views of the Policy Continuum 
>> hold) and it’s also possible to envision cases where expressions of intent can be “directly” implemented by a resource or set of resources. SDN is a step in the direction of (1) reducing the number of translations necessary for a large class of intent-based policy expressions and (2) virtualizing the implementation actions from the perspective of the “upper”
>> [* - Is it “IBNemo”, “ibnemo”, “IB-nemo” or something else? … I see 
>> it written all of those ways, and possibly more....]
>>
>> Avanti,
>>
>> BobN
>>
>> for multiple intermediate E-C-A translations at multiple layers of 
>> the policy continuum has heretofore been a major impediment to progress on policy-based management, IMHO.
>>
>> /what/ he want without having the knowledge about /how/ to do it. 
>> Then the /how/ procedure will be transferred to /what /in the lower layer according to knowledge and context. These transfer procedure lead to the completion of requirement. Same with the example in draft. Although the ultimate effect is same, the focus is different which will bring out the differentiation of intent.
>>
>> For network administrators, intent can be specific operations on a 
>> set of devices such as configuring IP addresses on network servers in 
>> a data center.
>>
>> To
>>
>> destinatario, puede contener información privilegiada o confidencial 
>> y es para uso exclusivo de la persona o entidad de destino. Si no es

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 14:16:15 -0400

Bob: 

Glad we are both +1 on the need for both sides of Tianran/Terrence’s diagram.   On the right side debate,  I agree we should begin with the following consumers: 

1)      Who: Business entities, end-user customer entities, or non-profit organizations 

2)      What distance model from executable

In order to know where to place: 

3)      Yang/informational model 

I agree that the left side “intent-engine”, controller” and “run-time system” show distance.  However, one thing that the top-level language (e.g. Nemo) can provide to bridge the distance is the casting of the context at the top-level model into lower level definitions for components of intent (object, results, constraints).

An example may help.  Business intent says “connect all Rite-Start corporate offices together”.  The business SLAs and corproate translate this intent into a model of 5 Rite-Start corporate offices, p2p connections, with a data flow rate of 5 Gbps.  Or in intent terms: 

Intent (objects: 5 Rite-start offices, 5 p2p links, constraint), 

            results (5 Gps Data Flows, constraint), 

            constraint (SLA, cost).

Roles/classes of intent provide general constraints for objects, results, constraints which can be amended by specific constraints. 

We can borrow these concepts of roles/classes from the SQL environment that created a general way to model DBs which could then be tailored. 

What do you think? 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Friday, June 05, 2015 12:23 AM
To: Susan Hares; 'Zhoutianran'; [email-masked]
Cc: [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Avanti,

BobN

Tianran/Terrence: 

Sue 

Hi Bob and Sue,

 

Terence

intent network arch.gif

Hi Sue,

Avanti,

BobN

Tianran: 

Sue 

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 14:58:20 -0400

Bob:

+1 on goal of concept of a funnel of intent to specific network behavior. 

Summary on roles – I believe that roles are constraints on the intent (as email message indicates).  These constraints impact the range of valid values for the components of intent (object, result, constraints).  Why is this valuable?  Just like in SQL, we have validity checks for the components of intent within a context.  The roles help set these validity checks.  For example, if you are a node, link, flow object and your level is the business level.  You will utilize nodes that summarize whole business sites not the router-interface a.    In the model work we have done for Nemo, the Nemo model allows context to stored and utilized to fill-in/validate the intent’s content. 

Does this help? 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Friday, June 05, 2015 1:01 AM
To: Susan Hares; 'Xiayinben'; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] 答复: Defining a Common Model for intent

Hi Sue,

Avanti,

BobN

Bob: 

Sue 

Hi Yinben,

Avanti,

BobN

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 15:00:10 -0400

Bob:

Thank you for this excellent explanation. 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Friday, June 05, 2015 1:15 AM
To: Susan Hares; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ibnemo] Defining a Common Model for intent

Hi Sue,

Avanti,

BobN

Bob:

Sue 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 5 Jun 2015 20:16:13 +0000

Hi Sue,

Thanks for the explanation. The general behavior you describe below conforms to mainstream understanding of policy-based management, I’d say … it’s just the use of the term “role” and it’s particular elevation in your model. There are innumerable possible constraints on validity on each side of every translation, from creation through execution … many to most of those constraints are contextual, often in context-rich environments. I could go on, but I don’t want to belabor this point any further.

As I indicated in my response to Terence last night, if you and the other active contributors to IBNEMO feel that you are making concrete progress toward consensus on an implementable standard based on the e-mail traffic, I don’t want to derail that. You have all given me ample room on the soapbox and I am rooting for your success at this point!

Avanti,
BobN

Sent: Friday, June 05, 2015 2:58 PM

Bob:

Does this help?

Sue

To: Susan Hares; 'Xiayinben'; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Sue,

Avanti,
BobN

To: Natale, Bob; 'Xiayinben'; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Bob:

Sue

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Sat, 6 Jun 2015 09:26:37 +0000

Hi Tina,

Thanks for your information.
Actually I still don’t understand why it is necessary for a generic policy model on top of intent and ECA. I am sorry, hope this is only my problem.
I think ECA is already a well known generic information model for policy. It represents about “if event/condition then action”.
This is a clear information model for condition type operation. But the intent discussion is around how to simply expressing user’s intention.
Maybe it because some intent will map to ECA policy. But some intent don’t need map to ECA, such as simple provisioning. And all this is only related with intent’s execution. I think all of them will not impact intent definition and content.

Yinben

发件人: Tina TSOU
发送时间: 2015年6月5日 13:06
收件人: Xiayinben; Natale, Bob; Zhoutianran; Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Ibnemo] 答复: Defining a Common Model for intent

Dear Yinben et al,

4.2. SUPA Approach

Thank you,
Tina

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Sat, 6 Jun 2015 09:46:53 +0000

Hi Bob,

IMHO, you think too much about how to translate intent to execution interface. I think this implementation detail maybe restrict your thinking in intent content. Let’s leave implementation detail until we have clear intent content.
BTW, I think it is not necessary to translate every intent to ECA. For example, user’s intent is a connection between A and B.  This type of connection intent  create a tunnel. It is straightforward<javascript:void(0);>. It is a simple provisioning intent which we don’t need translate to ECA policy.

Yinben

发件人: Nfvrg [mailto:[email-masked]] 代表 Natale, Bob
发送时间: 2015年6月5日 13:15
收件人: Susan Hares; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [Nfvrg] [Ibnemo] Defining a Common Model for intent

Hi Sue,

Avanti,
BobN

To: Natale, Bob; 'Zhoutianran'; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Bob:

•       What is the “distance” from the top level intent expressions to executable actions that affect network behavior?

Sue

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Sat, 6 Jun 2015 10:05:41 +0000

Hi Bob,

Thanks for your encourage.
I think a big target always need several trials to achieve.
Here, our big target is making network easier to be used and more innovation. Policy continuum was a great trial tens of years before which had the same target.
But it seems this target is still difficult to meet. The network interface is still  complex. So we try to find a new track to achieve this big target.  It doesn’t mean it is not worthy to study and refer to previous experience and trials. But it is necessary to avoid repeat previous trials.
Nevertheless, what you discussed here is worthy to be considered. I hope you still could provide new deep idea on this new trial

Yinben

发件人: Natale, Bob [mailto:[email-masked]]
发送时间: 2015年6月6日 4:16
收件人: Susan Hares; Xiayinben; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Ibnemo] 答复: Defining a Common Model for intent

Hi Sue,

Avanti,
BobN

Bob:

Does this help?

Sue

Hi Sue,

Avanti,
BobN

Bob:

Sue

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Mon, 8 Jun 2015 07:00:36 +0000

Sue,

I think this is a faery good starting point. Just an additional question that is bugging me. Can we also try to explore recursiveness in the model?
I mean: At one level in time we have a ‘Node’ that is a whole business site, say an autonomous system. This ‘Node’ can be expanded as a set of areas (in the OSPF lingo,level in the IS-IS lingo), right? So diving into this level, we could say that each area is ‘Node’ and that areas are interconnected by links. Then each Node at this level is, when zoomed in, a set of interconnected routers. I think we also need to express this kind or recursiveness. In the ODL NEMO project, one of the sue cases is a virtual data-centre model with a similar concept of layering, recursion(?)

What is your feeling on this?

Best, /PA
De: Sue Hares <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 5 de junio de 2015 20:58
Para: "'Natale, Bob'" <[email-masked]<mailto:[email-masked]>>, 'Xiayinben' <[email-masked]<mailto:[email-masked]>>, 'Zhoutianran' <[email-masked]<mailto:[email-masked]>>, "'zhangyali (D)'" <[email-masked]<mailto:[email-masked]>>, PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Ibnemo] 答复: Defining a Common Model for intent

Bob:

Does this help?

Sue

Hi Sue,

Avanti,
BobN

Bob:

Sue

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

From: Zhoutianran <[email-masked]>
Date: Mon, 8 Jun 2015 09:10:39 +0000

Hi Pedro,

In the VDC use case, we did have the “recursion”. But can we just treat them as different kind of nodes that have specific functions?
I mean we do not have to put each node instance in the seat where the network level is.
This will make the modeling more flexible to capture the user intent, not be constrained by the network infrastructure.

Best,
Terence

From: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
Sent: Monday, June 08, 2015 3:01 PM
To: Susan Hares; 'Natale, Bob'; Xiayinben; Zhoutianran; zhangyali (D); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] 答复: Defining a Common Model for intent

Sue,

Best, /PA

Bob:

Does this help?

Sue

Hi Sue,

Avanti,
BobN

Bob:

Sue

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Mon, 8 Jun 2015 09:20:19 +0000

Hi Tianran

Sure we could treat them as different kinds of nodes, but I think that recursiveness allows us to include properties from the lower layers into the upper layers(or at least to give some thought on this). Plus this is a characteristic that exists very clearly in the “infrastructure” axis which IMHO is difficult to reproduce in the role axis of the problem. This is why I see that role is orthogonal to infrastructure.

Best, /PA

De: Zhoutianran <[email-masked]<mailto:[email-masked]>>
Fecha: lunes, 8 de junio de 2015 11:10
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, Sue Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Ibnemo] RE: Defining a Common Model for intent

Hi Pedro,

Best,
Terence

To: Susan Hares; 'Natale, Bob'; Xiayinben; Zhoutianran; zhangyali (D); [email-masked]<mailto:[email-masked]>

Sue,

Best, /PA

Bob:

Does this help?

Sue

Hi Sue,

Avanti,
BobN

Bob:

Sue

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: Zhoutianran <[email-masked]>
Date: Mon, 8 Jun 2015 09:32:09 +0000

Hi Pedro,

That’s a very interesting idea. It goes down to the design details. To verify this, I think we can go back to the implementation.
And I think we can try to work on this as a concrete example of role based intent.
What’s your opinion?

Best,
Terence

From: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
Sent: Monday, June 08, 2015 5:20 PM
To: Zhoutianran; Susan Hares; [email-masked]
Cc: [email-masked]
Subject: Re: [Ibnemo] RE: Defining a Common Model for intent

Hi Tianran

Best, /PA

Hi Pedro,

Best,
Terence

Sue,

Best, /PA

Bob:

Does this help?

Sue

Hi Sue,

Avanti,
BobN

Bob:

Sue

Hi Yinben,

Avanti,
BobN

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jun 2015 18:29:50 -0400

Yinben:

This response comes later. I really needed to think about your comment – we really do not need about the relationship between two roles.  I think Diego’s comment states we have two types of roles:  security and the abstract function we want to do.  The relationship between these types of roles may be interesting for the security concepts – but let us first try to define the abstract functions, and then go back to look at the security roles of an intent. 

My example below has to do with the abstract/business view AS1 was to do.  The role is “being provider’s provider” because that is the global intent and the role.  The object is AS2. The result is “Be AS2’s provider”.  The operation is “carry traffic”.   Are we saying that a global intent may form an abstract role?  Is there any generic intent/declarative language with this point? 

Sue 

	Intent Being Provider’s Provider ,Load balance traffic to/from AS2,Object: AS2 ,Result: Be AS2’s provider ,Operation: Carry traffic 	

 

 

 

 

 

From: Ibnemo [mailto:[email-masked]] On Behalf Of Xiayinben
Sent: Friday, June 05, 2015 11:07 AM
To: Susan Hares; 'Natale, Bob'; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: [Nfvrg] 答复: Defining a Common Model for intent

Sue,

Yinben 

Yinben: 

a)      AS1 is AS2’s provider 

Sue 

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jun 2015 18:36:52 -0400

Yinben: 

I agree with this viewpoint that: 

Pure intent is r(x) only; Impure intent is r(x)+c(y)+f(z).   f(z) is part of list of f(a),f(b)..,f(t) 

Can we determine the r(x) for a class of roles?  I believe we can.  

Sue 

-----Original Message-----
From: Ibnemo [mailto:[email-masked]] On Behalf Of Xiayinben
Sent: Friday, June 05, 2015 11:15 AM
To: Bert Wijnen (IETF); Susan Hares; Zhoutianran; 'Natale, Bob'; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: Defining a Common Model for intent

              f(1)   f(2)   ...    f(n)

                ^     ^     ^     ^

                |     |     |     |

                 |     |     |     |

                v     v     v     v

               r(1)   r(2)   ...   r(m)

Whole picture like this,

     |---------------------------|

     |---------------------------|

          |     |     |     |

        v     v     v     v

         r(1)   r(2)   ...   r(m)

                                         |-----------|

      O                            c(1)<--|           |

    - - + - -                             |  context  |

      +                            c(2)<--|           |

     /  \                                |           |

                                    c(p)<--|           |

                                          |------------|

        f(1)   f(2)   ...   f(n)

          ^     ^     ^     ^

          |     |     |     |

Pure intent is r(x) only; Impure intent is r(x)+c(y)+f(z).   f(z) is part of list of f(a),f(b)..,f(t) 

Yinben

-----邮件原件-----

发件人: Ibnemo [ <mailto:[email-masked]> mailto:[email-masked]] 代表 Bert Wijnen (IETF)

发送时间: 2015年6月5日 2:56

收件人: Susan Hares; Zhoutianran; 'Natale, Bob'; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ';  <mailto:[email-masked]> [email-masked]

抄送:  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]

See also inline

On 04/06/15 20:41, Susan Hares wrote:

Bert

> *From:*Zhoutianran [ <mailto:[email-masked]> mailto:[email-masked]]

> GUTIERREZ';  <mailto:[email-masked]> [email-masked]

> *Cc:*  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]

> *From:*Natale, Bob [ <mailto:[email-masked]> mailto:[email-masked]]

> GUTIERREZ';  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

> *Cc:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> *From:*Ibnemo [ <mailto:[email-masked]> mailto:[email-masked]] *On Behalf Of 

> *Zhoutianran

> GUTIERREZ';  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

> *Cc:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> *From:*Ibnemo [ <mailto:[email-masked]> mailto:[email-masked]] *On Behalf Of *Natale, 

> Bob

> *To:* Susan Hares; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; 

>  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

> *Cc:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> *From:*Susan Hares [ <mailto:[email-masked]> mailto:[email-masked]]

> *To:* Natale, Bob; 'zhangyali (D)'; 'PEDRO ANDRES ARANDA GUTIERREZ'; 

>  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

> *Cc:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

>  <http://www.tssg.org/files/archives/2007_MACE_SDavy_Jennings_final.pdf> http://www.tssg.org/files/archives/2007_MACE_SDavy_Jennings_final.pdf

> *From:*Natale, Bob [ <mailto:[email-masked]> mailto:[email-masked]]

> *To:* zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; 

>  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

> *Cc:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> *From:*Ibnemo [ <mailto:[email-masked]> mailto:[email-masked]] *On Behalf Of 

> *zhangyali (D)

> *To:* PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> *Cc:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> *发件人**:*PEDRO ANDRES ARANDA GUTIERREZ 

> [ <mailto:[email-masked]> mailto:[email-masked]]

> *收件人:* Susan Hares;  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

> *抄送:*  <mailto:[email-masked]> [email-masked]

> < <mailto:[email-masked]> mailto:[email-masked]>;  <mailto:[email-masked]> [email-masked] 

> < <mailto:[email-masked]> mailto:[email-masked]>

> A small clarification proposal for draft  <https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/> https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/.

>  <mailto:[email-masked]> [email-masked]

>  <https://www.ietf.org/mailman/listinfo/ibnemo> https://www.ietf.org/mailman/listinfo/ibnemo

Ibnemo mailing list

 <mailto:[email-masked]> [email-masked]

 <https://www.ietf.org/mailman/listinfo/ibnemo> https://www.ietf.org/mailman/listinfo/ibnemo

Ibnemo mailing list

 <mailto:[email-masked]> [email-masked]

 <https://www.ietf.org/mailman/listinfo/ibnemo> https://www.ietf.org/mailman/listinfo/ibnemo

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jun 2015 18:51:06 -0400

Yinben:

After thought and Diego’s differentiation between security role and abstract role – I agree we should focus on the abstract role.  As Pedro suggested, the roles may have recursion within the intent (object, result, operation).   Let’s see what we can find that is common among two different examples. 

Example 1: Provider’s provider – Intent: Carry AS 2 traffic (sub-role load balance across AS1-AS2 connections).   

Example 2: Enhanced services Data Center Services – Network Access, mail cleaning in DPI, firewall 

Does this seem like a good idea? 

Sue 

From: Xiayinben [mailto:[email-masked]] 
Sent: Friday, June 05, 2015 11:07 AM
To: Susan Hares; 'Natale, Bob'; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: 答复: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Sue,

Yinben 

Yinben: 

a)      AS1 is AS2’s provider 

Sue 

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jun 2015 19:07:52 -0400

Pedro: 

I agree 100% that we have to look at recursiveness in the model.   I proposed to network specific models.  I will check to see if the ODL Virtual data center is different.  If it is, we should add that one. 

1)      Provider’s provider 

2)      Enhanced services Virtual Data Center Services – Network Access, mail cleaning in DPI, firewall  with SFC paths between 

Sue Hares 

From: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]] 
Sent: Monday, June 08, 2015 3:01 AM
To: Susan Hares; 'Natale, Bob'; 'Xiayinben'; 'Zhoutianran'; 'zhangyali (D)'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ibnemo] 答复: Defining a Common Model for intent

Sue,

Best, /PA

De: Sue Hares <[email-masked]>
Fecha: viernes, 5 de junio de 2015 20:58
Para: "'Natale, Bob'" <[email-masked]>, 'Xiayinben' <[email-masked]>, 'Zhoutianran' <[email-masked]>, "'zhangyali (D)'" <[email-masked]>, PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>, "[email-masked]" <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: RE: [Ibnemo] 答复: Defining a Common Model for intent

Bob:

Does this help? 

Sue 

Hi Sue,

Avanti,

BobN

Bob: 

Sue 

Hi Yinben,

Avanti,

BobN

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jun 2015 19:19:45 -0400

Tianran/Terence: 

If we have 3 different and orthogonal types of roles:  security, infrastructure, and abstract functions – then we would need to be able to associate these three different types of roles together.   This is different that providing recursion within an intent or an object.  It should be used without levels.  For infrastructure, the recursion can be the expansion of the AS object to a set of objects.   This should be allowed to be part of the intent construct (object, result, operation). 

Sue 

From: Zhoutianran [mailto:[email-masked]] 
Sent: Monday, June 08, 2015 5:11 AM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]
Subject: RE: [Ibnemo] RE: Defining a Common Model for intent

Hi Pedro,

Best,

Terence

Sue,

Best, /PA

Bob:

Does this help? 

Sue 

Hi Sue,

Avanti,

BobN

Bob: 

Sue 

Hi Yinben,

Avanti,

BobN

Hi Bob,

Yinben 

Hi Terence,

Avanti,

BobN

 

Hi Bob,

Regards,

Terence

Hi Sue,

Avanti,

BobN

Bob:

Sue 

With all due respect:

Avanti,

BobN

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: Xiayinben <[email-masked]>
Date: Tue, 9 Jun 2015 09:39:40 +0000

I agree this ☺

Yinben
发送时间: 2015年6月9日 6:51

Yinben:

To: Susan Hares; 'Natale, Bob'; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Sue,

Yinben
发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年6月5日 0:36
收件人: Xiayinben; 'Natale, Bob'; Zhoutianran; zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Yinben:

a)      AS1 is AS2’s provider

Sue

Hi Bob,

Yinben

Hi Terence,

Avanti,
BobN

Hi Bob,

Regards,
Terence

Hi Sue,

Avanti,
BobN

Bob:

Sue

With all due respect:

Avanti,
BobN

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -