Subject: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Tue, 2 Jun 2015 06:38:23 +0000

Hi Yali,

let’s keep in the networking domain :-) I strongly believe that we need different levels or layers of intent. However, there are (at least) two different viewpoints:

If you follow the infrastructure view(which is where I feel more comfortable), I hope we agree that it is a completely different situation when you are designing a network element-by-element than when you are designing the network at a sub-domain level (for example levels in an IS-IS based network or areas if you use OSPF) or if you are defining the interconnections of a service provider’s AS (and dealing with BGP-4 policies) or if you are defining an end-to-end service. Although at the end, the upper layers will use all the features provided by the lower layers.

Now, I’m sure we can find the equivalent layering from a role point of view:

The user wants to access a service (for example a Web page), the provider of that Web page wants it to be served with the best quality of experience and so he chooses a specific provider – normally a CDN). The CDN provider will choose a given carrier to get access to the user’s service provider. The user’s service provider will dimension his network to fulfill a series of criteria. Within the service provider, the operators sitting at the Network Operations Centre will have to fulfill a series of KPIs, etc.

As you see, I’m more a ‘box’ thinker. However, if someone can complete the ‘role’ example we can compare both approaches and try to identify if we can do any mapping between the two views. Maybe we could come up at end with a set of common denominators we can use to continue this discussion.

Best,
/PA

De: "zhangyali (D)" <[email-masked]<mailto:[email-masked]>>
Fecha: martes, 2 de junio de 2015 05:52
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, Sue Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: 答复: [Ibnemo] Defining a Common Model for intent
Nuevo envío de: <[email-masked]<mailto:[email-masked]>>
Nuevo envío para: <[email-masked]<mailto:[email-masked]>>
Fecha de nuevo envío: martes, 2 de junio de 2015 05:52

Hi Pedro,

Thanks for reviewing the draft and giving modification.

The question you have mentioned is a very important point for the abstraction of intent model. Maybe we can propose the transport market as a analogy.

1.       A customer wants to transport his goods from A to B. So his intent is getting his goods from A to B without carrying about how to do it. Then his intent is transferred to the transportation system.

2.       This system analyzes customer’s requirement, and choose a suitable way to complete the requirement. For example, the system choose truck as the means. So the intent of transportation system is transferring the goods with truck.

3.       The driver of this truck analyze the path from A to B, and choose a most appropriate path to complete this order which will save more time. So  the intent of driver may be transferring the goods with the least time. Then the driver will start the engine, step on the gas, etc.

From this analogy, the ultimate effect is the same, namely, transfer the goods from A to B. But the specific intent of different roles has some differences which depends on user’ role, knowledge, responsibility, etc. For example, transportation system is responsible for transporting goods, and he know the various ways. So he can form his intent by rendering the upper customer’s intent.

Supposing we divide users into different layers according to the implementation series, users in upper layer expresses his intent as what he want without having the knowledge about how to do it. Then the how procedure will be transferred to what in the lower layer according to knowledge and context. These transfer procedure lead to the completion of requirement. Same with the example in draft. Although the ultimate effect is same, the focus is different which will bring out the differentiation of intent.

This is just my immature opinion about intent. Do you think the differentiation of intent to complete the same thing is important and reasonable?

Best Regards,

Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月1日 17:15
收件人: Susan Hares; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Ibnemo] Defining a Common Model for intent

Hi,

A small clarification proposal for draft https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/ .

In section 2.4, I would leave the following as a paragraph

For example, in the network area the intent of end-users could be

safe connectivity between two sites which a technology independent

and device independent requirement. For business-based network

designers, the network connectivity can be selected which is device-

independent but technology specific. An example of the business-based

technology is the L3VPN.

And change:

For network administrators, intent can be

specific operations on a set of devices such as configuring IP

addresses on network servers in a data center.
To

For network administrators, intent can be <new>defining a network topology like a router connected to a firewall, connected to a load balancer and this to two L2 networks where WWW servers sit or specifying the</new> operations on a set of devices such as configuring IP addresses on network servers in a data center.

Rationale behind this is again, that intent should be anything that is invariant and that expresses what a network operator/administrator may need to do, as opposed to how he would do that, i.e. The router is a HW device from vendor X or a virtual machine running a specific routing daemon over a given data-path implementation.

Best, /PA
---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "zhangyali (D)" <[email-masked]>
Date: Tue, 2 Jun 2015 12:28:57 +0000

Hi Pedro,

That’s very good for enumerating these two different viewpoints when discuss the layer of intent. Definitely, these two viewpoints are two important perspectives for intent representation.

I am not sure if my understanding is consistent with you, and I assume I have gotten what you said. So if my understanding is wrong, please point it out without any hesitation.

For viewpoint 1, intent is divided into hierarchical relationship according a specific implementation procedure which lower layers are completely used to fulfill the requirements of upper layers. At this point, the intent of lower layer serve as the implementation and the rendering layer by layer lead to the realization of highest layer’ intent. This confirms to implementation procedure of a specific affair, however, if we consider the responsibility of the whole layer, there are some intent just serve itself, i.e. A administrator want to do a backup line to ensure the stabilization. Another problem is that there may be some extra intent independent of present upper layer intent.
For viewpoint 2, intent is divided according to roles differentiation which have different knowledge, responsibility, etc. Users with different roles can express their intent separately, and different roles do not have the relationship of serve-client. All users with different roles have the liberty to express their own intent without worrying about what is the other users’ intent, even though the function is used by them in some specific affair. This classification give users with different roles liberty to express their intent which may involve brief vision or detailed function.

By comparing these two viewpoints, I think the classification of intent according to the difference of roles is a better way. Do you have same opinion or any comments?

Best Regards,
Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月2日 14:38
收件人: zhangyali (D); Susan Hares; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: 答复: [Ibnemo] Defining a Common Model for intent

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 2 Jun 2015 18:48:23 -0400

Pedro and Yali: 

It helps to keep in the networking domain where I am familiar with work!  I agree that intent goes through the layers, but I still struggle to make the connections. 

I know that instances of code (BGP) on devices create zones  of connectivity (sub-domains/subnets, AS, Groups of AS), but I think there must be  more in the intent discuss.  Yinben and Yali’s comments that 

User à intent à context 

is still the key information.    Is it Intent + context (layer n) to ? at layer n-1.  

Sue 

PS - Perhaps I am tainted by the ISO model that suggests lower layers provide services for lower layers. 

From: Nfvrg [mailto:[email-masked]] On Behalf Of PEDRO ANDRES ARANDA GUTIERREZ
Sent: Tuesday, June 02, 2015 2:38 AM
To: zhangyali (D); Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi Yali,

Best,

/PA

De: "zhangyali (D)" <[email-masked]>
Fecha: martes, 2 de junio de 2015 05:52
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>, Sue Hares <[email-masked]>, "[email-masked]" <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: 答复: [Ibnemo] Defining a Common Model for intent
Nuevo envío de: <[email-masked]>
Nuevo envío para: <[email-masked]>
Fecha de nuevo envío: martes, 2 de junio de 2015 05:52

Hi Pedro,

Best Regards,

Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]] 
发送时间: 2015年6月1日 17:15
收件人: Susan Hares; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [Ibnemo] Defining a Common Model for intent

Hi,

A small clarification proposal for draft  <https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/> https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/ .

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 2 Jun 2015 19:26:43 -0400

Yali:

While I believe the lower layers exist to serve the upper layers, I think Intent is a quality of declarative policy which provides a prescriptive rather than descriptive description.   It is not upper/lower layers – for that reduces the concept. 

I still come back to you fundamental: User (of the layer) à intent à context. 

Do you have any other examples? 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Tuesday, June 02, 2015 8:29 AM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: 答复: Defining a Common Model for intent

Hi Pedro,

Best Regards,

Yali

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Wed, 3 Jun 2015 06:12:40 +0000

Hi,

So, let’s keep in one layer first. And since you mention my pet-topic (BGP), let’s stay there :-)

Ex.1
There is a lot of work on the relations between autonomous systems (provider, client, sibling, etc.)
So intent for me is the assertion "AS1 is a provider for AS2”; the implementation would use advertisements, route-maps etc. and that is not intent

Ex.2
AS1 is connected to AS2, he has several links and wants to implement load-balancing between them. “Load balancing" is the intent and advertisements, route-maps etc. is the implementation and that’s not intent.

From an infrastructure point of view, we have two instances of intent at the same “layer”. However role-wise, the decision of entering a client-provider relationship between ASes is taken in the ‘management floor’ and the decision of load-balancing in taken in the Network Operation Centre. This is the reason for my double take at intent

Regarding whether intent @ layer N + context @ layer N —> something @ layer N-1 and from my example above depends how or whether we structure the role dimension into layers.

The policy continuum paper would somehow suggest that this mapping between layers somehow happens in the infrastructure dimension

My .2 cents,
/PA

De: Sue Hares <[email-masked]<mailto:[email-masked]>>
Fecha: miércoles, 3 de junio de 2015 00:48
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, "'zhangyali (D)'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Pedro and Yali:

I know that instances of code (BGP) on devices create zones  of connectivity (sub-domains/subnets, AS, Groups of AS), but I think there must be  more in the intent discuss.  Yinben and Yali’s comments that
User --> intent --> context

Sue

From: Nfvrg [mailto:[email-masked]] On Behalf Of PEDRO ANDRES ARANDA GUTIERREZ
Sent: Tuesday, June 02, 2015 2:38 AM
To: zhangyali (D); Susan Hares; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Wed, 3 Jun 2015 15:38:00 +0000

HI Pedro,

In my understanding, your examples are two roles’ intent at same layer in infrastructure.
So I think that a intent is only related with  what are role’s caring. Finding which layer it is in is not helpful.
Even in translating the intent to a set of real interfaces, it is not necessary to map layer by layer.

My 2 cents,
Yinben

发件人: Nfvrg [mailto:[email-masked]] 代表 PEDRO ANDRES ARANDA GUTIERREZ
发送时间: 2015年6月3日 14:13
收件人: Susan Hares; zhangyali (D); [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi,

Ex.1

Ex.2

My .2 cents,
/PA

Pedro and Yali:

Sue

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 3 Jun 2015 21:52:19 -0400

Yali:

I this example really helps.  I think the intent is the connection and the price a context that the user may want to have as a constraint. 

Intent à users à context --- constraint. 

Does this make sense? 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Tuesday, June 02, 2015 11:44 PM
To: Susan Hares; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: 答复: 答复: Defining a Common Model for intent

Hi Sue:

It’s very good for coming back to the fundamental, even though discussing about classification of intent is also a meaningful topic. 

For a user, intent is the result he desired or some operations he want to take in a context. For example, a end-user want to make the communication between two sites is the minimum. For this intent, price is the context. Though context is omitted usually, it is really a important factor to affect the decision. Do you think this example is suitable to express general intent?

Best,

Yali

发件人: Susan Hares [mailto:[email-masked]] 
发送时间: 2015年6月3日 7:27
收件人: zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Ibnemo] 答复: 答复: Defining a Common Model for intent

Yali:

Sue 

Hi Pedro,

Best Regards,

Yali

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 3 Jun 2015 22:11:53 -0400

Pedro:

I agree with your BGP examples.  It too is my favorite topic.  

Example 1 : AS1 as provider for AS2 – 

This service provider’s (user’s) intent with the context of BGP infrastructure.

Is it AS1 intent or AS2 intent or symmetric intent?  I think symmetric. 

This is like a link in a node AS1--- AS-Link -- AS2 

Example 2: AS1 as a provider intents to load balance traffic to AS 2: 

                  This is AS1’s intent. 

                  This intent is like our original model:  AS1-link-AS2 with Dataflow balanced. 

                                Intent = connection at flow distribution

                                Context: BGP infrastructure 

Do you think I understand your examples? 

Sue 

 

From: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]] 
Sent: Wednesday, June 03, 2015 2:13 AM
To: Susan Hares; 'zhangyali (D)'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

De: Sue Hares <[email-masked]>
Fecha: miércoles, 3 de junio de 2015 00:48
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>, "'zhangyali (D)'" <[email-masked]>, "[email-masked]" <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 11:28:58 -0400

Yinben: 

I agree that the intent is being expressed by two roles: 

1)      Provider’s provider – AS1 is a provider for AS 2. 

2)      Traffic balancer – AS 1 is traffic balance traffic to AS 2. 

Is this what you meant? 

Sue  

From: Ibnemo [mailto:[email-masked]] On Behalf Of Xiayinben
Sent: Wednesday, June 03, 2015 11:38 AM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; zhangyali (D); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: [Nfvrg] 答复: Defining a Common Model for intent

HI Pedro,

My 2 cents,

Yinben 

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 14:23:18 -0400

Yali: 

I agree that context is the external background information

user  à intent à context.

I struggle with the line between background and intent.  If intent is decomposed into object, result and constraint, the real question is whether the intent is pure or mixed.  If we are adding constraints then it is impure or constraint based.   My difficultly is that I know that constraints operate within a context.  In your example, costs operate within the context of a monetary evaluation ($1000, $2000) and line costs operate within a market (price goes up and down).  

I can agree that intent is object, result and constraint.   Howevere there is a a lot of context in constraint.  Have you observed this? 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Wednesday, June 03, 2015 11:03 PM
To: Susan Hares; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: 答复: 答复: 答复: Defining a Common Model for intent

Sue:

Sorry for having different understanding for context of this example. 

In this example, price, as the context,  is marked by the provider of pipelines which is identical to all the users. For example, common circuit is marked as $1000, and dedicated line is marked $2000, etc. So context is the background information which could not changed as the result of intent. It’s free for users to describe context or not when expressing intent. Though context can be obtained by system automatically, it is important factor for the implementation of intent. In this example, when system choose the least cost, it will know the price of each way. So intent is the background information of intent, rather than part of intent’ content.

Therefore, the fundamental of intent always be: user  à intent à context. 

User is the subject to express intent (the enterprise, in this example), and intent is the result he desired (i.e. connect two sites with the least cost), and context is the external background information (i.e. the price of each line)

Though this example, maybe we can dig up the content of intent. The real intent is connect two sites with the least cost. So, intent can be decomposed into object and result. In this example, objects are these two sites, and result is the connectivity between these objects with the least money. If we treat the constraint as a individual part of intent, intent can be decomposed into object, result and constraint. In this example, objects are also these two sites, result is the connectivity, and constraint is the least cost.

Are you agree for the definition of context? And do you think this decomposition is suitable? Or any comments?

Yali

发件人: Susan Hares [mailto:[email-masked]] 
发送时间: 2015年6月4日 9:52
收件人: zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Ibnemo] 答复: 答复: 答复: Defining a Common Model for intent

Yali:

Does this make sense? 

Sue 

Hi Sue:

Best,

Yali

Yali:

Sue 

Hi Pedro,

Best Regards,

Yali

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 14:48:05 -0400

Yali: 

Your statement: 

“So intent is role-related, even though different roles is organized into hierarchy relation in some affairs. Intent of one role depends on its responsibility and knowledge, and is not just for severing another role.”

This statement says you are linking intent’s components (object, results, and constraints) + its context to a role.  As a PhD student in organizations and cultures – I must point out this is a cultural opinion that:  “with roles come responsibility and knowledge”.     This idea is common across most cultures, but it is strong in some cultures.  It is common in most US-European trained business human cultures. 

If we all agree on this statement, then we can begin to talk about

Intent [object, results,  constraints [practical + role-based]. 

Sue  

From: zhangyali (D) [mailto:[email-masked]] 
Sent: Thursday, June 04, 2015 4:01 AM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: 答复: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi Pedro and Sue,

Thanks for giving these two useful examples to compare different intent with different roles. From these examples, I very agree with you that intent is strongly related with roles. Different roles have different focuses even though the basic is same. 

So intent is role-related, even though different roles is organized into hierarchy relation in some affairs. Intent of one role depends on its responsibility and knowledge, and is not just for severing another role.

So “Intent + context (layer n) to ? at layer n-1” is the manifestation of implementation of different roles’ intent.

Let’s back to the fundamental: User à intent à context . Users is the subject who own the intent, intent is the content of user’ desire result or operations, and context is the background information. In your example 2, user is the network operators, and intent is doing load-balancing for the links between AS1 and AS2. 

Any comments?

Best,

Yali

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "zhangyali (D)" <[email-masked]>
Date: Thu, 4 Jun 2015 03:02:36 +0000

Sue:

Therefore, the fundamental of intent always be: user  --> intent --> context.
User is the subject to express intent (the enterprise, in this example), and intent is the result he desired (i.e. connect two sites with the least cost), and context is the external background information (i.e. the price of each line)

Yali

Yali:

Intent --> users --> context --- constraint.

Does this make sense?

Sue

To: Susan Hares; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>

Hi Sue:

Best,
Yali

发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年6月3日 7:27
收件人: zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: [Ibnemo] 答复: 答复: Defining a Common Model for intent

Yali:

I still come back to you fundamental: User (of the layer) --> intent --> context.

Sue

To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]<mailto:[email-masked]>

Hi Pedro,

Best Regards,
Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月2日 14:38
收件人: zhangyali (D); Susan Hares; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: 答复: [Ibnemo] Defining a Common Model for intent

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

From: "zhangyali (D)" <[email-masked]>
Date: Thu, 4 Jun 2015 08:00:51 +0000

Hi Pedro and Sue,

Let’s back to the fundamental: User --> intent --> context . Users is the subject who own the intent, intent is the content of user’ desire result or operations, and context is the background information. In your example 2, user is the network operators, and intent is doing load-balancing for the links between AS1 and AS2.

Any comments?

Best,
Yali

Hi,

Ex.1

Ex.2

My .2 cents,
/PA

Pedro and Yali:

Sue

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2015 15:32:06 -0400

Yali: 

I sent the similar example a few minutes ago.   100% agree with your point. 

Sue 

From: Nfvrg [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Thursday, June 04, 2015 4:01 AM
To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Nfvrg] 答复: 答复: [Ibnemo] Defining a Common Model for intent

Hi Pedro and Sue,

Any comments?

Best,

Yali

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Thu, 4 Jun 2015 20:17:08 +0000

Hi,

Let me try to bring a new view on this (hence no quotation of previous exchanges) in the hope it helps to get to a common understanding.

Those of you who know me have probably heard me saying that to complete the promise of SDN we need something like a "network SQL": a declarative language based on a formal network model that would allow both defining network properties and manipulating network behavior, and, what is of capital importance in my view, support the seamless integration of these definitions and manipulations within general-purpose applications. This is my hope for intent-based networking, and that is my understanding of an intent expression.

An intent model would precisely define this formal network model on which to base the declarative language. Different models would support different views (or roles?) and therefore translate into different declarative languages, the same way we have several mechanisms to manipulate data that are not necessarily SQL.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: "zhangyali (D)" <[email-masked]>
Date: Fri, 5 Jun 2015 03:57:23 +0000

Sue:

Thanks for your acceptance for the meaning of context. But I feel uncertain for the classification of “pure” or “impure” intent. Could you add more information about the difference between them?

And as I have mentioned, constraint is a part of intent. It dependents on what intent users want to express. The constraints may involve context or some others, such as the constraint to object or implementation, etc. If the constraint is related with context, the change of context will affect the implementation way rather than intent itself.

By the way, intent=object+ result + constraint is appropriate for the above example class, however, I am not sure if it is general for all situations.

Yali

发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年6月5日 2:23
收件人: zhangyali (D); 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Ibnemo] 答复: 答复: 答复: 答复: Defining a Common Model for intent

Yali:

I agree that context is the external background information
user  --> intent --> context.
I struggle with the line between background and intent.  If intent is decomposed into object, result and constraint, the real question is whether the intent is pure or mixed.  If we are adding constraints then it is impure or constraint based.   My difficultly is that I know that constraints operate within a context.  In your example, costs operate within the context of a monetary evaluation ($1000, $2000) and line costs operate within a market (price goes up and down).

Sue

Sue:

Yali

Yali:

Does this make sense?

Sue

Hi Sue:

Best,
Yali

Yali:

Sue

Hi Pedro,

Best Regards,
Yali

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

From: "Natale, Bob" <[email-masked]>
Date: Fri, 5 Jun 2015 04:01:52 +0000

Major +1 from me Diego’s statement of the need … absolutely on the mark, in my judgment.

Two things I have found confusing in the threads on this topic:

- Use of “role” (and I think Diego may be questioning this too) … I think I understand the usage, but that term carries a certain specificity that is too rigid in the context of understanding the levels of translation usually modeled into policy-based management solutions … “views” or “perspectives” or something like that is more common.

- The targeting of “user” intent in this discussion … other than where “user” is proxy for “operator” or “provider” or something like that (and I think Bert might have touched on that too), I don’t think we should focus on user intents yet. I would agree that user intents will ultimately be addressed via successful intent-based policy management solutions but that’s too aggressive for where we are now … better to assume that user intents come into the service provider business model at the top and are mediated by that business model (e.g., via service offerings, SLAs, etc.) and represented in the intents that the service provider/network operator use to control network behavior on behalf the their users.

Avanti,
BobN

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Thursday, June 04, 2015 4:17 PM
To: Susan Hares
Cc: [email-masked]; PEDRO ANDRES ARANDA GUTIERREZ; [email-masked]; zhangyali (D); [email-masked]
Subject: Re: [Nfvrg] [Ibnemo] 答复: 答复: Defining a Common Model for intent

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Fri, 5 Jun 2015 05:50:13 +0000

Hi Sue,

Let me refine a bit:

Example 1:
AS1 provider for AS2: normally means that AS1 sets a set of policies that filter out any prefixes that don’t come from AS2 or its clients, while AS2 receives all advertisements from AS1. There is no implied symmetry there and how these policies are then implemented depends on the equipment AS1 and AS2 have.

Example 2:
Load balancing: in the context of AS1 being a provider for AS2 means that As1 will indicate AS2 how to mark advertisements to accomplish load balancing.

So for role based intent these are two different ‘layers’ in a company (top manager versus NOC responsible)
However, if we try to layer the infrastructure we are in the same ‘inter domain’ layer (as opposed to an ‘intra domain’ layer)
This is why I see the ‘role-based’ intent being orthogonal to an ‘infrastructure-based’ intent. I believe that we need to take these (hopefully only) two dimensions into account.

Best, /PA

Fecha: jueves, 4 de junio de 2015 04:11

Pedro:

Sue

To: Susan Hares; 'zhangyali (D)'; [email-masked]<mailto:[email-masked]>

Hi,

Ex.1

Ex.2

My .2 cents,
/PA

Pedro and Yali:

Sue

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: Xiayinben <[email-masked]>
Date: Fri, 5 Jun 2015 13:02:02 +0000

Yes. According to Pedro’s word, one role belongs to “management floor” and another belongs to “Network Operation Centre”.

Yinben

发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年6月4日 23:29
收件人: Xiayinben; 'PEDRO ANDRES ARANDA GUTIERREZ'; zhangyali (D); [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: [Ibnemo] 答复: [Nfvrg] 答复: Defining a Common Model for intent

Yinben:

Is this what you meant?

Sue

To: PEDRO ANDRES ARANDA GUTIERREZ; Susan Hares; zhangyali (D); [email-masked]<mailto:[email-masked]>

HI Pedro,

My 2 cents,
Yinben

发件人: Nfvrg [mailto:[email-masked]] 代表 PEDRO ANDRES ARANDA GUTIERREZ
发送时间: 2015年6月3日 14:13
收件人: Susan Hares; zhangyali (D); [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi,

Ex.1

Ex.2

My .2 cents,
/PA

Pedro and Yali:

Sue

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 13:14:48 -0400

Diego: 

I 100% agree with your goals on creating a “network SQL that is a declarative language. 

Sue 

From: DIEGO LOPEZ GARCIA [mailto:[email-masked]] 
Sent: Thursday, June 04, 2015 4:17 PM
To: Susan Hares
Cc: zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Ibnemo] [Nfvrg] 答复: 答复: Defining a Common Model for intent

Hi, 

Be goode,

--

Dr Diego R. Lopez
Telefonica I+D

 

  _____

---

From: "Gember-Jacobson, Aaron" <[email-masked]>
Date: Fri, 5 Jun 2015 12:41:00 -0500

Flowlog is a "network SQL" for SDN (
https://www.usenix.org/conference/nsdi14/technical-sessions/presentation/nelson).
There's also NDlog (
http://www.cis.upenn.edu/~boonloo/papers/declarenet_cacm09.pdf). However, I
think the level of abstraction provided by both Flowlog and NDlog is lower
on the policy continuum than many expressions of intent. Nonetheless, these
works may be a valuable starting point for a declarative language for
intent.

Aaron

On Fri, Jun 5, 2015 at 12:14 PM, Susan Hares <[email-masked]> wrote:

> *From:* DIEGO LOPEZ GARCIA [mailto:[email-masked]]
> *Sent:* Thursday, June 04, 2015 4:17 PM
> *To:* Susan Hares
> *Cc:* zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; [email-masked];
> [email-masked]; [email-masked]
> *Subject:* Re: [Ibnemo] [Nfvrg] 答复: 答复: Defining a Common Model for intent
>
>
>
> Hi,
>
>
>
> Let me try to bring a new view on this (hence no quotation of previous
> exchanges) in the hope it helps to get to a common understanding.
>
>
>
> Those of you who know me have probably heard me saying that to complete
> the promise of SDN we need something like a "network SQL": a declarative
> language based on a formal network model that would allow both defining
> network properties and manipulating network behavior, and, what is of
> capital importance in my view, support the seamless integration of these
> definitions and manipulations within general-purpose applications. This is
> my hope for intent-based networking, and that is my understanding of an
> intent expression.
>
>
>
> An intent model would precisely define this formal network model on which
> to base the declarative language. Different models would support different
> views (or roles?) and therefore translate into different declarative
> languages, the same way we have several mechanisms to manipulate data that
> are not necessarily SQL.
>
>
>
> Be goode,
>
>
>
> --
>
> ------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>
> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 13:51:54 -0400

Yali: 

I think that we are best to leave “pure” and “impure” out of the discussion.  I borrowed it from some ONF NBI/Keystone work, but I think it is confusing. 

I am pleased you feel: 

Intent == (defined as)  object + results + constraints.   

Constraint  varies with context. 

In my other mail, I suggest that objects, results, and constraints all have a component of role/class constraint

Object(class-constraint), results (class-constraint),  constraints (class-constraint).  

If you agree this is true, we can create classes for a network SQL that provide define constraints.  This is similar to the SQL function in DB.  

What do you think of considering roles as classes of constraints to the basic intent components (object, result, constraints)? 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of zhangyali (D)
Sent: Thursday, June 04, 2015 11:57 PM
To: Susan Hares; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] 答复: 答复: 答复: 答复: 答复: Defining a Common Model for intent

Sue:

 

Yali

Yali: 

user  à intent à context.

Sue 

Sue:

Yali

Yali:

Does this make sense? 

Sue 

Hi Sue:

Best,

Yali

Yali:

Sue 

Hi Pedro,

Best Regards,

Yali

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 13:56:25 -0400

Bob: 

+1 on Diego’s statement of need. 

+1 on your comment to start with the business user and funnel through SLAs/Service offerings. 

BGP provider roles I described are really business roles that get cast into BGP identities.  We should stay with business policies first.  I tried to provide this email previous to this one. 

Sue 

From: Natale, Bob [mailto:[email-masked]] 
Sent: Friday, June 05, 2015 12:02 AM
To: DIEGO LOPEZ GARCIA; Susan Hares
Cc: [email-masked]; PEDRO ANDRES ARANDA GUTIERREZ; [email-masked]; zhangyali (D); [email-masked]
Subject: RE: [Nfvrg] [Ibnemo] 答复: 答复: Defining a Common Model for intent

Avanti,

BobN

Hi, 

Be goode,

--

Dr Diego R. Lopez
Telefonica I+D

 

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 14:51:34 -0400

Yinben:

I would suggest along with Bob that these are two business level intents. 

a)      Be a provider’s provider for AS2 

b)      Load Balance traffic to AS 2 

Intent = object (AS2), result (be provider for AS2), constraint ((implied) SLAs)

              Object (AS2), result (traffic load-balanced on connections), constraint (implied, SLAs) 

What do you think?  It matches your original definition of intent, and I think these can be two classes of intent (contract, network traffc). 

Sue 

From: Xiayinben [mailto:[email-masked]] 
Sent: Friday, June 05, 2015 9:02 AM
To: Susan Hares; 'PEDRO ANDRES ARANDA GUTIERREZ'; zhangyali (D); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: 答复: [Ibnemo] 答复: [Nfvrg] 答复: Defining a Common Model for intent

Yinben

Yinben: 

Is this what you meant? 

Sue  

HI Pedro,

My 2 cents,

Yinben 

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 5 Jun 2015 15:04:27 -0400

Pedro: 

Interesting!  You consider level within the company a role (top managers vs. NOC) and the infrastructure-based  - a different orthogonal.   I think this still fits within my concept that we are describing roles as groups of constraints on intent.   Do you think role and infrastructure-based roles/constraints – are orthogonal constraints on intent? 

Sue  

Sent: Friday, June 05, 2015 1:50 AM

Hi Sue,

Let me refine a bit:

Example 1:

Example 2:

Best, /PA

Pedro:

                  This is AS1’s intent. 

Sue 

 

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____

---

From: Xiayinben <[email-masked]>
Date: Sat, 6 Jun 2015 09:03:01 +0000

“Network SQL” is definitely the vision of intent discussion.
Why we start intent discussion? Because it is still complex to manipulate network by now, although there are some trials before, this issue is still existing, we hope to find a new way to solve it.

Cheers,
Yinben
发件人: Ibnemo [mailto:[email-masked]] 代表 DIEGO LOPEZ GARCIA
发送时间: 2015年6月5日 4:17
收件人: Susan Hares
抄送: [email-masked]; [email-masked]; zhangyali (D); [email-masked]
主题: Re: [Ibnemo] [Nfvrg] 答复: 答复: Defining a Common Model for intent

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Mon, 8 Jun 2015 06:15:22 +0000

Aaron,

Catching up on the mailing list…

Thanks for the references. They provide a nice background to start with. Have you gone through the NEMO page and looked at the language proposed there? IMHO, after reading the papers, I find NEMO to be ‘easier’ to understand than Flowlog. Just look at the ping example :-) However, as you say, both papers are worth reading.

Best /PA
De: <Gember-Jacobson>, Aaron <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 5 de junio de 2015 19:41
Para: Sue Hares <[email-masked]<mailto:[email-masked]>>
CC: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, "zhangyali (D)" <[email-masked]<mailto:[email-masked]>>, DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: Re: [Nfvrg] [Ibnemo] 答复: 答复: Defining a Common Model for intent

Flowlog is a "network SQL" for SDN (https://www.usenix.org/conference/nsdi14/technical-sessions/presentation/nelson). There's also NDlog (http://www.cis.upenn.edu/~boonloo/papers/declarenet_cacm09.pdf). However, I think the level of abstraction provided by both Flowlog and NDlog is lower on the policy continuum than many expressions of intent. Nonetheless, these works may be a valuable starting point for a declarative language for intent.

Aaron

On Fri, Jun 5, 2015 at 12:14 PM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:
Diego:

Sue

From: DIEGO LOPEZ GARCIA [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, June 04, 2015 4:17 PM
To: Susan Hares
Cc: zhangyali (D); PEDRO ANDRES ARANDA GUTIERREZ; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ibnemo] [Nfvrg] 答复: 答复: Defining a Common Model for intent

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
----------------------------------

_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

---

Technology Exploration -

---

From: Zhoutianran <[email-masked]>
Date: Mon, 8 Jun 2015 09:35:25 +0000

Hi Sue,

I agree your concept that “roles are constraints on the intent”.
Can we use the following figure to show the orthogonal?

1.  We organize intent with role groups.

2.  For each role, the intent can cover many layers functions.

And in this way, we do not have to constrain role’s intent into a specific layer. That would be more flexible and easy to express one’s intent.

Best,
Terence

From: Nfvrg [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Saturday, June 06, 2015 3:04 AM
To: 'PEDRO ANDRES ARANDA GUTIERREZ'; zhangyali (D); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Pedro:

Sue

Hi Sue,

Let me refine a bit:

Example 1:

Example 2:

Best, /PA

Pedro:

Sue

Hi,

Ex.1

Ex.2

My .2 cents,
/PA

Pedro and Yali:

Sue

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Mon, 8 Jun 2015 09:55:53 +0000

Hi Tianran,

I like the figure. If you think about what you have done…  ticking things in some layers but not in others, this clearly reveals the two dimensions I’m talking about ;-)

Best, /PA

De: Zhoutianran <[email-masked]<mailto:[email-masked]>>
Fecha: lunes, 8 de junio de 2015 11:35
Para: Sue Hares <[email-masked]<mailto:[email-masked]>>, PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent

Hi Sue,

Best,
Terence

To: 'PEDRO ANDRES ARANDA GUTIERREZ'; zhangyali (D); [email-masked]<mailto:[email-masked]>

Pedro:

Sue

Hi Sue,

Let me refine a bit:

Example 1:

Example 2:

Best, /PA

Pedro:

Sue

Hi,

Ex.1

Ex.2

My .2 cents,
/PA

Pedro and Yali:

Sue

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Mon, 08 Jun 2015 13:54:40 +0200

i like the picture below, and it makes sense I think (at least to me it does)

Bert
On 08/06/15 11:35, Zhoutianran wrote:
> 1.We organize intent with role groups.
>
> 2.For each role, the intent can cover many layers functions.
>
> role.png
> *From:*Nfvrg [mailto:[email-masked]] *On Behalf Of *Susan Hares
> *Sent:* Saturday, June 06, 2015 3:04 AM
> *To:* 'PEDRO ANDRES ARANDA GUTIERREZ'; zhangyali (D); [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent
>
> Pedro:
>
> Interesting! You consider level within the company a role (top managers vs. NOC) and the infrastructure-based  - a different 
> orthogonal.   I think this still fits within my concept that we are describing roles as groups of constraints on intent.   Do you 
> think role and infrastructure-based roles/constraints – are orthogonal constraints on intent?
>
> Sue
>
> *From:*PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
> *Sent:* Friday, June 05, 2015 1:50 AM
> *To:* Susan Hares; 'zhangyali (D)'; [email-masked] <mailto:[email-masked]>
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent
>
> Hi Sue,
>
> Let me refine a bit:
>
> Example 1:
>
> AS1 provider for AS2: normally means that AS1 sets a set of policies that filter out any prefixes that don’t come from AS2 or its 
> clients, while AS2 receives all advertisements from AS1. There is no implied symmetry there and how these policies are then 
> implemented depends on the equipment AS1 and AS2 have.
>
> Example 2:
>
> So for role based intent these are two different ‘layers’in a company (top manager versus NOC responsible)
>
> However, if we try to layer the infrastructure we are in the same ‘inter domain’layer (as opposed to an ‘intra domain’layer)
>
> This is why I see the ‘role-based’intent being orthogonal to an ‘infrastructure-based’intent. I believe that we need to take these 
> (hopefully only) two dimensions into account.
>
> Best, /PA
>
> *De: *Sue Hares <[email-masked] <mailto:[email-masked]>>
> *Fecha: *jueves, 4 de junio de 2015 04:11
> *Para: *PEDRO ANDRES ARANDA GUTIERREZ <[email-masked] <mailto:[email-masked]>>, "'zhangyali (D)'" 
> <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> *CC: *"[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> *Asunto: *RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent
>
>     Pedro:
>
>     *From:*PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
>     *Sent:* Wednesday, June 03, 2015 2:13 AM
>     *To:* Susan Hares; 'zhangyali (D)'; [email-masked] <mailto:[email-masked]>
>     *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Nfvrg] 答 复: [Ibnemo] Defining a Common Model for intent
>
>     Hi,
>
>     AS1 is connected to AS2, he has several links and wants to implement load-balancing between them. “Load balancing" is the
>     intent and advertisements, route-maps etc. is the implementation and that’s not intent.
>
>     From an infrastructure point of view, we have two instances of intent at the same “layer”. However role-wise, the decision of
>     entering a client-provider relationship between ASes is taken in the ‘management floor’and the decision of load-balancing in
>     taken in the Network Operation Centre. This is the reason for my double take at intent
>
>     Regarding whether intent @ layer N + context @ layer N —> something @ layer N-1 and from my example above depends how or
>     whether we structure the role dimension into layers.
>
>     *De: *Sue Hares <[email-masked] <mailto:[email-masked]>>
>     *Fecha: *miércoles, 3 de junio de 2015 00:48
>     *Para: *PEDRO ANDRES ARANDA GUTIERREZ <[email-masked] <mailto:[email-masked]>>, "'zhangyali (D)'"
>     <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>
>     *CC: *"[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>, "[email-masked]
>     <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>     *Asunto: *RE: [Nfvrg] 答复: [Ibnemo] Defining a Common Model for intent
>
>         Pedro and Yali:
>
>         It helps to keep in the networking domain where I am familiar with work!  I agree that intent goes through the layers, but
>         I still struggle to make the connections.
>
>         I know that instances of code (BGP) on devices create zones  of connectivity (sub-domains/subnets, AS, Groups of AS), but
>         I think there must be  more in the intent discuss.  Yinben and Yali’s comments that
>
>         User àintent àcontext
>
>         *From:*Nfvrg [mailto:[email-masked]] *On Behalf Of *PEDRO ANDRES ARANDA GUTIERREZ
>         *Sent:* Tuesday, June 02, 2015 2:38 AM
>         *To:* zhangyali (D); Susan Hares; [email-masked] <mailto:[email-masked]>
>         *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked]
>         <mailto:[email-masked]>
>         *Subject:* Re: [Nfvrg] 答 复: [Ibnemo] Defining a Common Model for intent
>
>         Hi Yali,
>
>         let’s keep in the networking domain :-) I strongly believe that we need different levels or layers of intent. However,
>         there are (at least) two different viewpoints:
>
>         If you follow the infrastructure view(which is where I feel more comfortable), I hope we agree that it is a completely
>         different situation when you are designing a network element-by-element than when you are designing the network at a
>         sub-domain level (for example levels in an IS-IS based network or areas if you use OSPF) or if you are defining the
>         interconnections of a service provider’s AS (and dealing with BGP-4 policies) or if you are defining an end-to-end
>         service. Although at the end, the upper layers will use all the features provided by the lower layers.
>
>         The user wants to access a service (for example a Web page), the provider of that Web page wants it to be served with the
>         best quality of experience and so he chooses a specific provider –normally a CDN). The CDN provider will choose a given
>         carrier to get access to the user’s service provider. The user’s service provider will dimension his network to fulfill a
>         series of criteria. Within the service provider, the operators sitting at the Network Operations Centre will have to
>         fulfill a series of KPIs, etc.
>
>         As you see, I’m more a ‘box’thinker. However, if someone can complete the ‘role’example we can compare both approaches and
>         try to identify if we can do any mapping between the two views. Maybe we could come up at end with a set of common
>         denominators we can use to continue this discussion.
>
>         Best,
>
>         /PA
>
>         *De: *"zhangyali (D)" <[email-masked] <mailto:[email-masked]>>
>         *Fecha: *martes, 2 de junio de 2015 05:52
>         *Para: *PEDRO ANDRES ARANDA GUTIERREZ <[email-masked] <mailto:[email-masked]>>, Sue Hares
>         <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>         *CC: *"[email-masked] <mailto:[email-masked]>"
>         <[email-masked] <mailto:[email-masked]>>, "[email-masked]
>         <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>         *Asunto: *答 复: [Ibnemo] Defining a Common Model for intent
>         *Nuevo envío de: *<[email-masked] <mailto:[email-masked]>>
>         *Nuevo envío para: *<[email-masked] <mailto:[email-masked]>>
>         *Fecha de nuevo envío: *martes, 2 de junio de 2015 05:52
>
>             Hi Pedro,
>
>             1.A customer wants to transport his goods from A to B. So his intent is getting his goods from A to B without carrying
>             about how to do it. Then his intent is transferred to the transportation system.
>
>             2.This system analyzes customer’s requirement, and choose a suitable way to complete the requirement. For example, the
>             system choose truck as the means. So the intent of transportation system is transferring the goods with truck.
>
>             3.The driver of this truck analyze the path from A to B, and choose a most appropriate path to complete this order
>             which will save more time. So  the intent of driver may be transferring the goods with the least time. Then the driver
>             will start the engine, step on the gas, etc.
>
>             From this analogy, the ultimate effect is the same, namely, transfer the goods from A to B. But the specific intent of
>             different roles has some differences which depends on user’ role, knowledge, responsibility, etc. For example,
>             transportation system is responsible for transporting goods, and he know the various ways. So he can form his intent
>             by rendering the upper customer’s intent.
>
>             Supposing we divide users into different layers according to the implementation series, users in upper layer expresses
>             his intent as /what/ he want without having the knowledge about /how/ to do it. Then the /how/ procedure will be
>             transferred to /what /in the lower layer according to knowledge and context. These transfer procedure lead to the
>             completion of requirement. Same with the example in draft. Although the ultimate effect is same, the focus is
>             different which will bring out the differentiation of intent.
>
>             *发 件人:*PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
>             *发 送时间:*2015年6月1日17:15
>             *收件人:*Susan Hares; [email-masked] <mailto:[email-masked]>
>             *抄送:[email-masked] <mailto:[email-masked]>; [email-masked]
>             <mailto:[email-masked]>
>             *主题:*Re: [Ibnemo] Defining a Common Model for intent
>
>             Hi,
>
>             A small clarification proposal for draft https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/.
>
>             Rationale behind this is again, that intent should be anything that is invariant and that expresses/what/  a network operator/administrator may need to do, as opposed to/how/  he would do that, i.e. The router is a HW device from vendor X or a virtual machine running a specific routing daemon over a given data-path implementation.
>
>             Best, /PA
>
>             ---
>
>             ------------------------------------------------------------------------------------------------------------------------------------
>
>
>             Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o
>             confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado,
>             queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en
>             virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique
>             inmediatamente por esta misma vía y proceda a su destrucción.
>
>             The information contained in this transmission is privileged and confidential information intended only for the use of
>             the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby
>             notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have
>             received this transmission in error, do not read it. Please immediately reply to the sender that you have received
>             this communication in error and then delete it.
>
>             Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou
>             confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado,
>             fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da
>             legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma
>             via e proceda a sua destruição
>
>         ---
>
>         ------------------------------------------------------------------------------------------------------------------------------------
>
>
>         Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o
>         confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda
>         notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la
>         legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma
>         vía y proceda a su destrucción.
>
>         The information contained in this transmission is privileged and confidential information intended only for the use of the
>         individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified
>         that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this
>         transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in
>         error and then delete it.
>
>         Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou
>         confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado,
>         fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da
>         legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e
>         proceda a sua destruição
>
>     ---
>
>     ------------------------------------------------------------------------------------------------------------------------------------
>
>
>     Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o
>     confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda
>     notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la
>     legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía
>     y proceda a su destrucción.
>
>     The information contained in this transmission is privileged and confidential information intended only for the use of the
>     individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that
>     any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this
>     transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in
>     error and then delete it.
>
>     Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial
>     e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de
>     que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se
>     recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
>
> ---
>
> ------------------------------------------------------------------------------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la 
> lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha 
> recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
>
> The information contained in this transmission is privileged and confidential information intended only for the use of the 
> individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any 
> dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in 
> error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é 
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a 
> leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta 
> mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
>
>
>
> Ibnemo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ibnemo

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 8 Jun 2015 19:22:14 -0400

Tianran/Terence: 

This looks great – go and work through an example. 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Monday, June 08, 2015 5:35 AM
To: Susan Hares; 'PEDRO ANDRES ARANDA GUTIERREZ'; [email-masked]
Cc: [email-masked]
Subject: Re: [Ibnemo] [Nfvrg] 答复: Defining a Common Model for intent

Hi Sue,

role.png

Best,

Terence

Pedro: 

Sue  

Hi Sue,

Let me refine a bit:

Example 1:

Example 2:

Best, /PA

Pedro:

                  This is AS1’s intent. 

Sue 

 

Hi,

Ex.1  

Ex.2 

My .2 cents,

/PA

Pedro and Yali: 

User à intent à context 

Sue 

Hi Yali,

Best,

/PA

Hi Pedro,

Best Regards,

Yali

Hi,

To

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____  

 

---

Technology Exploration -

28006 Madrid, Spain

Georg Kreisler

  _____