Subject: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Sun, 6 Dec 2015 00:06:03 +0000

Hi,

This message is to open a two-week adoption call for draft-unify-nfvrg-recursive-programming, and to identify to which of the special interest areas it should be associated with.

Please indicate in your comments “support” or “no support” and discuss how this draft will contribute to a better understanding of NFV infrastructures and how to model them.

The current draft is available at:

https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 7 Dec 2015 06:58:26 +0000

yes/support

                Regards,
                                Greg

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Saturday, December 05, 2015 4:06 PM
To: [email-masked]
Subject: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Sun, 13 Dec 2015 20:50:39 +0000

Hi,

This is a reminder to all of you in the NVRG about this adoption call. So far, only two (affirmative) answers have been received.

Be goode,

On 6 Dec 2015, at 01:06 , DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

Dr Diego R. Lopez
Telefonica I+D

---

From: Meral Shirazipour <[email-masked]>
Date: Sun, 13 Dec 2015 21:09:43 +0000

Hi,
  Yes support.

One comment: it would be good to also mention relation to ONF's [TR-502] which talks about recursive SDN.

Best,
Meral
[ONF TR-502]https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN_ARCH_1.0_06062014.pdf

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Mon, 14 Dec 2015 07:16:49 -0200

+1 Support

recursion is a powerful problem-solving technique that the draft explores
in the context of NFV anf SDN but following a generic approach based on
networking and computibg resources.

On Sat, Dec 5, 2015 at 10:06 PM, DIEGO LOPEZ GARCIA <
[email-masked]> wrote:
> Hi,
>
> This message is to open a two-week adoption call for
> draft-unify-nfvrg-recursive-programming, and to identify to which of the
> special interest areas it should be associated with.
>
> Please indicate in your comments “support” or “no support” and discuss how
> this draft will contribute to a better understanding of NFV
infrastructures
> and how to model them.
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
la
> legislación vigente. Si ha recibido este mensaje por error, le rogamos que
> nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to
the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação
vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>
> [email-masked]

---

From: Kostas Pentikousis <[email-masked]>
Date: Mon, 14 Dec 2015 10:52:43 +0100

+1 Support for this draft as well.

Best regards,

Kostas

From: Christian Esteve Rothenberg [mailto:[email-masked]]
Sent: Montag, 14. Dezember 2015 10:17
To: DIEGO LOPEZ GARCIA
Cc: [email-masked]
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

+1 Support

recursion is a powerful problem-solving technique that the draft explores in the context of NFV anf SDN but following a generic approach based on networking and computibg resources.

On Sat, Dec 5, 2015 at 10:06 PM, DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>> wrote:
> this draft will contribute to a better understanding of NFV infrastructures
> and how to model them.
>
> divulgación y/o copia sin autorización puede estar prohibida en virtud de la
> this transmission in error, do not read it. Please immediately reply to the
> cópia sem autorização pode estar proibida em virtude da legislação vigente.

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 14 Dec 2015 21:00:09 +0000

+1 Support.

Linda Dunbar

From: Christian Esteve Rothenberg [mailto:[email-masked]]
Sent: Montag, 14. Dezember 2015 10:17
To: DIEGO LOPEZ GARCIA
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

+1 Support

---

From: Balazs Sonkoly <[email-masked]>
Date: Tue, 15 Dec 2015 07:12:02 +0100

+1 support.

(We have been implementing a proof of concept prototype following this 
recursive orchestration approach.)

Regards,
Balazs

On 12/06/2015 01:06 AM, DIEGO LOPEZ GARCIA wrote:
> Hi,
>
> This message is to open a two-week adoption call
> for draft-unify-nfvrg-recursive-programming, and to identify to which of
> the special interest areas it should be associated with.
>
> Please indicate in your comments “support” or “no support” and discuss
> how this draft will contribute to a better understanding of NFV
> infrastructures and how to model them.
>
> _https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/_
> _
> _
> Be goode,
>
> --
> ------------------------------------------------------------------------
>
> divulgación y/o copia sin autorización puede estar prohibida en virtud
> de la legislación vigente. Si ha recibido este mensaje por error, le
> rogamos que nos lo comunique inmediatamente por esta misma vía y proceda
> a su destrucción.
>
> recipient, you are hereby notified that any dissemination, distribution
> or copying of this communication is strictly prohibited. If you have
> received this transmission in error, do not read it. Please immediately
> reply to the sender that you have received this communication in error
> and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em
> virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição

---

From: Róbert Szabó <[email-masked]>
Date: Tue, 15 Dec 2015 19:43:23 +0000

Thanks, Meral!
We will include it in the next update!
Br,
Robert

From: Nfvrg [mailto:[email-masked]] On Behalf Of Meral Shirazipour
Sent: Sunday, December 13, 2015 10:10 PM
To: [email-masked]
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi,
  Yes support.

Best,
Meral

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Saturday, December 05, 2015 4:06 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Thu, 24 Dec 2015 02:00:48 +0200

Greetings to the list,

Many wishes for the holidays and the new year to everyone.

I’d like to support the document for adoption.

Regards,

Evangelos.

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Sunday, December 06, 2015 2:06 AM
To: [email-masked]
Subject: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi, 

Be goode,

Dr Diego R. Lopez
Telefonica I+D

 

  _____

---

From: <[email-masked]>
Date: Sat, 26 Dec 2015 23:16:39 -0600

While I support this document, I would like the following to be addressed.

As co-chair

·         Merge the unify problem statement and challenges draft (https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/?include_text=1) with this document.

As participant

·         The current scope seems to be only storage local to a server. It is worth addressing the shared storage aspect as we make progress. Please clarify this aspect.

·         I see the data model as exemplary where different implementations could have variations. That said, at this stage, it is probably more useful to define an information model. Also, it worth tying this to infrastructure policies.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Sunday, December 13, 2015 12:51 PM
To: [email-masked]
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi,

Be goode,

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: Gino Carrozzo <[email-masked]>
Date: Mon, 28 Dec 2015 09:15:16 +0100

Dear Ramki

As presented in Yokohama and briefly discussed at the interim meeting in
Heidelberg, draft unify-challenges is currently merged with
https://datatracker.ietf.org/doc/draft-felix-nfvrg-recursive-orchestration/.

Both drafts converged into
https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/,
which we (authors) aim to advance to NFVRG official I-D.

br
Gino

On 27 December 2015 at 06:16, <[email-masked]> wrote:

> *As co-chair*
> ·         Merge the unify problem statement and challenges draft (
> https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/?include_text=1)
> with this document.
>
>
>
> *As participant*
>
> ·         The current scope seems to be only storage local to a server.
> It is worth addressing the shared storage aspect as we make progress.
> Please clarify this aspect.
>
> ·         I see the data model as exemplary where different
> implementations could have variations. That said, at this stage, it is
> probably more useful to define an information model. Also, it worth tying
> this to infrastructure policies.
>
>
>
> Thanks,
>
> Ramki
>
>
>
> *From:* Nfvrg [mailto:[email-masked]] *On Behalf Of *DIEGO LOPEZ
> GARCIA
> *Sent:* Sunday, December 13, 2015 12:51 PM
> *To:* [email-masked]
> *Subject:* Re: [Nfvrg] RG adoption of
> draft-unify-nfvrg-recursive-programming
>
>
>
> Hi,
>
>
>
> This is a reminder to all of you in the NVRG about this adoption call. So
> far, only two (affirmative) answers have been received.
>
>
>
> Be goode,
>
>
>
> On 6 Dec 2015, at 01:06 , DIEGO LOPEZ GARCIA <[email-masked]>
> wrote:
>
>
>
> Hi,
>
>
>
> *https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/
> <https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/>*
>
>
>
> Be goode,
>
>
>
> --
> ------------------------------
>
>
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> ------------------------------
>
>
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>

-- 
==============================================================
  Dr. Gino Carrozzo
  Deputy Head of R&D

  mobile    : +39 348 7610 081
  landline  : +39 050 3871 679
  fax         : +39 050 3871 601
  e-mail    : [email-masked]
  web       : www.nextworks.it
  address   : Nextworks s.r.l.
                  via Livornese, 1027
                  56122 S.Piero a Grado, Pisa, ITALY
==============================================================

---

From: <[email-masked]>
Date: Mon, 28 Dec 2015 06:26:24 -0600

Thanks Gino.
So, https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/ should refer to the merged document https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/ and not https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/. I guess, this is the source of confusion.
Regarding further merging of https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/, we can have a separate discussion as needed.
Thanks,
Ramki

From: Gino Carrozzo [mailto:[email-masked]]
Sent: Monday, December 28, 2015 12:15 AM
To: Krishnan, Ramki <[email-masked]>
Cc: DIEGO LOPEZ GARCIA <[email-masked]>; [email-masked]
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Dear Ramki

As presented in Yokohama and briefly discussed at the interim meeting in Heidelberg, draft unify-challenges is currently merged with https://datatracker.ietf.org/doc/draft-felix-nfvrg-recursive-orchestration/.

Both drafts converged into https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/, which we (authors) aim to advance to NFVRG official I-D.

br
Gino

On 27 December 2015 at 06:16, <[email-masked]<mailto:[email-masked]>> wrote:
While I support this document, I would like the following to be addressed.

As co-chair

•         Merge the unify problem statement and challenges draft (https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/?include_text=1) with this document.

As participant

•         The current scope seems to be only storage local to a server. It is worth addressing the shared storage aspect as we make progress. Please clarify this aspect.

•         I see the data model as exemplary where different implementations could have variations. That said, at this stage, it is probably more useful to define an information model. Also, it worth tying this to infrastructure policies.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Sunday, December 13, 2015 12:51 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi,

Be goode,

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
----------------------------------

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
----------------------------------

  mobile    : +39 348 7610 081
  landline  : +39 050 3871 679
  fax         : +39 050 3871 601
  e-mail    : [email-masked]<mailto:[email-masked]>
  web       : www.nextworks.it<http://www.nextworks.it>
  address   : Nextworks s.r.l.
                  via Livornese, 1027
                  56122 S.Piero a Grado, Pisa, ITALY
==============================================================

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Thu, 31 Dec 2015 20:10:29 +0000

Hi,

With some delay due to the Christmas break and given that a sufficient number of received comments supported adoption and none was against it, this message is to declare the adoption of this draft by the RG. Following the discussion on the list, this refers to the document draft-caszpe-nfvrg-orchestration-challenges, as a merge of the previous draft-unify-nfvrg-recursive-programming and draft-felix-nfvrg-recursive-orchestration

Authors, please upload an updated version under the name draft-irtf-nfvrg-orchestration-challenges addressing the comments received.

Be goode and may the New Year bring All the Beste,

Dr Diego R. Lopez
Telefonica I+D