Subject: Re: [Nfvrg] RG adoption of draft-caszpe-nfvrg-orchestration-challenges

From: Róbert Szabó <[email-masked]>
Date: Sat, 2 Jan 2016 15:08:25 +0000

Hi Diego, All,

draft-caszpe-nfvrg-orchestration-challenges is the result of partial merger of the draft-unify-nfvrg-challenges-02, while draft-unify-nfvrg-recursive-programming is a standalone contender for the most recent adoption call.

Thanks,
Robert

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Thursday, December 31, 2015 9:10 PM
To: [email-masked]
Subject: [Nfvrg] RG adoption of draft-caszpe-nfvrg-orchestration-challenges

Hi,

With some delay due to the Christmas break and given that a sufficient number of received comments supported adoption and none was against it, this message is to declare the adoption of this draft by the RG. Following the discussion on the list, this refers to the document draft-caszpe-nfvrg-orchestration-challenges, as a merge of the previous draft-unify-nfvrg-recursive-programming and draft-felix-nfvrg-recursive-orchestration

Authors, please upload an updated version under the name draft-irtf-nfvrg-orchestration-challenges addressing the comments received.

Be goode and may the New Year bring All the Beste,

On 6 Dec 2015, at 01:06 , DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>> wrote:

This message is to open a two-week adoption call for draft-unify-nfvrg-recursive-programming, and to identify to which of the special interest areas it should be associated with.

Please indicate in your comments “support” or “no support” and discuss how this draft will contribute to a better understanding of NFV infrastructures and how to model them.

The current draft is available at:

https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Róbert Szabó <[email-masked]>
Date: Sat, 2 Jan 2016 15:14:32 +0000

Hi Ramki, Gino,

Let me add my view to this question as one of the editor for the https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/. Our plan is to merged the content of this draft into the following two drafts:

1.       https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/

2.       https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/

While (2) may receive challenges related contents (1) shall host discussions related to different approaches to the problems. I think this is in alignment of your request.

We will update the references and follow with content merge if agreement.

Regards,
Robert

From: Nfvrg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 28, 2015 1:26 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Thanks Gino.
So, https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programming/ should refer to the merged document https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/ and not https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/. I guess, this is the source of confusion.
Regarding further merging of https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/, we can have a separate discussion as needed.
Thanks,
Ramki

From: Gino Carrozzo [mailto:[email-masked]]
Sent: Monday, December 28, 2015 12:15 AM
To: Krishnan, Ramki <[email-masked]<mailto:[email-masked]>>
Cc: DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Dear Ramki

As presented in Yokohama and briefly discussed at the interim meeting in Heidelberg, draft unify-challenges is currently merged with https://datatracker.ietf.org/doc/draft-felix-nfvrg-recursive-orchestration/.

Both drafts converged into https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challenges/, which we (authors) aim to advance to NFVRG official I-D.

br
Gino

On 27 December 2015 at 06:16, <[email-masked]<mailto:[email-masked]>> wrote:
While I support this document, I would like the following to be addressed.

As co-chair

•         Merge the unify problem statement and challenges draft (https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/?include_text=1) with this document.

As participant

•         The current scope seems to be only storage local to a server. It is worth addressing the shared storage aspect as we make progress. Please clarify this aspect.

•         I see the data model as exemplary where different implementations could have variations. That said, at this stage, it is probably more useful to define an information model. Also, it worth tying this to infrastructure policies.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Sunday, December 13, 2015 12:51 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi,

This is a reminder to all of you in the NVRG about this adoption call. So far, only two (affirmative) answers have been received.

Be goode,

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
----------------------------------

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
----------------------------------

_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

--
==============================================================
  Dr. Gino Carrozzo
  Deputy Head of R&D

  mobile    : +39 348 7610 081
  landline  : +39 050 3871 679
  fax         : +39 050 3871 601
  e-mail    : [email-masked]<mailto:[email-masked]>
  web       : www.nextworks.it<http://www.nextworks.it>
  address   : Nextworks s.r.l.
                  via Livornese, 1027
                  56122 S.Piero a Grado, Pisa, ITALY
==============================================================

---

From: Róbert Szabó <[email-masked]>
Date: Sat, 2 Jan 2016 15:31:18 +0000

Dear Ramki, All,

On Sun, Dec 27, 2015 at 06:16:39, [email-masked] wrote:
> ·         Merge the unify problem statement and challenges draft
> (https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/?include_
> text=1) with this document.

ACK. (see also other clarifications w.r.t. the draft-caszpe-nfvrg-orchestration-challenges)

> 
> 
> 
> As participant
> 
> ·         The current scope seems to be only storage local to a server.
> It is worth addressing the shared storage aspect as we make progress.
> Please clarify this aspect.

Proposals are highly appreciated!

> 
> ·         I see the data model as exemplary where different
> implementations could have variations. That said, at this stage, it is
> probably more useful to define an information model. Also, it worth
> tying this to infrastructure policies.

I would like to point out that the presented data model has been implemented (https://github.com/Ericsson/unify-virtualizer) and is part of different proof of concept prototypes (http://fp7-unify.eu/index.php/results.html#OpenSource). 
Our plan is to release a standalone PoC demo package to foster experiments and discussions related to the information/data models in the near future.

Regards,
Robert

> This is a reminder to all of you in the NVRG about this adoption call.
> So far, only two (affirmative) answers have been received.
> 
> 
> 
> Be goode,
> 
> 
> 
> 	On 6 Dec 2015, at 01:06 , DIEGO LOPEZ GARCIA
> <[email-masked]> wrote:
> 
> 
> 
> 	Hi,
> 
> 
> 
> 	This message is to open a two-week adoption call for
> draft-unify-nfvrg-recursive-programming, and to identify to which of the
> special interest areas it should be associated with.
> 
> 
> 
> 	Please indicate in your comments “support” or “no support” and
> discuss how this draft will contribute to a better understanding of NFV
> infrastructures and how to model them.
> 
> 
> 
> 	e-mail: [email-masked]
> 	Tel:    +34 913 129 041
> 	Mobile: +34 682 051 091
> 	Este mensaje y sus adjuntos se dirigen exclusivamente a su
> destinatario, puede contener información privilegiada o confidencial y
> es para uso exclusivo de la persona o entidad de destino. Si no es
> usted. el destinatario indicado, queda notificado de que la lectura,
> utilización, divulgación y/o copia sin autorización puede estar
> prohibida en virtud de la legislación vigente. Si ha recibido este
> mensaje por error, le rogamos que nos lo comunique inmediatamente por
> esta misma vía y proceda a su destrucción.
> 
> 	The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution
> or copying of this communication is strictly prohibited. If you have
> received this transmission in error, do not read it. Please immediately
> reply to the sender that you have received this communication in error
> and then delete it.
> 
> 	Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em
> virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição
> 
> 	[email-masked]
> e-mail: [email-masked]
> Tel:    +34 913 129 041
> Mobile: +34 682 051 091
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud
> de la legislación vigente. Si ha recibido este mensaje por error, le
> rogamos que nos lo comunique inmediatamente por esta misma vía y
> proceda
> a su destrucción.
> 
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution
> or copying of this communication is strictly prohibited. If you have
> received this transmission in error, do not read it. Please immediately
> reply to the sender that you have received this communication in error
> and then delete it.
> 
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em
> virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição

---

From: <[email-masked]>
Date: Sat, 2 Jan 2016 09:43:39 -0600

This approach overall sounds good to me. I want to confirm that the challenges document (2) will be referenced by the programming document (1).

Thanks,
Ramki

From: Róbert Szabó [mailto:[email-masked]]
Sent: Saturday, January 02, 2016 7:15 AM
To: Krishnan, Ramki <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Hi Ramki, Gino,

Regards,
Robert

From: Nfvrg [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Monday, December 28, 2015 1:26 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Thanks Gino.

Dear Ramki

br
Gino

As co-chair

As participant

Thanks,
Ramki

Hi,

Be goode,

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: <[email-masked]>
Date: Sat, 2 Jan 2016 09:50:37 -0600

Inline please.

Thanks,
Ramki

-----Original Message-----
From: Róbert Szabó [mailto:[email-masked]] 
Sent: Saturday, January 02, 2016 7:31 AM
To: Krishnan, Ramki <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [Nfvrg] RG adoption of draft-unify-nfvrg-recursive-programming

Dear Ramki, All,

Ramki: Sounds good. Worth adding a reference to the implementation in the document. 

Regards,
Robert

> draft-unify-nfvrg-recursive-programming, and to identify to which of 
> the special interest areas it should be associated with.
> 
> 
> 
> discuss how this draft will contribute to a better understanding of 
> NFV infrastructures and how to model them.
> 
> 
> 
> https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programmi
> ng
> /
> 
> 
> 
> 	Be goode,
> 
> 
> 
> 	--
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
> 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro, 
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
> 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro,

---

From: Róbert Szabó <[email-masked]>
Date: Sat, 2 Jan 2016 15:50:50 +0000

ACK. 
/r
On Sat, Jan 02, 2016 at 16:43:39, [email-masked] wrote:
> This approach overall sounds good to me. I want to confirm that the
> challenges document (2) will be referenced by the programming document
> (1).
> 
> 
> 
> Thanks,
> 
> Ramki
> 
> 
> 
> Let me add my view to this question as one of the editor for the
> https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/. Our plan
> is to merged the content of this draft into the following two drafts:
> 
> 1.
> <https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programmin
> g/>
> 
> 2.
> https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challe
> nges/
> <https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-chall
> enges/>
> 
> 
> 
> While (2) may receive challenges related contents (1) shall host
> discussions related to different approaches to the problems. I think
> this is in alignment of your request.
> 
> 
> 
> So,
> <https://datatracker.ietf.org/doc/draft-unify-nfvrg-recursive-programmin
> g/>  should refer to the merged document
> https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challe
> nges/
> <https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-chall
> enges/>  and not
> https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/
> <https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/> . I
> guess, this is the source of confusion.
> 
> Regarding further merging of
> https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challe
> nges/
> <https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-chall
> enges/> , we can have a separate discussion as needed.
> 
> Thanks,
> 
> Ramki
> 
> 
> 
> To: Krishnan, Ramki <[email-masked]>
> Cc: DIEGO LOPEZ GARCIA <[email-masked]>; [email-masked]
> As presented in Yokohama and briefly discussed at the interim meeting in
> Heidelberg, draft unify-challenges is currently merged with
> https://datatracker.ietf.org/doc/draft-felix-nfvrg-recursive-orchestrati
> on/.
> 
> 
> 
> Both drafts converged into
> https://datatracker.ietf.org/doc/draft-caszpe-nfvrg-orchestration-challe
> nges/, which we (authors) aim to advance to NFVRG official I-D.
> 
> 
> 
> br
> 
> Gino
> 
> 
> 
> On 27 December 2015 at 06:16, <[email-masked]> wrote:
> 
> 	·         The current scope seems to be only storage local to a
> server. It is worth addressing the shared storage aspect as we make
> progress. Please clarify this aspect.
> 
> 	This is a reminder to all of you in the NVRG about this adoption
> call. So far, only two (affirmative) answers have been received.
> 
> 
> 
> 	Be goode,
> 
> 
> 
> 		Please indicate in your comments “support” or “no
> support” and discuss how this draft will contribute to a better
> understanding of NFV infrastructures and how to model them.
> 
> 
> 
> 		Tel:    +34 913 129 041 <tel:%2B34%20913%20129%20041>
> 		Mobile: +34 682 051 091
> <tel:%2B34%20682%20051%20091>
> 		Este mensaje y sus adjuntos se dirigen exclusivamente a
> su destinatario, puede contener información privilegiada o confidencial
> y es para uso exclusivo de la persona o entidad de destino. Si no es
> 		The information contained in this transmission is
> privileged and confidential information intended only for the use of the
> individual or entity named above. If the reader of this message is not
> the intended recipient, you are hereby notified that any dissemination,
> distribution or copying of this communication is strictly prohibited. If
> you have received this transmission in error, do not read it. Please
> immediately reply to the sender that you have received this
> 		Esta mensagem e seus anexos se dirigem exclusivamente ao
> seu destinatário, pode conter informação privilegiada ou confidencial e
> é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> 	Tel:    +34 913 129 041 <tel:%2B34%20913%20129%20041>
> 	Mobile: +34 682 051 091 <tel:%2B34%20682%20051%20091>
>   e-mail    : [email-masked]
> 
>   web       : www.nextworks.it
>

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Sat, 2 Jan 2016 17:36:36 +0000

Hi Robert,

You are completely right, my apologies. In my defense I can say I was mistaken by the discussion in a parallel thread, the amount of pending emails after my holidays and the relaxed mind state I brought from them.

Let me remake the statement:

This message is to declare the adoption of draft-unify-nfvrg-recursive-programming by the RG. Authors, please upload an updated version under the name draft-irtf-nfvrg-recursive-programming addressing the comments received.

Be goode,

> On 2 Jan 2016, at 16:08 , Róbert Szabó <[email-masked]> wrote:
>
> Hi Diego, All,
>
> On 6 Dec 2015, at 01:06 , DIEGO LOPEZ GARCIA <[email-masked]> wrote:
>

Dr Diego R. Lopez
Telefonica I+D