Subject: [Nfvrg] Using container based hypervisor in NFV

From: nikhil ap <[email-masked]>
Date: Fri, 17 Mar 2017 02:09:25 +0530

Currently, the NFV architecture dictates that virtual functions run on top
of full fledged hypervisor. However, recent advancements in container based
hypervisor  such as LXD looks promising.

I think there will be a significant performance benefit in using Lxd over
KVM although security is the obvious concern. Going forward, do we see
container based hypervisor replacing KVM like hypervisors in deploying
network virtual function?

-- 
Regards,
Nikhil

---

From: GENG Liang <[email-masked]>
Date: Fri, 17 Mar 2017 02:41:34 +0000

"Currently, the NFV architecture dictates that virtual functions run on top of full fledged hypervisor. However, recent advancements in container based hypervisor  such as LXD looks promising. "

Much of the current NFV work is based on centralized DC environment where VM is considered a robust and secured solution. However there may be scenarios where containers are prefered because of its light-weight characteristic, especially in NFVI-PoPs with limited computing resources, i.e. distributed edge devices.

"I think there will be a significant performance benefit in using Lxd over KVM although security is the obvious concern. Going forward, do we see container based hypervisor replacing KVM like hypervisors in deploying network virtual function? "

These is a draft (expired)https://datatracker.ietf.org/doc/draft-natarajan-nfvrg-containers-for-nfv/  reviews the performance of containers.
I think you also need to be careful about the word "relacing". What I see is that VMs and Containers both have pros and cons. The different natures in terms of virtualization technologeis make them intrinsicly fit for differerent implementation scenarios.

I have also been closely looking at distributed NFV scenarios where I believe containers will play a considerably important role. You can find a very initial draft discussing the distributed NFV concept on https://datatracker.ietf.org/doc/draft-geng-nfvrg-distributed-nfv/

________________________________
Liang GENG
China Mobile Research Institute

From: nikhil ap<mailto:[email-masked]>
Date: 2017-03-17 05:09
To: nfvrg<mailto:[email-masked]>
Subject: [Nfvrg] Using container based hypervisor in NFV
Currently, the NFV architecture dictates that virtual functions run on top of full fledged hypervisor. However, recent advancements in container based hypervisor  such as LXD looks promising.

I think there will be a significant performance benefit in using Lxd over KVM although security is the obvious concern. Going forward, do we see container based hypervisor replacing KVM like hypervisors in deploying network virtual function?

--
Regards,
Nikhil

---

From: Roberto Riggio <[email-masked]>
Date: Fri, 17 Mar 2017 09:03:09 +0100

Dear Nikhil,

there performance benefits of using containers are clear, both in terms of
footprint and
time to spawn them (which however is not always a concern). However I would
not talk
about replacing but about addressing different niches in the ecosystems.

What is clearly missing are also lightweight management and orchestration
stack going
from VIM up to ORCH. We are actually working on a LightMANO concept based on
kubernetes and docker and supporting also process based virtualization
solutions like
click. We could have something to share in the near future on this topic.

Cheers

On Thu, Mar 16, 2017 at 9:39 PM, nikhil ap <[email-masked]> wrote:

> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg
>
>

-- 
Roberto Riggio, PhD
Chief Scientist
​FuN - Future Networks
​----------------------------------------
CREATE-NET Research Center
Fondazione Bruno Kessler (FBK)
via alla Cascata 56D
38123 Povo, Trento (Italy)
F: +39 0461 31​ 24 81
M: +39 ​338 72 93 203
e-mail: ​[email-masked]
www: http://create-net.fbk.eu​