Subject: Re: [Nfvrg] Research interest in NFV

From: nikhil ap <[email-masked]>
Date: Sat, 27 May 2017 13:59:39 +0530

Hello All,

I am keen on starting my research in NFV and after spending about a couple
of months looking and playing around with the technology, I found the area
of QoS and SFC to be of interest.

I was going over the paper on Network Virtualisation Research Challenges
and the challenge on using a different virtualisation technology other than
a VM intrigued me.

I later stumbled upon the paper on " An Analysis of Lightweight
Virtualisation Technologies for NFV" which I found interesting and I want
to start my research on "Challenges in Building NFV Platforms using light
weight virtualisation technology and distributed micro-service network
functions"

I this is a viable option/topic? Is there any research already happening in
this area?
Any of your thoughts/feedback/suggestions would be most welcome.

Regards,
Nikhil

On Tue, Feb 28, 2017 at 4:28 AM, Diego R. Lopez <
[email-masked]> wrote:

> Hi Nikhil,
>
> It should be easy: just use the list and ask, comment, or suggest what you
> see fit.
>
> Be goode,
>
> On 27 Feb 2017, at 18:47 , nikhil ap <[email-masked]> wrote:
>
> Hello,
>
> I am a part-time PhD student at BITS PILANI, India  currently working in
> Aryaka Networks. I am interested in doing research/PhD in Nfv. Is there a
> procedure or a process which I need to follow in order to start working?
> There are bunch of areas which I am interested in. How do I know if anyone
> else is working on it. Are researches assigned the work items? Kindly let
> me know.
>
> Regards,
> Nikhil
> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg
>
>
> --
> "Esta vez no fallaremos, Doctor Infierno"
>
> Dr Diego R. Lopez
> Telefonica I+D
> http://people.tid.es/diego.lopez/
>
> e-mail: [email-masked]
> Tel:    +34 913 129 041 <+34%20913%2012%2090%2041>
> Mobile: +34 682 051 091 <+34%20682%2005%2010%2091>
> ----------------------------------
>
>

-- 
Regards,
Nikhil

---

From: Richard Cziva <[email-masked]>
Date: Sat, 27 May 2017 10:04:54 +0100

Hi Nikhil,

It is indeed a viable topic. In Glasgow we are building Glasgow Network Functions (GNF) (https://netlab.dcs.gla.ac.uk/projects/glasgow-network-functions) which is proposing Linux containers for NFV. We presented multiple use cases where container vNFs can be useful (e.g., roaming vNFs, running vNFs on cloud VMs, etc.) - see publications at the end of the page. Our most recent publication is coming out next month in IEEE Communications Magazine, titled: “Container Network Functions: Bringing NFV to the Network Edge” - this paper explores the benefits of running container vNFs in close proximity of the users.

Regards,
Richard

> On 27 May 2017, at 09:29, nikhil ap <[email-masked]> wrote:
> 
> Hello All,
> 
> I am keen on starting my research in NFV and after spending about a couple of months looking and playing around with the technology, I found the area of QoS and SFC to be of interest.
> 
> I was going over the paper on Network Virtualisation Research Challenges and the challenge on using a different virtualisation technology other than a VM intrigued me. 
> 
> I later stumbled upon the paper on " An Analysis of Lightweight Virtualisation Technologies for NFV" which I found interesting and I want to start my research on "Challenges in Building NFV Platforms using light weight virtualisation technology and distributed micro-service network functions"
>  
> I this is a viable option/topic? Is there any research already happening in this area?
> On Tue, Feb 28, 2017 at 4:28 AM, Diego R. Lopez <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Nikhil,
> 
> It should be easy: just use the list and ask, comment, or suggest what you see fit.
> 
> Be goode,
> 
>> On 27 Feb 2017, at 18:47 , nikhil ap <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hello,
>> 
>> I am a part-time PhD student at BITS PILANI, India  currently working in Aryaka Networks. I am interested in doing research/PhD in Nfv. Is there a procedure or a process which I need to follow in order to start working? There are bunch of areas which I am interested in. How do I know if anyone else is working on it. Are researches assigned the work items? Kindly let me know.
>> 
>> Regards,
>> Nikhil
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nfvrg <https://www.irtf.org/mailman/listinfo/nfvrg>
> 
> --
> http://people.tid.es/diego.lopez/ <http://people.tid.es/diego.lopez/>
> 
> e-mail: [email-masked] <mailto:[email-masked]>
> Tel:    +34 913 129 041 <tel:+34%20913%2012%2090%2041>
> Mobile: +34 682 051 091 <tel:+34%20682%2005%2010%2091>
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nfvrg <https://www.irtf.org/mailman/listinfo/nfvrg>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 27 May 2017 13:31:31 +0000

Hi,

I concur this is a viable and interesting topic, which is well aligned with one of the matters in which we want to focus the activity of the RG in the coming times. Just as a reminder, these are the items we recently shared on the list:

* Re-architecting functions. This would include aspects such as new architectural and design patterns (containerization, statelessness, serverless, control/data plane separation…), SDN integration, and proposals on programmability (think of P4 and beyond)

* New management frameworks. This would consider aspects related to new OAM mechanisms (configuration control, hybrid descriptors…) and lightweight MANO proposals.

* Techniques to guarantee low latency, resource isolation, and other dataplane features. This would include hardware acceleration, functional offloading to dataplane elements (including NICs), and related approaches.

* Measurement and benchmarking. This would address both internal measurements (think of BMWG) and external applications (think of MAPRG). We need to find matters that are distinctive to NFVRG, while considering the results and directions originated in the mentioned groups.

You are at least addressing the first and the third ones.

In addition to what RIchard suggests, I’d recommend you to have a look at this document, in which an approach to push-down functionalities to forwarding elements to enhance performance: http://nfvwiki.etsi.org/images/NFVTST%2817%29000026r1_PoC_Toward_an_efficient_dataplane_processing.pdf<http://nfvwiki.etsi.org/images/NFVTST(17)000026r1_PoC_Toward_an_efficient_dataplane_processing.pdf>

Be goode,

On 27 May 2017, at 11:04 , Richard Cziva <[email-masked]<mailto:[email-masked]>> wrote:

Hi Nikhil,

Regards,
Richard

On 27 May 2017, at 09:29, nikhil ap <[email-masked]<mailto:[email-masked]>> wrote:

Hello All,

Regards,
Nikhil

On Tue, Feb 28, 2017 at 4:28 AM, Diego R. Lopez <[email-masked]<mailto:[email-masked]>> wrote:
Hi Nikhil,

Be goode,

On 27 Feb 2017, at 18:47 , nikhil ap <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Regards,
Nikhil

_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:+34%20913%2012%2090%2041>
Mobile: +34 682 051 091<tel:+34%20682%2005%2010%2091>
----------------------------------

--
Regards,
Nikhil
_______________________________________________
Nfvrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nfvrg

Dr Diego R. Lopez
Telefonica I+D

Tel:    +34 913 129 041
Mobile: +34 682 051 091

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: nikhil ap <[email-masked]>
Date: Sat, 27 May 2017 22:43:30 +0530

Thank you all for the input. I will look more into this and update.

Regards,
Nikhil

On Sat, May 27, 2017 at 7:01 PM, Diego R. Lopez <
[email-masked]> wrote:

> Hi,
>
> I concur this is a viable and interesting topic, which is well aligned
> with one of the matters in which we want to focus the activity of the RG in
> the coming times. Just as a reminder, these are the items we recently
> shared on the list:
>
> * Re-architecting functions. This would include aspects such as new
> architectural and design patterns (containerization, statelessness,
> serverless, control/data plane separation…), SDN integration, and proposals
> on programmability (think of P4 and beyond)
>
> * New management frameworks. This would consider aspects related to new
> OAM mechanisms (configuration control, hybrid descriptors…) and lightweight
> MANO proposals.
>
> * Techniques to guarantee low latency, resource isolation, and other
> dataplane features. This would include hardware acceleration, functional
> offloading to dataplane elements (including NICs), and related approaches.
>
> * Measurement and benchmarking. This would address both internal
> measurements (think of BMWG) and external applications (think of MAPRG). We
> need to find matters that are distinctive to NFVRG, while considering the
> results and directions originated in the mentioned groups.
>
>
> In addition to what RIchard suggests, I’d recommend you to have a look at
> this document, in which an approach to push-down functionalities to
> forwarding elements to enhance performance: http://nfvwiki.
> etsi.org/images/NFVTST%2817%29000026r1_PoC_Toward_an_efficient_dataplane_
> processing.pdf
> <http://nfvwiki.etsi.org/images/NFVTST(17)000026r1_PoC_Toward_an_efficient_dataplane_processing.pdf>
>
> Be goode,
>
>
> On 27 May 2017, at 11:04 , Richard Cziva <[email-masked]>
> wrote:
>
> Hi Nikhil,
>
> It is indeed a viable topic. In Glasgow we are building Glasgow Network
> Functions (GNF) (https://netlab.dcs.gla.ac.uk/projects/glasgow-network-
> functions) which is proposing Linux containers for NFV. We presented
> multiple use cases where container vNFs can be useful (e.g., roaming vNFs,
> running vNFs on cloud VMs, etc.) - see publications at the end of the page.
> Our most recent publication is coming out next month in IEEE Communications
> Magazine, titled: “Container Network Functions: Bringing NFV to the Network
> Edge” - this paper explores the benefits of running container vNFs in close
> proximity of the users.
>
> Regards,
> Richard
>
> and the challenge on using a different virtualisation technology other
> than a VM intrigued me.
>
> On Tue, Feb 28, 2017 at 4:28 AM, Diego R. Lopez <diego.r.lopez@
> telefonica.com> wrote:
>
>> Hi Nikhil,
>>
> ------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>

-- 
Regards,
Nikhil