Subject: Re: [Nfvrg] Planning for the coming NFVRG meetings

From: "Ciavaglia, Laurent (Nokia - FR/Nozay)" <[email-masked]>
Date: Wed, 3 May 2017 07:26:52 +0000

Dear NFVRG, Diego,

Looks like a good proposal, and since you asked (requested) for feedback, here is mine:

-I support setting priority on more discussion / interaction time during f2f meetings. Making a prior check with the presenters/proponents of the topics that issues are well identified and highlighted is important to make sure can happen on these issues during the meeting.

-Re management frameworks, if the RG / chairs find it relevant and useful, we could also work together with the NMRG. As an example, I had some good discussions following the first NFRG meeting in IETF98 on two items that were presented and have links to management aspects (distributed NFV and verification). Identifying management issues/items that are common to NFV and NM could bring an additional reading/understanding.

-Question: you wrote " focusing each meeting (or series of meetings) on a particular issue ", do you consider the 4 topics/domains listed in your email (or other / different granularity topics)? 
  The point is that if one topic per meeting, and one if NFVRG meeting per IETF, then a topic will be discussed "live" only once a year... not sure this is the expected effect.
  I understand discussion should also happen on the mailing list, but this is a general question I have about the new meeting scheme (also since we face similar issue in the NMRG).

HTH a little, Good luck,
Laurent.

-----Original Message-----
From: Nfvrg [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: Sunday, April 30, 2017 3:15 PM
To: [email-masked]
Subject: [Nfvrg] Planning for the coming NFVRG meetings

Hi,

In discussions we had in Chicago with Allison, our new IETF chair, some concerns were raised about work and meeting time within the group (exemplified by the problems around area-oriented document consolidation), and we considered ways for better driving the quality of our research and the impact on the RG as a whole. We want to share with you a new proposal for meeting schedules, and solicit your inputs on it.

The basic idea is to shorten the meeting duration (no more than a two-hour slot) and focusing each meeting (or series of meetings) on a particular issue, looking for just a few presentations (no more than three in any case) and in-depth discussions. We for sure will leave some room to document updates, but most of the discussions on documents must happen on the mailing list.

With this in mind, we would like to propose a few matters for you to express your opinions and ideas, including any alternate issues that you think can be of interest. In particular, we have been thinking of:

* Re-architecting functions. This would include aspects such as new architectural and design patterns (containerization, statelessness, serverless, control/data plane separation…), SDN integration, and proposals on programmability (think of P4 and beyond)

* New management frameworks. This would consider aspects related to new OAM mechanisms (configuration control, hybrid descriptors…) and lightweight MANO proposals.

* Techniques to guarantee low latency, resource isolation, and other dataplane features. This would include hardware acceleration, functional offloading to dataplane elements (including NICs), and related approaches.

* Measurement and benchmarking. This would address both internal measurements (think of BMWG) and external applications (think of MAPRG). We need to find matters that are distinctive to NFVRG, while considering the results and directions originated in the mentioned groups.

Comments are not only welcome but essential.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição _______________________________________________
Nfvrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nfvrg

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 16 May 2017 17:57:59 +0000

Hi Laurent,

Thanks for your comments! Let’s see if them, and my reply, make others express their opinions on the list and help the community to shape the new NFVRG stage…

On 3 May 2017, at 09:26 , Ciavaglia, Laurent (Nokia - FR/Nozay) <[email-masked]<mailto:[email-masked]>> wrote:

Dear NFVRG, Diego,

I cannot agree more!

I hope the interest in management frameworks is confirmed, and definitely will welcome any kind of common approach to NFV management issues.

What I had in mind was not necessarily a round-robin approach, nor a pattern of discussion only at the IETF meetings (or on the list). If we agree on these few items (or a similar number) and we can assign a priority to them, higher-priority items will get more dedicated sessions, at the IETF or elsewhere, by means of interim meetings that we are considering to have at specific venues related with a particular issue.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição