Subject: Re: [NGO] Tutorial on RELAX NG and/or XSD at Vancouver IETF?

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 11 Oct 2007 10:13:24 +0200

Hi,

I provided the input requested by the EDUteam but haven't got any feedback yet. However, I can only cover RELAX NG, so if the tutorial is to include both RNG and XSD on a symmetrical basis, someone else should volunteer to do the XSD part.

Lada

Ladislav Lhotka, CESNET
PGP Key: E74E8C0C

----- Original message -----
From: Benoit Claise <[email-masked]>
To: Andy Bierman <[email-masked]>
Cc: [email-masked], [email-masked]
Sent: Wed, 10 Oct 2007, 23:05:52 CEST
Subject: Re: [NGO] Tutorial on RELAX NG and/or XSD at Vancouver IETF?
Hi there,

Is this tutorial taking place?

Regards, Benoit.
> Romascanu, Dan (Dan) wrote:
>> EDU Team,
>>
>> I support this, and also an XSD tutorial. Both are needed and closely 
>> related to current work and debates in the OPS area, and probably 
>> other areas like APPS may also be interested.
>
> Don't forget Xpath ;-)
>
>> Dan
>
> Andy
>
>>
>>
>>  
>>  
>>
>>> -----Original Message-----
>>> From: Wijnen, Bert (Bert) [mailto:[email-masked]] Sent: 
>>> Friday, September 14, 2007 2:45 PM
>>> To: [email-masked]
>>> Cc: [email-masked]
>>> Subject: [NGO] Tutorial on RELAX NG and/or XSD at Vancouver IETF?
>>>
>>> Forwarding to EDU team, so they are aware of it
>>> NGO/Netconf folk, we need to show our interest FAST if we want this 
>>> to happen. If the EDU-team does not have a slot, we could try for a 
>>> separate smaller session outside the normal program.
>>>
>>> It would be good to also have an XSD tutorial though, so we can much 
>>> better compare the two.
>>>
>>> Bert Wijnen
>>> -----Original Message-----
>>> From: Ladislav Lhotka [mailto:[email-masked]]
>>> Sent: Friday, September 14, 2007 1:35 PM
>>> To: Wijnen, Bert (Bert)
>>> Cc: Andy Bierman; [email-masked]
>>> Subject: RE: [NGO] NETCONF Data Modeling BoF (NDM) proposal
>>>
>>> Wijnen, Bert (Bert) píše v Pá 14. 09. 2007 v 13:21 +0200:
>>>>> From: Ladislav Lhotka [mailto:[email-masked]]
>>>>> Sent: Thursday, September 13, 2007 9:12 AM
>>>>> To: Andy Bierman
>>>>> Cc: [email-masked]
>>>>> Subject: Re: [NGO] NETCONF Data Modeling BoF (NDM) proposal
>>>>>
>>>>> Try it and you will see that RELAX NG is way easier and more 
>>>>> predictable. James Clark claims the RNG Tutorial can get 
>>> you going
>>>>> in 30 minutes, which is probably an exaggeration, but perhaps two 
>>>>> hours could be enough?
>>>>>
>>>> Candidate tutorial for Vancouver?
>>> OK, if there is interest, I am volunteering to prepare it.
>>>
>>> Lada
>>>
>>> -- 
>>> Ladislav Lhotka, CESNET
>>> PGP Key ID: E74E8C0C
>>>
>>>
>>>
>>> _______________________________________________
>>> NGO mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/ngo
>>>
>>
>>
>> _______________________________________________
>> NGO mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/ngo
>>
>>
>
>
>
> _______________________________________________
> NGO mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ngo

_______________________________________________
NGO mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ngo

_______________________________________________
NGO mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ngo

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 11 Oct 2007 13:04:16 +0200

I believe that the EDU team is on track with doing this tutorial. We are however still missing an expert to do the XSD part, so any proposals about folks with expertise in the field to do this part are welcome. 

Dan

> Sent: Thursday, October 11, 2007 10:13 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> I provided the input requested by the EDUteam but haven't got 
> any feedback yet. However, I can only cover RELAX NG, so if 
> the tutorial is to include both RNG and XSD on a symmetrical 
> basis, someone else should volunteer to do the XSD part.
> 
> Lada
> 
> Ladislav Lhotka, CESNET
> PGP Key: E74E8C0C
> 
> >>> From: Wijnen, Bert (Bert) 
> [mailto:[email-masked]] Sent: 
> NGO/Netconf folk, we 
> >>> need to show our interest FAST if we want this to happen. If the 
> >>> EDU-team does not have a slot, we could try for a 
> separate smaller

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 16 Oct 2007 15:30:41 +0200

Margaret,

I would say that IETF 71 may not be too late, but IETF 70 is certainly not too early. Is really all hope lost for finding an expert to run the XSD part of the tutorial? Can't the query to the APPS ADs and maybe to XML directorate be run now? 

I have added to the distribution list a few more folks in the hope that they may be able to help. 

Dan

> From: Margaret Wasserman [mailto:[email-masked]] 
> Sent: Tuesday, October 16, 2007 3:00 PM
> To: Romascanu, Dan (Dan)
> Cc: Ladislav Lhotka; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [edu-team] RE: [NGO] Tutorial on RELAX NG and/or 
> XSD at Vancouver IETF?
> 
> 
> Hi Dan,
> 
> Given that we do not have a complete proposal or an XSD 
> expert volunteer, I believe it is too late to put this 
> tutorial together for Vancouver.  If you think it would still 
> be useful by IETF 71, I'd be happy to work with the apps and 
> management ADs to try to put together an XML modeling 
> tutorial (including Relax NG and XSD) to debut at IETF 71 in 
> Pittsburgh.  Hopefully we could have a tutorial that would be 
> useful both to management and apps folks working in this area.
> 
> Margaret
> 
> On Oct 11, 2007, at 7:04 AM, Romascanu, Dan (Dan) wrote:
> 
> > I believe that the EDU team is on track with doing this tutorial.  
> > We are however still missing an expert to do the XSD part, so any 
> > proposals about folks with expertise in the field to do 
> this part are 
> > welcome.
> >
> > Dan
> >
> >
> >
> >
> >
> >> I provided the input requested by the EDUteam but haven't got any 
> >> feedback yet. However, I can only cover RELAX NG, so if 
> the tutorial 
> >> is to include both RNG and XSD on a symmetrical basis, 
> someone else 
> >> should volunteer to do the XSD part.
> >>
> >> Lada
> >>
> >> Ladislav Lhotka, CESNET
> >> PGP Key: E74E8C0C
> >>
> > edu-team mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/edu-team
>

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 16 Oct 2007 08:59:57 -0400

Hi Dan,

Given that we do not have a complete proposal or an XSD expert  
volunteer, I believe it is too late to put this tutorial together for  
Vancouver.  If you think it would still be useful by IETF 71, I'd be  
happy to work with the apps and management ADs to try to put together  
an XML modeling tutorial (including Relax NG and XSD) to debut at  
IETF 71 in Pittsburgh.  Hopefully we could have a tutorial that would  
be useful both to management and apps folks working in this area.

Margaret

On Oct 11, 2007, at 7:04 AM, Romascanu, Dan (Dan) wrote:

> proposals about folks with expertise in the field to do this part  
> are welcome.
>
> Dan
>
>
>
>
>