Subject: [NGO] Use of normative DML in Standards track document WAS: Re: completed CANMOD agenda

From: Mehmet Ersue <[email-masked]>
Date: Wed, 27 Feb 2008 09:59:55 +0000 (GMT)

Hi Balazs,

you did what we agreed, so it's fine. Having additional examples 
in the appendix is useful and important on our way to an official DML.

> so IMO it is extremely urgent to pick an official modeling language 
> for NETCONF.

I guess, for the time being we have to live with XSD.

Cheers, 
Mehmet 

> -----Original Message-----
> From: ext Balazs Lengyel [mailto:[email-masked]] 
> Sent: Wednesday, February 27, 2008 10:17 AM
> To: Mehmet Ersue
> Cc: NGO; Andy; [email-masked]
> Subject: Re: [NGO] completed CANMOD agenda
> 
> Hello Mehmet,
> The YANG model is in the appendix, with the explicit 
> statement "non-normative", so I hope I 
> followed Dan's advice. Is it OK like that? The reason I put 
> in the YANG version is to
> - make it easier to understand partial locking
> - make it possible to compare different modeling approaches 
> (even if that is not the main goal 
> of this draft in the final run).
> 
> YANG is not an official language, as we do not have any 
> official language for Netconf modeling. 
> This is the reason I included two different descriptions of 
> the same thing (YANG, XSD).
> 
> OPINION: Some such OFFICIAL model should be included in my 
> draft/rfc, so IMO it is extremely 
> urgent to pick an official modeling language for NETCONF.
> 
> Balazs
> 
> Mehmet Ersue wrote:
> > 
> > Hi All,
> > 
> > I don't want to be a nitpicker here but we had a long discussion
> > in the IETF #70 NETCONF session whether we should keep the
> > YANG-based data model in the document "Partial Lock RPC"
> > 
> (http://www.ietf.org/internet-drafts/draft-ietf-netconf-partia
> l-lock-01.txt).
> > 
> > Since it is not an official language yet Dan recommended to use it
> > in the Appendix only. I understand your enthusiasm but I guess IESG
> > will not support the usage a Standards track document (at 
> least currently).
> > 
> > Cheers,
> > Mehmet
> > 
> >  
> > 
> >  > -----Original Message-----
> >  > From: [email-masked] [mailto:[email-masked]] On
> >  > Behalf Of ext Andy Bierman
> >  > Sent: Tuesday, February 26, 2008 7:58 PM
> >  > To: Ladislav Lhotka
> >  > Cc: [email-masked]
> >  > Subject: Re: [NGO] completed CANMOD agenda
> >  >
> >  > Hi,
> >  >
> >  > ...
> >  > > My suggestion is to let the supporters of each methodology
> >  > create few
> >  > > non-trivial data models and show how they can be used.
> >  > Without practical
> >  > > experience, these discussions are indeed academic.
> >  > >
> >  >
> >  >
> >  > Great idea.
> >  >
> >  > An IPFIX configuration data model was just published:
> >>  http://www.ietf.org/internet-drafts/draft-muenz-ipfix-configur
> >  > ation-04.txt
> >  >
> >  > This is a real data model, developed by a real WG.
> >  > This is exactly the scenario that the NETCONF WG is looking for:
> >  > non-NETCONF and non-XML DM writers who are creating a 
> domain-specific
> >  > data model.
> >  >
> >  > The true measure of 'ease-of-use' is not whether the authors
> >  > know their own proposal, or a few experts know the technology,
> >  > but whether or not the intended audience (NETCONF data modelers)
> >  > actually think it is easy to use.
> >  >
> >  >
> >  > Andy
> >  > _______________________________________________
> >  > NGO mailing list
> >  > [email-masked]
> >>  http://www.ietf.org/mailman/listinfo/ngo
> >  >
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> --------------------------------------------------------------
> ----------
> > *Ihre erste Baustelle?* Wissenswertes für Bastler und Hobby 
> Handwerker. 
> > 
> <http://de.rd.yahoo.com/evt=48734/*http://de.answers.yahoo.com
> /dir/;_ylc=X3oDMTEzY2IyNmI0BF9TAzIxMTQ3MTgzMjIEc2VjA01haWwEc2x
> rA3RhZ2xpbmVz?link=list&sid=396545394>
> > 
> > 
> > 
> --------------------------------------------------------------
> ----------
> > 
> > _______________________________________________
> > NGO mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/ngo
> 
> -- 
> Balazs Lengyel                       Ericsson Hungary Ltd.
> TSP System Manager
> ECN: 831 7320                        Fax: +36 1 4377792
> Tel: +36-1-437-7320     email: [email-masked]
> 

       __________________________________  Ihre erste Baustelle? Wissenswertes für Bastler und Hobby Handwerker. www.yahoo.de/clever

_______________________________________________
NGO mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ngo

---

From: David Partain <[email-masked]>
Date: Wed, 27 Feb 2008 12:29:38 +0100

Hi,

XSD is no more the "chosen one" than is YANG, Kalua, or DSDL or anything else.  
I agree with Balazs that it's time to choose and, in the meantime, we'll just 
have lots of duplication of effort.  That duplication of effort (recreating 
the same model in multiple forms) is useful, though, if he helps us see the 
benefits and drawbacks of the various proposals.

Cheers,

David