Subject: Re: [NGO] completed CANMOD agenda

From: Mehmet Ersue <[email-masked]>
Date: Tue, 26 Feb 2008 20:13:49 +0000 (GMT)

Hi All,

I don't want to be a nitpicker here but we had a long discussion 
in the IETF #70 NETCONF session whether we should keep the 
YANG-based data model in the document "Partial Lock RPC"
(http://www.ietf.org/internet-drafts/draft-ietf-netconf-partial-lock-01.txt).

Since it is not an official language yet Dan recommended to use it 
in the Appendix only. I understand your enthusiasm but I guess IESG 
will not support the usage a Standards track document (at least currently).

Cheers, 
Mehmet 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of ext Andy Bierman
> Sent: Tuesday, February 26, 2008 7:58 PM
> To: Ladislav Lhotka
> Cc: [email-masked]
> Subject: Re: [NGO] completed CANMOD agenda
> 
> Hi,
> 
> ...
> > My suggestion is to let the supporters of each methodology 
> create few
> > non-trivial data models and show how they can be used. 
> Without practical
> > experience, these discussions are indeed academic.
> > 
> 
> 
> Great idea.
> 
> An IPFIX configuration data model was just published:
> http://www.ietf.org/internet-drafts/draft-muenz-ipfix-configur
> ation-04.txt
> 
> This is a real data model, developed by a real WG.
> This is exactly the scenario that the NETCONF WG is looking for:
> non-NETCONF and non-XML DM writers who are creating a domain-specific
> data model.
> 
> The true measure of 'ease-of-use' is not whether the authors
> know their own proposal, or a few experts know the technology,
> but whether or not the intended audience (NETCONF data modelers)
> actually think it is easy to use.
> 
> 
> Andy
> _______________________________________________
> NGO mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/ngo
> 

      Heute schon einen Blick in die Zukunft von E-Mails wagen? Versuchen Sie´s mit dem neuen Yahoo! Mail. www.yahoo.de/mail

_______________________________________________
NGO mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ngo

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 27 Feb 2008 10:16:31 +0100

Hello Mehmet,
The YANG model is in the appendix, with the explicit statement "non-normative", so I hope I 
followed Dan's advice. Is it OK like that? The reason I put in the YANG version is to
- make it easier to understand partial locking
- make it possible to compare different modeling approaches (even if that is not the main goal 
of this draft in the final run).

YANG is not an official language, as we do not have any official language for Netconf modeling. 
This is the reason I included two different descriptions of the same thing (YANG, XSD).

OPINION: Some such OFFICIAL model should be included in my draft/rfc, so IMO it is extremely 
urgent to pick an official modeling language for NETCONF.

Balazs

Mehmet Ersue wrote:
> ------------------------------------------------------------------------
> *Ihre erste Baustelle?* Wissenswertes für Bastler und Hobby Handwerker. 
> <http://de.rd.yahoo.com/evt=48734/*http://de.answers.yahoo.com/dir/;_ylc=X3oDMTEzY2IyNmI0BF9TAzIxMTQ3MTgzMjIEc2VjA01haWwEc2xrA3RhZ2xpbmVz?link=list&sid=396545394>
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
NGO mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ngo

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 27 Feb 2008 10:19:43 +0100

I hereby invite all DML teams to send me their version of the partial-locking data model. I 
will include it in the draft. In the long run probably most will be removed, but it can serve 
as a small real-life example to show of your DML.

Balazs

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 27 Feb 2008 11:10:00 +0100

By 'official' you probably mean 'standard' :-) 

Yes, expressing the data model in different languages in a non-normative annex is OK. More than that, I believe that it is very useful because it provides a hands-on experience about how the different languages perform and how the model looks like in the different proposed languages. 

I would encourage folks who are behind the various proposals to prepare more such examples for the discussions ahead. 

Dan

> Behalf Of Balazs Lengyel
> Sent: Wednesday, February 27, 2008 11:17 AM
> To: Mehmet Ersue
> Cc: NGO; [email-masked]
> The YANG model is in the appendix, with the explicit 
> statement "non-normative", so I hope I followed Dan's advice. 
> Is it OK like that? The reason I put in the YANG version is to
> - make it possible to compare different modeling approaches 
> (even if that is not the main goal of this draft in the final run).
> 
> OPINION: Some such OFFICIAL model should be included in my 
> draft/rfc, so IMO it is extremely urgent to pick an official 
> modeling language for NETCONF.
> 
> Balazs
> 
> Mehmet Ersue wrote:
> > 
> > Hi All,
> > 
> > I don't want to be a nitpicker here but we had a long discussion in 
> > the IETF #70 NETCONF session whether we should keep the YANG-based 
> > data model in the document "Partial Lock RPC"
> > 
> Since it is not an official language yet Dan recommended to use it in 
> the Appendix only. I understand your enthusiasm but I guess IESG will 
> not support the usage a Standards track document (at least currently).
> 
> Cheers,
> Mehmet
> 
>  
> 
>  > From: [email-masked] [mailto:[email-masked]] On  > 
> Behalf Of ext Andy Bierman  > Sent: Tuesday, February 26, 2008 7:58 PM  
> > To: Ladislav Lhotka  > Cc: [email-masked]  > Subject: Re: [NGO] 
> completed CANMOD agenda  >  > Hi,  >  > ...
>  > > My suggestion is to let the supporters of each methodology  > 
> create few  > > non-trivial data models and show how they can be used.
>  > Without practical
>  > non-NETCONF and non-XML DM writers who are creating a 
> domain-specific  > data model.
>  >
>  > The true measure of 'ease-of-use' is not whether the authors  > 
> know their own proposal, or a few experts know the technology,  > but 
> whether or not the intended audience (NETCONF data modelers)  > 
> ----------------------------------------------------------------------
> -- *Ihre erste Baustelle?* Wissenswertes für Bastler und Hobby 
> Handwerker.
> <http://de.rd.yahoo.com/evt=48734/*http://de.answers.yahoo.com/dir/;_y
> lc=X3oDMTEzY2IyNmI0BF9TAzIxMTQ3MTgzMjIEc2VjA01haWwEc2xrA3RhZ2xpbmVz?li
> nk=list&sid=396545394>
> 
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 Feb 2008 12:02:51 -0800

Hi -

> From: "Balazs Lengyel" <[email-masked]>
> To: "NGO" <[email-masked]>
> Sent: Wednesday, February 27, 2008 1:19 AM
...

Having the same model represented using each of the modeling approaches
would be very helpful to the discussion at the canmod BOF.  It's
probably the fastest way for folks who aren't involved in the
development of a specific proposal to gain an appreciation of
the power, expressiveness, and feel of each approach.  Reading
the specifications is one thing.  Seeing the same non-trivial model
fully worked out is quite another.

Randy