Subject: [NGO] comments on draft-presuhn-rcdml-01

From: Balazs Lengyel <[email-masked]>
Date: Thu, 14 Feb 2008 10:38:51 +0100

Hi,
3.1.3.  Define Actions (NOT Agreed)

What is the difference between actions and operations? Before I can agree/disagree with this I 
want to understand what it means.

Balazs
_______________________________________________
NGO mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ngo

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 14 Feb 2008 12:42:17 -0800

Hi -

> From: "Balazs Lengyel" <[email-masked]>
> To: "NETCONF Goes On" <[email-masked]>
> Sent: Thursday, February 14, 2008 1:38 AM
> Subject: [NGO] comments on draft-presuhn-rcdml-01
>
> Hi,

This distinction comes from other management frameworks, such as CMIP/GDMO.
Due to the design of netconf protocol, they'd probably be indistinguishable on the
wire, but there still are important differences from a modeling / implementation
perspective.  Specifically:  an "action" is associated in a model with specific
object classes. For example, a "rewind" action might be associated with a tape
drive or a VCR, but is pretty meaningless with an ethernet interface.  "Operations"
are much more general - not associated with a particular object, they are really
extensions to the protocol itself.

In SNMP SMI, actions are entirely overloaded onto the "set" operation.  The SMI's
object model is pretty weak, so the DESCRIPTION clause does all the heavy lifting.
SNMP SMI has no way of defining new operations.

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 14 Feb 2008 21:51:22 +0100

On Thu, Feb 14, 2008 at 12:42:17PM -0800, Randy Presuhn wrote:
 
> This distinction comes from other management frameworks, such as
> CMIP/GDMO.  Due to the design of netconf protocol, they'd probably
> be indistinguishable on the wire, but there still are important
> differences from a modeling / implementation perspective.
> Specifically: an "action" is associated in a model with specific
> object classes. For example, a "rewind" action might be associated
> with a tape drive or a VCR, but is pretty meaningless with an
> ethernet interface.  "Operations" are much more general - not
> associated with a particular object, they are really extensions to
> the protocol itself.

I don't think operations are extensions of the protocol. Operations
are simply actions that are not bound to a notion of an object, much
like a C function is not bound to a data structure.

Taking CMIP/GDMO aside, I note that most CLIs do not bind commands to
objects. And NETCONF is really about CLIs...

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
NGO mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ngo

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 18 Feb 2008 14:20:38 +0100

Randy Presuhn wrote:
> object classes. 

IMHO this means that on the wire an action is always associated with some kind of pointer to 
the object.

Balazs