Subject: (ngtrans) Re: Ipv6 Migration

From: Kazuaki Tsuchiya <[email-masked]>
Date: Sun, 07 Mar 1999 17:28:25 +0900

Dear Chris,

At 13:51 99/03/05 +0000, Chris Harding wrote:
> >	Also I would like to note that the approach is similar to
> >	draft-tsuchiya-ipv4-ipv6-translator-00. (worth a look)
> >
> Yes there is similarity  - thanks for the pointer!
> 
> The big difference is that this approach is implemented in the host, not
in a
> gateway or router. The host is an IPv6 host, so we are talking about IPv4
> applications in an IPv6 host, not about an IPv4 host in an IPv6 ocean. The
> address mapper and translator functions needed in the host would be similar 
> to the ones described in draft-tsuchiya-ipv4-ipv6-translator-00.
> 

Please see also draft-ietf-ngtrans-dual-stack-hosts-00 in addition
to draft-tsuchiya-ipv4-ipv6-translator-00.

There will be what you want, I believe.

> Other points are that
> 
>  - there is no impact on DNS
> 

Right!

>  - since this is all done in the host, IPSEC can still work.
> 

At this point hosts' implementation surpasses routers' one, I think.

------ Additional info -------

We have 2 implementations.
One is routers' implementation, and the other is hosts'.
Both of them have already worked well.
Please see the following URL.

(1)Hosts' implementation
http://www.hitachi.co.jp/Prod/comp/network/pexv6-e.htm
# You can get the free evaluation kit for Windows PCs here.

(2)Routers' implementation
http://www.hitachi.co.jp/Prod/comp/network/nr60e.htm

> >>The questions are:
> >>   Will this work?
> >>   Should it be required behavior for conforming UNIX implementations?
> >
> >	I believe this will work, but I think we do not need to/want to
> >	mandate this.
> >
> The benefit of making it a requirement is that users who buy a UNIX-branded
> system will know that their existing applications are guaranteed to work
> with IPv6.
> 

That's just exactly what I want to say.

Best regards.

-- Kazuaki Tsuchiya.

--------------------------------------------------------
Kazuaki Tsuchiya (E-mail:[email-masked])
  Hitachi, Ltd.  Server & Network Development Division
    Phone:+81-462-32-2111(ex.2458)   Fax:+81-462-35-8324

---

From: Kazuaki Tsuchiya <[email-masked]>
Date: Sun, 07 Mar 1999 18:19:34 +0900

Dear Chris and IPv6 folks,

> That's just exactly what I want to say.

Sorry. I made a mistake.

What I wanted to say is the following.

We do not need to make this mandatory.
But this is one of useful migration ways for end-users.
There is a meaning in having many people know this.

Best regards.
 
-- Kazuaki Tsuchiya.