Subject: (ngtrans) Integration IPv4 in IPv6

From: "Rolf Kozlowski" <[email-masked]>
Date: Fri, 12 Feb 99 12:19 +0100

Hi,

I have a rather technical problem concerning the IPv4/IPv6
transition phase. 

Currently I am involved in a study concerning the
implementation of a pan-European network for Air Traffic
Control. This network consists of the interconnection of
existing national networks which have been build up
independently from each other. Due to this fact, there is no
consistent addressing scheme between the networks and
further more, the national networks use the address space
for private networks (RFC1918) so that address rooms overlap
and no address space is free anymore (e.g. for routing).

To overcome this problem, one approach would be to build up
an IPv6 network using the advantage of 16 Byte addresses and
the extended routing capabilities.
In the first phase of the pan-European Air Traffic Control
network all hosts connected to it would be pure IPv4 hosts.
Unfortunately, migration strategies are concerned about
integration of IPv6 hosts/routers in an IPv4 environment and
not the other way round. Is there any link I am missing
which deals with connecting IPv4 hosts over an IPv6 backbone
or is this subject for future study ?

Personally, I think that there are several possibilities for
"4over6":
(1) Header Translation:
    Converting the IPv4 header of each packet into an IPv6
    header at the IPv4/IPv6 frontier seems to be not a big
    problem, but we would need header translation in both
    directions IPv4/IPv6 and IPv6/IPv4.
	Are there any draft documents available yet ?
	
(2) "4over6" tunneling:
    When more and more systems are IPv6 compatible this
    "4over6" tunneling will be from a special interest, but
    I am not sure if there are plans concerning this type of
    investigation right now.
	Are there any further information about this ?
	
I would appreciate if you have some minutes time to let me
know how you think about the approach to route IPv4 traffic
over IPv6.

So, best regards and thanks in advance

--
Rolf Kozlowski   [email-masked]
______________________________________________________________________
Kostenlose E-Mail mit digitaler Unterschrift und Verschluesselung bei:
http://freemail.web.de

---

From: Francis Dupont <[email-masked]>
Date: Fri, 12 Feb 1999 14:52:09 +0100

In your previous mail you wrote:

=> it is the same (ie symmetrical) problem than connecting IPv6 hosts/sites
over an IPv4 backbone.

=> header translation can be made symmetrical...

   (2) "4over6" tunneling:

=> there are 4over6 tunnels (for instance a "dynamic" version of it for DTI).
Technically foo over bar is easy to do and very easy when foo != bar.

=> the only difficult thing in your case is the (re/ab)use of private
addressing space... If you have to renumber then it should be easier
to go to IPv6 (no ambiguity between 32 and 128 bit addresses :-).

Regards

[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 12 Feb 1999 14:35:14 +0000

Rolf,

The bad news is that, obviously, if you are using Net 10 on two
sites, without coordinated address assignment, there is no way those
two sites can communicate without using network address translation.
Having an IPv6 cloud between them as a transit network will change
nothing in this respect. Actually, this is why we need IPv6 in the
first place - to avoid the need for private addresses and
address translation.

    Brian Carpenter