Subject: Fwd: (ngtrans) diff-serv comments on transition mechanisms spec

From: Bob Fink <[email-masked]>
Date: Mon, 26 Apr 1999 15:31:28 -0700

NGtrans Folk:

I would like to call attention to Erik's request for comments on the diff-serv wording changes proposed by Brian Carpenter to the basic transition mechanisms document. I'm surprised no one on ngtrans has made any comment except Brian Carpenter.

It is very important that we come to some agreement about this, not only for the sake of Diff-serv, but for the general progress of our core/base set of ipv6 standards documents. So please take a look and suggest helpful things :-)

Anyway, if we hear nothing by next Monday the 3rd of May, the chairs, authors and ADs will have to make their own call (and we aren't ever wrong, are we?).

Thanks,

Bob

===
>Date: Wed, 21 Apr 1999 13:51:08 -0700 (PDT)
>From: Erik Nordmark <[email-masked]>
>Subject: (ngtrans) diff-serv comments on transition mechanisms spec
>To: [email-masked]
>
>I've forwarded the discussion from diff-serv.
>
>The issue is what to say about the TOS field when encapsulating
>and decapsulating.
>
>Brian suggested some text which I can paraphrase as "diff-serv considerations
>might change this behavior in the future".
>I don't know how useful such change would be - all it would do is to flag
>the reader that something else might happen. I assume there would
>still need to be a specification for tunnel implications for diff-serv,
>since we have many different tunneling schemes.
>
>David Black suggested text to state what needs to be done
>but the issue of the two ECN bits is not resolved.
>
>Note that transition mechanisms is moving towards draft standard
>and the diff-serv RFCs are at proposed. Thus we can't have a normative
>reference to the diff-serv RFCs since they are at a lower level.
>
>So perhaps the best thing is to have diff-serv publish documents that
>refer to all forms of tunneling.
>
>   Erik

---

From: "Matt Crawford" <[email-masked]>
Date: Tue, 27 Apr 1999 08:56:24 -0500

> > reference to the diff-serv RFCs since they are at a lower level.

I usually seem to be on the wrong frequency about "normative
references", but here's my 2 ore worth: Just declare that the
handling of the TOS/Precedence/Traffic Class fields are undefined in
your document.  Then (a) implementation of your spec is possible
without reference to diff-serv, and (b) implementation of a diff-serv
PS will not conflict.
				Matt
			  (Gordian?  Not!)

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Apr 1999 15:11:40 +0100

The advantage of that ploy is that it also takes care of ECN.

  Brian