Subject: RE: (ngtrans) 6to4 test?

From: Richard Draves <[email-masked]>
Date: Thu, 20 May 1999 14:39:34 -0700

Speak of the devil! I'm in the middle of implementing 6to4 support myself.
Give me a couple hours and I'll be ready to test. I'll followup with private
email.

Rich

> -----Original Message-----
> From: Markku Savela [mailto:[email-masked]]
> Sent: Thursday, May 20, 1999 4:50 AM
> To: [email-masked]
> Subject: (ngtrans) 6to4 test?
> 
> 
> hi,
> 
> Does anyone have "6to4" capable host on the internet that would answer
> to "6to4 wrapped" ICMP 6 echo request with "6to4 wrapped" reply?
> 
> I woudl like to do
> 
> 	ping 2010:<ipv4-address>::
> 
> and actually get replies back to the source address over IPv4.
> 
> Is the "prefix" "2010:.."?
> 
> -- 
> Markku Savela ([email-masked]), Technical Research 
> Centre of Finland
> Multimedia Systems, P.O.Box 1203,FIN-02044 
> VTT,http://www.vtt.fi/tte/staff/msa/
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 May 1999 11:13:25 +0100

OK, but remember that

- 6to4 as in the draft is a router technique, not a host technique,
  so I'm not too sure what a "6to4 host" might be.
- the draft is very preliminary; in fact the authors are arguing 
  in private, which is why you haven't seen a new one recently :-)

   Brian
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter (IAB Chair)
Program Director, Internet Standards & Technology, IBM Internet Div
As of May 24, 1999: on assignment for IBM at http://www.iCAIR.org 
Non-IBM email: [email-masked]

--

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 May 1999 15:41:31 +0100

Yes, I see, but I don't see it scaling and I don't see how it fits
into the mixed world (some 6to4 and some native IPv6) where the
relay router is essential. If *all* IPv6 was 6to4 this would do
fine, but in that scenario IPv4-compatible addresses and automatic
tunnels would be fine too.

   Brian

Markku Savela wrote:
> If I have a portable IPv6/IPv4 host that connects to internet via IPv4
> PPP (when ISP does not support IPv6 yet), internal 6to4 gateway
> between the stacks inside the host just seemed like simple way for
> enabling IPv6 applications. In this context 6to4 is fairly simple to
> do, and I just made an experimental version of it.
> 
>    IPv6
>    App
>     |
>    IPv6                   IPv4
>    Stack                  Stack
>     | if=2010::     pro=41|  |
>     +<-------> 6to4 <---->+  |
>                              V
>                           PPP (IPv4)
>                              |
>  ..................... IPv4 internet ............
>     |
>    ....
>    6to4
>    ....
>     |
>    Some
>    IPv6
>    Appl.
> 
> "Host 6to4" would appear quite useful for IPv6 hosts that are also
> addressable with IPv4 address. Then I could have native IPv6
> applications that talk to other native IPv6 applications over normal
> IPv4 network. This would be great for testing purposes at least.
> 
> --
> Markku Savela ([email-masked]), Technical Research Centre of Finland
> Multimedia Systems, P.O.Box 1203,FIN-02044 VTT,http://www.vtt.fi/tte/staff/msa/

---

From: Markku Savela <[email-masked]>
Date: Fri, 21 May 1999 14:25:51 +0300 (EET DST)

IPv6
   App
    |
   IPv6                   IPv4
   Stack                  Stack
    | if=2010::     pro=41|  |