Subject: (ngtrans) what pieces are actually missing

From: Randy Bush <[email-masked]>
Date: Tue, 8 Jun 1999 23:43:12 -0700 (PDT)

in an iesg discussion, we started to wonder what pieces were missing if one
wanted to do widescale ipv6 deployment.  we came up with some guesses which
are appended.

we also thought about what would happen if we merely wanted to make an ietf
terminal room ipv6-only.

wg comments on both would be appreciated.

randy

IPv6 - what it does, and what does moving forward without deployment mean
-  IPv6 is at draft
-  IPv6 addressing is at Proposed
-  Sequence of what we need
   1 DNS    AAAA               - Proposed
            A6                 - I-D
   2 IP
     - IPV6                    - Draft
       (TCP, UDP)
     - ICMP                    - Draft
     - Neighour Discovery      - Draft
     - Path MTU                - Draft
     - Stateless Addr Autocfg  - Draft
   3 IP over foo               - Proposed
   4 MIBs                      - Proposed
   5 Routing
     - BGP extensions          - Proposed (but run on IPv4)
     - RIPng                   - Proposed
     - OSPF extensions         - I-D
     - IBGP                    -
     - ISIS                    - ??
   6 IPsec                     - Proposed
     Kerberos no (carries addresses)
   7 SNMP mostly
   8 Applications
     FTP                       - Proposed
     domain/address Literals   - ???
     Fax
   9 DHCPv6 ??
   10 Multicast ?? (PIM spec I-D??)

- Implementation status
  - Host  - IP stack support
    available for some 30 platforms (not many as product)
  - Router - CPE equipment avilable off-the-shelf
             (obsolete equipment/code, code is not off-the-shelf)
    no 7500-class router available
    viable to route IPv6 using MPLS?
  - Application support
    essentially not existent
  - RDNS support (Bind 8.2 - AAAA - over v4 only)
  - SNMP support (none)
  - Ping and Traceroute exist

---

From: Francis Dupont <[email-masked]>
Date: Wed, 09 Jun 1999 14:18:35 +0200

In your previous mail you wrote:

=> without a wide spread IPv6 stack for Windows 9x I am afraid this
is only a smart way to reserve free places in the terminal room
(not so crowded) to ngtrans mailing list readers... (:-)

=> we need A6 implementations asap and dates for A6 availability yesterday!

      5 Routing

=> BGP4+ for IPv6 runs over TCP/IPv6 even it is theorically possible
to negociate an IPv4/IPv6 dual-BGP4 over something. Pedro?
(PS: there are many implementations but we have to wait some months
before to be elligible for a draft standard. The generic BGP4+ document
(RFC 2283 and draft-ietf-idr-bgp4-multiprotocol-v2-02.txt) needs to
become a draft standard too but BGP4+ is used both for IPv4 multicast
and IPv6 unicast then there is a strong support in two communities for it).

        - OSPF extensions         - I-D

=> last I-D (draft-ietf-ospf-ospfv6-05.txt) is from november 1997!

        - IBGP                    -

=> what is this?

        - ISIS                    - ??

=> I've tried to arouse some interest for an IPv6 support in new IS-IS
with a moderate success...

      8 Applications
        FTP                       - Proposed

=> some cleanup is needed (too many old proposals).

=> IPv6 in URLs?

      9 DHCPv6 ??

=> this should be fixed ASAP, the spec is not really finished
and there is no implementation (then no implementation feedback)...

=> there are some works both on spec and implementations,
unfortunately we hardly need IPv6 multicast support on common routers.

   - Implementation status

=> I have IPv6 capable IOS on my 7505 router?

=> MPLS is supposed to be multiprotocol
   ^

     - Application support
       essentially not existent

=> what do you mean?

     - SNMP support (none)

=> there are some IPv6 capable SNMP (with both IPv6 transport and IPv6 MIBs).

Regards

[email-masked]

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 09 Jun 1999 09:10:24 -0400

Randy,
	This is a good short list and a good food of thoughts.

	I would like to make a small comment about application support, where the
iesg is saying "essentially non-existent". Well, it is true that in the MS
world, it is "essentially non-existent", but if you look at the ports done
by the Kame people, it has everything you need and more! you can run a
complete IPv6 unix workstation or server with about everything you need:
web, mail, telnet, ssh, multicast tool, even a MP3 player and server!
	here is an abstract of a recent kame ports directory:

Makefile        ethereal        inn             mrt             python
    squid11         v6tun
XFree86         fetchmail       kaffe           ncftp3          qmail
    ssh             vat6
altq            fwtk6           libident6       newbie
rev_v6_address  tcp_wrapper     vnc
apache12        gated-ipv6      lynx            perl5           rsync
    tcpd6           wbd
apache13        geta            mediator        pident6d        ruby
    tcptrace        wget
bind8           heimdal         mozilla         popper          sendmail6
    ucd-snmp        wu-ftpd
ct              icecast         mpg123          ppp             socks64
    v6eval          zebra

	so I would propose to change the iesg statement to: "application support:
very good on some platforms, essentially non-existent on others".

Regards, Marc. 

>  - Ping and Traceroute exist

-----------------------------------------------------------
Marc Blanchet			| [email-masked]
Viagénie inc.			| http://www.viagenie.qc.ca
3107 des hôtels		| tél.: 418-656-9254 
Ste-Foy, Québec		| fax.: 418-656-0183
Canada, G1W 4W5		| radio: VA2-JAZ
------------------------------------------------------------
Internet Engineering Standards/Normes d'ingénierie Internet
               http://www.normos.org
------------------------------------------------------------

---

From: "Matt Crawford" <[email-masked]>
Date: Wed, 09 Jun 1999 08:39:05 -0500

> we also thought about what would happen if we merely wanted to make an ietf

Interesting.  But before that step, I'd recommend making the ethernet
drops DHCP-only, enforced by router filters updated by the DHCP server.

---

From: "Matt Crawford" <[email-masked]>
Date: Wed, 09 Jun 1999 08:37:42 -0500

> [...]

Kerberos has been on my mind lately.  When the time comes for porting
it to IPv6, I think the addresses it carries should be replaced by
hostnames if possible, but more likely expressed as

	a list of
		triples of
			N, between 0 and 128
			a list of N-bit prefixes
			a list of 128-N-bit suffixes

For example, a ticket for a dual-homed host in a dual-homed site
which employs site-local addresses might embed 6 addresses this way

	{ ( 48, { 3ffe:07c0:0040, 2001:0001:0002, fec0:0000:0000 },
	        { 0009:0000:0cff:fe17:f4f6, 0102:0000:0cff:fe17:f4f9 } ) }

(The BER or DER of the bit-strings might make the prefix length N
unnecessary.)
					Matt

---

From: Randy Bush <[email-masked]>
Date: Wed, 9 Jun 1999 08:54:26 -0700 (PDT)

> (not so crowded) to ngtrans mailing list readers... (:-)

i suspect that there is also the apps chicken/egg issue.  and, for those
sshing home, what requirements would this put on home?  this may be another
way of asking what happens to a pure v6 island with strong ties to the
mainland.

> => we need A6 implementations asap and dates for A6 availability yesterday!

and moving a6 to proposed is blocked in the iesg.

> to negociate an IPv4/IPv6 dual-BGP4 over something. Pedro?

as far as i can tell, one can run bgp+ over a native v6 wire between peers
by letting the router ids be v4 loopback addresses.

> and IPv6 unicast then there is a strong support in two communities for it).

bgp4+ with a multicast nlri is deployed by multiple vendors.  is a v6 nlri?

> => last I-D (draft-ietf-ospf-ospfv6-05.txt) is from november 1997!

do you need iesg help?  (we're from the iesg and we're here to help:-)

> => what is this?

iBGP is how the multiple borders routers in a v6 AS share edge routes with
eachother.  if v6 nlri works, this should work.  pedro?

> => I have IPv6 capable IOS on my 7505 router?

huh?  i am only aware of code for cisco models 2501 and 4000.

> => MPLS is supposed to be multiprotocol

and then there is the reality.

> => what do you mean?

what do applications need to do to be able to live in a true native v6
environment?  back to thinking about the ietf terminal room.  has anyone
seen an ipv6 printer?  can i ssh home?

> => there are some IPv6 capable SNMP (with both IPv6 transport and IPv6 MIBs).

bert?

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 9 Jun 1999 09:02:00 -0700 (PDT)

> if you look at the ports done by the Kame people, it has everything you
> need and more! you can run a complete IPv6 unix workstation or server with
> about everything you need: web, mail, telnet, ssh, multicast tool, even a
> MP3 player and server!

excellent!  thanks marc.

randy

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 09 Jun 1999 15:33:41 -0400

>seen an ipv6 printer?  can i ssh home?

well, talking about that terminal room, I can talk about it: since IETF
Chicago (aug 98) where we have first installed the IPv6 router in the
terminal room (with some political problems because ipv6 was viewed as a
potential problem...), a lot of people have been using IPv6 to read their
mail, go to their home network, etc.. Even at Chicago, one person reported
(if I remember well, was Jun-ichiro itojun Hagino) that he sshed at home
using native IPv6. In december Orlando, there was more than 100Mbytes of
native IPv6 trafic in the only week of IETF in the terminal room.

I think the picture is much better than what iesg think. As said, the only
big exception is MS world.

regards, Marc.

---

From: Randy Bush <[email-masked]>
Date: Wed, 9 Jun 1999 12:46:45 -0700 (PDT)

> Even at Chicago, one person reported (if I remember well, was Jun-ichiro
> itojun Hagino) that he sshed at home using native IPv6. In december
> Orlando, there was more than 100Mbytes of native IPv6 trafic in the only
> week of IETF in the terminal room.

great!  what worked and what did not?  e.g.
  printing
  radio modems
  ...

> I think the picture is much better than what iesg think.

iesg does not think (you should know that:-).  iesg is trying to find out
what already works, what could work if people were inclined to implement,
and, perhaps most important for the iesg, what standards track (or maybe
bcp) work precludes or is needed for ipv6.

randy

---

From: [email-masked]
Date: Thu, 10 Jun 1999 05:17:39 +0900

>native IPv6 trafic in the only week of IETF in the terminal room.

	Many Japanese guys do ssh6 to their home, as IPv6 provides much better
	connectivity than IPv4 does.  Transpacific IPv4 link is fairly
	congested (well, depending on which link your packet will travel)
	and IPv6 link is considered experimental :-)

	If I remember correctly, I saw nearly 30 IPv6 nodes on Orlando
	IETF terminal room subnet.  I checked with multicast icmp6 echo.

itojun

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 09 Jun 1999 16:08:59 -0400

>great!  what worked and what did not?  e.g.

well, we installed the router and try to support the service the best we
can. But, we were a bit "lazy" in doing statistics, because we were
attending ietf sessions (which is why we are there... surprised?).  So I
can't tell exactly what people used, what people didn't, ... we were only
offering the layer 3 service, no specific details about the upper layers!

>bcp) work precludes or is needed for ipv6.

I understood that part!

Regards, Marc.

---

From: Magnus Ahltorp <[email-masked]>
Date: 09 Jun 1999 23:08:49 +0200

> hostnames if possible, but more likely expressed as

Have a look at heimdal, the kerberos 5 implementation from KTH. There
is IPv6 code in it, but I haven't tried that support out yet (mostly
because we don't have any IPv6-only machines here yet).

/Magnus

---

From: Kenji OTA <[email-masked]>
Date: Thu, 10 Jun 1999 22:00:58 +0900

Hello,

NTT provided IPv6 reachability toward Japan in IETF terminal room on
last two IETF meetings, IETF-43 and IETF-44.
We stored the traffic data and analized it. Then, we found that most
people had used "ssh" to connect their network.
I made a presentation for it at Grenoble interim meeting, and you can
see the presentation slides on "http://www.nttv6.net/Grenoble/".

Thank you.

--------------------------------------
    Kenji OTA  < [email-masked] >
NTT Information Sharing Platform Labs.

From: Marc Blanchet <[email-masked]>
Subject: Re: (ngtrans) what pieces are actually missing 
Date: Wed, 09 Jun 1999 16:08:59 -0400

---

From: Kenji OTA <[email-masked]>
Date: Thu, 10 Jun 1999 22:15:48 +0900

NGtrans Folks,

# I forgot important information in my previous e-mail.
"http://www.nttv6.net/Grenoble/" is IPv6 accessible web site (not
only IPv4).

Thank you.

From: Kenji OTA <[email-masked]>
Subject: Re: (ngtrans) what pieces are actually missing 
Date: Thu, 10 Jun 1999 22:00:58 +0900

---

From: "Matt Crawford" <[email-masked]>
Date: Thu, 10 Jun 1999 08:41:56 -0500

> > Even at Chicago, one person reported ...
> 

Way back in Montreal I got the INRIA stack going over the wireless
net -- it was just a matter of 6 or 8 lines in the WaveLan driver to
make it go.

---

From: Philip Smith <[email-masked]>
Date: Fri, 11 Jun 1999 01:38:39 +1000

>huh?  i am only aware of code for cisco models 2501 and 4000.

code is available for 1000, 1005, 1600, 2500, 2600, 36x0, 4x00, 5200, 7200
and 7500. All but 2600 have had code available for at least a year. So, a
few more apart from 2501 and 4000 to play with... ;-)

philip
--

---

From: Francis Dupont <[email-masked]>
Date: Thu, 10 Jun 1999 17:45:19 +0200

> great!  what worked and what did not?  e.g.

=> if you replace your Ethernet printer with a terribly broken
TCP/IP(v4) stack by a nice Unix box running an IPv6 Unix with
a PostScript driver and a parallel link to a cheap printer
you can solve this problem (and perhaps other :-).

=> I use old WaveLANs with IPv6 for mobility experiments every
days. I am setting up the last FreeBSD+PAO on a (second) laptop
in order to switch to new "IEEE" WaveLANs and I'll add the IPv6
6/8 lines asap. For GSM (9600bits/s data service) you can use IPv6 PPP
and I know there is something for Metricom Ricochet...
 Really if this kind of junk hardware accepts to work with your junk
driver on your junk laptop with no free IRQ IPv6 is very easy to get! (:-)

Regards

[email-masked]

---

From: Peter Tattam <[email-masked]>
Date: Fri, 11 Jun 1999 11:06:22 +1000 (EST)

For Win32 world, we have....

Winsock 1.1 TCP/IP stack.  Runs on Win95, Win98, WinNT 4.0.  Supports also Win16 API.
No Win3.x support.

Internet Server for the above... (Fanfare(tm))
SMTP,POP3,HTTP,FTP,TELNET,DNS
general purpose INETD style interface

Tunnel Client/Server for dynamic tunnels

Telnet client (Win16)

We have a number of applications that could be ported to Ipv6. One is our
mailreader (MailBird(tm))

Peter
--
Peter R. Tattam                            [email-masked]
Managing Director,    Trumpet Software International Pty Ltd
Hobart, Australia,  Ph. +61-3-6245-0220,  Fax +61-3-62450210