Subject: RE: (ngtrans) I-D ACTION:draft-ietf-ngtrans-6to4-03.txt

From: Richard Draves <[email-masked]>
Date: Thu, 14 Oct 1999 15:32:49 -0700

> I don't think we can punt on the problem by letting the user/admin
> manually configure the policy.
> (I can see it now: The IPv6 mobile phone asks me to configure 
> address selecting
> policy when I turn it on the first time. :-)
> 
> We must provide defaults which we believe will work 
> reasonable well in 90%
> of the cases (well, 99.99% of the cases for the billion 
> mobile phones to
> reduce the number of support calls) for this to be useful.
> 
> Having said that, I don't see a problem providing some policy 
> hooks for
> those who want something different.

I think we agree.

Over in the ipng list, I'm trying to figure out how the source & destination
address selection algorithms can be expressed in a way that allows for
flexible administrative policy/override.

Here in the ngtrans list, we can discuss what the default policy (in absence
of site/node configuration) should with 6to4 and v4-compatible addresses.

I would want the default to prefer native addresses to 6to4 addresses or
v4-compatible addresses when both are available.

Rich

---

From: Jim Bound <[email-masked]>
Date: Thu, 14 Oct 1999 21:50:28 -0400

rich,

as long as you have default the policy must be optional...

are you doing thsi draft?  when?  if late I am going to do it but we
need it real soon.

/jim

---

From: Alain Durand <[email-masked]>
Date: Fri, 15 Oct 1999 11:55:55 +0200

> > those who want something different.

I agree 100%

>v4-compatible addresses when both are available.

I agree too.
Default should be to prefer native IPv6 over ANY transition mechanism.

         - Alain.